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このマニュアルで使用する表記規則

このマニュアルでは、次の表記規則を使用します。

Getting Started 斜体文字は、書名または強調語を表します。

Dialog Box 用語集で定義されている語句がマニュアル中に
初めて出現したときは、太字で表記します。

File コンピュータ・フォントの文字は、メニュー名、
機能、ボタン、入力するテキストなど、画面上
に表示されるテキストを表します。

dir filename この場合、コンピュータ・フォントの文字は示
されたとおり正確に入力する引数を表し、斜体
文字は実際の値で置換えるべき引数を表します。

[File]⇒ [Open] 「⇒」は、VEE 機能のメニュー内の位置を簡単

に表すために使用します。たとえば [File]⇒

[Open]は、[File]メニューを選択し、次に

[Open]を選択することを示します。

Sml | Med | Lrg 縦棒 (|) で区切られたコンピュータ・フォント

の選択肢は、オプションの 1 つを選択する必要

があることを示します。

Enterキーを押します。 この場合、太字はキーボード上のキーを表します。

Ctrl + O キーを押し

ます。

キーボード上で同時に押すキーの組合わせを表
します。
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はじめに 

この章では、Agilent VEE とその主要機能を紹介します。また、VEE のイン

ストール方法、習得方法、VEE サポートの利用方法について解説します。
2 はじめにはじめにはじめにはじめに 



Agilent VEE の概要の概要の概要の概要
Agilent VEE の概要

Agilent VEE は、テスト / 計測アプリケーションおよびオペレータ・インタ

フェースを備えたプログラム構築を目的として最適化されたグラフィカル
なプログラミング言語です。Agilent VEE 製品グループのこのバージョンに

は、複雑なテスト / 計測システムを構築する技術者グループ向けの VEE Pro 
6.0 と、設計やデータ収集を行う技術者や科学者個人向けの VEE OneLab 
6.0 があります。

テスト開発に Agilent VEE を使用する利点

VEE は、テスト開発において、次の多くの利点を提供します。

生産性を大幅に高めます。顧客からの報告によると、プログラム開発時

間を最大 80% まで削減できます。

VEE は、機能テスト、設計の検証、評価、データの取込みと制御など、

幅広いアプリケーションで使用できます。

GPIB、VXI、シリアル、GPIO, PC プラグイン・カード、LAN 計測器を制

御する計測器 I/O がより柔軟になりました。パネル・ドライバ、VXI 
plug & play ドライバ、ODAS ドライバ、標準的なインタフェースのた

めの「direct I/O」、さまざまなベンダからインポートされたライブラリ

を使用できます。

ActiveXオートメーションおよびActiveXコントロールを使用して、PC上

で MS Word、Excel、Access などほかのアプリケーションを制御できま

す。これらのアプリケーションを利用して、レポートを作成したり、
データを表示して分析したり、テスト結果を将来使用するためにデータ
ベース化できます。

処理量が増えたため、より大きなプログラムを簡単に構築できるほか、

計測器の管理がより柔軟になりました。VEE が採用するコンパイラは、

大規模で複雑なプログラムに適したプロフェッショナル開発環境と高度
な計測器管理能力を提供します。

作成したプログラムを C/C++、Visual Basic、Pascal、Fortran、Rocky 
Mountain Basic などのテキスト形式言語に統合できます。
はじめにはじめにはじめにはじめに 3333



Agilent VEE の概要の概要の概要の概要
Agilent VEE におけるプログラムの作成方法

VEE のプログラムは、メニューからオブジェクトを選択し、それらを接続

することによって作成されます。VEE で作成されたプログラムはデータ・

フロー・ダイアグラムに似ており、従来のコード列に比べて使いやすく、
理解しやすくなっています。VEE を使用すると、編集 - コンパイル - リン

ク - 実行という面倒な繰返しを行う必要がありません。

次の 2 つの図は、簡単な関数をテキスト形式言語 (ANSI C) でプログラムし

た場合と、VEE でプログラムした場合を比較したものです。どちらの場合

も、関数は 10 個の乱数から成る配列を作成し、最大値を見つけ、配列と最

大値を表示します。

図 1 は、ANSI C 言語で書かれた「Random」というプログラムを示します。
4 はじめにはじめにはじめにはじめに 
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図 I-1. ANSI C による「Random」プログラム

図 2 は、VEE で作成した同じプログラムを示します。

/* 配列の最大要素を見つけるプログラム */

#include <math.h>

main( )

{

double num[10],max;

int i;

for (i=0;i<10,i++){

num[i]=(double) rand( )/pow(2.0,15.0);

printf("%f/n",num[i];

}

max=num[0];

for {i=1;i<10;i++){

if (num[i]>max)max=num[i];

}

printf("/nmax; %f/n",max);

}
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図 I-2. VEE による同じ「Random」プログラム 

VEE では、プログラムはオブジェクトと呼ばれるプログラム要素で構築さ

れます。オブジェクトは VEE プログラムの構成単位であり、I/O 操作、分

析、表示などさまざまな機能を実行します。オブジェクトとその接続をす
べて図 2 のように表示したものを詳細ビューと呼びます。詳細ビューは、

テキスト形式言語におけるソース・コードに似ています。

VEE では、データが 1 つのオブジェクトから次のオブジェクトへ整合性を

維持しながら移動します。データは、オブジェクトの左側から入力され、
右側から出力されます。またオブジェクトの上下には動作を操作するシー
ケンス・ピンがあります。

オブジェクトは、結合して 1 つのプログラムを形成します。プログラムは

左から右へ実行されます。図 2 で示した「Random」プログラムでは、乱数

が「Collector - Create Array」オブジェクトに 10 回追加され、配

列が作成されます。次にプログラムは、配列中の最大値を見つけて、「Max 

Value」と「Array Values」と表示します。

モジュール・プログラミングの手法を用いる VEE を使用すると、計測器を

制御するプログラムを作成したり、カスタマイズしたデータを表示したり、
オペレータ・インタフェースを開発する時間が短縮されます。このテスト
開発方式は、従来の手法に比べて生産性を大きく高めます。
6 はじめにはじめにはじめにはじめに 
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メモ 図 2 には、詳細が表示されたオブジェクトと名前だけが表示されているオ

ブジェクトがあります。詳細が表示されたオブジェクトは、オープン・
ビューで表示されます。オープン・ビューでは、オブジェクトの詳細を表
示できます。スペースを節約してプログラムの実行速度を上げるには、オ
ブジェクトをアイコン化して、つまりオブジェクトを縮小して、名前だけ
が表示されるようにします。

たとえば図 2 では、Random Numberのラベルが付いたオブジェクトがア

イコンで表示されています。Create Arrayのラベルが付いたオブジェク

トはオープン・ビューで表示されています。オープン・ビューでは、オブ
ジェクトがより大きく詳細に表示されます。オブジェクトの表示について
は、第 1 章「Agilent VEE 開発環境の使用方法」の 32 ページの「オブジェ

クトの表示の変更」で詳述します。

Agilent VEE におけるオペレータ・インタフェースの

作成

また、VEE でプログラムを記述すれば、オペレータ・インタフェースを簡

単に作成できます。

図 2 の「Random」プログラムを使用する場合、オペレータに表示する必要

があるオブジェクトを選択してパネル・ビューに入れます。パネル・
ビューには、オペレータがプログラムを実行するために必要なオブジェク
トと、結果として得られたデータだけが表示されます。図 3 は、図 2 の

「Random」プログラムのパネル・ビューを示しています。

メモ プログラムとオペレータ・インタフェースは、同じ VEE プログラムを異な

る方法で表示したものです。VEE ウィンドウのタイトル・バーで詳細

ビュー・ボタンとパネル・ビュー・ボタンをクリックすることにより、
ビューを切替えることができます。プログラム ( 詳細ビュー ) を編集した

り更新すると、オペレータ・インタフェース ( パネル・ビュー ) も自動的

に編集 / 更新されます。また、オペレータ・インタフェースが不用意に変

更されないように設定することもできます。

オペレータ・インタフェースの作成方法についての詳細は、93 ページの

「パネル・ビュー ( オペレータ・インタフェース ) の作成方法」を参照して

ください。
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図 I-3. VEE プログラムのパネル・ビュー

( またはオペレータ・インタフェース ) 

VEE を使用すると、テキスト形式言語では何日もかかるような作業が数分

で完成する場合があります。

カラフルで直観的なフロント・エンドを作成できる。

キーボードとマウス、またはキーボード入力だけを使用するオペレー

タ・インタフェースを作成できる。

入力方法とデータ表示機能を幅広い組合わせの中から選択できる。

ポップアップ・パネルを使ってフォーカスを作成でき、画面スペースを

節約できる。

プログラムを不用意に変更できないように設定できる。

ラベルを使用したり、色とフォントを選択したり、さまざまな形式の警

告音、notepads、ボタン、スイッチを追加できる。
8 はじめにはじめにはじめにはじめに 
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独自または標準の既存 ActiveX コントロールを使用して、データ入力ま

たは表示を行うことができる (PC のみ )。

既存のテスト・プログラムと Agilent VEE との統合

サポートするすべてのオペレーティング・システム上で、VEE は、市販ア

プリケーションだけでなく通常のテスト・プログラムも結合する仕組みを
提供します。たとえば、VEE を使用して、Rocky Mountain Basic、C、C++、
Visual Basic、Fortran、Pascal、またはそのオペレーティング・システムで使

用できる任意のコンパイラとインタープリタで書かれた既存のテストを順
に実行できます。VEE はまた、データベースやスプレッドシートなどの市

販アプリケーションとデータを共用するために、数多くのプロセス間通信
機能を提供します。

PC 上の VEE は、ActiveX オートメーション、ActiveX コントロール、DLL
との標準的な接続をサポートします。HP-UX 上の VEE は、名前付きパイ

プと共有ライブラリをサポートします。.

Agilent VEE での計測器の制御

VEE は、計測器を制御し、計測器と通信するためのオプションを数多く提

供します。

さまざまなベンダから提供されている 450 以上の計測器用パネル・ドライ

バ ( 計測器ドライバ ) を使用できる。また、Windows 95、Windows 98、
Windows 2000、Windows NT 4.0、HP-UX フレームワークと互換性がある

さまざまなベンダの VXI plug & play ドライバをすべて使用できる。

VEE の Direct I/O を使用すると、計測器のコマンド文字列を GPIB(IEEE - 
488)、GPIO、RS 232、VXI、LAN ベース計測器などの標準的なインタ

フェースに送信して、リモート・テストを行うことができる。

標準的な ODAS ドライバ、あるいはボードに付属する DLL(Dynamic Link 
Library) を供給する製造元の PC プラグイン・ボードを制御できる。

埋込みPCまたはワークステーションを使ってVXIのバックプレーン制御

を直接使用できる。

簡単で組織化された計測器管理機能により、多くの種類の計測器を制御

できる。
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Agilent VEE によるテストの強化

VEE 製品には、次の機能と利点があります。

グラフィカル・プログラミングによる開発 / 保守時間の削減

C、C++、Visual Basic、Pascal、Fortran、RMB などの従来の言語との統合

使いやすく柔軟なオペレータ・インタフェース機能

一般的なテスト・プラットフォームのほとんどをサポート

ActiveX オートメーションおよび ActiveX コントロールの使用

Agilent Technologies の数多くのサポート・オプションを利用可能

簡単で強力な文書ツール

テスト・データをレポート作成のために標準的なスプレッドシートや

ワープロに簡単に移植可能

リレーショナル・データベースや統計分析パッケージ (VEE Pro 6.0のみ )な
どのほかのアプリケーションとリンクするためのプロセス間通信ツール

大規模で複雑なプログラムの開発と保守を効率よく行うためのデバッ

グ・ツール (VEE Pro 6.0 のみ )

製品に付属する強力なテスト実行ツール (VEE Pro 6.0 のみ )

VEE の Web モニタ機能によるリモート・テスト機能 (VEE Pro 6.0 のみ )

RunTime を無制限に配布可能 (VEE Pro 6.0 のみ ) 

低価格のサイト・ライセンス (VEE Pro 6.0 のみ )
10 はじめにはじめにはじめにはじめに 
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Agilent VEE のインストールと習得

このセクションでは、VEE のインストールと習得に関するガイドラインを

提供します。VEE のインストール方法、VEE の習得方法、VEE の使用方

法、VEE サポートの利用方法などについて説明します。

Agilent VEE および I/O ライブラリのインストール方法

VEE Pro 6.0 および I/O ライブラリのインストール方法についての情報は、

VEE に添付されているインストール・マニュアルを参照してください。I/O
ライブラリは、VEE と計測器との通信に使用されます。

オンライン・ヘルプの「Installing and Distributing VEE Pro 6.0 RunTime」で

は、VEE Pro 6.0 RunTime 版のインストール方法と配布方法を説明します。

RunTime 版は、VEE ソフトウェアがインストールされていない PC 上で

VEE プログラムを実行するときに使用します。RunTime 環境についての詳

細は、オンライン・ヘルプを参照してください。 [Help]⇒ [Contents 

and Index]をクリックして、「Agilent VEEInstalling and 

Distributing Agilent VEE Pro RunTime」を選択します。必要に応

じて情報を印刷できます。

Agilent VEE の習得

VEE の使用方法についてさらに学習するには、VEE のマルチメディア・

チュートリアル、オンライン・ヘルプ、または本書などのマニュアルを参
照してください。VEE 講習に参加する方法もあります。

VEE マルチメディア・チュートリアル : VEE の [Help]⇒ [Welcome]メ

ニューにあり、VEE の重要な概念を説明するビデオ・プレゼンテー

ションです。VEE メニューの使用方法、オブジェクトの編集方法、プ

ログラムの実行方法を説明します。それぞれのプレゼンテーションは終
了までに 3、4 分かかり、何回でも再生できます。チュートリアルを一

時停止して、VEE を実行して学んだことを試した後、またチュートリ

アルを再開できます。

VEE オンライン・ヘルプ :VEE の新機能については、[Help]⇒

[Contents and Index]を選択し、「What's New in Agilent VEE 6.0」
を選択して学習できます。[Help]⇒ [Welcome]⇒ [Introduction]
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を選択すると、VEE 製品の概要を読むことができます。

オンライン・ヘルプには、ほかにもさまざまな機能があります。詳細
は、25 ページの「ヘルプの利用」と 101 ページの「オンライン・ヘル

プの使用方法」を参照してください。

VEE マニュアル : VEE のマニュアル・セットには、このマニュアルのほ

かに、『VEE Pro ユーザーズガイド』と『VEE Pro Advanced 
Techniques』が含まれます。

Agilent VEE 講習 :VEE 講習についての情報は、Web サイト

http://www.agilent.com/comms/educationを参照してください。

メモ このマニュアルに記載されている練習問題やプログラミング例で使用した
VEE プログラムの多くは、VEE に付属しています。[Help]⇒ [Open 

Example...]⇒ [Manual]⇒ [UsersGuide]を選択してください。

無料評価ソフトウェアの注文

無料の評価ソフトウェアを CD で入手できます。または、VEE Web サイト

からダウンロードできます。Agilent Technologies VEE 評価キット CD を注

文するには、米国 (800) 829-4444 に電話するか、または以下の Agilent 
Technologies Web サイトにご連絡ください。

http://www.agilent.com/tmo
12 はじめにはじめにはじめにはじめに 
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MATLAB Script 概要

MATLAB® Script は、MathWorks 社製の高機能 MATLAB のサブセットです。

これにより、ユーザは高度な数式処理、データ分析、科学的 / 工学的グラ

フィックなど MATLAB の中核機能に直接アクセスできます。MATLAB 
Script オブジェクトは、どのような Agilent VEE プログラムにも簡単に挿入

できます。

MATLAB Script には、次のような数多くの機能があります。

データの分析と視覚化

次の数値計算

線形代数および行列演算

フーリエ解析および統計分析

微分方程式の計算

三角関数および基本関数の数式演算

次の科学的、工学的グラフィック

三角データ、グリッド・データなどの二次元および三次元表示

スカラおよびベクトル・データの視覚化

矢印 (quiver)、リボン (ribbon)、散布図 (scatter)、棒グラフ (bar)、円グラ

フ (pie)、離散グラフ (stem) のプロット

Signal Processing Toolbox
VEE 用の MATLAB Script には、フィルタ設計とスペクトル分析技術に基づ

いて構築された MATLAB Signal Processing Toolbox のサブセットが含まれま

す。これには、次の機能があります。

信号および線形システム・モデル

アナログ・フィルタの設計
はじめにはじめにはじめにはじめに 13131313



MATLAB Script 概要概要概要概要
FIR および IIR ディジタル・フィルタの設計、解析、実装

FFT および DCT などの変換処理

スペクトル推定と統計的信号処理

時系列パラメータ・モデリング

波形の生成

高機能 MATLAB について

MATLAB は、数値計算、高度なグラフィックおよび視覚化、高機能プログ

ラミング言語を統合した統合型テクニカル・コンピューティング環境です。
MATLAB には、次のような数多くの機能があります。

データの分析と視覚化

数値および記号の計算

工学的、科学的グラフィック

モデリング、シミュレーションおよび試作

プログラミング、アプリケーション開発、GUI 設計

MATLAB は、信号処理、画像処理、制御システム設計、財務管理、医学研

究など、さまざまな分野のアプリケーションで使用されます。オープン・
アーキテクチャにより、MATLAB と関連製品を使用すると、データの調査

やカスタムツールの作成を簡単に行うことができ、分析時間が短縮されて
競争上優位に立つことができます。

VEE ユーザは、データ分析、視覚化、モデリングなどを必要とするアプリ

ケーションに、MATLAB と Signal Processing Toolbox の全機能を組込むこと

ができます。これらの製品をフル・バージョンにアップグレードすれば、
ユーザ定義関数 (M ファイル )、MATLAB コマンド・ウィンドウ、

MATLAB エディタ / デバッガ、Signal Processing GUI へのアクセスなどの

MATLAB 機能を VEE アプリケーションで幅広く使用できます。
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メモ VEE プログラムにおける MATLAB Script オブジェクトの使用方法について

の詳細は、第 4 章「テスト・データの分析と表示」の 189 ページの

「Agilent VEE における MATLAB Script の使用」を参照してください。
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Agilent VEE サポートの利用

VEE を使い始めるときに、Web サイトまたは電話によるサポートを利用で

きます。

World Wide Web で情報を得る 
VEE Web サイトでは、アプリケーション情報、ユーザのためのヒント、技

術情報、PC プラグイン・ボード・ベンダの VEE パートナー情報など、さ

まざまな情報が提供されています。

VEE のメイン Web サイト : http://www.agilent.com/find/vee

最新サポート情報 : ネットワークに接続した状態で、VEE で [Help]⇒

[Agilent VEE on the Web]⇒ [Support]をクリックします。図

4 は、VEE での [Support] メニューの選択方法を示します。また Web
ブラウザでは、http://www.agilent.com/find/veeに接続し

て、[Support] をクリックします。

図 I-4. VEE の [Help] メニューから製品サポートを利用

無料のスタートアップ・サポートについては、オンライン・ヘルプの電

話サポート情報をご覧ください。VEE では、[Help]⇒ [Contents 

and Index]をクリックして、「Agilent VEE Support」を選択し

ます。
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MATLAB の追加情報源

MATLAB Script オブジェクトの使用についての完全で詳細な情報は、

「MATLAB SCRIPT Help Desk」を参照してください。VEE で [Help]⇒

[MATLAB Script]⇒ [Help Desk]を選択すると、Web ブラウザに

MATLAB Help Deskが表示されます。

MATLAB、MATLAB Toolboxes、および MathWorks 社のその他の製品につ

いての詳細は、www.mathworks.comを参照するか、または米国 (508) 
647-7000 に電話してください。

ほかにも次の情報源があります。

MATLAB ドキュメント全文 : 
www.mathworks.com/access/helpdesk/help/helpdesk.shtml

MATLAB アップグレード申込み :VEE Pro 6.0 および VEE OneLab 6.0 の

ユーザは、特別価格でアップグレードをお申込みになれます。詳細は、
www.mathworks.com/veeupgradeを参照してください。

MATLAB 製品情報 : www.mathworks.com/products

MATLAB 技術サポート : www.mathworks.com/support

MathWorks オンラインショップ : www.mathworks.com/store

MathWorks ホームページ : www.mathworks.com

Usenetニュースグループ:comp.soft-sys.matlabニュースグループに

は、MATLAB を使用する専門家と学生のためのフォーラムがあります。

MATLAB と関連製品についての質問やコメントが掲載されています。
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Agilent VEE 開発環境の使用方法

この章の内容

対応システム

ヘルプ・システムの使用方法

VEE の起動方法

VEE ウィンドウについて

オブジェクトの扱い方

ワークスペースの管理方法

メニュー項目の選択方法

VEE オブジェクトのピンと端子

オブジェクトの接続とプログラム作成

プログラムの作成、実行、印刷、保存、オープン

VEE プログラムの動作の仕方

平均的な必要時間 :1.5 時間 
20 第第第第1章章章章 
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概要概要概要概要
概要

この章では、VEE の起動方法、メニューの使用方法、オブジェクトの扱い

方を説明します。また VEE におけるピンと端子について解説します。オブ

ジェクトを接続して簡単な VEE プログラムを作成し、VEE プログラムの

動作の仕方についても学習します。
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Agilent VEE の対話型操作

このセクションでは、VEE のグラフィカル・プログラミング言語の使用方

法を説明します。また、対応システム、マウスとメニューの使用方法、ヘ
ルプの利用方法、VEE の起動方法、VEE ウィンドウでの操作方法について

も説明します。

対応システム

VEE バージョン 6.0 は、次のシステムに対応しています。

PC 上の Windows 95、Windows 98、Windows 2000、および Windows NT 4.0

HP-UXワークステーション (シリーズ 700のバージョン 10.20)。VEEの本

バージョンは、HP-UX のバージョン 11.x または 10.2 以前のバージョン

では動作しません。

マウスとメニュー

プルダウン・メニュー、ツールバー、マウスとキーボードで制御するダイ
アログ・ボックスなど、マウスとメニューを駆使したコンピュータのイン
タフェースについては、よくご存知と思います。VEE では、このコン

ピュータのインタフェースを使用します。次は、マウスを使ってメニュー、
アイコン、ボタン、オブジェクトを操作するときの共通事項です。

項目を「クリック」するには、マウス・ポインタを目的の項目に合わせ

て、マウスの左ボタンをすばやく押して離します。

項目を「ダブルクリック」するには、マウス・ポインタを目的の項目に

合わせて、マウスの左ボタンを 2 回、すばやく続けてクリックします。

項目を「ドラッグ」するには、マウス・ポインタを目的の項目に合わせ

て、マウスの左ボタンを押したまま、項目を適切な位置まで移動しま
す。次にマウスのボタンを離します。

メモ マウスの右ボタンはあまり使用しません。マウスの右ボタンをクリックす
る必要がある場合は、そのことを明記します。また、中央ボタンを備えた
マウスもありますが、VEE では中央ボタンを使用しません。
22 第第第第1章章章章 
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Agilent VEE の起動方法 

Agilent VEE ウィンドウ

VEE をインストールして起動すると、図 1-1 のような VEE ウィンドウが表

示されます。

図 1-1. VEE 開発環境

Windows [スタート ]⇒ [プログラム ]⇒ [VEE Pro 6.0] をクリッ
クします。

HP-UX HP VUE または X11 ウィンドウのシェル・プロンプトで、
「veetest」と入力し、Return キーを押します。PATH変数
に /usr/binが含まれている必要があります。

タイトル・バー
メニュー・バー
ツールバー

プログラム・
エクスプローラ 

作業領域

ステータス・バー
第第第第 1 章章章章 23232323
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次に、VEE ウィンドウの各部について説明します。

タイトル・
バー

ウィンドウの最上部の行には、VEE アイコン、ウィンド
ウ名、[ 最小化 ] ボタン、[ 最大化」ボタン、[ 閉じる ] ボ
タンが表示されます。タイトル・バーをドラッグすると、
ウィンドウが移動します。VEE アイコンをクリックする
と、ウィンドウ・メニューが表示されます。

メニュー・
バー

2 行目にはメニュー項目があり、それぞれ VEE のコマン
ドまたはオブジェクトを提供します。

ツールバー 3 行目にはアイコンまたはボタンが並びます。これらのボ
タンから、使用頻度が高いメニュー・コマンドに直接アク
セスできます ( ショートカット )。ボタン上にマウス・ポ
インタを置くと、そのボタンの機能が表示されます。

作業領域 メイン・ウィンドウ、UserObject編集ウィンドウ、
UserFunction編集ウィンドウなど、オブジェクトを配
置して結線するプログラミング ( 編集 ) ウィンドウの領域
です。

プログラ
ム・エクス
プローラ

VEE ウィンドウの左側の領域には、VEE プログラムの構
造が表示されます。上隅には、現在のプログラム名が
myprog.veeまたは Untitledなどと表示されます。

プログラム・エクスプローラを使ってプログラミング・
ウィンドウ間を移動できます。プログラム・エクスプロー
ラのサイズを変更するには、右側の作業領域との境界線上
に通常のマウス・ポインタを移動し、ポインタが縦の分割
ポインタに変化したら、クリックして境界線を移動します。

メイン・
ウィンドウ

VEE プログラムを開発して編集する作業領域を含むウィ
ンドウです。UserObject編集ウィンドウなどのほかの
プログラミング / 編集ウィンドウも、ここに表示されます。

ステータ
ス・バー

一番下の行には、VEE の状態に関するメッセージが表示
されます。また、右隅には 4 つの状態インジケータが表示
されます。次のインジケータが左から右へ順番に表示され
ます。
実行モード
Profiler の ON/OFF 状態
プログラムが変更されると MOD と表示されます。
Web サーバが使用可能かどうか
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メモ このマニュアルは、VEE バージョン 6.0 の説明です。VEE の旧バージョン

をお持ちの場合は、低価格でアップグレードできます。バージョンを確認
するには、[Help]⇒ [About VEE Pro]をクリックします。ソフトウェ

アのアップデートについてサポート契約を結んだ方には、自動的に新しい
バージョンが配布されます。

ヘルプの利用

VEE は、VEE 環境全体と、個々のオブジェクトおよびトピックに関するに

ついてのオンライン・ヘルプ・システムを提供します。また、コンピュー
タとオペレーティング・システムに付属するマニュアルを利用することも
できます。PC のオンライン・ヘルプには、次の情報が記載されています。

メニュー・バー上のコマンドの選択方法

メニュー項目の選択方法と閉じ方

ツールバーの使用方法

タイトル・バーとステータス・バーの理解

アイコンとボタンのクリック方法

ダイアログ・ボックスの扱い方

さまざまなウィンドウの扱い方

オンライン・ヘルプの使用方法

最初は [Help]⇒ [Welcome]を選択して、[Welcome] 画面から開始する

ことをお勧めします。この画面から VEE マルチメディア・チュートリアル

にアクセスできます。[Welcome] 画面を図 1-2 に示します。
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図 1-2. ヘルプにおける VEE の [Welcome] 画面

VEE のオンライン・ヘルプは、お使いのオペレーティング・システムに合

わせて設計されています。[Help]をクリックすると、図 1-3 のようなメ

ニューが表示されます。[Help] メニューでは、[Contents and Index] とチュー

トリアルがある [Welcome] メニューのほか、計測器ドライバ、Web サイト

情報、サンプル、バージョン情報などが提供されます。

この入門トレーニングは、VEE のマニュアルを使用しなくても完了できま

す。しかし、特定の機能や概念についてより詳しく知りたい場合は、製品
のマニュアルを参照してください。特定の VEE トピックを検索するには、

ヘルプ・システムを使用します。ヘルプ・システムでは、関連するトピッ
クに「ジャンプ」することもできます。
26 第第第第1章章章章 



Agilent VEE 開発環境の使用方法

Agilent VEE の対話型操作の対話型操作の対話型操作の対話型操作
図 1-3. [Help] メニューの使用

[Contents and Index]を選択すると、図 1-4 のような VEE ヘルプが表

示されます。

ただし、HP-UX の画面は少し異なります。
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図 1-4. VEE ヘルプの [ 目次 ] タブ

ヘルプの [目次 ]タブには、次のトピックがあります。

「Agilent VEE 6.0 の
新機能」

新機能について説明します。

「使用法」 基本的な操作方法を説明します。

「以下の項目についての
説明」

VEE の概念を説明します。

「Agilent VEE サンプル・
プログラム・ガイド」

VEE に搭載されているサンプル・プログラ

ムの要約です。

「リファレンス」 すべての関数およびオブジェクトに関する
リファレンス情報を提供します。
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メモ 選択したオブジェクトやダイアログ・ボックスについてのヘルプを簡単に
表示するには、キーボードの F1 キーを押します。また、オブジェクト・

メニューの [Help]をクリックして、そのオブジェクトについての情報を

得ることもできます。

プログラム開発時にオンライン・ヘルプの特定の機能を使用する方法につ
いての詳細は、101 ページの「ヘルプ機能の使用方法」を参照してください。

「Agilent VEE サポートに
ついて」

VEE サポートの利用方法についての情報を

提供します。

「Agilent VEE Pro RunTime
製品のインストールと配布
方法」

VEE Pro RunTime 環境の配布方法を説明し

ます。
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オブジェクトの扱い方

VEE プログラムは、接続されたオブジェクトで構成されます。プログラム

を作成するには、Flow、Data、Displayなどのオブジェクトを VEE メ

ニューから選択します。そして、オブジェクトのピンに付いているライン
を介してオブジェクトを接続します。ピンについての詳細は、48 ページの

「ピンと端子について」を参照してください。接続されたオブジェクトのグ
ループでプログラムが作成されます。

このセクションでは、プログラム内のオブジェクトの選択方法と使用方法
を説明します。

1. VEE を起動する。Windows では、[スタート ]⇒ [プログラム ]⇒

[VEE Pro 6.0]をクリックします。HP-UX では、HP VUE または X11
ウィンドウのシェル・プロンプトで「veetest」と入力し、Return
キーを押します。PATH 変数に /usr/bin が含まれている必要があり

ます。

2. このセクションの説明に従ってオブジェクトの扱い方を学びます。

メモ 次の練習では、VEE ソフトウェアが実行されていることが前提となりま

す。VEE の起動方法については、上の説明、または 23 ページの「Agilent 
VEE の起動方法」セクションを参照してください。

作業領域へのオブジェクトの追加 
適切なプルダウン・メニューを開き、目的のオブジェクトをクリッ
クします。次に、オブジェクトを作業領域内の適切な位置までド
ラッグし、クリックします。輪郭線が消え、オブジェクトが表示さ
れます。

1. たとえば、Function Generatorオブジェクトを作業領域に追加する

には、図 1-5 のように、メニュー・バーから [Device]⇒ [Virtual 

Source]⇒ [Function Generator]を選択します。
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メモ [Virtual Source]メニューの右側にある矢印は、サブメニューがある

ことを示します。メニュー項目名の後に続く 3 つのピリオドは、そのメ

ニューを選択するとダイアログ・ボックスが表示されることを示します。
たとえば、[File]⇒ [Save As...]を選択すると、ダイアログ・ボック

スが表示されます。

図 1-5. 作業領域へのオブジェクトの追加

オブジェクトの輪郭線が作業領域に表示されます。

2. Function Generatorを作業領域の中心まで移動します。クリックし

てオブジェクトを配置すると、図 1-6 のように Function Generator

が表示されます。
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図 1-6. Function Generator オブジェクトの追加

作業領域にオブジェクトを配置したら、オブジェクトのタイトル・バーを
ドラッグしてオブジェクトを移動できます。これは、ウィンドウを移動す
るときと同じ操作です。

メモ これ以降は、説明を簡潔な表現で行います。たとえば、Function 

Generatorオブジェクトの選択は、次のように簡略化して表記します。

[Device]⇒ [Virtual Source]⇒ [Function Generator] 

メモ 画面上により多くのスペースを空けるには、[View]⇒ [Program 

Explorer]をクリックします。これにより、[Program Explorer] メニュー

が選択解除され、プログラム・エクスプローラが画面から消えます。メ
ニュー項目の前にチェック・マークが付いている場合、そのメニュー項目
は「選択」されています。

オブジェクトの表示の変更

VEE では、図 1-7 のように、オブジェクトが「アイコン・ビュー」または

「オープン・ビュー」のいずれかで表示されます。
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図 1-7. オープン・ビューおよびアイコン・ビューのオブジェクト

アイコン・ビューは作業領域内のスペースを節約し、プログラムを読みや
すくします。オープン・ビューはオブジェクトの詳細を表示し、プロパ
ティと設定を編集できます。

1. オープン・ビューからアイコン・ビューに切替えるには、[ 最小化 ] ボ
タン ( オブジェクトのタイトル・バーの右端にある四角形 ) をクリック

します。

2. オープン・ビューに戻るには、アイコン・ビューのオブジェクトの任意
の位置をダブルクリックします。

メモ オブジェクト・メニューで、[Minimize]または [Restore]を選択する

こともできます。オブジェクト・メニューを表示するには、タイトル・
バーの左端にあるオブジェクト・メニュー・ボタンをクリックするか、オ
ブジェクト上でマウスの右ボタンをクリックします。

すべてのオブジェクトが同じ構造や部品を持っているわけではありません
が、オープン・ビューではオブジェクトを編集でき、アイコン・ビューで
はスペースを節約できます。

オブジェクト・メニューの選択

VEE のオブジェクトにはそれぞれオブジェクト・メニューがあり、オブ

ジェクトに対して [Clone]、[Size]、[Cut]、[Move]、[Minimize]

などの操作を実行できます。オブジェクトのほとんどが同様のメニューを
持っていますが、オブジェクトの機能によってメニューに違いがあります。

オープン・ビュー アイコン・ビュー

[ 最小化 ] ボタン

オブジェ
クト・メ
ニュー・
ボタン
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オブジェクト・メニューから、各オブジェクトのオンライン・ヘルプを参
照してください。

1. オブジェクト・メニューを選択するには、オブジェクト・メニュー・ボ
タンを 1 度だけクリックします。オブジェクト・メニューはすべて同じ

方法で開くことができます。オブジェクト・メニューが図 1-8 のように

表示されます。オブジェクト・メニュー・ボタンをダブルクリックしな
いでください。ダブルクリックすると、オブジェクトが削除されます。

2. 次に、いずれかのオブジェクト・メニュー項目をクリックして、目的の
操作を実行します。メニューを閉じるには、メニュー以外の何もない領
域をクリックします。

図 1-8. オブジェクト・メニューの選択

ショートカット : マウス・ポインタをオブジェクト上に置いてマウスの右
ボタンをクリックしても、オブジェクト・メニューを選択できます。この
操作は、オープン・ビューとアイコン・ビューのどちらでも実行できます。

オブジェクトの移動

1. Function Generatorオブジェクトを移動するには、オブジェクト・

メニューで [Move]を選択します。次にマウスの左ボタンをクリック

し、押したままにします。オブジェクトの輪郭線が表示されます。 

2. マウスのボタンを押したまま、図 1-9 のように輪郭線を新しい位置まで

移動します。マウスのボタンを離すと、オブジェクトが新しい位置に移
動します。

オブジェクト・メ
ニュー・ボタン

オブジェクト・
メニュー
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図 1-9. オブジェクトの移動

オブジェクトの移動は、次の方法でも行うことができます。

オープン・ビューで表示されているオブジェクトのタイトル部分をク

リックし、オブジェクトを新しい位置までドラッグします。
オープン・ビューで表示されているオブジェクトの、ボタン、入力

フィールド、ピン、端子、およびオブジェクトのサイズ変更に使用する
四隅以外の場所をクリックして、オブジェクトを新しい位置までドラッ
グします。
アイコン・ビューで表示されているオブジェクトの四隅から離れた場所

をクリックして、アイコンを新しい位置までドラッグします。オブジェ
クトの四隅は、オブジェクトのサイズを変更するときに使用します。

メモ VEE ウィンドウ最下部のステータス・バーに表示される「オブジェクトの

位置情報」は、輪郭線の左上隅の位置をワークスペースの左上隅を基準と
した X 座標と Y 座標 ( ピクセル単位 ) で表したものです。オブジェクトの

正確な位置を表示するには、オブジェクト上でマウスの左ボタンをクリッ
クしてオブジェクトを選択し、マウスの左ボタンを押したままにします。
ステータス・バーに位置が表示されます。オブジェクトを正確に配置する
必要がある場合は、この情報を使用します。
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オブジェクトの複製作成 ( クローン )
クローン操作により、サイズや名前の変更などオブジェクトに対して行っ
た変更内容も含めて、オブジェクトの正確な複製を作成できます。クロー
ンは、カット・アンド・ペースト操作のショートカットです。

1. オブジェクト・メニューを開き、[Clone]を選択します。複製された

オブジェクトの輪郭線が表示されます。 

2. 輪郭線を目的の位置まで移動し、クリックしてオブジェクトを配置しま
す。複製されたオブジェクトが表示されますが、元のオブジェクトも残
ります。図 1-10 では、Function Generatorを 1 つ複製した後で、

さらにオブジェクト・メニューからクローンを実行するコマンドが選択
されています。

図 1-10. オブジェクトのクローン作成

オブジェクトのコピー 
この操作は、オブジェクトをクリップボードにコピーします。コピーした
オブジェクトは、VEE、または MS Paint や MS Word などのほかのアプリ

ケーションにコピーできます。

1. オブジェクトをクリックしてオブジェクトを強調表示します。次に
[Edit]⇒ [Copy]をクリックします。

- または -
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オブジェクトをクリックしてオブジェクトを強調表示します。次に
Ctrl+C キーを押します。

オブジェクトの削除 ( 切取り )
作業領域からオブジェクトを削除する ( または切取る ) には、削除するオ

ブジェクトのオブジェクト・メニューを開き、[Cut]をクリックします。

たとえば、Function Generatorのオブジェクト・メニューを開いて

[Cut]をクリックします。オブジェクトは作業領域から消えますが、カッ

ト・バッファに保存されます。

1. オブジェクト・メニューを開き、[Cut]を選択します。

- または -

オブジェクトをクリックしてオブジェクトを選択し、Ctrl+X キーをク

リックします。

- または -

マウス・カーソルをオブジェクト・メニュー・ボタンに合わせて、ダブ
ルクリックします。

メモ オブジェクト・メニュー・ボタンをダブルクリックしてオブジェクトを不
用意に削除してしまうことがよくありますので、注意してください。誤っ
てオブジェクトを削除してしまった場合は、ツールバーの [Paste]を使

用します。または [Edit]⇒ [Paste]を選択します。これにより、オブ

ジェクトと接続がすべて復元されます。

オブジェクトの貼付け ( 切取りの復元 ) 
次の方法で、コピーまたは削除した ( 切取った ) オブジェクトを作業領域

に貼付けます。

1. オブジェクトをコピーまたは削除した後、[Edit]⇒ [Paste]をク

リックします。オブジェクトの輪郭線が表示されます。オブジェクトを
配置した後、クリックしてオブジェクトを離します。

- または -
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Ctrl+V キーを押します。

メモ オブジェクトにラインが接続されている場合、接続は維持されます。この
操作は、ほかのプログラムの「元に戻す (Undo)」と同じ機能を持っていま

す。この操作を「元に戻す」と呼ばないのは、VEE のすべてのプログラム

操作に適用できるとは限らないためです。たとえば、「元に戻す」操作は、
削除したオブジェクト群に対しても実行できます。

オブジェクトのサイズの変更

1. マウス・ポインタをオブジェクトの四隅のいずれかに置き、サイズ変更
矢印が表示されたら、クリックして目的の大きさになるまでドラッグし
ます。マウスのボタンを離して、サイズを確定します。図 1-11 は、サ

イズ変更矢印でオブジェクトのサイズを変更している例です。

- または -

オブジェクト・メニューを開き、[Size]をクリックします。マウス・

ポインタが角かっこの形になります。この角かっこを、サイズ変更後の
オブジェクトの右下隅が位置する場所に移動し、クリックしてサイズを
変更します。
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図 1-11. オブジェクトのサイズの変更

オブジェクトの名前 ( タイトル ) の変更 

1. オブジェクト・メニューを開き、[Properties]を選択します。

[Properties] ダイアログ・ボックスが表示され、図 1-12 のように現在の

タイトルが強調表示されます。

2. 新しいタイトルを入力して [OK]をクリックします。タイトル領域に新

しいタイトルが表示されます。オブジェクトを最小化すると、アイコン
に新しいタイトルが表示されます。

- または -

1. オブジェクトのタイトル・バーをダブルクリックして [Properties] ダイ

アログ・ボックスを直接開きます。

2. 新しいタイトルを入力して [OK]をクリックします。
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メモ 標準的なキーボードとマウスによる編集テクニックを使用すると、時間を
短縮できます。たとえば、[Properties]ダイアログ・ボックスの

[Title]フィールドで、編集領域の一番左端でクリックすると、そこに

カーソルが表示されます。これにより、既存のタイトルを削除せずに新し
いテキストを追加できます。

図 1-12. オブジェクトのタイトルの変更

オブジェクトの選択 / 選択解除

1. オブジェクトを選択するには、そのオブジェクトをクリックします。オ
ブジェクトに影が付きます。たとえば、図 1-13 では For Countオブ

ジェクトが選択されています。

2. オブジェクトの選択を解除するには、マウス・ポインタを何もない領域
に移動してクリックします。影が消えます。たとえば、図 1-13 では

Formulaオブジェクトは選択されていません。
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図 1-13. 選択されたオブジェクトと選択されていないオブジェクト

メモ 「選択する」という言葉は、メニュー項目の選択を指す場合にも使用されま
すが、前後の文脈から判断すれば、どちらの意味かを確実に判断できます。

複数オブジェクトの選択

オブジェクトをクリックして選択するとき、オブジェクトは 1 つしか選択

できません。別のオブジェクトをクリックして選択すると、前のオブジェ
クトは選択が解除されて影が消えます。複数のオブジェクトを選択し、選
択したすべてのオブジェクトにまとめて [Cut]などの操作を実行するに

は、次のようにします。

1. Ctrl キーを押したまま、選択するオブジェクトのそれぞれをクリックし

ます。すべて選択したら、Ctrl キーを離します。

- または -

Ctrl キーを押します。次に、選択するオブジェクトを四角形で囲むよう

にクリック・アンド・ドラッグします。選択されたオブジェクトに影が
付きます。

すべてのオブジェクトの選択 / 選択解除

1. すべてのオブジェクトを選択するには、[Edit]⇒ [Select All]を

クリックします。または Ctrl+A キーを押します。

2. すべてのオブジェクトの選択を解除するには、ウィンドウ内の何もない
領域でクリックします。
第第第第 1 章章章章 41414141



Agilent VEE 開発環境の使用方法

オブジェクトの扱い方オブジェクトの扱い方オブジェクトの扱い方オブジェクトの扱い方
複数オブジェクトのコピー

1. いずれかのオブジェクトの上にカーソルを置き、選択されている複数の
オブジェクトをコピーします。Ctrl キーを押したままで、マウスの左ボ

タンを使って複数のオブジェクト ( 輪郭線 ) を目的の位置までドラッグ

します。目的の位置にそれぞれのオブジェクトが新しく作成されます。

- または -

[Edit]⇒ [Copy]を使用して、選択した複数のオブジェクトをカッ

ト・バッファにコピーします。[Edit]メニューまたはツールバーにあ

る [Paste]をクリックし、オブジェクト ( 輪郭線 ) を目的の位置まで

移動し、マウスの左ボタンをクリックします。図 1-14 はコピー中のオ

ブジェクトを示しています。

図 1-14. コピー中の複数オブジェクト

メモ Windows 版 VEE で切取ったオブジェクトとコピーしたオブジェクトは、ク

リップボード上にも格納されます。したがって、これらを Windows のク

リップボードをサポートするほかの Windows アプリケーションに貼付ける

ことができます。

オブジェクトの編集

VEE では、オブジェクトをいくつかの方法で編集でき、各編集メニューに

表示される選択肢がそれぞれ異なります。編集メニューまたは編集アイコ
ンを選択するには、次のようにします。
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1. VEE のメニュー・バー上で [Edit]をクリックして [Edit]メニュー

を表示し、実行する操作を選択します。[Edit]メニューのコマンド

は、すべての VEE で共通です。

- または -

VEE のツールバー上のアイコンをクリックします。VEE のツールバー

には、[Cut]、[Copy]、[Paste]などの使用頻度が高い編集コマンド

のアイコンが表示されます。

- または -

オブジェクトのオブジェクト・メニュー・ボタンをクリックしてオブ
ジェクト・メニューを開き、実行する操作を選択します。オブジェク
ト・メニューには、[Properties]メニューなど、メインの [Edit]

メニューには表示されないオブジェクト固有の編集操作が含まれます。
オブジェクト・メニューのコマンドは、オブジェクトの種類によって異
なります。たとえば、[Device]⇒ [Formula]で追加した Formula オ

ブジェクトと、[I/O]⇒ [To]⇒ [File]で追加した File オブジェク

トのオブジェクト・メニューを比較してみてください。この 2 つのメ

ニューには、それぞれのオブジェクトに固有な異なる選択肢が表示され
ます。

- または -

マウス・ポインタを作業領域の何もないスペースに置き、マウスの右ボ
タンをクリックします。[Edit] ポップアップ・メニューが表示され

ます。

メモ アクティブでないメニュー項目には、アクティブな項目とは異なる影が付
きます ( 淡色表示 )。たとえば、[Edit]メニューの [Cut]、[Copy]、

[Clone]操作は、オブジェクトが作業領域内で強調表示されないかぎり、

アクティブなメニュー項目とは異なる影が付いて表示されます。

オブジェクト間のデータ・ラインの作成

1. 一方のオブジェクトのデータ出力ピンの上またはそのすぐ外側でクリッ
クし、次に、もう一方のオブジェクトのデータ入力ピンをクリックしま
す。図 1-15 はこの様子を示しています。ポインタを一方のピンからも

う一方のピンへ移動すると、ポインタの後にラインが表示されます。
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2. カーソルを離すと、VEE は 2 つのオブジェクト間にラインを描きます。

オブジェクトの位置を変更しても、オブジェクト間のラインは維持され
ます。

メモ ピンについての詳細は、48 ページの「ピンと端子について」を参照してく

ださい。

図 1-15. オブジェクト間のデータ・ラインの作成

オブジェクト間のデータ・ラインの削除

1. Shift+Ctrl キーを押したままで、削除するラインをクリックします。

- または -

[Edit]⇒ [Delete Line]を選択します。次に、削除するラインをク

リックします。

作業領域全体の移動

1. 作業領域内に少なくとも 1 つのアイコンがあることを確認します。マウ

ス・ポインタを作業領域の背景に合わせて、マウスの左ボタンを押しま
す。次に、作業領域を目的の方向へ移動します。

データ出力ピン

データ入力ピン
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メモ プログラムが作業領域より大きい場合は、図 1-16 のようにスクロール・

バーが表示されます。

メモ 端子の近くでクリックすると、ライン ( ワイヤ ) が表示される場合があり

ます。その場合は、ポインタを作業領域の外側に移動してダブルクリック
します。

図 1-16. 作業領域のスクロール・バー

作業領域のクリア

1. [Edit]⇒ [Select All]をクリックします。次にツールバー上の

[Cut] ボタンをクリックします。これにより、アクティブ・ウィンドウ

内のすべてのオブジェクトが削除され、カット・バッファに格納され
ます。

- または -

[File]⇒ [New]を選択するか、ツールバー上の [New] ボタンをク

リックします。変更を保存するかどうかを確認するメッセージが表示さ
れます。

垂直のスク
ロール・バー

水平のスクロール・バー
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- または -

オブジェクトをクリックしてアクティブにした後、ツールバーの
[Cut]ボタンをクリックして、オブジェクトを 1 つずつクリアします。

デフォルト設定の変更

[Default Preferences]ダイアログ・ボックスでは、VEE 環境のデ

フォルト設定を変更します。

1. ツールバーの [Default Preferences]ボタンをクリックします。

- または -

[File]⇒ [Default Preferences]をクリックします。図 1-17 の

ように、[Default Preferences]ダイアログ・ボックスが表示され

ます。

図 1-17. [Default Preferences] ダイアログ・ボックス
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このダイアログ・ボックスにはタブがあり、編集するオプションを選択で
きます。

詳細は、VEE メニュー・バーから [Help]⇒ [Contents and Index]

を選択し、オンライン・ヘルプを参照してください。目次から「使用法」、
「以下の項目についての説明」、「リファレンス」のいずれかを選択します。

[General] 先ほど示した方法で [Default Preferences]ダイア
ログ・ボックスを表示したとき、一番手前に表示される
デフォルトのタブです。[Environment]、
[Execution Mode]などのパラメータ値を変更します。

[Colors] VEE 環境の色をカスタマイズします。

[Fonts] VEE 環境のフォントをカスタマイズします。

[Number] 数のデフォルト書式を変更します。

[Printing] 印刷に関するパラメータ値を設定します。

[Web Server] 組込まれている Web サーバ機能を使ってリモートの
Web サーバからプログラムをモニタし、トラブルシュー
ティングを行います。
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ピンと端子について

VEE プログラムは、作業領域内のオブジェクトとそのオブジェクト

を接続するラインで構成されます。VEE オブジェクトを接続するラ

インは、各オブジェクトのピンで接続されます。各オブジェクトに
は図 1-18 のように数個のピンがあります。図 1-18 では、例として

Formulaオブジェクトを挙げていますが、どのオブジェクトでも同

じです。

 

図 1-18. データ・ピンとシーケンス・ピン 

オブジェクト間でデータを伝達するには、データ入力ピンとデータ出力ピ
ンを接続します。特に指定しないかぎり、ピンは上から下の順に実行され
ます。シーケンス・ピンによる接続はオプションです。シーケンス・ピン
を使用すると、実行順序を制御できます。

データ入力ピン オブジェクトの左側にあるピン

データ出力ピン オブジェクトの右側にあるピン

シーケンス
入力ピン

オブジェクトの上辺にあるピン

シーケンス出力
ピン

オブジェクトの下辺にあるピン

シーケンス入力ピン

シーケンス出力ピン

データ入力ピン データ出力ピン
48 第第第第1章章章章 



Agilent VEE 開発環境の使用方法

ピンと端子についてピンと端子についてピンと端子についてピンと端子について
メモ 詳細は、113 ページの「オブジェクト内部のイベントの順番を追跡する」

を参照してください。

オブジェクトをオープン・ビューで表示すると、データ入力 / 出力ピンは

入力 / 出力端子として表示されます。オブジェクトがアイコン・ビューで

表示されている場合は、アイコンをダブルクリックしてオープン・ビュー
に切替えます。端子は、端子名や伝達されるデータの種類と値などの詳細
情報を持ちます。端子のラベルは、オブジェクトがオープン・ビューで表
示されており、オブジェクトの [Show Terminals]オプションが選択さ

れている場合にのみ表示されます。オブジェクト・メニューの
[Properties]を参照してください。

たとえば、図 1-19 には 2 つの Formulaオブジェクトがあります。左側の

Formulaオブジェクトには「A」と「Result」の端子ラベルが表示され

ていますが、右側の Formulaオブジェクトには、[Show Terminals]が

オフになっているためにラベルが表示されていません。

図 1-19. オブジェクトの [Show Terminals] オプション

[Show Terminals]オプションのオン / オフを切替えるには、オブジェク

ト・メニューから [Properties]を選択します。[Properties] ダイアログ・

ボックスでは、[Show Terminals]の前にチェックボックスが表示され

ます ( 図 1-20 参照 )。

[Show terminals]
オプションがオン

[Show terminals]
オプションがオフ
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図 1-20. [Show Terminals] チェックボックスの使用

チェックボックスをクリックすると、[Show Terminals]がオフになり

ます。チェックボックスを再度クリックすると、[Show Terminals]が

オンに戻ります。選択したら、[OK]をクリックします。

端子の追加

オブジェクトには端子を追加できます。たとえば、Formulaオブ

ジェクトに 2 番目のデータ入力端子を追加できます。

1. オブジェクト・メニューを開き、[Add Terminal]⇒ [Data Input]

を選択します。 

- または -

[Show Terminals]がオンの場合は、マウス・ポインタを端子領域

( オープン・ビューで表示されているオブジェクトの左側の余白 ) に置

き、Ctrl+A キーを押します (Ctrl と A のキーを同時に押します )。

図 1-21 では、一方の Formulaのオブジェクトではデータ入力端子を追加

するためにオブジェクト・メニューが開かれており、もう一方の Formula

オブジェクトでは 2 番目の端子がすでに追加されています。新しい端子に

はラベル「B」が付けられています。データ入力が計測器ドライバのような

特定の機能に結び付けられている場合は、その機能のメニュー名が付けら
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れます。それ以外の場合、端子には「A」、「B」、「C」などの名前が付けら

れます。

図 1-21. 端子の追加

端子情報の編集

端子についての情報を表示するには、ラベル領域をダブルクリックします。
たとえば、「B」をダブルクリックすると、図 1-22 のダイアログ・ボックス

が表示されます。

 

図 1-22. 端子情報の表示
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これで、端子を編集できます。ダイアログ・ボックスには 3 種類のフィー

ルドがあります。

図 1-23. 選択フィールドの使用

データ入力端子に「Any」以外のデータ型を選択すると、端子は、指定し

たデータ型またはその型に変換できるデータだけを受入れるようになりま
す。通常、[Required Type]および [Required Shape]フィールドに

は [Any]を設定しておくことをお勧めします。詳細は、VEE メニュー・

バーから [Help]⇒ [Contents and Index]を選択し、オンライン・ヘ

ルプを参照してください。「使用法」、「以下の項目についての説明」、
「リファレンス」のいずれかを選択します。

入力
フィールド

背景が白く矢印の付いていないフィールドです。ク
リックすると、入力できるようになります。たとえ
ば、[Name]フィールドの [B]をクリックすると、端
子の名前を変更できます。

ステータス・
フィールド

灰色の背景のフィールドは、編集できません。たとえ
ば、[Mode]フィールドは編集できません。

選択
フィールド

背景が白で右側に矢印が付いているフィールドです。
フィールドまたは矢印をクリックするとドロップダウ
ン・リストが表示されます。たとえば、[Required 
Type]フィールドの [Any]または矢印をクリックす
ると、図 1-23 のようなリストが表示され、リストをク
リックすることによって別のデータ型を選択できます。
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端子の削除

1. オブジェクト・メニューを開き、[Delete Terminal]⇒ [Input]を

選択します。または [Delete Terminal]⇒ [Output]を選択して、

削除する入力 / 出力端子を選択し、[OK]をクリックします。たとえば、

図 1-24 は、[Delete Terminal]⇒ [Input]を選択した場合に表示

されるダイアログ・ボックスです。

- または -

マウス・ポインタを端子の上に置き、CTRL+D キーを押します。

図 1-24. [Delete Terminal] ダイアログ・ボックス
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オブジェクトの接続とプログラムの作成 
このセクションでは VEE プログラムの作成方法を紹介します。例題 1-1 で

は、VEE プログラムの作成、VEE の画面の印刷、プログラムの保存を行い

ます。

例題 1-1 : 波形表示プログラム

VEE プログラムは、実行可能なオブジェクト・ダイアグラムに接続された

VEE オブジェクトで構成されています。次のプログラムは波形を表示し

ます。

VEE がすでに実行されている場合は、ツールバーの [New]ボタンをク

リックするか、[File]⇒ [New]を選択して、ワークスペースをクリアし

ます。まだ起動していない場合は、VEE を起動して、次に進みます。

1. プログラムのドキュメントを作成します。[Display]⇒ [Note Pad]

を選択して、作業領域の上部中央に配置します。編集領域をクリックし
てカーソルを置き、次のように入力します。

Display Waveform generates a cosine waveform and sends 

it to a real time display. (波形表示プログラムは余弦波の波

形を生成して、同時に画面に表示します )

画面によっては、Note Padのサイズを変更しなければならない場合が

あります。オブジェクトのサイズを変更するには、オブジェクト・メ
ニューを開いて [Size]を選択し、サイズ変更矢印をオブジェクトの隅

に移動してドラッグします。オブジェクトのいずれかの隅をクリック
し、ドラッグすることもできます。

2. Function Generatorオブジェクトを追加します。[Device]⇒

[Virtual Source]⇒ [Function Generator]を選択します。次

に、輪郭線を作業領域の左側まで移動してクリックし、オブジェクトを
配置します。[Frequency]フィールド内でクリックし、「100」と入力

して周波数に 100 を指定します。

3. Waveform(Time)オブジェクトを追加します。[Display]⇒

[Waveform (Time)]を選択して、図 1-25 のように作業領域の右側に

オブジェクトを配置します。
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図 1-25. プログラムの作成

図 1-25 の Function Generatorオブジェクトにある Funcラベルは

データ出力ピンを表し、Waveform(Time)オブジェクトにある

Trace1ラベルはデータ入力ピンを表します。VEE プログラムでは、オ

ブジェクト間でデータ・ピンを接続することにより、プログラムの流れ
を決定します。

4. Function Generatorのデータ出力ピン (Funcの右 ) を Waveform 

(Time)のデータ入力ピン (Trace1の左 ) に接続して、プログラムを完

成します。接続するには、カーソルをピンの一方へ移動します。

カーソルを接続可能なピンに近づけると、カーソルの形が変化します。
マウスの左ボタンをクリックし、マウス・カーソルをもう一方のピンま
で移動して、もう一度クリックします。2 つのピンの間にラインが自動

的に引かれ、プログラムが完成します。

一方のオブジェクトのタイトル・バーをドラッグして、移動してみてく
ださい。ピンや端子をドラッグすると、ラインが引かれるので注意して
ください。2 つのオブジェクト間の論理パスに従って、ラインが自動的

に引き直されます。
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ラインが煩雑に見える場合は、[Edit]⇒ [Clean Up Lines]を選択

し、プログラム内のラインを引き直します。

プログラムの実行

5. 同じ例題で練習を続けます。ツールバーの [Run] ボタンをクリックする

か、[Debug]⇒ [Run]を選択して、プログラムを実行します。プログ

ラムは、図 1-26 のように、Waveform (Time)画面に 100Hz の余弦波

を表示します。なお、オブジェクトの周波数が異なってもかまいませ
ん。周波数は、この例題では重要ではありません。

図 1-26. プログラムの実行

ツールバーでは、[Run] ボタンだけでなく、[Stop]、[Pause]、[Step Into] ボ
タンもプログラムを制御するために使用できます。プログラムの実行を休
止 (Pause) した場合は、[Resume] ボタン ([Run] ボタンと同じ ) を使って再

開できます。ツールバーの [Step Into] ボタンを使用して、オブジェクトを

1 つずつ実行することもできます。
56 第第第第1章章章章 



Agilent VEE 開発環境の使用方法

オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成
プログラムの実行方法を理解したら、ツールバーの [Run] ボタンをクリッ

クするか、Ctrl+G キーを押してください。または、次のキーボード・

ショートカットを使用します。

オブジェクトのプロパティの変更

オブジェクト・メニューから [Properties]を選択してオブジェクトの

プロパティを変更する方法については、すでに説明しました。オープン・
ビューでは、オブジェクトの一般的なプロパティを直接変更できます。
Function Generator オブジェクトには 2 種類のフィールドがあります。右側

に矢印が付いているフィールドは選択フィールドです。

6. 同じ例題で練習を続けます。Functionフィールドの [Cosine]( また

は矢印 ) をクリックします。選択肢がドロップダウン・リストに表示さ

れます。[Sine]をクリックして、図 1-27 のように正弦関数を選択し

ます。[Function] フィールドが [Cosine] から [Sine]に変わり

ます。

[Pause] Ctrl+P

[Resume] Ctrl+G

[Step Into] Ctrl+T
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図 1-27. [Function] フィールドを正弦波に変更

ダイアログ・ボックスには、矢印が付いていないフィールドもありま
す。これらは入力フィールドで、クリックすると入力できます。フィー
ルド内をクリックするとカーソルが表示されます。標準のキーボードと
マウスによる編集方法でカーソルを移動し、目的の値を入力します。

7. [Frequency]フィールドの数値 100の右側をクリックします。次に、

マウスのボタンを押したままマウスを左へ動かして、図 1-28 のように

最後の 0 が強調表示されるようにします。

図 1-28. [Frequency] フィールドの数字を強調表示する
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8. Delete キーを押して最後の 0を削除して、[Frequency]の値を [10]

に変更します。プログラムを実行します。図 1-29 のように表示されます。

図 1-29. [Frequency] フィールドを [10Hz] に変更した例

今度は、10Hz の正弦波の波形が表示されました。次に、オブジェクトのパ

ラメータを以下のように変更してみます。

Function Generatorオブジェクトの[Deg](または矢印 )をクリック

し、Phase の単位を [Rad]に変更します。次に、[Phase]値フィール

ドをクリックして、値「PI」を入力します。プログラムを実行して、

表示される波形に位相のシフトが起きていることを確認します。次に、
[Phase]値を [0]に、単位を [Deg]に戻します。

Waveform (Time)オブジェクトのY軸の限界値は、あらかじめ-1から

1までに設定されています。Y 軸の名前 [Mag]をクリックして、設定

変更のためのダイアログ・ボックスを表示します。[Maximum]および

[Minimum]フィールドをクリックして、限界値を [2]と [-2]に変更

します。波形が新しい限界値で表示されます。X 軸スケールに対して同

様のパラメータの変更を行うには、[Time]をクリックします。
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画面の印刷

9. 同じ例題を使って練習を続けます。画面を印刷するには、[File]⇒

[Print Screen]を選択します。Windows では、図 1-30 のダイアロ

グ・ボックスが表示されます。

 

図 1-30. 画面の印刷

[OK]をクリックすると、VEE はダイアログ・ボックスに示されたデ

フォルトのプリンタで画面を印刷します。プリンタの変更、印刷範囲の
変更、部数の変更が可能です。[プロパティ ]ボタンをクリックする

と、ほかの設定も行うことができます。プリンタ・ドライバにより、表
示されるダイアログ・ボックスも異なります。Windows のダイアログ・

ボックスの使用方法についての詳細は、Microsoft Windows のヘルプを

参照してください。

HP-UX では、図 1-31 のダイアログ・ボックスが表示されます。
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図 1-31. [Print Screen] ダイアログ・ボックス

[OK]をクリックすると、VEE は選択したプリンタで画面を印刷しま

す。このダイアログ・ボックスでは、グラフィック・プリンタまたはテ
キスト・プリンタを選択します。また、印刷の前にデバイスの設定を変
更します。

ショートカット : ツールバーの [Print Screen]ボタンをクリックして、

画面を直接印刷できます。

プログラムの保存 
プログラムは、作業領域内の内容やプログラムが完成しているかどうかに
かかわりなく、いつでも保存できます。

10. 同じ例題で練習を続けます。[File]⇒ [Save As]を選択して、ダイ

アログ・ボックスで必要事項を設定します。

[Save File]という名前のダイアログ・ボックスが表示されます。図

1-32 に PC で表示されるダイアログ・ボックスの形式を示します。
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図 1-32. [Save File] ダイアログ・ボックス (PC)

11. 特に指定しないかぎり、Windows 版 VEE は、My Documentsディレク

トリのサブディレクトリ VEE Programsにファイルを保存します。作

成中の例題プログラムを保存するには、[File name]フィールドに

「simple-program」と名前を入力して [Save]をクリックします。拡

張子を指定しないと、VEE が自動的に拡張子 .veeをファイル名に追加

します。

メモ Windows 版 VEE では、Windows 95、Windows 98、Windows 2000、および

Windows NT 4.0 で認められている長いファイル名を使用できます。

PC の [Save File]ダイアログ・ボックスでは、次の設定を行うことがで

きます。

[ 保存する場所 ] ドロップダウン・メニューを開いてディレクトリま
たはドライブを変更します。フォルダを開くには、
そのフォルダをダブルクリックします。

[ ファイル名 ] 任意のファイル名を入力します。
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メモ 評価キット・ソフトウェアを使用している場合、プログラムは EVAL.VEE

というファイルにだけ保存できます。ほかの例題で練習する場合は、この
ファイルを上書きしてください。

HP-UX 版の [Save File]ダイアログ・ボックスについては、図 1-33 を

参照してください。

[ ファイルの種類 ] VEE プログラムは、通常 .veeという拡張子が付け
られて保存されますが、ファイルの種類は変更でき
ます。拡張子を付けずにファイル名を入力すると、
拡張子 .veeが自動的に付加されます。

[Save colors and 
fonts with 
program]

( オプション ) [Default Preferences]メ
ニューを使ってプログラムの色とフォントを変更
し、次にプログラムをロードしたとき、デフォルト
の色およびフォントではなく、変更した色および
フォントが使用されるように設定するには、この項
目をチェックします。

チェックすると、デフォルト設定に加えた変更がプ
ログラムの一部として保存されます。

[Save I/O 
configuration with 
program]

( オプション ) [Instrument Manager]で計測器
を設定し、次にプログラムをロードしたときに、デ
フォルトではなく変更した値を使用するには、この
項目をチェックします。

チェックすると、I/O 設定がプログラムの一部とし
て保存されます。
第第第第 1 章章章章 63636363



Agilent VEE 開発環境の使用方法

オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成
図 1-33. [Save File] ダイアログ・ボックス (UNIX)

特に指定しないかぎり、HP-UX 版 VEE は、VEE を起動したディレクトリ

にファイルを保存します。作成中の例題プログラムを保存するには、ファ
イル名 ( たとえば、simple-program.vee) を入力して [OK]をクリック

します。

ファイルを別のディレクトリに保存するには、Backspace キーを使用し

て、「./」を削除します。次に、完全なパスを含めてファイル名を入力し、

[OK]をクリックします。HP-UX では、拡張子「.vee」を追加する必要が

あります。

ヒント : ダイアログ・ボックスの入力内容を簡単に置換えるには、マウス・
ポインタで入力内容をクリック・アンド・ドラッグして強調表示します。
または入力フィールドをダブルクリックして、入力内容を強調表示します。
次に訂正内容を入力して [OK]をクリックします。

メモ 同じファイル名でプログラムを再保存するには、任意の時点で [Save]ボ

タンをクリックするか、Ctrl+S キーを押します ([File]⇒ [Save])。プ

ログラム作成中はファイルの保存を頻繁に行うことをお勧めします。編集
したプログラムを別のファイル名で保存するには、Ctrl+W キーを押すか、

[File]⇒ [Save As]を選択します。
64 第第第第1章章章章 



Agilent VEE 開発環境の使用方法

オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成オブジェクトの接続とプログラムの作成
Agilent VEE の終了

12. [File]⇒ [Exit]を選択して VEE のアプリケーション・ウィンドウ

を閉じます。

ショートカット : Ctrl+E キーを押して VEE を終了します。またはタイト

ル・バーの右端にある [x] ボタンをクリックします。

万一、VEE がマウスやキーボードに反応しなくなった場合は、次の操作を

行ってください。 

Agilent VEE の再起動とプログラムの実行

1. PC:Windows では、[Start]⇒ [Programs]⇒ [VEE Pro 6.0]を選

択します。

HP-UX: ホーム・ディレクトリから、「veetest」と入力します。イン

ストール時に、パスに含めるべき /usr/bin/veetestへのリンクが実

Windows 95 およ
び Windows 98 の
場合

Ctrl+Alt+Delete キーを押すと、さまざまなオプショ
ンを含むウィンドウが表示されます。Microsoft 
Windows の指示に従って操作します。または [終
了 ]をクリックします。

Windows NT 4.0
および Windows 
2000 の場合

Ctrl+Alt+Delete キーを押し [Task Manager]ボタ
ンをクリックします。アプリケーション・リストで
VEEを選択し、[終了 ]をクリックします。

HP-UX の場合 プロセスを kill する必要があります。kill は UNIX
の用語です。

1. プロセスの ID 番号を確認するために、HP-UX
のプロンプトで「ps -ef | grep vee」と入

力します。行末に veetestと表示された行が

表示されます。ログイン名の後ろの数字がプロ
セスの ID 番号です。たとえば、johnj 
number... veetestと表示されます。

2. 「kill -9 number」と入力して VEE アプリケー

ションを終了します。その後、「veetest」と

入力すると再起動できます。
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行ファイルに作成されています。作成されていない場合は、そのディレ
クトリに移動します。VEE を別のディレクトリにインストールした場

合は、完全なパスを入力する必要があります。

2. [File]⇒ [Open]を選択し、[Open File]ダイアログ・ボックスで

必要な設定を行います。

ダイアログ・ボックスの形式は [Save File]ダイアログ・ボックスと

同じです。Windows 版 VEE では、インストール時に特に設定を行って

いなければ、ユーザが作成したプログラムのデフォルトのディレクトリ
は、「VEE_USER」ディレクトリです。VEE はプログラムをメイン・

ウィンドウで開きます。

3. [Run] ボタンをクリックします。このボタンは、小さい矢じりに似た形

をしており、図 1-34 のように、ツールバーの [Debug]メニューの下に

あります。

 

図 1-34. ツールバーの [Run] ボタン

メモ PC: Windows では、コマンド vee.exe -r filename を入力すると、VEE が

起動して、filename で指定したプログラムが自動的に実行されます。たと

えば、Windows のデスクトップ上にアイコンを作成し、アイコンのプロパ

ティに、特定の VEE プログラムを実行するためのショートカットを設定し

ます。こうしておくと、デスクトップ上のアイコンをダブルクリックする
だけで、自動的に VEE を起動してプログラムを実行できます。詳細は、

Windows のコマンドおよびプロンプトのパスについてのヘルプを参照して

ください。

HP-UX: veetest -r filename コマンドを実行すると、VEE が起動して

filename で指定したプログラムが自動的に実行されます。VEE ディレクト

リがパスに含まれていない場合は、完全なパス ( 通常は

/usr/bin/veetest -r filename) を入力する必要があります。

[Run] ボタン
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ワークスペースでの複数ウィンドウの管理

ここまでの説明のほとんどは、メイン・ウィンドウ内の作業領域について
でした。しかし、大きな VEE プログラムでは、メイン・ウィンドウ内に複

数のウィンドウが含まれることがあります。たとえば、UserObjectsや

UserFunctionsなど、ユーザが定義したオブジェクトがプログラムに含

まれる場合があります。UserObjectsおよび UserFunctionsは、メイ

ン・プログラムのサブ・ルーチンまたはサブ・プログラムと考えることが
できます。UserObjectsおよび UserFunctionsについては、第 2 章

「Agilent VEE のプログラミング技術」の 80 ページの「UserObject の作成方

法」セクションで詳述します。ここでは、VEE の複数ウィンドウを含むプ

ログラムの管理方法を説明します。

図 1-35 は、4 つのウィンドウがあるプログラムを示しています。それぞれ

のウィンドウには、メニュー・コマンドを備えたアイコン、タイトル、[ 最
小化 ] ボタン、[ 最大化 ] ボタン、および [ 閉じる ] ボタンがあります。

ウィンドウを最大化すると、VEE ワークスペースで使用できる領域がその

ウィンドウで占有されます。ウィンドウを最小化すると、VEE ワークス

ペースの最下部にそのウィンドウのアイコンが表示されます。ウィンドウ
を閉じると、ウィンドウはワークスペースから消えます。VEE では、作業

中のウィンドウはタイトル・バーが強調表示されます。
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図 1-35. 作業領域における複数ウィンドウ

図 1-35 のように、プログラムの階層構造がプログラム・エクスプローラに

リストされます。この組込みのモジュール構造により、プログラムのすべ
ての部分に簡単にアクセスできます。

プログラム・エクスプローラが表示されていない場合は、[View]⇒

[Program Explorer]をクリックします。デフォルトの設定では、プロ

グラム・エクスプローラが表示されます。[Program Explorer]メ

ニューのチェックを外し、次に [File]⇒ [Default Preferences]を

選択すると表示されるダイアログ・ボックスで [Save]ボタンをクリック

すると、次に VEE を起動したときからプログラム・エクスプローラが表示

されなくなります。

メイン・ウィンドウを一番手前に表示するには、メイン・ウィンドウをク
リックするか、プログラム・エクスプローラでメイン・ウィンドウのアイ
コンをダブルクリックします。

メモ VEE でメイン・ウィンドウを閉じた後、[View]⇒ [Main]を選択する

と、再びメイン・ウィンドウが表示されます。

最小化されている
User Object

プログラム・
エクスプ
ローラ メイン・

ウィンドウ

オープン・
ビューの
UserObject

アイコン・
ビューの
UserObject
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Agilent VEE プログラムの動作

VEE では、プログラムの一般的な処理の流れを伝達と呼びます。プログラ

ムの伝達は、プログラム内のオブジェクトの物理的な位置によって決定さ
れるのではなく、オブジェクトの接続のされ方によって決まります。伝達
は、第一にデータ・フローによって決定されます。そしてデータ・フロー
は、オブジェクトのデータ入力ピンとデータ出力ピンがどのように接続さ
れているかによって決定されます。

メモ C、BASIC、Pascal などほかのプログラミング言語では、プログラム文が実

行される順序は、シーケンスと選択ルールの組合わせによって決定されま
す。一般にプログラム文は、特定の文が別の文やコードのスレッドへの分
岐を生じないかぎり、プログラムに記述されている順番で実行されます。

VEE プログラムでのデータ・フローの規則は次のとおりです。

データはオブジェクト内を左から右へ移動します。つまり、データ・ピ

ンがあるすべてのオブジェクトにおいて、左側のデータ・ピンは入力ピ
ン、右側のデータ・ピンは出力ピンということになります。

オブジェクトのデータ入力ピンは、すべて接続する必要があります。接

続していない場合、プログラムを実行するとエラーになります。

オブジェクトは、すべてのデータ入力ピンが新しいデータを受取るま

で、動作しません。

オブジェクトは、接続されている適切なデータ出力ピンがすべてアク

ティブになったときに動作を終了します。

VEE では、シーケンス入力 / 出力ピンを使って動作の順番を変更できます。

しかし、通常はシーケンス・ピンを使用する必要はありません。一般に、
シーケンス・ピンの使用はお勧めできません。できれば、データ・フロー
によってプログラムの実行を制御してください。

例題 1-2 : データ・フローと伝達の表示 
データ・フローを表示するには、まず作成したプログラムを開きます。
ツールバーの [Open]ボタンをクリックして、「simple-program.vee」

プログラムを開いてください。「simple-program.vee」プログラムにつ
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いては、54 ページの「波形表示プログラム」セクションで説明されていま

す。次に、プログラムを実行します。プログラムが図 1-36 のように表示さ

れますが、パラメータを変更している場合は結果が多少異なる場合もあり
ます。

図 1-36. simple-program.vee プログラムの典型的な表示

ここでは、Function Generatorオブジェクトのデータ出力ピンが、

Waveform (Time)オブジェクトのデータ入力ピンに接続されています。

プログラムを実行しても、Waveform (Time)オブジェクトは、

Function Generatorオブジェクトからデータを受取るまで動作しませ

ん。これは、データ・フローの簡単な一例です。

例題 1-3 : Noise Generator の追加

Noise Generatorオブジェクトを simple-program.veeに追加するこ

とにより、図 1-37 のようにノイズ付きの正弦波を加えます。
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図 1-37. Noise Generator オブジェクトを追加した例

メモ このマニュアルに記載されている練習問題やプログラミング例で使用した
VEE プログラムの多くは、VEE に付属しています。[Help]⇒ [Open 

Example...]⇒ [Manual]⇒ [UsersGuide]を選択してください。

1. 元のプログラムで、Function Generatorと Waveform (Time)の

オブジェクトを接続しているラインを削除します。ツールバーの
[Delete Line] ボタンをクリックし、次にラインをクリックします。また

は、Shift+Ctrl キーを押したままでラインをクリックします。

2. Function Generatorを最小化してアイコンにします。

3. Noise Generatorオブジェクトを追加します。それには、[Device]

⇒ [Virtual Source]⇒ [Noise Generator]を選択します。

4. [Device]⇒ [Function & Object Browser]を選択し、A+Bオブ

ジェクトを追加します。

Function & Object Browserが図 1-38 のように表示されます。

[Type]では、[Operators]を選択します。[Category]では、

[Arithmetic]を選択します。[Operators]では、[+]を選択しま

す。[Create Formula]をクリックし、作業領域の Function 

Generatorと Waveform(Time)オブジェクトの間にオブジェクトを

配置します。A+Bオブジェクトを最小化します。
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図 1-38. Function and Object Browser

5. 入力ピンと出力ピンを図 1-37 のように接続します。

6. プログラムを実行します。

A+Bオブジェクトは、Function Generatorと Noise Generator

オブジェクトが動作するまで動作しません。また Function 

Generatorと Noise Generatorは、どちらが先に動作してもかまい

ません。結果は同じになります。

A+Bのデータ入力ピンの両方がデータを受取ると、A+Bオブジェクトは

動作して 2 つの値を合計し、結果を Waveform (Time)オブジェクト

に出力します。

メモ VEE プログラムではデータ・フローが動作を決定します。

動作の順番を表示するには、[Debug]メニューで [Show Execution 

Flow]と [Show Data Flow]をオンにします。または、ツールバーの該

当するボタンをクリックします。プログラムを再度実行します。オブジェ
クトが動作すると、そのオブジェクトは強調表示され、小さい四角形の
マーカがラインに沿って移動してデータの流れを表します。
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メモ [Show Execution Flow]と [Show Data Flow]を有効にするには、

ツールバーの該当するボタンをクリックするか、[Debug]メニューでそれ

ぞれのコマンドを選択します。プログラムの実行速度が遅くなるため、通
常、これらのコマンドはオフにしておくことをお勧めします。

例題 1-4 : Amplitude 入力端子および Real64 Slider オ
ブジェクトの追加

simple-program.veeプログラムに Amplitude( 振幅 ) 入力端子と Real64 
Slider オブジェクトを追加します。

1. オブジェクト・メニューをクリックするか、またはマウス・ポインタを
Noise Generatorの左側の端子領域に置き、Ctrl+A キーを押します。

入力端子を追加するためのダイアログ・ボックスが図 1-39 のように表

示されます。

図 1-39. 入力端子を追加する例

2. [Amplitude]を選択し、[OK]をクリックします。Amplitude入力端

子が表示されます 

これで、Noise Generatorオブジェクトに Amplitude 入力ピンが追加

され、振幅データを実数として入力できます。VEE には、[Data]メ

ニューに Real64 Sliderというオブジェクトがあり、データ入力を

簡単に行うことができます。Real64 Constantオブジェクトまたは

Real64 Knobオブジェクトを使用することもできます。

3. [Data]⇒ [Continuous]⇒ [Real64 Slider]を選択して、

Real64 Sliderオブジェクトを追加します。次に、図 1-40 のように、

Real64 Slider オブジェクトのデータ出力ピンを Amplitude 端子に接続し

ます。プログラムを実行します。
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図 1-40. Real64 Slider オブジェクトを追加した例

Real64 Slider オブジェクトのスライダをドラッグして、ノイズの

振幅を変更してみてください。プログラムを実行すると、ノイズの
振幅が変化します。表示される波形のノイズ要素は Real64 Slider

が出力する値で決まります。

ここでも、実行順序はデータ・フローで決定されます。Noise 

Generatorは、Real64 Sliderが動作するまで動作しません。A+B

オブジェクトは、Function Generatorと Noise Generatorが動

作するまで動作しません。ただし、どちらのオブジェクトが先に動
作するかは問題になりません。最後に、A+Bオブジェクトが動作し

た後で Waveform (Time)オブジェクトが動作します。

メモ マウスをライン上に合わせたままにすると、出力値が表示されます。たと
えば、Real64 Sliderオブジェクトから Noise Generatorオブジェク

トまでのライン上にマウスを合わせたままにすると、0.401と表示されま

す。ライン上の数値 (0.401) は、図 1-41 のように Real64 Sliderに表

示される値と一致します。これらのオブジェクトはアイコン・ビューで表
示されます。
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図 1-41. 出力ピン上の値を表示する

4. プログラムを「simple-program.vee」に保存します。次章では、こ

のプログラムにさらに機能を追加します。
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この章の復習

本章では、次の操作について学びました。次の章に進む前に、必要なト
ピックを復習してください。

メイン・メニュー・バーおよびオブジェクト・メニューからオンライ

ン・ヘルプを参照する。

VEE を起動する。

メイン・メニュー・バー、ツールバーのボタン、作業領域、ステータ

ス・バーの位置を確認する。

プログラム・エクスプローラとは何か、またその目的は何かを説明する。

メイン・メニューおよびオブジェクト・メニューからメニュー項目を選

択する。

オブジェクトに対して、移動、名前の変更、アイコン化、オープン・

ビューへの切替え、サイズの変更、選択、選択解除、削除、クローン作
成などの操作を実行する。

作業領域の移動、クリアを行う。また、複数ウィンドウを管理する。

オブジェクト上のデータ・ピンおよびシーケンス・ピンの位置を確認

し、それぞれの目的を説明する。

端子を検査し、名前を変更する。

オブジェクトを接続してプログラムを作成し、波形データをシミュレー

トする。

プログラムの作成、実行、印刷、保存を行う。

VEE を終了し、プログラムを再度開く。

VEE プログラムのデータ・フローを説明できる。
76 第第第第1章章章章 



2

Agilent VEE のプログラミング技術



Agilent VEE のプログラミング技術

この章の内容

UserObjectの作成方法

入力用ダイアログ・ボックスの追加方法

データ・ファイルの使用方法

パネル・ビュー ( オペレータ・インタフェース ) の作成方法

データの数式処理方法

計測器との通信方法

プログラムのドキュメント作成

デバッグ・ツールの使用方法

平均的な必要時間 :2 時間
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概要概要概要概要
概要

この章では、ユーザが独自のプログラムを構築するときに役立つ VEE プロ

グラミング技術を学びます。たとえば VEE では、UserObjects と呼ばれる

カスタム・オブジェクトを作成できます。また、オペレータが使用するイ
ンタフェースをプログラムの必要な部分だけを表示するように作成するこ
ともできます。これらは、プログラムのパネル・ビューに表示されます。

VEE からファイルにデータを書出したり、ファイルから VEE にデータを

読込むことができます。データ・ファイルおよび関連する I/O トランザク

ションは、計測器、ファイル、文字列、オペレーティング・システム、イ
ンタフェース、ほかのプログラム、Rocky Mountain Basic、プリンタとの通

信など、さまざまな目的に使用できます。

VEE は数多くのデータ形式をサポートします。また、広範な数式処理能力

を提供します。VEE を使用して、さまざまな方法で計測器と通信できま

す。VEE はまた、プログラム内の問題点をデバッグするための強力なデ

バッグ・ツールを提供します。
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一般的な技術

VEE では、メイン・プログラム内に「UserObjects」と呼ばれるオブ

ジェクトの論理的なグループを作成できます。UserObjectオブジェクト

( 以下 UserObject) は、UserObject編集ウィンドウにオブジェクトの

論理的なグループを配置することによって作成します。UserObject編集

ウィンドウ内でメイン・プログラムと同じ方法で入力ピンと出力ピンを接
続します。また通常のオブジェクトと同じように、UserObject自体をメ

イン・プログラム内のほかのオブジェクトに入力ピンと出力ピンで接続で
きます。

UserObjectを開発するということは、メイン・プログラム内で有用な処

理を行う独自のコンテキストを作成するということです。メイン・プログ
ラムの作業領域内でスペースを節約できるうえに、構造化によってわかり
やすいプログラムを記述することができます。

VEE プログラムでは、メイン・プログラム内に複数の入れ子構造の

UserObjectsを入れることができます。UserObjectsはそれぞれ、メ

イン・ウィンドウ内ではアイコン・ビューで表示されます。メイン・プロ
グラムにある UserObjectsのアイコン・ビューと、対応する

UserObjects編集ウィンドウとを関連付けるには、編集ウィンドウで

UserObjectsに名前を付けます。対応するアイコン・ビューも同じ名前

になります。たとえば、UserObjectsに AddNoiseという名前を付けた

場合、メイン・プログラム内のアイコン・ウィンドウと UserObjects編

集ウィンドウのタイトル・バーの両方に AddNoiseが表示されます。次の

例題では、UserObjectsの作成方法を学びます。  

例題 2-1: UserObject の作成方法 
VEE プログラムで UserObjectを作成する方法は、2 とおりあります。

メニュー・バーから [Device]⇒ [UserObject]を選択すると、メイン

ウィンドウに空の UserObjectアイコンが現れるので、このアイコン

にオブジェクトを追加します。UserObjectアイコンをダブルクリッ

クすると、図 2-1 のようにオープン・ビュー表示になります。

プログラム内のオブジェクトを選択します。次に、[Edit]⇒ [Create 

UserObject]をクリックして、選択したオブジェクトから

UserObjectを作成します。
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図 2-1. UserObject 編集ウィンドウ

作成した UserObjectは、メイン・プログラムの一部になります。また

UserObject編集ウィンドウの表示方法には、次のように、アイコン、

オープン・ビュー、画面最下部に最小化の 3 とおりあります。

[ 閉じる ] ボタンをクリックして編集ウィンドウを閉じます。

UserObjectはメイン・ウィンドウ内でアイコンとして表示されます。

[ 最大化 ] ボタンをクリックして編集ウィンドウを最大化します。

UserObject編集ウィンドウは、VEE ワークスペース内で使用できる

全領域を占有します。

[ 最小化 ] ボタンをクリックして編集ウィンドウを最小化します。最小化

された UserObjectは VEE のワークスペースの最下部に表示されます。

メモ UserObjectのアイコン・ビューはメイン・ウィンドウに常にあり、メイ

ン・ウィンドウ内でほかのオブジェクトに接続できます。

メモ 作業を開始する前に、メイン・ウィンドウ内の画面スペースをできるだけ
確保するため、[View]メニューの [Program Explorer]の選択を解除

してください。

では、プログラムから UserObjectを作成してみます。
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1. 73 ページの「Amplitude 入力端子および Real64 Slider オブジェクトの追

加」で作成したプログラム (simple-program.vee) を開きます。プロ

グラムは、主作業領域に表示されます。

2. プログラムから Real64 Sliderを削除します。このオブジェクトは、

この例題では使用しません。Real64 Sliderのオブジェクト・メ

ニューを開いて [Cut]を選択するか、Real64 Sliderのオブジェク

ト・メニュー・ボタンをダブルクリックします。

メモ Real64 Sliderオブジェクトを削除し、Noise Generatorに入力ピン

を残した状態でプログラムを実行すると、Noise Generator上の入力ピ

ン Amplitudeが接続されていないというエラー・メッセージが表示され

ます。VEE プログラムを実行するときは、すべての入力ピンを接続する必

要があります。

3. Noise Generatorオブジェクトで、オブジェクト・メニュー・ボタ

ンをクリックするか、オブジェクト上でマウスの右ボタンをクリックし
て、オブジェクト・メニューを開きます。[Delete Terminal]⇒

[Input]を選択し、削除する入力ピンを選択するためのダイアログ・

ボックスで [Amplitude] を強調表示し、[OK] をクリックします。

4. プログラムの名前を変更します。[File]⇒ [Save As]を選択し、新

しい名前「usrobj-program1.vee」を入力します。

5. 次に、Noise Generatorオブジェクトを最小化して、図 2-2 のように

オブジェクトを再配置します。
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図 2-2. 初期段階の usrobj-program.vee

6. Ctrl キーを押したままマウスの左ボタンを使用して、Noise 

Generatorおよび A+Bオブジェクトを選択します。[Edit]⇒

[Create UserObject]を選択します。「Create UserObject」の

ラベルが付いたダイアログ・ボックスが表示されます。新しい名前を入
力してオブジェクトの名前を変更できます。[OK]をクリックして

UserObjectを作成します。

UserObjectの編集ウィンドウには Noise Generatorおよび A+Bオ

ブジェクトが含まれます。またメイン・ウィンドウには、図 2-3 のよう

に適切な入力ピンと出力ピンが付けられ、接続済みの UserObjectが

自動的に作成されます。

ヒント : キーボードの Home ボタンを押すだけで、UserObjectの左

上にアイコンを配置できます。
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図 2-3. UserObject の作成方法

メモ UserObjectを作成する前にオブジェクトの整理しておくと、作業が楽に

なります。UserObjectに入れるオブジェクトを 1 か所に集めておかな

かった場合、UserObjectは選択したオブジェクトすべてを囲むほどの大

きさになります。その場合は、UserObjectの作業領域を整理して大きさ

を変更し、主作業領域内の適切な位置に UserObjectを移動します。しか

し、あらかじめオブジェクトを論理的に配置した場合は、クリーンアップ
を行う方が簡単です。

メモ [Edit]⇒ [Clean Up Lines]を使用して、プログラム内の経路指定ラ

インを整理できます。このコマンドはコンテキスト依存です。
UserObjectのラインを整理するには、UserObject編集ウィンドウがア

クティブでなければなりません。UserObject編集ウィンドウをクリック

してから、[Edit]⇒ [Clean Up Lines]を使用します。
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ヒント : 初めに UserObject編集ウィンドウ内で UserObjectを作成

してから、UserObjectをアイコン表示にして使用すると、画面のス

ペースを節約できます。

7. UserObjectの動作を把握しやすいように、UserObjectのタイトル

を AddNoiseに変更します。タイトル・バーをダブルクリックして

[Properties] ダイアログ・ボックスに新しいタイトルを入力します。図

2-4 は、これによりプログラムが追跡しやすくなった様子を示してい

ます。

ヒント : オブジェクトの [Properties] ダイアログ・ボックスをすばやく表

示するには、タイトル・バーをダブルクリックします。

図 2-4. UserObject の名前を「AddNoise」に変更

8. [Run] ボタンをクリックして、図 2-5 のようにノイズ付きの余弦波を表

示します。AddNoiseが最小化されてワークスペースの最下部にアイコ

ンで表示されていることを確認してください。AddNoiseを最小化する

には、タイトル・バーにあるアンダーバー (_) の形をした [ 最小化 ] ボ
タンをクリックします。
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図 2-5. ノイズ付きの余弦波

効果的な UserObjectsを作成するコツは、UserObjectsにプログラム

内で論理的な処理を実行させることです。この独自のオブジェクトは、ス
ペースを節約するためだけの手段ではなく、プログラムを構造化する手段
です。UserObjectsを使用すると、VEE プログラムに「トップダウン」

設計の手法を取入れることができます。VEE にはまた、UserFunction

と呼ばれるオブジェクトがありますが、これは繰返し使用できるコード・
モジュールです。UserObjectsと UserFunctionsについての詳細は、

299 ページの第 8 章「Agilent VEE 関数の使用方法」を参照してください。

UserObjectsについての詳細は、VEE メニュー・バーから [Help]⇒

[Contents and Index]を選択してオンライン・ヘルプを参照してくだ

さい。「使用法」、「以下の項目についての説明」、「リファレンス」のいずれ
かを選択します。

この後のセクションでも、この例題を使って学習を続けます。ここでいっ
たん学習を終了する場合は、プログラムに usrobj-program3.veeと名

前を付けて保存してください。
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例題 2-2: ユーザ入力用ダイアログ・ボックスの作成
方法 
プログラム usrobj-program3.veeを開いていない場合は、まずプログ

ラムを開きます。

[Data]⇒ [Dialog Box]のサブメニューには、ダイアログ・ボックス作

成のために次の選択肢があります。[Text Input]、[Int32 Input]、

[Real64 Input]、[Message Box]、[List Box]、[File Name 

Selection]の 6 つです。テキスト、整数、実数用のメニューを選択した

場合は、ダイアログ・ボックスで、プロンプトやラベル、デフォルト値、
値の制約、エラー・メッセージなどを設定できます。これらのダイアロ
グ・ボックスをプログラムに入れると、プログラム実行時にポップアップ
入力ボックスが表示されます。

1. [Data]⇒ [Dialog Box]⇒ [Int32 Input]を選択して、

Function Generatorの左に Int32 Input オブジェクトを配置します。

[Prompt/Label]フィールドを [Enter Frequency:]に変更しま

す。変更を行う前に、忘れずにフィールドをクリック・アンド・ドラッ
グして強調表示してください。[Default Value]を [100]に変更し

ます。

ヒント : 入力フィールドをダブルクリックして入力内容を強調表示する
こともできます。

2. [Value Constraints]の最低値を [1]に、最高値を [193]に変更

します。図 2-6 のように、エラー・メッセージの内容も、新しく入力し

た値を反映するように変更します。最後に Int32 Inputオブジェクト

をアイコン化します。

図 2-6. Int32 Input 設定ボックス
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3. Function Generatorのオブジェクト・メニューを開き、[Add 

Terminal]⇒ [Data Input]を選択します。追加する入力端子選択

のためのダイアログ・ボックスで [Frequency] を選択して [OK] をクリッ

クします。

4. Int32 Inputオブジェクトの上の出力ピンを Function Generator

の入力ピンに接続します。これで、Frequencyは、入力ピンを介して

のみ変更可能になり、[Frequency]入力フィールドでは変更できなく

なります。プログラムは図 2-7 のように表示されます。

図 2-7. Int32 Input を追加した usrobj-program.vee プログラム

5. プログラムを実行します。Int32 Inputの入力ボックスが表示され、

Enter Frequency:と周波数の入力を求められます。入力ボックスに

さまざまな周波数を入力してプログラムを実行してみてください。図
2-8 は、プログラム実行時にポップアップ入力ボックスが表示されたと

ころを示します。ポップアップ・ボックスをクリック・アンド・ドラッ
グするだけで表示位置を制御できます。
88 第第第第2章章章章 



Agilent VEE のプログラミング技術

一般的な技術一般的な技術一般的な技術一般的な技術
図 2-8. プログラム実行時のポップアップ入力ボックス

周波数に 193 以上を指定すると、エラー・メッセージ・ボックスが表示さ

れます。設定したエラー・メッセージが正確に表示されることを確認して
ください。

この後のセクションでも、この例題を使って学習を続けます。ここでいっ
たん学習を終了する場合は、プログラムに usrobj1-program4.veeと名

前を付けて保存してください。

メモ このマニュアルに記載されている練習問題やプログラミング例で使用した
VEE プログラムの多くは、VEE に付属しています。[Help]⇒ [Open 

Example...]⇒ [Manual]⇒ [UsersGuide]を選択してください。

例題 2-3: データ・ファイルの使用方法 
プログラムに To Fileおよび From File オブジェクトを入れることに

より、VEE からデータをデータ・ファイルに書出したり、ファイルのデー

タを VEE に読込むことができます。例題では、構築したプログラムの詳細

ビューに To Fileオブジェクトを追加します。

プログラム usrobj-program4.veeを開いていない場合は、まずプログ

ラムを開きます。
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1. [I/O]⇒ [To]⇒ [File]を選択して、To Fileオブジェクトを主作

業領域に配置します。

2. デフォルトのファイル名 myFileを wavedataに変更します。

[Clear File At PreRun & Open]の左にチェック・マークが付い

ていない場合は、小さい入力ボックスをクリックします。To Fileの

デフォルト設定では、既存ファイルにデータを追加します。しかし、こ
の場合は、プログラムを実行するたびにファイルをクリアします。この
時点で、To File オブジェクトは図 2-9 のように表示されるはずです。

図 2-9. データ・ファイルの追加

3. データを書出すには、Double-Click to Add Transactionのラベ

ルが付いた領域をダブルクリックします。図 2-10 のダイアログ・ボッ

クスが表示されます。[TEXT]フィールド ( または右側の矢印 ) をク

リックしてデータ型のドロップダウン・リストを表示し、
[CONTAINER]をクリックします。[OK] をクリックします。[I/O 

Transaction]ダイアログ・ボックスで [OK]をクリックすると、To 

Fileオブジェクトに入力ピン「a」が自動的に追加されることを確認

してください。

[WRITE CONTAINER]のほかにトランザクションの別のオプションを

確認するには、To Fileのオブジェクト・メニューでヘルプを参照し

てください。トランザクションについては、VEE Pro Advanced 
Techniques マニュアルの付録および第 5 章「テスト結果の保管方法と読

取り方法」で詳述しています。
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図 2-10. I/O トランザクションの選択

4. AddNoise UserObjectのデータ出力ピンを To Fileのデータ入力ピ

ンに接続します。プログラムは図 2-11 のように表示されます。 

メモ データ出力ピンは複数のデータ入力ピンに接続できます。
第第第第 2 章章章章 91919191



Agilent VEE のプログラミング技術

一般的な技術一般的な技術一般的な技術一般的な技術
図 2-11. To File オブジェクトの追加

5. ツールバーの [Run] ボタンを再度クリックして、プログラムをテストし

ます。プログラムは、AddNoise UserObject が出力したノイズ付きの余

弦波を表示し、波形のデータ・コンテナを wavedataファイルに書出

します。

To Fileオブジェクトをダブルクリックしてオープン・ビュー表示に

します。次に入力端子「a」をダブルクリックして内容を確認します。

256 の点を持つ配列が表示されます。

データを読込み直すには、From Fileオブジェクトをプログラムに追加し

ます。

6. [I/O]⇒ [From]⇒ [File]を選択し、それを [Main] 作業領域内に配

置します。READ CONTAINER xに読込みトランザクションを追加し

て、ファイル名を wavedataに変更します ( 手順は To Fileと同じで

す )。次に、AddNoiseと Waveform (Time)オブジェクト間のライン
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を削除して、オブジェクトを図 2-12 のように接続します。To Fileと

From File間のシーケンス・ラインにより、データは読込まれる前に

確実にファイルに書出されます。

7. プログラムを実行します。図 2-12 のように表示されます。プログラム

を「usrobj-program.vee」のファイル名で保存します。

図 2-12. From File オブジェクトの追加

例題 2-4: パネル・ビュー ( オペレータ・インタ

フェース ) の作成方法 
プログラムを開発したら、今度は、オペレータ・インタフェースを作成す
ることになります。これを行うには、プログラムのパネル・ビューを作成
します。ここでは、69 ページの「データ・フローと伝達の表示」で作成し

たプログラムを使って学習します。 
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1. プログラム「simple-program.vee」を開きます。プログラムは図

2-13 のように表示されます。 

図 2-13. simple-program.vee

2. オペレータ・インタフェースとして動作するパネル・ビューに表示する
オブジェクトを選択します。Ctrl キーを押しながら、選択するオブジェ

クトをすべてクリックします ( オブジェクトを間違って選択しないよう

注意してください )。ここでは、Real64 Sliderと

Waveform(Time)オブジェクトを選択します。選択したオブジェクト

には、選択されていることを示す影が表示されます。

3. ツールバーの [Add to Panel]ボタンをクリックして選択したオブ

ジェクトをパネルに追加します。または [Edit]⇒ [Add To Panel]

を選択します。パネル・ビューが現れ、パネルに追加した 2 つのオブ

ジェクトが表示されます。

パネル・ビュー内のオブジェクトのサイズを変更して適切な位置に移動
し、図 2-14 に示したようなパネルを作成します。
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図 2-14. パネル・ビューの作成例

4. メイン・ウィンドウのタイトル・バーの左上にある [To Detail] ボタンを

押して、詳細ビュー表示に切替えます。[To Panel] ボタンをクリックす

ると、パネル・ビューに戻ります。

詳細ビューは、プログラムを編集する通常のウィンドウです。パネル・
ビューでは、詳細ビューとは独立してオブジェクトの移動、サイズの変
更、削除を行うことができます。詳細ビューはプログラムの開発に使用
され、パネル・ビューはオペレータ・インタフェースの提供に使用され
ます。

5. プログラムに simple-program_with_panel.veeと名前を付けて保

存します。 

パネル・ビューでは次のような変更を行うことができます。

パネルの背景色を変更するには、パネル・ビュー表示のメイン・ウィン

ドウでオブジェクト・メニューから [Properties]を選択します。次

に [Colors]を選択し、[Panel View]⇒ [Background:]ボタンを

クリックして、色を選択します。
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オブジェクトの色またはフォントを変更するには、タイトル・バーをダ

ブルクリックして [Properties]ダイアログ・ボックスを表示しま

す。次に、[Colors]または [Fonts]タブをクリックして、色または

フォントを変更します。

パネル・ビューのオブジェクトを浮出し表示するには、そのオブジェク

トの [Properties]ダイアログ・ボックスを開き、タブをクリックし

[Appearance]フォルダを開きます。次に、[Border]グループの

[Raised]を選択します。

パネル・ビューの名前を変更するには、メインの [Properties]ダイ

アログ・ボックスを開き、パネル・ビューに名前を付けます。プログラ
ムを実行すると、入力した名前が表示されます。

例題 2-5: データの数式処理方法 
VEE は、MATLAB のデータ / 信号処理能力のすべてを含む広範な組込み数

式処理能力を提供します。詳細は、VEE Pro Advanced Techniques マニュアル

を参照してください。

データ型の使用
方法

VEE は、テキスト、整数、実数、複素数、座標などを含むさまざまなデー

タ型をサポートします。すでに、前の例題で A+Bオブジェクトが 2 つの波

形をどのように合算するかを学びました。加法 (+)のような数式処理は、

複数のデータ型を処理できるだけでなく、データ型が混在している場合で
も処理を行うことができます。

たとえば、次のプログラムを作成するには、メイン・ウィンドウをクリア
し、メイン・ウィンドウに以下に示すオブジェクトを配置し、それらのオ
ブジェクトを接続します。

1. [File]⇒ [New]を選択して作業領域をクリアします。

2. [Data]⇒ [Constant]⇒ [Real64]を選択して、Real64 

Constantオブジェクトを追加します。

3. [Data]⇒ [Constant]⇒ [Complex]を選択して、Complex 

Constantオブジェクトを追加します。

4. A+Bオブジェクトを追加します。[Device]⇒ [Function & Object 

Browser]を選択して [Function & Object Browser]を表示しま

す。次に、[Type]には [Operators]を、[Category]には
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[Arithmetic]を、[Operators]には [+]を選択します。[Create 

Formula]をクリックしてオブジェクトを作成します。 

5. [Display]⇒ [AlphaNumeric]を選択して、AlphaNumericオブ

ジェクトを追加します。図 2-15 のようにオブジェクトを接続します。

Real64 Constantオブジェクトのデータ入力フィールドに数値

「1.53」を入力します。また Complexオブジェクトに複素数「(2,1)」

を入力します。プログラムを実行すると、図 2-15 のような結果になり

ます。

図 2-15. データ型の使用方法

VEE は、A+Bオブジェクトで、自動的に必要なデータ変換を行ったうえで

加法を実行します。実数 1.53は複素数 (1.53,0)に変換され、複素数

(2,1)に加算されます。結果の複素数 (3.53,1)は、AlphaNumericオ

ブジェクトに表示されます。

メモ 通常、VEE は、すべてのデータ型変換を自動的に処理します。詳細は、

VEE メニュー・バーから [Help]⇒ [Contents and Index]を選択し、

オンライン・ヘルプを参照してください。「使用法」、「以下の項目について
の説明」、「リファレンス」のいずれかを選択します。

データの種類の使
用方法

VEE は、スカラや配列など、さまざまなデータの種類をサポートします。

多くのプログラミング言語とは異なり、VEE のオブジェクトは 1 つの要素

に対してだけよりも配列全体に対して処理を行います。

次のプログラムは、10 要素から成る 1 次元配列を作成し 10 個の値の中央

値を計算して表示します。
第第第第 2 章章章章 97979797



Agilent VEE のプログラミング技術

一般的な技術一般的な技術一般的な技術一般的な技術
1. [File]⇒ [New]を選択して作業領域をクリアします。

2. [Flow]⇒ [Repeat]⇒ [For Range]を選択して、For Rangeオブ

ジェクトを追加します。

3. [Data]⇒ [Sliding Collector]を選択して、Sliding 

Collectorオブジェクトを追加します。

4. median(x)オブジェクトを追加します。[Device]⇒ [Function & 

Object Browser]を選択します。次に、[Type]には [Built-in 

Functions]を、[Category]には [Probability & 

Statistics]を、[Functions]には [median]を選択して、

[Create Formula]をクリックします。

ショートカット : [Function & Object Browser]は、ツールバーの

[fx] ボタンをクリックすると表示できます。

5. [Display]⇒ [AlphaNumeric]を選択して、AlphaNumericオブ

ジェクトを追加します。図 2-16 のようにオブジェクトを接続します。

プログラムを実行します。オブジェクトの入力値を変更していなけれ
ば、結果が図 2-16 のように表示されます。

図 2-16. データ・オブジェクトの接続 

Formula オブジェ
クトの使用

VEE が提供する算術演算子と関数については、オンライン・ヘルプの

「Reference」で解説されています。[Help]⇒ [Contents and 

Index]を選択します。次に、「Reference」を選択して目的の項目を表

示します。

定義済みの演算子および関数オブジェクトを使用するには、[Device]⇒

[Function & Object Browser]( またはツールバーの [fx] ボタン ) を選

択します。[Function & Object Browser]の [Type:]、

[Category:]、[Functions:]の 3 種類のリストで選択を行うことに
98 第第第第2章章章章 



Agilent VEE のプログラミング技術

一般的な技術一般的な技術一般的な技術一般的な技術
よって、演算子 / 関数を選択します。[Create Formula]をクリックして

オブジェクトを作成します。 

定義済みの演算子および関数のほかに、[Device]メニューにある

Formulaオブジェクトを使用して VEE で有効な演算式を作成できます。

このセクションでは、Formulaオブジェクトを使用してプログラムを作成

します。初めにメイン・ウィンドウをクリアしてから、次のステップに進
んでください。

1. メイン・ウィンドウに Function Generatorオブジェクトを追加し、

オブジェクトを修正して 100Hz の余弦波を作成します。[Device]⇒

[Virtual Source]⇒ [Function Generator]を選択します。

2. [Device]⇒ [Formula]を選択して、Formula オブジェクトをメイ

ン・ウィンドウに追加します。オブジェクトの入力端子領域にマウス・
ポインタを置いて Ctrl+A キーを押し、2 番目の入力端子 (B) をオブジェ

クトに追加します。

3. 入力フィールドに演算式「abs(A)+B」を入力します。

4. [Data]⇒ [Constant]⇒ [Real64]を選択して、Real64 
Constantオブジェクトをメイン・ウィンドウに追加します。値

「0.5」を入力します。

5. [Display]⇒ [Waveform (Time)]を選択して、[y-axis]スケー

ルを [-2]から [2]までに設定します。[Automatic Scaling]を

[Off]に設定します。これらのパラメータを設定するダイアログ・

ボックスを表示するには、[Mag]をクリックします。

6. 図 2-17 のようにオブジェクトを接続します。プログラムを実行します。
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図 2-17. Formula オブジェクトのプログラムを作成する

プログラムを実行すると、Formulaオブジェクトは波形の入力値 Aと実数

Bを受取り、Aの絶対値に Bを加算します。

その結果、式 abs(A)+Bは余弦波を「ブレンド」して「DC オフセット」

を追加します。A+Bおよび abs(x)オブジェクトを使用しても同じ結果を

得ることができますが、Formulaオブジェクトに式を読込む方が簡単で、

スペースを節約できます。

Formulaオブジェクトの入力 / 出力端子をダブルクリックしてみてくださ

い。入力端子 Bの実数のスカラが、入力端子 Aの波形データ (1 次元配列 )
の各要素に追加されます。そして、結果として得られた波形が Result端

子に出力されます。

メモ VEE の広範な数式能力をさらに増大するために、さらに数多くの算術関数

が提供されており、MATLAB Script を統合することによって使用できます。

これらの関数は [Function & Object Browser]で表示できます。

MATLAB 関数の使用についての詳細は、第 4 章「テスト・データの分析と

表示」の 189 ページの「Agilent VEE における MATLAB Script の使用」を

参照してください。
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ここまで簡単なプログラムをいくつか作成しました。VEE についてさらに

学ぶには、次の方法があります。

1. まず、[Help]⇒ [Welcome]メニューにあるマルチメディア・チュー

トリアルを実行します。チュートリアルでは、VEE の主要機能の多く

をデモンストレーションし、短時間で VEE について学習できます。

チュートリアルは、VEE プログラムの構築と実行を画面でデモンスト

レーションし、表示される内容について解説します。チュートリアルは
また、VEE を効果的に使用するためのポイントとなる概念を紹介し

ます。

2. VEE に慣れてきたら、オブジェクト・メニューのヘルプでさらに詳し

い情報を探します。オブジェクトの動作について理解できるまで、オブ
ジェクトを試してみることができます。オブジェクトについてさらに知
識が必要な場合は、オブジェクト・メニューでオブジェクトに固有の情
報を得ることができます。最初にその情報を参照してください。

3. ヘルプの目次、索引、検索機能を使用するには、メイン・ウィンドウの
VEE メニュー・バーから [Help]を開きます。

メモ メイン・ウィンドウのヘルプ機能を開いてヘルプの目次リストを表示する
方法については、第 1 章「Agilent VEE 開発環境の使用方法」の 25 ページ

の「ヘルプの利用」を参照してください。

ヘルプ機能の使用方法

オンライン・ヘルプは次のトピックについて情報を提供します。

すべてのメニュー項目およびメニューへのショートカット

計測器ドライバ情報

使用頻度の高い処理とプログラム例

VEE 用語の定義

ヘルプ機能の使用方法
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VEE のバージョン

ヘルプの表示、キーワード索引の使用、関連するトピックへのハイパーリ
ンクの使用、検索を実行できます。VEE には、プログラム開発時に使用で

きるヘルプ機能が数多くあります。

メモ VEE にはまた、Line Probe のような、プログラムの開発およびデバッグに

役立つ機能もあります。詳細は、104 ページの「Agilent VEE におけるプロ

グラムのデバッグ方法」を参照してください。 

オブジェクトについてのヘルプの表示

オブジェクトに関するヘルプを表示するには、オブジェクト・メニュー・
ボタンをクリックしてヘルプを選択します。

[Flow]⇒[Repeat]⇒[For Count]を選択してFor Countオブジェ

クトを作成します。オブジェクト・メニュー・ボタンをクリックして
[Help]を選択します。For Countオブジェクトについてのヘルプの

トピックが表示されます。

[Device]⇒[Formula]を選択してFormulaオブジェクトを作成しま

す。オブジェクト・メニュー・ボタンをクリックして [Help]を選択し

ます。Formulaオブジェクトに表示される特定の式についてのヘルプ

のトピックが表示されます。

[Device]⇒ [Function & Object Browser]を選択します。選択項

目を任意の組合わせで選択して [Help]をクリックします。選択した特

定のオブジェクトについてのヘルプのトピックが表示されます。

オブジェクトのメニューの位置を探す

オブジェクトのメニュー内での位置を探して、そのオブジェクトについて
の情報を表示するには、[Help]⇒ [Contents and Index]を選択しま

す。次に、[Index]タブをクリックしてオブジェクト名を入力し、

[Display]をクリックします。

たとえば、[Help]⇒ [Contents and Index]を選択して、[Index]

タブをクリックし、「Collector」と入力します。[Display]をクリック

すると、Collectorオブジェクトについてのヘルプのトピックが表示さ

れます。
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オンライン・ヘルプの使用方法オンライン・ヘルプの使用方法オンライン・ヘルプの使用方法オンライン・ヘルプの使用方法
ヘルプ機能使用のための追加の練習問題

オブジェクトを削除するためのショートカットを調べる

[Help]⇒ [Contents and Index]⇒「How Do I...」⇒「Use 

the Keyboard Shortcuts」⇒「Editing Programs」⇒「To Cut 

an Object or Text」を選択します。

「端子」という言葉を調べる

[Help]⇒ [Contents and Index]⇒「Reference」⇒

「Glossary」⇒「Terminal」を選択します。

VEE のバージョンを調べる

[Help]⇒ [About VEE Pro]を選択します。

Agilent VEE の本バージョンの新機能を知る

[Help]⇒ [Contents and Index] ⇒「What's New in Agilent VEE 
6.0」を選択します。
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Agilent VEE におけるプログラムのデバッ
グ方法

ここでは、2-4 ページの「パネル・ビュー ( オペレータ・インタフェース )
の作成方法」で作成したプログラムを使って学習します。[File]⇒

[Open]を選択し、[simple-program_with_panel.vee]を強調表示

して、[OK]をクリックします。

VEE は、プログラムの開発時や実行時にエラー・メッセージを表示しま

す。次のような警告、エラー、情報メッセージが表示されます。

プログラム実行時に、タイトルが黄色の [Caution]ボックスが表示さ

れる場合があります。

プログラム実行時に、タイトルが赤い [Error]ボックスが表示される

場合があります。

プログラムを作成中に、Int16 Constantに 33000の範囲を超える値

を入力するなどの間違いがあると、タイトル・バーが濃紺の [Error(

エラー )]メッセージ・ボックスが表示されます。

また、ステータス・バーにエラーや警告についての情報が表示されま

す。ステータス・バーは VEE ウィンドウの最下部にあります。

データ・フローの表示

1. 図 2-18 のように、ツールバーの中央にある [Show Data Flow] ボタンを

クリックします。または、[Debug]⇒ [Show Data Flow]を選択し

ます。
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図 2-18. データ・フローの表示

表示をオフに切替えるには、ボタンを再度クリックします。プログラム
を実行すると、小さな四角形がデータのラインに沿って移動して、デー
タの流れを示します。

図 2-19. simple-program.vee におけるデータ・フロー

たとえば図 2-19 では、データが Real64 Sliderから Noise 

Generatorへ移動します。Noise Generatorと Function 

Generatorからの出力は A+Bオブジェクトに入力され、結果が

Waveform (Time)の画面に表示されます。

ツールバーの [Show Data Flow] ボタン
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プログラム実行フローの表示

1. 図 2-20 のように、ツールバーにある [Show Execution Flow] ボタンをク

リックします。または、[Debug]⇒ [Show Execution Flow]を選

択します。

図 2-20. プログラム実行フローの表示

プログラムを実行すると、動作中のオブジェクトは色付きの輪郭線で囲ま
れます。

[Data Flow]および [Execution Flow]を使用するとプログラムがど

のように動作するかを確認できます。これらをオフにすると、プログラム
の実行速度が速くなります。またこれらの機能をブレークポイントのよう
なデバッグ・ツールと結合すると、VEE プログラムがどのように動作しエ

ラーの可能性がどこにあるかを確認するのに役立ちます。

ライン上のデータの表示

プログラム内の異なる地点でデータをチェックすると、プログラムのデ
バッグをすばやく効果的に行うことができます。Line Probe は、指定した

ライン上のデータを表示します。

詳細ビューで、データ・ライン上にマウス・ポインタを置きます。カーソ
ルが虫めがねの形になります。ラインとその接続が強調表示され、ライン
上のデータ値を示すボックスが表示されます。虫めがねのカーソルをク
リックするか、[Debug]⇒ [Line Probe]を選択しラインをクリックす

ると、データ・ラインについてのさらに詳しい情報を示すダイアログ・
ボックスが表示されます。

たとえば、図 2-21 は VEE プログラムの一部を表していますが、アイコン

化した Function Generatorからの出力値が表示されています。出力値

ツールバーの [Show Execution Flow] ボタン
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は、Function Generatorが 256 の点を持つ波形配列を生成しているこ

とを示しています。

図 2-21. 出力ピン上の値を表示する

データ・ラインをクリックすると、ライン上のデータについてのすべての
情報がダイアログ・ボックスに表示されます。たとえば、図 2-22 は、

Function Generatorの出力ピンをクリックしたときに表示されるダイ

アログ・ボックスを示しています。

ライン情報
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図 2-22. ライン情報の表示

端子を調べる

端子を調べるには、48 ページの「ピンと端子について」で説明したよう

に、オープン・ビュー表示で端子をダブルクリックします。オブジェクト
がアイコン化されている場合は、マウス・ポインタを端子上に置くと、端
子の名前が自動的にポップアップ表示されます。

デバッグのための Alphanumeric 表示オブジェクトの

使用

プログラム内の異なる地点に Alphanumericまたは Logging 

Alphanumeric表示オブジェクトを追加すると、データの流れを追跡でき

ます。プログラムが正しく実行されたら、これらのオブジェクトは削除し
ます。AlphaNumericは、単一のデータ・コンテナ ( スカラ値、1次元配

列または 2次元配列 ) を表示します。Logging AlphaNumeric( スカラま
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たは 1次元配列 ) は、連続した入力値を値の履歴として表示します。また、

Counterを使用してオブジェクトの実行回数を表示することもできます。

ブレークポイントの使用

ブレークポイントは、特定のオブジェクトを実行する前にプログラムを
いったん休止します。プログラム内にブレークポイントを設定してデータ
を調べることができます。あるオブジェクトにブレークポイントを設定し
た場合、そのオブジェクトは強調表示され、オレンジ色の輪郭線で囲まれ
ます。プログラムを実行すると、そのオブジェクトを実行する前に、プロ
グラムが休止します。

1. 1 つのオブジェクトにブレークポイントを設定します。オブジェクトの

タイトル・バーをダブルクリックして [Properties]ダイアログ・

ボックスを表示します。次に、[Breakpoint Enabled]を選択して

[OK]をクリックします。次に、[Debug]⇒ [Activate 

Breakpoints]を選択します。プログラムを実行します。ブレークポ

イントを設定したオブジェクトの手前でプログラムが休止します。

2. ほかの複数のオブジェクトに追加のブレークポイントを設定します。オ
ブジェクトを選択します。それには、Ctrl キーを押しながら各オブジェ

クトをクリックします。図 2-23 のように、ツールバーの [Toggle 
Breakpoint(s)] ボタンをクリックします。または Ctrl+B キーを押しま

す。再びプログラムを実行すると、ブレークポイントを設定した最初の
オブジェクトの手前でプログラムが休止します。

図 2-23. ブレークポイントの設定

3. プログラムを再開すると、プログラムが続行され、次にブレークポイン
トが設定されているオブジェクトの手前で休止します。図 2-24 に示し

たように、ツールバーの [Resume] ボタンをクリックします。または

[Debug]メニューにある [Resume] を選択します。

[Toggle Breakpoint] ボタン
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図 2-24. プログラムを再開する ([Run] ボタンと同じ )

4. 今度は、ブレークポイントをプログラムからクリアします。ブレークポ
イントが設定されているオブジェクトを選択します。図 2-25 に示した

ように、ツールバーの [Toggle Breakpoint(s)] ボタンをクリックします。

または、[Debug]⇒ [Clear All Breakpoints]を選択します。

図 2-25. ブレークポイントのクリア

5. プログラムを休止または停止するには、図 2-26 に示したツールバーの

[Pause] ボタンまたは [Stop] ボタンをクリックします。または

[Debug]メニューにある [Toggle Breakpoint(s)] を選択します。

図 2-26. プログラムの休止または停止

[Resume] ボタン

([Run] ボタンと同じです。)

[Toggle Breakpoint] ボタン

[Pause] ボタン [Stop] ボタン
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エラーの解決

プログラムの実行時にエラー・メッセージが表示された場合、VEE は、エ

ラーが発見されたオブジェクトを自動的に赤い輪郭線で囲みます。

エラーを修正すると輪郭線は消えます。[Stop] ボタンをクリックして赤い

輪郭線を先に消去してから、エラーを修正することもできます。[Stop] ボ
タンをクリックした場合は、[View]⇒ [Last Error]を選択すると、プ

ログラムを再開する前にエラーを再度表示できます。

[Go To] ボタンを使用してエラーの位置を知る

図 2-27 は、実行時エラー・メッセージの例を示しています。このプログラ

ムを実行したところ、VEE は実行時エラーを表示して、UserObjectの

AddNoiseの周りに赤い輪郭線を示しました。[Go To]ボタンを押すと、

VEE は UserObject AddNoiseを開いて、A + Bオブジェクトの周りに

赤い輪郭線を示しましたが、このオブジェクトでは、入力ピン「A」の接続

が失われています。大きなプログラムでは、Go To機能を使用すると、エ

ラーの位置をすばやく見つけることができます。
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図 2-27. 実行時エラー・メッセージで [Go To] ボタンを使用した例

Call Stack の使用方法 
エラーがメイン・プログラム内にある場合は、簡単に見つけることができ
ます。しかし、大きなプログラムでは、Call Stackが階層深くにネスト

されたエラーを探すのを助けてくれます。

1. ツールバーの [Run] ボタンの隣にある [Pause] ボタンを押します。

2. エラー • ダイアログ・ボックスの [Call Stack]ボタンを押します。ま

たは [View]⇒ [Call Stack]を選択します。Call Stackには、プ

ログラムが実行した処理の階層がリストされます。
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図 2-28. Wheel.exe での Call Stack の使用

Call Stackには、プログラムが実行した処理の階層が表示されます。図

2-28 は、VEE に搭載されているサンプル・プログラムの

Examples/Gamesに収められている Wheel.exe プログラムを示してい

ます。図 2-28 では、プログラムは現在

AMovie_Wait_Until_Finished() User Function を実行していますが、

この User Function は、AMovie_Play_Sound_Syncによって呼出されて

おり、さらに元をたどるとメイン・ウィンドウの Next_Puzzleによって

呼出されています。Call Stack のリスト内の項目をダブルクリックすると、

VEE はその関数の位置と関数を表示します。

オブジェクト内部のイベントの順番を追跡する

図 2-29 は、オブジェクト内部のイベントの順番を示しています。
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図 2-29. オブジェクト内部のイベントの順番

図 2-29 では、ピンは次のように動作します。

1 シーケンス入力ピンが接続されている場合、オブジェクトは、実
行メッセージを受取るまで動作しません (VEE 用語集の「ピン」

参照 )。しかし、シーケンス入力ピンは、必ず接続する必要がある

わけではありません。

2 オブジェクトは、すべてのデータ入力ピンがデータを受取って初
めて動作します。ほとんどのオブジェクトにデータ入力 / 出力ピ

ンを追加できます。オブジェクト・メニューの [Add/Delete 
Terminal] メニューをクリックすると、追加できるピンを確認でき

ます。

3 オブジェクト自身の処理を実行します。この場合は、A が B に加

算され、結果が出力ピンへ渡されます。

4 データ出力ピンがアクティブになります。オブジェクトは、次の
オブジェクトからデータを受取ったという信号を受取って初めて、
処理を完了します。したがって、データ出力ピンに接続されてい
るすべてのオブジェクトがデータを受取るまでは、このオブジェ
クトのシーケンス出力ピンはアクティブになりません。

1( 接続されている場合 )

2

3

4

5 
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このシーケンス・ピンの動作には例外があります。

エラー出力ピンを追加してオブジェクト内のエラーを捕捉できます。エ

ラー出力ピンは、標準的なオブジェクトの動作を無視します。オブジェ
クトの動作時にエラーが発生した場合、エラー・ピンはメッセージを出
力し、データ出力ピンはアクティブになりません。

いくつかのオブジェクトにはコントロール入力ピンを追加できます。コ

ントロール・ピンはオブジェクトに即座に動作を起こさせる場合があり
ます。たとえば、Waveform (Time)にある Title表示や

Autoscale表示のようなオブジェクトのサブ機能は、コントロール・

ピンで動作させることができます。VEE プログラムでは、オブジェク

トへのコントロール・ラインの接続は破線で表示されます。

たとえば、図 2-30 は、Waveform の画面にカスタム・タイトルを設定す

るコントロール・ラインを示しています。オブジェクトは、この操作を
行うためデータをコントロール・ピン上に持つ必要はありません。オブ
ジェクト自体が動作するのではなく、タイトル設定のような操作が実行
されるだけです。[Show Data Flow]をクリックすると、Titleの入

力を制御するコントロール・ラインが始めにデータをどのように伝達す
るかを確認できます。

5 シーケンス出力ピンがアクティブになります。
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図 2-30. コントロール・ラインを使用してカスタム・タイトルを実行

プログラム内のオブジェクトの動作の順番を追う

VEE プログラムを実行すると、オブジェクトは次の順番で動作します。

1. Startオブジェクトが最初に動作します。

図 2-31 は、2 つのスレッドがある VEE プログラムを示しています。ス

レッドは、VEE プログラム内の実線で接続された一連のオブジェクト

です。Startオブジェクトは、[Flow]⇒ [Start]にありますが、プ

ログラム内の個々のスレッドを処理するために使われます。プログラム
に Startオブジェクトがある場合、Startオブジェクトが最初に動作

します。
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図 2-31. 別々のスレッドを動作させる Start オブジェクト

2. 次に、データ入力ピンのないオブジェクトが動作します。[Data]⇒

[Constant]にあるオブジェクトはこのカテゴリに入る場合が多いオ

ブジェクトです。

3. 入力ピンがあるオブジェクトは、接続されている入力ピンがすべてデー
タを受取ったときに初めて動作します。シーケンス入力ピンの接続はオ
プションであることを思い出してください。

プログラム中のステップ実行

プログラム中のステップ実行は、大変効果的なデバッグ・ツールです。
VEE には、オブジェクの [Step Into]、[Step Over]、[Step Out]

の機能があります。

ステップ実行を行うには、図 2-32 に示したように、ツールバーの [Step 
Into]、[Step Over]、[Step Out] のいずれかのボタンをクリックします。
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図 2-32. ツールバー上の [Step Into]、[Step Over]、[Step Out] ボタン

[Step Into] は、プログラムを実行する際に一度に 1 つのオブジェクトを実

行します。プログラムが UserObjectまたは UserFunctionに出会

うと、VEE は UserObjectまたは UserFunctionを詳細ビューで表

示し、その中のオブジェクトを 1 つ 1 つ実行します。

[Step Over] および [Step Out] はプログラムを実行する際に一度に１つの

オブジェクトを実行しますが、UserObjectsまたは UserFunctions

を開くことはしません。UserObjectまたは UserFunctionを見つけ

ると、VEE は UserObjectまたは UserFunctionをすべて実行します。

たとえば、プログラムをステップ実行するには次のようにします。

1. simple-program_with_panel.veeプログラムを開きます。

2. ツールバーの [Step Into] ボタンをクリックします。

3. [Step Into] をクリックするたびに、次に実行するオブジェクトの周りに

色の付いた輪郭線が表示され、プログラム中を次々にたどっていくこと
ができます。

ステップ実行を行うと、VEE は詳細ビューの後ろにパネル・ビューを置い

てオブジェクトが実行する順番を示します。メイン・ウィンドウ内では、
入力ボックスには入力ピンが接続されていないため、入力ボックスが動作
する順番は決まっていません。入力ボックスを特定の順番で動作させたい
場合は、シーケンス・ピンを接続することによって制御します。

データは左から右へ流れます。したがって、データ生成プログラム
(Generator) が動作する順番は決まっていません。加法 (A+B) オブジェクト

は両方の入力ピンがデータを受取るまで動作できません。次に

[Step Into] [Step Over]
[Step Out]
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Waveform(Time)オブジェクトを実行します。シーケンス・ピンまたは

[Flow]⇒ [Do]オブジェクトを使用して、プログラム内の任意の場所で

動作の順番を指定できます。[Do]オブジェクトについての詳細は、ヘル

プを参照してください。

メモ ステップ機能についての詳細は、オンライン・ヘルプを参照してください。
UserFunctionsについての詳細は、299 ページの第 8 章「Agilent VEE 関

数の使用方法」を参照してください。

複雑なプログラム内のオブジェクトの検索

特定のオブジェクトを大きなプログラムの中で検索するには、[Edit]⇒

[Find]を選択します。ポップアップ・ダイアログ・ボックスにオブジェ

クトまたは関数名を入力すると、VEE は、プログラム内にあるそのオブ

ジェクトまたは関数の全リストと場所を表示します。詳細は、327 ページ

の「大規模プログラム内の関数を検索する方法」を参照してください。
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プログラム演習

このセクションのプログラム演習を行うと、VEE の機能についてさらに学

ぶことができます。

例題 2-6: 乱数の生成

1. プログラムのドキュメント作成

a. [Display]⇒ [Note Pad]を選択して、作業領域の上部中央に配
置します。編集領域をクリックしてカーソルを置き、次のように入
力します。

This program, Random, generates a real number 

between 0 and 1, then displays the results. ( この

Random プログラムは、0 から 1 までの間の実数を生成して結果を表

示します )

2. [Device]⇒ [Function & Object Browser]を選択します。

[Type]は [Built-in]関数を、[Category]は [All]を、

[Functions]は [random]を選択します。[Create Formula] をクリッ

クします。オブジェクトを作業領域に配置し、クリックして位置を確定
します。

3. [Data]⇒ [Constant]⇒ [Int32]をクリックして、オブジェクトを

Randomの左に配置します。Int32のオブジェクト・メニューを開いて

[Clone]をクリックし、複製を元の Int32オブジェクトの下に配置し

ます。[0]をダブルクリックしてカーソルを表示し、「1」を入力しま

す。0が入力されている Constant オブジェクトを randomの Low 入力

ピンに接続します。また 1が入力されている Constant オブジェクトを

High 入力ピンに接続します。

4. [Display]⇒ [AlphaNumeric]を選択して、randomオブジェクト

の右に配置します。 オブジェクト・メニューを開き、[Help]を選択し

て、オブジェクトについてさらに理解してください。

5. randomオブジェクトの出力ピンを AlphaNumericの入力ピンに接続

します。2 つのオブジェクトを接続するデータ・ラインが表示されます。
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メモ ラインが付いているマウス・ポインタを目的のピンに近づけると、ピンが
強調表示されます。再度クリックして接続を確定します。

メモ 何らかの原因で、接続を確定する前にライン接続の操作を中止する場合は、
マウスをダブルクリックしてください。ラインが消えます。

6. ツールバーの [Run] ボタンをクリックします。図 2-33 のように、乱数

が表示されます。

図 2-33. Random プログラム

7. [File]⇒ [Save As]を選択して、「Random.VEE」と入力し、[OK]

をクリックします。評価キット・ソフトウェアをお使いの場合は、
EVAL.VEEに保存してください。この名前は、次にこのプログラムを開

いたときにタイトル・バーの VEE の隣に表示されます。

例題 2-7: グローバル変数の設定と表示

このプログラムでは、VEE プログラムを構築する基本的な技術についてさ

らに練習できます。またグローバル変数について理解できます。Set 

Variableオブジェクトを使用すると、後で Get Variableオブジェク

トを使ってプログラム中に再取込みできる変数を作成できます。VEE のど

のようなデータ型でも使用できます。この例題では、数値型の Real64を

使用します。VEE のデータ型についての詳細は、第 4 章「テスト・データ

の分析と表示」を参照してください。
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1. [Display]⇒ [Note Pad]を選択して、オブジェクトを作業領域の上

部中央に配置します。編集領域の左上隅をクリックしてカーソルを表示
させ、次の情報を入力します。

Set and Get a Global Variable prompts the user to 
enter a real number. The variable, num, is set to this 

real number. Then num is recalled and displayed. (グ

ローバル変数の設定と表示では、ユーザに実数を入力させます。この実
数を変数 numに設定します。次に numを再取込みして表示します )

2. [Data]⇒ [Constant]⇒ [Real64]を選択して、オブジェクトを作

業領域の左側に配置します。オブジェクト・メニューを開いて、ヘルプ
の内容を調べます。

3. Real64のオブジェクト・メニューを開いて、[Properties]を選択

します。プロンプトのタイトルを Enter a Real Number:に変更し

て [OK]をクリックします。

メモ この練習では、プロンプトのタイトルを変更することによって、Constant
オブジェクトの 1 つを入力ダイアログ・ボックスとして使用しています。

これは、ユーザに入力してもらうときの一般的なテクニックです。[Data]

⇒ [Dialog Box]⇒ [Real64 Input]を使用することもできます。ま

た、タイトル・バーをダブルクリックして [Constant Properties]ダ

イアログ・ボックスを表示することもできます。

4. [Data]⇒ [Variable]⇒ [Set Variable]を選択して、オブジェ

クトを Real64オブジェクトの右に配置します。[globalA]をダブル

クリックして強調表示します。次に「num」を入力します。オブジェク

トの名前が Set numに変わります。 

このことは、ユーザが Real64オブジェクトに実数を入力することを意

味します。ユーザが [Run] ボタンをクリックすると、数値がグローバル

変数 numに設定されます。

5. Realオブジェクトのデータ出力ピンを Set numオブジェクトのデー

タ入力ピンに接続します。

6. [Data]⇒ [Variable]⇒ [Get Variable]を選択して、オブジェ

クトを Set numオブジェクトの下に配置します。この変数の名前を

numに変更します。オブジェクトの名前が Get numに変わります。
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7. Set numのシーケンス出力ピンを Get numのシーケンス入力ピンに接

続します。

メモ グローバル変数は、使用する前に設定する必要があります。したがって、
Get numで再度取込む前に変数 num を確実に設定しておくために、シー

ケンス・ピンを使用します。

8. [Display]⇒ [AlphaNumeric]を選択し、オブジェクトを Get num

オブジェクトの右に配置します。

9. Get numのデータ出力ピンを AlphaNumericのデータ入力ピンに接続

します。

10. 実数を入力してツールバーの [Run] ボタンをクリックします。プログラ

ムは図 2-34 のようになります。

11. [File]⇒ [Save As]を選択して、プログラムに global.veeと名

前を付けて保存します。評価キット・ソフトウェアをお使いの場合は、
プログラムを EVAL.VEEに保存してください。

図 2-34. グローバル変数の設定と表示
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Agilent VEE プログラムのドキュメント作成

[File]⇒ [Save Documentation]コマンドを使用して、プログラムの

ドキュメントを自動的に生成できます。VEE は、すべてのオブジェクトを

基本設定、デフォルト名、ユーザ名、Description で入力したテキスト、「ネ

スト情報」とともにリストします。たとえば、UserObject内のオブジェ

クトは、メインの VEE 環境から 1 レベルだけネストされていますが、これ

らのレベルは数字で示されます。

また、Description を使用して個々のオブジェクトのドキュメントを作成す

ることもできます。この例題では、まず個別オブジェクトのドキュメント
作成方法について説明し、次にプログラムのドキュメント生成方法を説明
します。

[Description] ダイアログ・ボックスでのオブジェクト

のドキュメント作成

すべてのオブジェクトは、オブジェクト・メニューに Description項目

があり、このメニューのダイアログ・ボックスにその特定のオブジェクト
についてのドキュメントを入力できます。このドキュメント・ファイルで
は、ドキュメントを画面コピーに関連付けることができます。このセク
ションでは、[Description]ダイアログ・ボックスに入力します。

1. Random.veeプログラムを開きます。

2. メイン・オブジェクト・メニューで [Description]をクリックしま

す。ダイアログ・ボックスに、図 2-35 のようにテキストを入力します。

入力したら、[OK]をクリックします。
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図 2-35. [Description] ダイアログ・ボックス

メモ [Description]ダイアログ・ボックスに入力した内容は、オブジェク

ト・メニューからアクセスしないと、ユーザには表示されません。また、
このダイアログ・ボックスにはファイルやテンプレートを挿入できます。

ドキュメントの自動生成

ファイルまたはプログラムのドキュメントを生成するには、次のようにし
ます。

1. Random.veeをオープンします。[File]⇒ [Save 

Documentation]をクリックします。拡張子に *.txtを使用してファ

イル名を入力します ( たとえば Random.txt)。次に、[Save]をク

リックします。特に指定しないかぎり、ファイルは PC 上の「C:\My 

Documents\VEE Programs」に保存されます。

2. ファイルを表示または印刷するには、テキスト・エディタでファイルを
開きます。図 2-36、図 2-37、図 2-38 は、MS Windows98 のメモ帳を使

用してドキュメント・ファイルを表示したところを示しています。

図 2-36 は、ファイルの開始部分を示しています。ファイルについての

情報、更新日時、システムの I/O 設定などが記述されています。
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図 2-36. ドキュメント・ファイルの開始部分

Source file: "C:\\My Documents\\VEE Programs\\Random.vee"

File last revised: Mon Jan 03 15:29:02 2000

Date documented:  Mon Feb 28 14:43:27 2000

VEE revision: 6.0 

Execution mode: VEE 6

Convert Infinity on Binary Read: no

I/O Configuration

  My Configuration (C:\WINDOWS\Local Settings\Application 
Data\Agilent VEE\vee.io)
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図 2-37. ドキュメント・ファイルの中間部分

図 2-37 には、VEE オブジェクトとその設定が記述されています。各オ

ブジェクトの前にある数値は、そのオブジェクトの位置を示します。た
とえば、メイン・プログラムにある最初のオブジェクトは「M1」とし

てリストされます。参考までに、図 2-38 にこのドキュメント・ファイ

ルの末尾部分を示します。

M: Main

 Device Type              : Main

 Description              :

   1. The program, Random, generates a real number between 0 and 1

   2. and then displays the results.

 Context is secured       : off

 Trig mode                : Degrees

 Popup Panel Title Text   : Untitled

 Show Popup Panel Title   : on

 Show Popup Panel Border  : on

 Popup Moveable           : on

 Popup Panel Title Text Color         : Object Title Text

 Popup Panel Title Background Color   : Object Title

 Popup Panel Title Text Font          : Object Title Text

 Delete Globals at Prerun : on

M.0: Main/Note Pad

 Device Type              : Note Pad

 Note Contents            :

   1. This program, Random, generates a real

   2. number between 0 and 1, then displays

   3. the results.

   4. 

M.1: Main/random(low,high)

 Device Type              : Formula

  Input pin  1            : low (Any, Any)

  Input pin  2            : high (Any, Any)

  Output pin 1            : Result

 Formula                  : random(low,high)
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図 2-38. ドキュメント・ファイルの末尾部分

メモ [Save Documentation]コマンドを実行後は、[File]⇒ [Print 

Program]コマンドを実行してオブジェクトに識別番号をつけます。これ

により、ドキュメントのテキストとプリンタ出力とを一致させることがで
きます。

M.2: Main/Int32

 Device Type              : Constant

  Output pin 1            : Int32

 Wait For Event           : off

 Auto execute             : off

 Initialize At Prerun     : off

 Initialize at Activate   : off

 Constant size fixed      : off

 Password masking         : off

 Indices Enabled          : on

 Int32 Value              : 0

M.4: Main/Int32

 Device Type              : Constant

  Output pin 1            : Int32

 Wait For Event           : off

 Auto execute             : off

 Initialize At Prerun     : off

 Initialize at Activate   : off

 Constant size fixed      : off

 Password masking         : off

 Indices Enabled          : on

 Int32 Value              : 1

M.5: Main/AlphaNumeric

 Device Type              : AlphaNumeric

  Input pin  1            : Data (Any, Any)

 Clear At Prerun          : on

 Clear at Activate        : on

 Indices Enabled          : on
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この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
トピックを復習してください。

UserObjectを作成する。また、UserObjectsのプログラムを構造化

して画面上のスペースを節約する。

ユーザ入力用のポップアップ・ダイアログ・ボックスとスライダ ( また

はノブ ) を作成する。

データ・ファイルを使ってデータをファイルに保存したりファイルから

データをロードする。

プログラムのパネル・ビューを使ってオペレータ・インタフェースを作

成する。

さまざまなデータ型およびデータの種類を使用する。

算術演算子と関数を使用する。

オンライン・ヘルプを使用する。

プログラム内のデータ・フローと実行フローを表示する。

ライン、端子、Alphanumeric 表示上のデータを調べてプログラムをデ

バッグする。

ブレークポイントを使用する。

GoToコマンドでエラーを解決する。

Call Stack を使ってエラーを解決する。

プログラムを追跡しデバッグするために Step Into、Step Over、Step Out を
使用する。

検索機能を使用する。

[Description] ダイアログ・ボックスでオブジェクトのドキュメントを作

成する。
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ドキュメント・ファイルを生成する。
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簡単な計測器の操作
簡単な計測器の操作

この章の内容

計測器の設定方法

パネル・ドライバの使用方法

Direct I/O オブジェクトの使用方法

PC プラグイン・ボードの制御方法

VXI plug&play ドライバの使用方法

平均的な必要時間 :1 時間 
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概要概要概要概要
概要

この章では、VEE を使って計測器を制御する方法について学びます。VEE
では、次のような方法で計測器を制御できます。

「パネル」ドライバは、計測器をコンピュータ画面から制御するための

簡単なユーザ・インタフェース ( フロント・パネル ) を提供します。

VEE パネル・ドライバでパラメータを変更すると、計測器の対応する

ステートが変化します。パネル・ドライバは、Agilent Technologies に
よって VEE と共に提供され、さまざまなメーカから提供されている

450 以上の計測器をサポートします。

Direct I/O オブジェクトは、サポートされているさまざまなインタ

フェース上でコマンドを伝達したりデータを受取ることができます。こ
の技術は、Rocky Mountain Basic のようなテキスト形式言語でコマンド

文字列を使用するのと同じです。

Open Data Acquisition Standard ドライバ (ODAS ドライバ ) は、ActiveX
オートメーション技術を使って PC プラグイン・カード (PCPI カード )
を制御します。ODAS ドライバは標準の形式であるため、PC プラグイ

ン・カードのメーカやほかのサード・パーティから提供されています。

I/O ライブラリをインポートして PC プラグイン・ボードを制御できます。

インポートしたライブラリからは、Callオブジェクトを使用して関数

を呼出すことができます。これらのライブラリは、通常は Dynamic Link 
Libraries(DLL) として搭載されており、ODAS ドライバに似ています。

しかし、ODAS ドライバは標準であり簡単に使用できます。

VXI plug&play ドライバは、C 関数を呼出して計測器を制御するために

使用します。Agilent Technologies および計測器をサポートするメーカか

ら提供されています。

この章では、さまざまな状況に応じた計測器の制御方法の基礎知識を解説
します。詳細は、VEE Pro Advanced Techniques を参照してください。 

パネル・ドライバ

Agilent VEE では、異なる計測器メーカ向けに 450 以上のパネル・ドライバ

が用意されています。パネル・ドライバは VEE プログラム内に表示される
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概要概要概要概要
画面を使って動作しますが、この画面では対応する物理計測器の設定を制
御します。パネル・ドライバは、大変使いやすく、開発時間を最大限節約
します。図 3-1 は、パネル・ドライバの例です。

図 3-1. HP54600A スコープ・パネル・ドライバ

Direct I/O オブジェクト

VEE の Direct I/O オブジェクトを使用すると、標準のインタフェース上で、

すべてのメーカのすべての計測器と通信できます。計測器用のドライバが
あるかどうかは関係ありません。Direct I/O オブジェクトは、計測器にコマ

ンドを伝達したり、計測器からデータを読取ります。Direct I/O を使用する

と、通常は実行速度が上がります。最良の計測器制御方法としてどの方法
を選択すべきかは、ドライバの性能、テスト開発速度の必要性、必要な性
能によって決まります。図 3-2 は、Function Generator の制御に Direct I/O を

使用している例です。

図 3-2. Function Generator オブジェクトの Direct I/O
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ODAS ドライバを使った PC プラグイン・ボード制御

ODAS ドライバは、PC プラグイン・カードのメーカから提供されます。ま

た標準のドライバであるため、サード・パーティ製の ODAS ドライバも提

供されています。VEE では、Formulaオブジェクトで PC プラグイン・

ボード関数を選択することによって、ODAS ドライバを使って PC プラグ

イン・ボードを制御できます。

PC プラグイン・ボードの制御には、一般に専用 DLL よりも ODAS ドライ

バが標準として使用されます。また 1 つの PC から別の PC への移植も

ODAS ドライバの方がうまくいきます。図 3-3 は、VEE の Formulaオブ

ジェクトを使って ODAS ドライバで PC プラグイン・ボードを制御してい

る例です。

図 3-3. VEE プログラムにおける ODAS ドライバ・オブジェクト

I/O ライブラリを使用した PC プラグイン・ボード制御

I/O ライブラリは、通常 PC プラグイン・ボード用の Dynamically Linked 
Libraries(DLL ファイル ) として搭載されており、PC プラグイン・ボードの

メーカから提供されます。VEE では、Callオブジェクトでライブラリ関

数を呼出すことによって PC プラグイン・ボードを制御できます。図 3-4
は、VEE で関数を使用できるようにする Import Libraryオブジェクト

の例です。
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概要概要概要概要
図 3-4. PC プラグイン・ライブラリのインポート

VXI plug&play ドライバ

VXI plug&play ドライバは、計測器メーカまたは Agilent Technologies によっ

て提供されます。Agilent Technologies が提供する VXI plug&play ドライバの

リストについては、VEE 説明書または VEE Pro Advanced Techniques マニュ

アルを参照してください。そのほかの VXI plug&play ドライバについては

計測器メーカにお問合せください。VEE では、VXI plug&play ドライバを

呼出すことによって計測器を制御できます。図 3-5 は、VEE から VXI 
plug&play ドライバを呼出している例です。

図 3-5. VEE から VXI plug&play ドライバの呼出し
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計測器の設定方法

VEE では、計測器を接続していなくてもプログラムを開発できます。次の

例題では、パネル・ドライバを使ってオシロスコープの設定を行います。
次に、構成に物理的に計測器を追加します。

例題 3-1: 計測器を接続しないで計測器構成を設定する

1. [I/O]⇒ [Instrument Manager]を選択します。タイトル・バーを

クリック・アンド・ドラッグして、図 3-6 に示すダイアログ・ボックス

を作業領域の左上まで移動します。

図 3-6. [Instrument Manager] ダイアログ・ボックス

メモ 計測器を接続して電源を入れている場合、VEE は自動的に計測器とそのド

ライバを見つけます。計測器の自動検索および構成設定についての詳細は、
VEE のメイン画面で [Help]⇒ [Welcome]⇒ [Tutorials]を選択して

オンライン・チュートリアルを参照してください。
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特に指定しないかぎり、計測器構成は設定されていません。この例では、
[Instrument Manager]のリストに計測器が表示されていないと仮定し

ます。

2. [Instrument Manager]ダイアログ・ボックスで、[My 

Configuration]が強調表示されていることを確認して、

[Instrument]の下にある [Add]をクリックします。図 3-7 のような

[Instrument Properties]ダイアログ・ボックスが表示されます。

図 3-7. [Instrument Properties] ダイアログ・ボックス

[Instrument Properties]ダイアログ・ボックスには、次の設定項目

があります。

[Name] プログラム内での計測器の呼び名を指定します。次の規
則に従った名前を選択してください。

計測器名の最初の文字はアルファベットでなければな

りません。また、計測器名に使用できるのは英数字ま
たはアンダスコアです。

計測器名の中に空白を入れることはできません。

[Interface] インタフェースの種類を指定します。[GPIB]、[Serial]、
[GPIO]、[VXI] から選択します。
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3. [Name]を [scope]に変更し、ほかの項目はデフォルト値のままにし

て、[Advanced]をクリックします。[Advanced Instrument 

Properties]ダイアログ・ボックスが図 3-8 のように表示されます。

図 3-8. [Advanced Instrument Properties] ダイアログ・ボックス

Generalフォルダでの設定項目は次のとおりです。 

[Address] インタフェースの論理装置番号 ( 通常 GPIB は 7) に計測
器のローカル・バスのアドレス (0 から 31 までの数値 ) を
加えます。[Address] を [0] のままにした場合は、計測器を
接続しないで開発を行っていることを意味します。

[Gateway] 計測器をローカルで制御するかリモート制御するかを指
定します。計測器をローカルで制御する場合は、デフォ
ルト値 [This host]を使用します。リモート制御を行
う場合は [Gateway]を指定します。詳細は、VEE Pro 
Advanced Techniques マニュアルを参照してください。

[Timeout] I/O トランザクションが最大限何秒待機してから、エ
ラー・メッセージを生成するかを指定します。

[Live Mode] 計測器との通信を ON にするかどうかを指定します。
計測器が接続されていない場合は、[OFF]に設定しま
す。VEE のデフォルトの設定は [ON]です。
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4. [Live Mode]を [OFF]に切替えます。次に [Panel Driver]フォル

ダをクリックします。ダイアログ・ボックスの表示が図 3-9 のようにな

ります。

図 3-9. [Panel Driver] フォルダ

5. [ID Filename]の右側にあるフィールドをクリックすると、[Read 

from what instrument Driver?]という名前のリスト・ボックス

が表示されます。このリストには、VEE の改訂版と一緒に指定したディ

レクトリにロードされたパネル・ドライバの全ファイルが含まれます。

[Byte Ordering] デバイスがバイナリ・データの読取りや書込みを行う
際のバイト順を指定します。このフィールドで、
[MSB]( 最上位バイトから送信 ) か [LSB]( 最下位バイト
から送信 ) を指定します。IEEE 488.2 準拠デバイスは
すべて、[MSB] を指定する必要があります。

[Description] 識別子を入力します。たとえば、タイトル・バーに計
測器の番号を入れたい場合は、その番号を入力します。
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メモ この例題を完了するには、VEE CD-ROM からパネル・ドライバをインス

トールしておく必要があります。*.cidファイルは、コンパイル済みの計

測器ドライバ・ファイルを表します。

6. リストを下へスクロールして [hp54504a.cid]を強調表示します。次

に [Open]をクリックします。図 3-9 では、この計測器がすでに選択さ

れています。強調表示したファイルをダブルクリックして選択すること
もできます。

[Panel Driver] フォルダのそのほかの設定項目は次のとおりです。

7. [OK]をクリックすると、[Instrument Properties]ダイアログ・

ボックスに戻ります。[OK] をクリックします。

図 3-10 に示したように、使用できる計測器のリストに、ドライバ・

ファイル hp54504a.cidを使用して scopeという名前の計測器構成

が加わります。実際には接続されていないため、計測器にはバス・アド
レスがありません。このモードでプログラムの開発を行い、後で、計測
器をコンピュータに接続できるようになった時点でアドレスを追加でき
ます。

ヒント : フィールド内の入力を終えて次のフィールドに移動するには、
Tab キーを押します。前のフィールドに移動するには、Shift+Tab キー

を押します。Enter キーを押すのは、[OK]をクリックするのと同じで

す。VEE はダイアログ・ボックスを閉じます。

[Sub 
Address]

このフィールドは何も入力しないでおきます。[Sub 
Address] は、非 VXI カードケージ計測器がプラグイ
ン・モジュールを特定する場合にのみ使用します。

[Error 
Checking]

デフォルト設定の [ON]のままにします。[Error 
Checking]は特に処理量を増大させたい場合にオフに
しますが、その場合は I/O エラーはチェックされません。

[Incremental 
Mode]

デフォルト設定の [ON]のままにします。設定を変更
するたびに、計測器のステートを指定する計測器コマ
ンド文字列をすべて送信する場合は、[Incremental 
Mode]を [OFF] にします。
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図 3-10. 計測器リストにスコープを追加

8. [Save]をクリックして [Instrument Manager]ダイアログ・ボッ

クスを閉じます。[Create I/O Object]にある [Panel Driver]

をクリックすると、パネル・ドライバをプログラムにすぐに入れること
ができます。VEE は構成を自動的に保存します。

これで、HP 54504A オシロスコープを scopeという名前で計測器リストに

追加できました。実際に計測器を接続していなくても、プログラム作成時
にこのドライバを使用できます。

プログラムで使用する計測器の選択

1. [I/O]⇒ [Instrument Manager]を選択します。

2. [scope(@(NOT LIVE))]を選択して強調表示にします。次に、

[Create I/O Object]の下にある [Panel Driver]をクリックし

ます。
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メモ [Instrument Manager]では、設定した計測器の種類に応じて、

[Create I/O Object]にあるメニューを使って異なる種類のオブジェク

トを作成できます。たとえば、この例題で [Panel Driver]ではなく

[Direct I/O]を選択した場合、scope(@(NOT LIVE))という名前の

Direct I/Oオブジェクトが作成されます。VEE はまた、コンポーネン

ト・ドライバを提供しますが、これは パネル・ドライバが提供する関数の

サブセットを使用します。詳細は、VEE Pro Advanced Techniques マニュア

ルを参照してください。 

3. [scope]パネルの輪郭線を配置し、クリックして場所を確定します。

図 3-11 のように表示されます。 

図 3-11. scope(@(NOT LIVE)) の選択

これで、ほかの VEE オブジェクトと同じように、プログラム内でパネ

ル・ドライバを使用できます。

物理計測器の構成への追加

1. [I/O]⇒ [Instrument Manager]を選択して、[scope]を強調表示

にします。[Instrument]の下にある [Properties]をクリックし

ます。

2. [Address]フィールドをダブルクリックして現在の入力内容を強調表

示し、「709」と入力します。709の 7は、論理装置番号です。

GPIB(HP-IB) の論理装置番号が 7 でない場合は、7 を実際の論理装置番
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号と置換えてください。709の 9は、スコープのデフォルトのアドレス

です。

3. [Advanced:]をクリックして [Live Mode]を [ON]に切替えます。

次に [OK]をクリックします。[OK]をクリックし、[Instrument 

Properties]ボックスを閉じます。

4. [Save]をクリックして変更内容を保存します。
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パネル・ドライバの使用

この例題では、例として HP 3325B Function Generator を使用します。VEE
では、どのパネル・ドライバを使用する場合でも、基本的な操作は同じで
す。計測器を直接プログラムする代わりにパネル・ドライバを使用するこ
とによって、プログラムの開発 / 修正時間を節約できます。計測器の設定

は、メニューを選択したりダイアログ・ボックスのフィールドを編集する
ことによって変更できます。計測器が接続されていて、[Live Mode]が

[ON]の場合、変更した設定内容は計測器に反映されます。

プログラムでパネル・ドライバを使用するには、必要な入力 / 出力端子を

追加して、パネル・ドライバをほかのオブジェクトに接続します。計測器
に異なるステートを設定するために、プログラム内に同じドライバを複数
入れることができます。VEE では、パネル・ドライバをアイコン化してス

ペースを節約することも、オープン・ビューにして計測器の設定を表示す
ることもできます。またプログラム実行中に設定を変更できます。

例題 3-2: パネル・ドライバの設定変更

1. [I/O]⇒ [Instrument Manager]を選択します。[My 

Configuration]を選択して、[Instrument]の下にある [Add]を

クリックします。[Instrument Properties]ダイアログ・ボックス

が表示されるので、次のように設定を行います。

2. [Advanced]をクリックします。[General]フォルダで [Live 

Mode]を [OFF]に切替えます。

3. [Panel Driver]フォルダをクリックして、[ID Filename:]を

[hp3325b.cid]に設定します。[OK]を 2 回クリックすると、

[InstrumentManager]に戻ります。

4. [Create I/O Object]の下にある [Panel Driver]をクリックし

ます。オブジェクトをワークスペースの左側に配置します。計測器が設

[Name] 値を [fgen]に変更します。次に、Tab キーを 2 回押
して [Address]フィールドに移動します。

[Address] 値を [713]、またはバスに設定するアドレスに変更
します。
第第第第 3 章章章章 145145145145



簡単な計測器の操作

パネル・ドライバの使用パネル・ドライバの使用パネル・ドライバの使用パネル・ドライバの使用
定されリストに追加されているかぎりは、どのような計測器でも手順は
同じです。

メモ ここでは、計測器を接続しない前提でプログラムを行っています。計測器
を接続している場合は、適切なアドレスを設定してください。

5. [Function]フィールドの [Sine]をクリックしてポップアップ・メ

ニューを表示します。次に、図 3-12 のように [Triangle]を選択し

ます。

図 3-12. fgen の関数ポップアップ・メニュー

6. [Frequency]の右側のフィールドをクリックします。

7. 続いて表示される [FREQUENCY]ダイアログ・ボックスに「100」と入

力して [OK]をクリックします。[Frequency]の設定が変更されます。

どのようなドライバでも、同じ方法で計測器設定を変更できます。計測器
にアドレスを設定し [Live Mode]を [ON]にした場合、パネル・ドライ

バで設定した変更内容はすべて、その計測器に反映されます。

同じドライバの別のパネルへ移動する

ドライバの多くは、ユーザ・インタフェースをわかりやすくするためにパ
ネルを 2 つ以上持っています。別のパネルへ移動するには、オブジェクト

の [Main Panel]をクリックしてパネルのメニューを表示します。
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1. パネル・ドライバ・オブジェクトで [Main Panel]をクリックします。

図 3-13 のように [Discrete Component MENU]が表示されるので、

[Sweep]を選択します。

2. [OK]をクリックして [Sweep Panel]を表示します。ほかのパネルも

表示して設定内容を確認してください。

3. [OK]をクリックして [Main Panel]に戻ります。

図 3-13. [Discrete Component Menu] の [Sweep Panel]

パネル・ドライバに入力 / 出力端子を追加する

パネルで直接設定を行うほかに、ドライバにデータ入力 / 出力端子を追加

することによってプログラム内の計測器の設定を制御したり、計測器から
データを読取ることができます。図 3-14 は、入力 / 出力端子領域を示し

ます。
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図 3-14. ドライバ上のデータ入力 / 出力端子領域

1. マウス・ポインタを Function Generator 計測器パネルのデータ入力端子

領域に置き、CTRL+A キーを押してデータ入力端子を追加します。計測

器コンポーネントのリスト・ボックスが表示されます。

2. 表示されたメニューで目的のコンポーネントを選択します。

メモ オブジェクト・メニューを開いて、[Component]⇒ [Select Input 

Component]から [Add Terminal]を選択し、ドライバ上で目的のコン

ポーネント・フィールドを選択する方法もあります。

データ出力端子を追加するには、マウス・ポインタをデータ出力端子領域
に置いて、同じ操作を行います。

データ入力 / 出力端子の削除

マウス・ポインタを端子の上に置き、CTRL+D キーを押します。

メモ オブジェクト・メニューを開いて、オブジェクト・メニューから [Delete 

Terminal]⇒ [Input]を選択し、表示されるメニューで削除する入力端

子を選択する方法もあります。

データ入力端子領域 データ出力端子領域
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独習課題

HP 3325B Function Generator、または使用できるほかの Function Generator 上
でステートを設定します。[Function]の設定を [Square]に変更しま

す。[Amplitude]および [Frequency]に、入力コンポーネントを追加

します。振幅と周波数を入力するためのダイアログ・ボックスを作成し、
タイトルをオペレータに入力を促すものに修正します。振幅と周波数に異
なる値を入力してプログラムを実行し、値の入力後に設定が変更されたか
どうかを確認します。計測器を接続している場合は、[Live Mode]を

[ON]にすると、設定が変更されます。
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Direct I/O の使用方法 
特定の計測器用のドライバがない場合や、処理速度を上げたい場合は、
Direct I/O オブジェクトを使用します。

例題 3-3: Direct I/O の使用

この例題では、Direct I/O を使用して HP 3325B Function Generator の設定を

行います。

1. [I/O]⇒ [Instrument Manager]を選択します。

2. [fgen(@(NOT LIVE))]の項目を強調表示し、[Instrument]⇒

[Properties]を選択します。

3. [Advanced]をクリックします。図 3-15 のように、[Direct I/O]

フォルダを選択します。使用できるオプションをひととおり見たら、
[OK]をクリックして [Instrument Properties]に戻ります。次

に、[OK]を再度クリックして [Instrument Manager]に戻ります。

図 3-15. Direct I/O 設定フォルダ
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メモ この例では、GPIB インタフェース (IEEE488) を使用します。Serial、GPIO、

VXI 計測器の設定方法については VEE Pro Advanced Techniques マニュアル

を参照してください。

4. 画面上にオブジェクトを配置するには、[fgen(@(NOT LIVE))]が強

調表示されていることを確認して [Create I/O Object]⇒

[Direct I/O]をクリックします。図 3-16 は、作成された Direct I/O
オブジェクトを示しています。

図 3-16. Direct I/O オブジェクト

プログラム中で Direct I/Oオブジェクトを使用するには、I/O トランザ

クションを設定する必要があります。次のセクションでは、テキスト・コ
マンドの書込み、データの読込み、計測器のステートのアップロード / ダ
ウンロードについて説明します。

計測器に単一のテキスト・コマンドを送信する

計測器に単一のテキスト・コマンドを送信するには、適切な文字列を入力
します。GPIB 計測器のほとんどは、計測器に送信するコマンドに英数字の

文字列を使用します。たとえば、HP3325B Function Generator に振幅を 5 ボ

ルトに設定するコマンドを送信するには、コマンド文字列「AM 5 VO」を

入力します。

この例題では、前のセクションで設定した HP 3325B Function Generator を
使用します。必要な場合は、次へ進む前に 150 ページの「Direct I/O の使用

方法」に戻り、計測器の設定を行ってください。
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1. fgen(@(NOT LIVE))オブジェクトでトランザクション・バーをダブ

ルクリックして、図 3-17 に示した [I/O Transaction]ダイアログ・

ボックスを表示します。

図 3-17. [I/O Transaction] ダイアログ・ボックス

[WRITE]の隣にある下向き矢印をクリックすると、トランザクショ

ン・メニューに [READ]、[WRITE]、[EXECUTE]、[WAIT]が表示さ

れます。計測器にデータを書込むには、デフォルトの設定 [WRITE]を

使用します。各操作については、オブジェクト・メニューを開いてヘル
プを参照してください。

2. 各項目はデフォルトの設定、[WRITE]、[TEXT]、[DEFAULT 

FORMAT]、[EOL ON]を使用します。aのラベルが付いた入力フィール

ドをクリックし、「"AM 5 VO"」( 引用符も含めて ) を入力し、[OK]を

クリックします。

図 3-18 に示したようにトランザクション [WRITE TEXT "AM 5 VO" 

EOL]が表示されます。引用符で囲まれたテキストは、プログラムを実行

すると HP3325B に送信されるコマンドです。

図 3-18. Direct I/O トランザクション
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ほとんどの場合、計測器にテキスト・コマンドを送信する方法は、同じで
す。しかし、各コマンドの末尾やコマンド・グループの末尾に特定の文字
を送信する必要がある計測器があります。この送信文字については計測器
のドキュメントを参照し、[Direct I/O Configuration]ダイアログ・

ボックスでその文字を指定してください。

計測器への式リストの送信

計測器に式リストを送信したい場合があります。たとえば、Function 

Generatorでいくつかの周波数を繰返させたい場合です。Direct I/O トラ

ンザクションを使用してこれを行うには、式リストで周波数の変数を使用
します。Direct I/O オブジェクトにその変数のためのデータ入力端子を追加

します。次の手順で、計測器に式リストを送信します。

1. メイン・ウィンドウに HP3325B 用の 2 番目の Direct I/Oオブジェク

トを配置します。トランザクション領域内をダブルクリックして、
[I/O Transaction]ダイアログ・ボックスを表示します。

コマンド文字列以外はすべてデフォルトの設定を使用します。この場合
は、"FR", <frequency>, "HZ"フォーマットを使用します。これは式リ

ストであり、それぞれの式はコンマで分けられています。周波数は変数
Aによって表されますが、これは Direct I/Oオブジェクトのデータ

入力端子になります。

2. コマンド文字列の入力フィールドをクリックして「"FR",A,"HZ"」と

入力します。たとえば、Aの値が 100の場合、VEE は文字列 FR100HZ

を送信します。[OK]をクリックします。VEE は、A のラベルが付いた

データ入力ピンを自動的に追加します。

3. [Flow]⇒ [Repeat]⇒ [For Range]を選択し、オブジェクトを

Direct I/O オブジェクトの左に配置します。

4. For Rangeのデータ出力ピンを Direct I/Oのデータ入力ピンに接続

します。

5. [For Range]の各フィールドを編集して、[From]は [10]、[Thru]

は [1.8M]、[Step]は [50k]を指定します。

[For Range]は、10 から 180 万までの範囲の数値を 5 万ステップで送

信します。数値は Direct I/O オブジェクトで受取られ、コマンド文字列
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が Function Generator に周波数を出力させます。Direct I/O のセットアッ

プは図 3-19 のようになります。

図 3-19. 入力変数を使った Direct I/O のセットアップ

6. ( オプション ) コンピュータを所有している場合、HP3325B をコン

ピュータに接続し、この Direct I/O オブジェクトの設定を編集して計測

器のアドレスを付け加えます。プログラムを実行すると、計測器はこの
周波数を生成します。

計測器からのデータ読込み

計測器はさまざまなフォーマットでコンピュータにデータを送信します。
計測器からデータを読込むには、読込むデータの種類と、そのデータが単
一の値 ( スカラ ) または配列のどちらで返されるのかを知る必要がありま

す。また計測器がデータをテキスト (ASCII) またはバイナリのどちらで返

すのかも知る必要があります。

返されるデータについての情報は計測器のドキュメントで確認できるほか、
VEE の [I/O]メニューにある [Bus I/O Monitor]を使って調べること

ができます。この情報により、I/O トランザクションの設定方法が決まり

ます。

この例では、1 つ前の例題で説明したとおり、HP3478A マルチメータが

HP3325B Function Generator に接続されています。Generator が周波数を送信

すると、マルチメータはデータを読込んで結果を VEE に戻します。次の手

順では、マルチメータ用トランザクションの設定方法を説明します。

メモ この例では、[READ TEXT]トランザクションについて説明しています。

[READ]には、ほかに [BINARY]、[BINBLOCK]、[CONTAINER]の選択

肢がありますが、これらについては VEE Pro Advanced Techniques マニュア

ルで詳述しています。
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1. [I/O]⇒ [Instrument Manager]を選択します。[Add]をクリック

します。この名前を dvmに変更します。[Advanced]をクリックし、

[Live Mode:]を [OFF]に設定します。HP3478A を接続していない場

合は、[OK]をクリックして [Instrument Manager] に戻ります。HP3478A
を接続している場合は、アドレスを修正すると、計測器がコマンドを実
行します。

2. [dvm(@(NOT LIVE))]を強調表示し、[Create I/O Object]の下

にある [Direct I/O]をクリックします。

3. [<Double-Click to Add Transaction>]のバーをダブルクリック

して [I/O Transaction]ダイアログ・ボックスを表示します。

4. 入力フィールドを強調表示し、「T5」と入力します。次に、[OK]をク

リックします。これにより、計測器に Tコマンドが書込まれます。T5

は、マルチメータに対する単一のトリガのためのコマンドです。

5. オブジェクト・メニューを開いて [Add Trans]をクリックし、トラン

ザクション・バーをもう一つ追加します。または、[<Double-Click 

to Add Transaction>]をダブルクリックしてトランザクションを追

加し、[I/O Transaction]ダイアログ・ボックスを表示します。

6. [WRITE]の隣の下向き矢印をクリックしてドロップダウン・メニュー

を表示し、[READ]を選択します。[READ]を選択すると、[I/O 

Transaction]ダイアログ・ボックスに新しいボタンが表示されます。

7. [ExpressionList]入力フィールドをチェックして、「x」が入力され

ていることを確認します。Tab キーを押して次のフィールドに移動しま

す。計測器から返されるデータは、データ出力ピンへ送られます。この
場合は、データは計測器から読込まれ、「x」という名前でデータ出力ピ

ンへ送られます。

メモ 名前は大文字と小文字を区別しません。

8. [REAL64 FORMAT]はデフォルト値のままにします。マルチメータは

個々の読取り値を実数として返します。

9. [DEFAULT NUM CHARS]は変更しません。
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デフォルトの文字数は 20 です。文字数を変更するには、[DEFAULT 

NUM CHARS]をクリックして [MAX NUM CHARS]に切替え、20を目的

の数値に変更します。

10. [SCALAR]は変更しないで [OK]をクリックします。

バーに、トランザクションが READ TEXT X REAL64のように表示され

ます。VEE は「x」という名前のデータ出力端子を自動的に追加します。

メモ 計測器が数値配列を返す場合は、[I/O Transaction]ダイアログ・ボッ

クスの [SCALAR]メニューを選択して、図 3-20 のような次元のメニュー

を表示します。配列次元を選択した場合は、配列のサイズも指定する必要
があります。

図 3-20. READ トランザクションの設定

11. [Display]⇒ [AlphaNumeric]を選択して AlphaNumericオブ

ジェクトを右側に追加し、入力ピンを Direct I/Oの「x」のラベルが

付いた出力ピンに接続します。

2 つの Direct I/O トランザクションは図 3-21 のようになります。 
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図 3-21. 測定値を読込むように設定された Direct I/O

トランザクションを設定する手順は、READ TEXTトランザクションのデー

タ形式に関係なく、似ています。使用できるほかの形式を調べることがで
きます。各項目についての詳細は、VEE Pro Advanced Techniques マニュア

ルを参照してください。

完全なテスト・プログラムを作成するには、このマルチメータ・オブジェ
クトと Function Generator オブジェクトを VEE のデータと表示オブジェク

トで結合します。VEE では、完全に機能するテスト・プログラムを簡単に

作成できます。しかし、使用する可能性があるさまざまな計測器のすべて
について詳細を説明するのは、この入門のための章の範囲を超えています。
より複雑な例については、VEE Pro Advanced Techniques マニュアルを参照

してください。

計測器のステートのアップロード・ダウンロード

計測器のなかには、「ラーン・ストリング」能力を提供するものがありま
す。ラーン・ストリングには、計測器のステートを構成する関数設定のす
べてが含まれます。Direct I/O はこのラーン・ストリングをアップロードし

て特定の Direct I/O オブジェクトとともに保存します。保存したラーン・ス

トリングは、後でプログラム中の計測器にダウンロードできます。計測器
のステートのアップロードは、次の手順で行います。

1. 計測器を手動で目的のステートに設定します。

2. Direct I/Oオブジェクトのオブジェクト・メニューを開いて、

[Upload State]をクリックします。

これにより、設定したステートが、この特定の Direct I/O オブジェクト

に関連付けられます。

3. トランザクション領域でダブルクリックして、[I/O Transaction]

ダイアログ・ボックスを開きます。
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4. [TEXT]をクリックして [STATE (LEARN STRING)]を選択します。

次に [OK]をクリックして [I/O Transaction]ダイアログ・ボック

スを閉じます。この WRITEトランザクションを実行すると、あらかじ

め取得したステートが計測器に送信されます。

アップロードおよびダウンロードは、[Direct I/O Configuration] ダイアログ・

ボックスの設定によって制御されます。[Conformance] が IEEE 488.2 の場

合、VEE は、自動的に「488.2 *LRN?」定義を使ってラーン・ストリング

を処理します。[Conformance] が IEEE 488 の場合は、[Upload String]

がステートの照会に使用するコマンドを特定し、[Download String]が

ダウンロード時にステートの文字列の前に送信されるコマンドを特定しま
す。図 3-22 に例を示します。

図 3-22. HP54100A 用のラーン・ストリング設定

[Conformance] には、[IEEE 488] または [IEEE 488.2] を指定できます。この

例は HP 54100A Digitizing Oscilloscope を使用していますが、この製品は

IEEE 4881 規格に適合しており、ラーン・ストリングの照会には SETUP?

コマンドを、ダウンロード時のラーン・ストリングの前には SETUPコマン

ドを必要とします。[State (Learn String)]で [Configured]を選

択すると、Upload Stringおよび Download Stringというラベルが付

いた 2 つのフィールドが表示されます。この 2 つの入力フィールドには、

適切な文字列がすでに入力されています。
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PC プラグイン・ボードの使用方法

VEE では、PC プラグイン・ボードまたはカードを制御する方法として次

の 3 つが提供されています。

1. PC プラグイン・カード・メーカから提供される ODAS ドライバ

2. Data Translation 社の Visual Programming Interface。VPI アプリケーション

は Data Translation 社に直接注文してください。

3. ComputerBoards や Meilhaus のような PC ボード・メーカから提供されて

いる DLL(Dynamic link libraries)。DLL の使用方法についての詳細は、

425 ページの「ダイナミック・リンク・ライブラリの使用法」を参照し

てください。 

ODAS ドライバの使用方法

製造メーカの説明書に従って、PC プラグイン・ボードのインストール、

ODAS ドライバ・ソフトウェアのインストール、ODAS 設定ユーティリ

ティの実行を行います。次に、VEE でドライバの設定を行います。

1. [I/O]⇒ [Instrument Manager]を選択します。[Find 

Instruments]を選択します。[Instrument Manager]には図 3-23
のようなリストが表示されます。
第第第第 3 章章章章 159159159159



簡単な計測器の操作

PC プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法
図 3-23. [Instrument Manager] での ODAS ドライバリスト

2. [Thermistor0]のようなサブ項目を 1 つ選択し、[Create I/O 

Object]の下にある [PCPI Driver]を選択します。クリックしてオ

ブジェクトを配置します。図 3-24 のように、VEE に Formulaオブ

ジェクトが表示されます。

図 3-24. ODAS ドライバを設定した PC プラグイン・カードを表す

Formula オブジェクト

ODAS ドライバを設定した PC プラグイン・カードの使用についての詳細

は、VEE Pro Advanced Techniques マニュアルを参照してください。
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Data Translation 社の Visual Programming 
Interface(VPI) 
Data Translation の VPI は VEE で動作して、PC プラグインのためにシーム

レスなデータ取得性能を発揮します。Data Translation 社の Open Layers 規格

の柔軟性を導入することにより、50 以上のデータ取得ボードにアクセスで

きます。

VPI は、低いチャンネル数を要求するプラグイン ISA、PCI、USB ベースの

データ取得カードで直接動作します。VPI はメニューの選択項目と特定の

PC プラグイン・データ取得アイコンを VEE に追加します。これらは Data 
Translation 社製ハードウェアの機能を制御します。

Amplicon
Amplicon は、シリーズ 200 用の幅広いアナログおよびディジタルの I/O PC
プラグイン・ボードであり、すべて VEE によってサポートされています。

ソフトウェア・インタフェースは Amplicon の AMPD10 ドライバ・パッ

ケージの一部ですが、このパッケージは、Windows 用マルチスレッド DLL
で提供される 32 ビット API であり、割込み操作によるデータ取得をサ

ポートします。効率的で柔軟性のあるプログラム作成のために、VEE 固有

の定義ファイルおよび 1 つのプログラムに 8 つまでボードを使用できる機

能を利用して、API は、コンパイル済み関数として 100 以上の関数を呼出

すことができます。

Amplicon 自身のプラグイン・ボードには、シリアル通信デバイスが含まれ

ますが、Amplicon はさらに、データ取得、シリアル通信、GPIB アプリ

ケーションのために他製造元のボードを幅広く提供します。

図 3-25 で示したように、VEE 実行ソフトウェア (Amplicon のアナログ出力

ボード PCI224 と PCI234、およびアナログ入力ボード PCI230 と PCI260 で

無料で提供されています ) は、PC 上で入力 / 出力信号を同時に送信でき

ます。
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図 3-25. Amplicon によるデータ取得例

ComputerBoards が提供する PC プラグイン

ComputerBoards は、VEE と互換性のある低価格で強力な PC プラグイン・

ボードを提供します。サポートされている PC プラグイン・メーカの完全

なリストについては、VEE のドキュメントまたは VEE Pro Advanced 
Techniques を参照してください。

ボードと I/O ライブラリをインストールして、製造元が提供するプログラ

ムを使ってボードを設定します。説明書に従ってボードをデバイスに接続
します。VEE では、ライブラリをインポートすると、ComputerBoards I/O
ライブラリに測定関数を呼出すことができます。製造元が提供するデモ・
プログラムから抜粋した次の図を参照してください。
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図 3-26. VEE による ComputerBoards 100kHz ボードの使用

図 3-26 は、この 100kHz A/D ボードを使ったデモ・プログラムのパネル・

ビューです。また図 3-27 は、これらのデータ取得関数の呼出しを可能にす

る ComputerBoards I/O ライブラリを VEE がインポートしているところを示

します。

図 3-27. ComputerBoards I/O ライブラリのインポート
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PC プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法
Meilhaus Electronic の ME-DriverSystem
Meilhaus Electronic は、ヨーロッパで代表的な PC ベースのデータ取得 / イ
ンタフェース技術の設計・生産・販売会社です。CD-ROM で提供している

Windows 向け ME-DriverSystem には、Meilhaus Electronic によって生産され

ているすべてのデータ取得ボード (ME シリーズ ) が含まれます。ME-
DriverSystem はまた、VEE のメニュー構造に統合されます。

VEE 用 ME-DriverSystem をインストールすると、VEE のプルダウン・メ

ニューにドライバの関数が表示されます。図 3-28 は VEE における ME 
Board メニューを示しています。

図 3-28. VEE における ME Board メニュー

メニューの第 2 位のレベルには、Analog Input および Output、Digital I/O、

特定のボードの関数といった関数グループがあります。図 3-29 は、データ

取得ボード ME-3000 のユーザ・パネルを示します。
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PC プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法プラグイン・ボードの使用方法
図 3-29. データ取得ボード ME-3000 のユーザ・パネル 

最後に、第 3 位のメニューには、me3000AISingle のような実際の関数があ

ります。図 3-30 は関数パネルを示します。

図 3-30. ME-DriverSystem の関数パネル
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VXI plug&play ドライバの使用方法ドライバの使用方法ドライバの使用方法ドライバの使用方法
VXI plug&play ドライバの使用方法

VXI plug&play ドライバは、さまざまな計測器メーカから提供され、サポー

トされています。これは C ベースのドライバであり、最大限のパフォーマ

ンスと使いやすさを実現するように設計されています。

Agilent VEE は、VXI plug&play と完全に互換性があります。Agilent 
Technologies から入手できるすべての VXI plug&play ドライバは、別製品と

して搭載されています。また Web サイト

http://www.agilent.com/find/inst_driversでも入手できます。

また同じドライバが、すべての Agilent Technologies パネル・ドライバと共

に VEE に入っています。ほかの計測器用の VXI plug&play ドライバを入手

するには、計測器メーカにお問合せください。

例題 3-4: VXI Plug&play ドライバの設定

この例では、HPE1412 ドライバの設定方法を説明します。

1. [I/O]⇒ [Instrument Manager]を選択します。

2. [My Configuration]を強調表示して、[Instrument]の下にある

[Add]をクリックします。[Instrument Properties]ダイアログ・

ボックスが表示されます。「instrument」のように名前を入力し

[Advanced]をクリックし、[Advanced instrument 

Properties]ダイアログ・ボックスを表示します。

3. [Advanced instrument Properties]ダイアログ・ボックスで、

[Live Mode:]を [OFF]に切替え、[Plug&play Driver]フォルダ

を選択します。[Plug&play Driver Name:]フィールドをクリック

して、コンピュータにインストールされているすべてのドライバをリス
トしたドロップダウン・メニューを表示します。この例では、図 3-31
に示すように HPE1412 ドライバを使用します。
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VXI plug&play ドライバの使用方法ドライバの使用方法ドライバの使用方法ドライバの使用方法
図 3-31. VXI plug&play ドライバの選択

4. HPE1412ドライバを選択し [OK] をクリックして、[Instrument 

Properties]ダイアログ・ボックスに戻ります。次に、[OK]をク

リックして [Instrument Manager]に戻ります。これで、リストに

[instrument(@(NOT LIVE))]の項目が追加されます。

5. [instrument(@(NOT LIVE))]を強調表示して、[Create I/O 

Object]の下にある [Plug&play Driver]を選択します。クリック

してオブジェクトを配置します。

メモ VEE では、VXI plug&play ドライバは Direct I/O オブジェクトに似ています。

計測器で測定を行うには、VXI plug&play ドライバで C 関数を使用する I/O
トランザクションを設定する必要があります。ドライバは、使用すべき適
切な関数を選択するためのパネルを提供します。

6. <Double-click to Add Function>のラベルが付いたトランザク

ション・バーをダブルクリックすると、図 3-32 のように [Select a 

Function Panel]が表示されます。図 3-33 は、関数パネル内での関

数の階層を示しています。また、選択した項目についてのヘルプがダイ
アログ・ボックスに表示されます。
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VXI plug&play ドライバの使用方法ドライバの使用方法ドライバの使用方法ドライバの使用方法
メモ VEE は、自動的に計測器を初期化します。ほかのプログラム言語のように

init関数を使用する必要はありません。

図 3-32. VXI plug&play ドライバ用関数の選択

7. [Configure Present Settings]⇒ [Measurement Type]⇒

[Measurement Type Setup]をクリックします。[Edit Function Panel]
が表示されます。[func] の下でクリックしてドロップダウン・リストを

表示します。図 3-33 のように、デフォルトの [DC Voltage] を選択します。
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VXI plug&play ドライバの使用方法ドライバの使用方法ドライバの使用方法ドライバの使用方法
図 3-33. HPE1412 の [Edit Function Panel]

8. [OK] をクリックします。これで、図 3-34 のように、[To/From 

Instrument]オブジェクトに
[hpe1412_configure(instruHandle,hpe1412_CONF_VOLT_DC)]

の項目が追加されます。

図 3-34. VXI plug&play オブジェクトにおける DC Voltage Function
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VXI plug&play ドライバの使用方法ドライバの使用方法ドライバの使用方法ドライバの使用方法
9. [To/From Instrument]オブジェクトで <Double-click to Add 
Function>をダブルクリックし、[Measure]の下にある [Take 

Measurement]を選択します。[Configuration]フォルダをクリッ

クして、ダイアログ・ボックスの表示を図 3-35 のようにします。

図 3-35. [Edit Function Panel] の [Configuration] フォルダ

10. [OK] をクリックします。2 番目の関数の呼出しが [To/From 

Instrument]オブジェクトに図 3-36 のようにリストされます。

図 3-36. DC 読込みのために用意された HPE1412 ドライバ
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そのほかの I/O 機能

VEEのすべてのI/O機能については[I/O]⇒[Advanced I/O]のサブメ

ニュー、[Interface Operations]、[Instrument Event]、

[Interface Event]および [Multiinstrument Direct I/O]で

調べることができます。

I/O メニューでは、Bus I/O Moniter を使用してデバッグを行うためにバ

ス・アクティビティを表示、印刷、または保存できます。

VEE には、プログラムによって計測器を検索できる ActiveX オートメー

ション・サーバが含まれます。詳細は、VEE Pro Advanced Techniques マ
ニュアルを参照してください。

I/O 構成は、実行時にプログラムによって変更することもできます。詳

細は、VEE Pro Advanced Techniques マニュアルを参照してください。
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この章の復習この章の復習この章の復習この章の復習
この章の復習 
この章では、次の操作について学びました。次の章に進む前に、必要なら
適切なトピックを復習してください。

計測器ドライバおよび Direct I/O を使用する利点を説明する。

計測器を制御する手順を説明する。

ステート・ドライバで計測器を設定する。

Direct I/O で計測器を設定する。

計測器ドライバの設定を変更する。

入力 / 出力コンポーネントを追加 / 削除する。

計測器ドライバ上で異なるパネルに移動する。

Direct I/O を使って計測器にコマンドを書込む。

Direct I/O を使って計測器からデータを読込む。

ラーン・ストリングを使って計測器のステートをアップロード / ダウン

ロードする。

VXI plug&play ドライバを使って計測器と通信する。

PC プラグイン・ボードを制御する 3 つの方法を説明する。
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テスト・データの分析と表示 

この章の内容

VEE のデータ型

VEE の分析機能

演算オブジェクトの使用方法

Formula オブジェクトの使用

MATLAB Script オブジェクトの使用方法

VEE の表示機能

表示のカスタマイズ

平均的な必要時間 :1.5 時間
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概要概要概要概要
概要

この章では、VEE の分析機能および表示機能について学びます。また、ア

プリケーションに適切な演算オブジェクトを配置する方法およびテスト結
果の表示方法について学びます。これにより、データを有用な情報に簡単
にすばやく変換できるようになります。

また、ActiveX オートメーションを使用すると、MS Excel のような一般的

なアプリケーションを使ってデータを分析することもできます。詳細は、
249 ページの第 6 章「ActiveX を使ったレポートの簡単な作成方法」を参照

してください。ActiveX コントロールを使用すると、VEE の外部の表示機

能を使用できます。詳細は、404 ページの「ActiveX コントロールの使用方

法」を参照してください。この章では、VEE 自身の主要ツールと VEE に

含まれる MATLAB Script オブジェクトを中心に説明します。
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Agilent VEE のデータの種類とデータ型のデータの種類とデータ型のデータの種類とデータ型のデータの種類とデータ型
Agilent VEE のデータの種類とデータ型

VEE プログラムでは、データはオブジェクト間のラインを通って伝達さ

れ、次のオブジェクトで処理されます。データ集合を明確にするために、
VEE ではデータをデータの種類 ( スカラ、配列など ) とデータ型 (Int32、
Real64、テキストなど ) を持つ「コンテナ」というパッケージにします。

データの種類 : スカラは単一の数字で、複素数のような 2 つ以上の要素で

表現される数も含まれます。配列はデータ項目のグループで、1 次元

(Array 1D)、2 次元 (Array 2D)、などとして特定できます。

データ型 :VEE のデータ型については表 4-1 で説明しています。

一般には、データ型やデータの種類について気にする必要はありません。
ほとんどのオブジェクトは、VEE のどのようなデータ型に対しても動作し

ますし、そのオブジェクトで必要なデータ型にデータを自動的に変換する
からです。たとえば、Magnitude Spectrum の画面が Waveform のデータ型を

受取った場合、VEE は自動的に高速フーリエ変換を実行してデータをタイ

ム・ドメインから周波数ドメインに変換します。

しかし、特定のデータ型を要求するオブジェクトもあるので、それらにつ
いても知っておくべきです。また、VEE と MATLAB でのサポートされる

データ型の違いについての知識も役立ちます。詳細は、193 ページの

「データ型の処理方法」のセクションを参照してください。

次の表は、VEE のデータ型について、短時間で読むことができる簡単な説

明です。これらのデータ型の使用方法については、次章で説明します。

表 4-1. Agilent VEE のデータ型

データ型 [Description]

UInt8 0 から 255 までの無符号バイト数です。

Int16 16 ビットの 2 の補数整数です (-32768 ～

32767)。

Int32 32 ビットの 2 の補数整数です (-2147483648 ～

2147483647)。
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Real32 32 ビットの浮動小数点数で IEEE 754 標準に準拠

しています (+/-3.40282347E+/-38)。

Real64 64 ビットの浮動小数点数で IEEE 754 標準に準拠

しています (+/- 1.797693138623157 E308)。

PComplex (mag, @phase) の形式で表した大きさおよび位相

成分から成ります。位相は、デフォルトでは度数
単位に設定されていますが、[File] ⇒ [Default 
Preferences] ⇒ [Trig Mode setting] を選択してラ

ジアンやグラディアン単位に設定することができ
ます。

Complex 直交座標またはデカルト座標の複素数で、(real, 
imag) の形式で表した実数および虚数成分から成

ります。各成分のデータ型は Real64 です。たと

えば、複素数「1 + 2i」は (1,2) として表現され

ます。

Waveform タイム・ドメインの値から成る複合データ型であ
り、等間隔で線形にマッピングされた点の
Real64 値と、波形の全タイム・スパンを保持し

ています。Waveform のデータの種類は、1 次元

配列 (Array 1D) でなければなりません。 

Spectrum 周波数ドメインの値から成る複合データ型であ
り、点の PComplex 値と、周波数の最小値および

最大値を保持しています。ドメイン・データは対
数または線形にマッピングすることができます。
Spectrum のデータの種類は、1 次元配列 (Array 
1D) でなければなりません。

Coord (x,y,...) の形式で表され、最低 2 つの成分から成

りたつ複合データ型です。各成分のデータ型は
Real64 です。Coord のデータの種類はスカラま

たは Array 1D でなくてはなりません。

表 4-1. Agilent VEE のデータ型 ( 続き )

データ型 [Description]
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Agilent VEE のデータの種類とデータ型のデータの種類とデータ型のデータの種類とデータ型のデータの種類とデータ型
メモ 混在した環境でのデータの共有については、[I/O]⇒ [To/From 

Socket]を参照してください。

Enum 整数値に対応させたテキスト文字列です。
ordinal(x) 関数を使って整数値にアクセスできます。

Text 英数字文字列です。

Record 各データ型ごとのフィールドから成る複合データ
型です。各フィールドには名前とコンテナがあ
り、どのような型と種類 (Record を含む ) でも含

むことができます。

Object ActiveX オートメーションおよびコントロール専

用のデータ型で、ActiveX コントロールに対する

参照値、または ActiveX オートメーションの呼出

しから返される参照値です。実際には、このデー
タ型は IDispatch または IUnknown インタフェー

スに対する参照値です。

Variant ActiveX オートメーションおよびコントロール専

用で、ActiveX 方式の呼出しに対して By Ref パラ

メータ型として要求されるデータ型です。

表 4-1. Agilent VEE のデータ型 ( 続き )

データ型 [Description]
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Agilent VEE の分析機能の分析機能の分析機能の分析機能
Agilent VEE の分析機能

VEE は、一般的な算術演算子およびそのほかの数多くの関数をサポートし

ます。さらに、VEE には MATLAB Script 機能も備えられています。

MATLAB Script 機能は、MathWorks 社製の標準の高機能 MATLAB のサブ

セットであり、VEE に、信号処理、高度な数式処理、データ分析、科学的

/ 工学的グラフィックを含む算術機能を付加します。MATLAB Script 機能

は、VEE と完全に統合されているので、どのような VEE プログラムにも

MATLAB Script オブジェクトを入れることができます。

必要な演算関数が VEE と MATLAB のどちらにもない場合は、さらにいく

つかのオプションを使用できます。この章で後述する Formulaオブジェ

クトを使用すると関数を作成できます。C 言語のようなコンパイル済み言

語で関数を記述し、記述した関数を VEE にリンクさせることもできます。

また VEE から別のソフトウェアと通信することもできます。
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組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法
組込み演算オブジェクトの使用方法

VEE で、[Device]⇒ [Function & Object Browser]を選択すると、

VEE および MATLAB の組込み ( プログラム済み ) 算術式にアクセスでき

ます。

組込み演算子または関数へのアクセス 
VEE の算術演算子および関数にアクセスするには、[Device]⇒

[Function & Object Browser]を選択します。たとえば、特定の範囲

の乱数を返す式を作成するには、図 4-1 のように、[Type:]は [Built-

in Functions]、[Category:]は [Probability & Statistics]、

[Functions:]は [random]を選択します。

図 4-1. [Function & Object Browser] における VEE 関数

[Function & Object Browser]には、図 4-1 に示したように、現在の

選択項目についての簡単な説明が表示されます。また、[Help]ボタンを

クリックすると、現在の選択項目についてさらに詳しい説明が表示され、
定義、使用方法、構文、使用例といった情報を得ることができます。

関数の説明

現在の選択項目についてのヘルプを表示
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組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法
MATLAB の演算子および関数にアクセスするには、[Device]⇒

[Function & Object Browser]を選択し、[Type:]で [MATLAB 

Functions]を選択します。たとえば、ルートを多項式に変換するには、

図 4-2 のように、[Type:]は [MATLAB Functions]、[Category:]は

[Interpolation & Polynomials]、[Functions:]は [poly]を選

択します。

図 4-2. [Function & Object Browser] における MATLAB 関数

[Function & Object Browser]には、現在の選択項目についての簡単

な説明が表示されます。また、[Help]ボタンをクリックすると、現在の

選択項目についてさらに詳しい説明が表示されます。MATLAB の Runtime 
Engine および Script については、189 ページの「Agilent VEE における

MATLAB Script の使用」セクションで詳述しています。

例題 4-1: 標準偏差の算出

周波数が 1kHz、振幅が 1V、タイム・スパンが 20ms で、256 の点で表され

る余弦波形を生成します。この波形の標準偏差を算出して表示します。

1. [Device]⇒ [Virtual Source]⇒ [Function Generator]を選

択します。[Frequency]を適切に設定してアイコン化します。
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組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法組込み演算オブジェクトの使用方法
2. [Device]⇒ [Function & Object Browser]を選択し、次に、

[Built-in Functions]、 [Probability & Statistics]、

[sdev]を選択します。[Create Formula]をクリックします。

メモ 図 4-3 のようにツールバー上の [fx] アイコンを押すか、または Ctrl+I キー

を押すと、[Function & Object Browser] ダイアログ・ボックスに直接アクセ

スできます。

図 4-3. [fx] アイコンを使った [Function and Object Browser] の表示

3. sdev()のオブジェクト・メニューを開いて [Help]を調べます。

メモ sdev(x)オブジェクトは、xの分散の平方根として定義されます。xは、

UInt8、Int16、Int32、Real32、Real64、Coord、Waveform のいずれのデータ

型も可能です。Function Generator は、Waveform のデータ型を出力します。

4. Function Generatorを sdev(x)に接続します。

5. [Display]⇒ [AlphaNumeric]を選択し、sdev(x)データ出力ピン

に接続します。 

6. プログラムを実行します。図 4-4 のように表示されます。

図 4-4. 標準偏差の算出

[Function and Object Browser] アイコン
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Formula オブジェクトでの式の作成

Formulaオブジェクトは、VEE で算術式を記述するために使用できます。

式内の変数はデータ入力ピンの名前またはグローバル変数です。式の評価
結果はデータ出力ピンに渡されます。

図 4-5 は Formulaオブジェクトの例です。式を入力するためのフィールド

はオブジェクトの中央にあります。デフォルトの式 (2*A+3)が式を入力

する場所を示しています。フィールドをダブルクリックして、別の式を入
力します。

メモ Formulaの式は、複数行に入力できます。Formula式に改行が含まれる

場合、その式は複数行に入力された単一の式として解釈されます。
Formulaにセミコロン (;) で分けられた文が含まれる場合、それらの文は

Formula内の複数の式として解釈されます。

また、Formula内で式を編集するために、標準の編集コマンドを使用でき

ます。たとえば、マウスをドラッグして文字を強調表示し、Ctrl+C キーを

使って文字をコピーしたり、Ctrl+V キーを使って文字を貼付けたり、

Ctrl+X キーを使って文字を削除したりできます。

図 4-5. Formula オブジェクト

入力フィールド
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メモ [Devices]⇒ [Function & Object Browser]で [Type]に

[Built-in]を選択して関数を作成すると、適切に設定された式を持つ

Formula オブジェクトを簡単に作成できます。これらの関数は、関数を結

合したり、入力端子を追加 ( または削除 ) するなどして修正できます。ま

た、Formulaオブジェクトに複数行を入力したり、出力端子に値を割当て

ることもできます。

Formula オブジェクトを使った式の評価

この例では、2*A^6-Bという式を評価します。この式において A=2、また

B=1です。「^」の記号は累乗を表します。

メモ 変数の名前は、大文字小文字の区別はされません。

1. [Device] ⊄[Formula]を選択します。[Formula]の入力フィールド

をクリックし、「2*A^6-B」と入力します。

2. マウス・ポインタをデータ入力端子領域に置き ( 入力端子 Aの上に置か

ないようにします )、Ctrl+A キーを押して入力ピンを追加します。

メモ 追加された入力ピンはデフォルトでは Bのラベルが付けられますが、この

名前は変更できます。

3. [Data]⇒ [Constant]⇒ [Int32]を選択します。次にオブジェク

ト・メニューから [Clone]を選択して Int32 オブジェクトのクローン

を作成します。作成した 2 つの Int32 オブジェクトを Formula の Aと B

の入力ピンに接続します。

4. A Int32の入力ボックスに「2」を入力し、B Int32の入力ボックス

に「1」を入力します。

5. [Display]⇒ [AlphaNumeric]を選択し、作成されたオブジェクト

を Formula の出力ピンに接続します。そしてプログラムを実行します。

図 4-6 のように結果の 127 が表示されます。
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図 4-6. 式の評価

Formula オブジェクトでの Agilent VEE 関数の

使用方法

この例では、余弦波を生成し、Formulaオブジェクトを使って標準偏差と

根二乗平均を算出します。

1. [Function Generator]、[Formula]、[AlphaNumeric]を選択し

てオブジェクトを作成し、データ・ピンで互いに接続します。

2. Formulaオブジェクトのオブジェクト・メニューを開いて [Clone]を

選択して、クローンを作成します。次に、最初の Formulaオブジェク

トの下に作成したクローンを配置します。Function Generatorの

データ出力ピンを 2 番目の Formulaオブジェクトに接続します。

3. [AlphaNumeric] のクローンを作成し、作成したクローンを 2 番目の

[Formula]オブジェクトに接続します。

4. 最初の Formulaオブジェクトに「sdev(A)」を、2 番目の Formula

オブジェクトに「rms (A)」を入力します。

sdev(A)および rms (A)は、[Device]⇒ [Function & Object 

Browser]ダイアログ・ボックスで作成できる演算関数でもあります。

このように、これらは「関数」として呼出すことも「独立したオブジェ
クト」として呼出すこともでき、どちらの場合も同じ動作をします。

5. プログラムを実行します。図 4-7 に示したように、これらの関数を

Formulaオブジェクトに入れると、プログラムは、独立したオブジェ

クトとして使用した場合と同じ答えを表示します。
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図 4-7. VEE 関数を使った Formula の例

今度は、Formulaオブジェクトを 1 つだけ使って標準偏差および根二乗平

均を計算します。Formula オブジェクトは、それぞれに値を割当てられた

出力端子を複数持つことができます。

6. オブジェクト・メニュー・ボタンをダブルクリックして、[Formula]

オブジェクトの 1 つを削除します。

7. 残った Formulaオブジェクトで式を次のように変更します。
B=sdev(A);
C=rms(A)

メモ Formulaオブジェクトに式を複数含める場合は、式の終わりにセミコロン

を入れて次の式と区別ができるようにします。たとえば、B=sdev(A);の

式で、セミコロンは式の終わりを示します。

メモ Formulaオブジェクトでは、任意の位置に改行を入れることができます。

式は、セミコロンがないかぎり、1 つの式として解釈されます。たとえば、

単一の式を次のように入力することもできます。

B=sdev
(A) 

式にはまた、読みやすいようにスペースを入れることができます。

8. Formulaオブジェクトに出力端子を追加します。出力端子の名前を B

および Cに変更します。出力端子 Bを Alphanumericオブジェクトの
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1 つに、また出力端子 Cをもう 1 つの Alphanumericオブジェクトに

接続します。

9. プログラムを実行します。図 4-8 のように表示されます。

図 4-8. Formula オブジェクトを 1 つだけ使った VEE 関数

独習課題

図 4-9 に示すように、次の例題を完成して結果をチェックします。

1. [Built-in Functions]の Generateカテゴリにある rampオブ

ジェクトを使用して、1 から 2048 までの数の配列を作成します。この

配列の標準偏差を算出して、その値を表示します。

2. rampオブジェクトのかわりに Formulaオブジェクトで ramp()関数

を使用して、1 つ前の手順で説明したのと同じ課題を実行します。

3. 関数をネストして、1 つ前の手順で説明したの同じ例題を実行します。

オブジェクトは 2 つしか使用しません。
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図 4-9. Ramp および SDEV についての独習課題解答

2 番目および 3 番目の課題では、Formulaオブジェクトの入力端子 Aを削

除してエラー・メッセージが表示されないようにする必要があります。す
べてのデータ入力ピンが接続されデータを受取ってはじめて、オブジェク
トは動作できるからです。
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Agilent VEE における MATLAB Script の
使用

VEE には MATLAB Script オブジェクトがあり、MATLAB の機能にアクセ

スできます。VEE は MATLAB Script Engine とデータのやり取りができるの

で、VEE プログラムに MATLAB 算術関数を入れることができます。

メモ すでに MATLAB をインストールしている場合は、VEE はインストール済

みの MATLAB を使って MATLAB Script を処理します。しかし、Signal 
Processing Toolbox がない場合は、VEE に同梱されている MATLAB Script 
Engine を登録しないと、VEE から MATLAB の関数を使用することはでき

ません。MATLAB を登録するには、ディレクトリ (CD コマンドで ) を
<VEE_installation_dir>\MATLAB\binに変更して、次のコマンドを実行し

ます。
MATLAB.exe /regserver. 

MATLAB Script オブジェクトの使用例

VEE が生成したデータに対して MATLAB を動作させる。

MATLAB Script オブジェクトから結果を返して、VEE プログラムの別の

部分でその結果を使用する。
MATLAB の Signal Processing Toolbox 機能を使用して、MATLAB Script オ
ブジェクトで高度なフィルタの設計や実装を行う。
2 次元または 3 次元グラフを使ってデータを視覚化する。

図 4-10 は、VEE プログラム内で MATLAB Script オブジェクトがどのよう

に使われるかを示しています。MATLAB Script プログラムが動作すると、

データが生成されて Alphanumericオブジェクトに表示されます。
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図 4-10. VEE プログラムにおける MATLAB Script オブジェクト
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図 4-11 は、プログラムが実行されたときに作成されるグラフを示します。

図 4-11. プログラムによって生成されたグラフ

VEE プログラムに MATLAB Script を入れると、VEE は MATLAB Script 
Engine を呼出して MATLAB Script オブジェクト内の演算を実行します。情

報は、VEE から MATLAB へ渡され、再度 VEE に戻されます。MATLAB 
Script オブジェクト使用にあたってのポイントは次のとおりです。

プログラム内で最初に動作する MATLAB Script オブジェクトは、1 つの

MATLAB セッションを開きます。プログラム内にあるほかの MATLAB 
Script オブジェクトはすべて、そのセッションを共有します。これによ

り、MATLAB Script オブジェクトは MATLAB ワークスペース内のグ

ローバル変数を共有できます。

VEE は、MATLAB Script Engine を呼出さないかぎり、MATLAB のコマン

ドの構文をチェックしません。MATLAB によって生成されるエラーお
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よび警告は、VEE のエラーや警告と同じように、通常の VEE のダイア

ログ・ボックスに表示されます。

VEE と異なり、MATLAB は大文字小文字の区別を行います。MATLAB 
Script オブジェクトの入力 / 出力端子に大文字の Xの名前を付けた場合、

MATLAB では必ず、小文字の x ではなく大文字の X を使用してくだ

さい。

MATLAB Script に入力できる VEE のデータ型には制限があります。この

制限については、次のセクションで詳述します。

Agilent VEE に MATLAB Script オブジェクトを入れる

VEE プログラム内で使用する MATLAB オブジェクトは、VEE の Formula

オブジェクトに似ています。MATLAB Script オブジェクトをプログラムに

追加する方法は 2 とおりあります。

1. [Device]⇒ [MATLAB Script]を選択して、プログラム内のオブ

ジェクトを配置する位置をクリックします。これにより、目的に応じて
編集できるデフォルトの MATLAB Script オブジェクトが作成されます。

- または -

[Device]⇒ [Function & Object Browser]を選択し、[Type:] で
MATLAB の関数を選択します。定義済みの MATLAB 関数を選択し、

[Create Formula]をクリックします。プログラム内のオブジェクト

を配置する位置をクリックします。図 4-12 に、VEE プログラムに追加

できる定義済み MATLAB 関数の例を示します。

図 4-12. 定義済み MATLAB オブジェクトの VEE プログラムへの追加
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各 MATLAB オブジェクトの名前は MATLAB Script<function name> の

形式で付けられ、ほかの VEEFormula オブジェクトと区別できます。組

込みの VEEFormula オブジェクトと同じように、各オブジェクトにはそ

のオブジェクトが実行する関数が入力されており、また必要と思われる
入力および出力ピンが付けられています。また、ほかの VEE オブジェ

クトと同様に編集もできます。

メモ MATLAB 関数についての詳細は、VEE のメイン・ウィンドウで [Help]

⇒ [MATLAB Script]⇒ [Help Desk]を選択してください。

データ型の処理方法

VEE のデータ型のサブセットのみが MATLAB オブジェクトの入力および

出力データとしてサポートされています。

VEE は、VEE と MATLAB の関数が混在するプログラムで処理しやすいよ

うに、1 次元配列を自動的に変換します。たとえば、VEE の 1 次元テキス

ト配列は、MATLAB Script オブジェクトに入力されるとき、自動的に 2 次

元の文字配列に変換されます。また MATLAB Script オブジェクトからの 1
次元文字配列は、MATLAB Script オブジェクトから出力されるとき、自動

的に Text Scalar に変換されます。

メモ VEE のデータ型と MATLAB のデータ型との自動変換の全リストおよび解

説については、VEE のオンライン・ヘルプを参照してください。

次の例で示すように、入力端子のデータ型を制限することにより、別のオ
ブジェクトから入力されるデータがサポートされているデータ型に確実に
変換されるようにすることもできます。

1. [Data]⇒ [Constant]⇒ [Int32]を選択して、オブジェクトを配置

する位置をクリックします。値を 7 に変更します。オブジェクトのク

ローンを作成して、2 番目の Int32を最初の Int32の下に配置しま

す。値を 20 に変更します。 

2. [Device]⇒ [MATLAB Script]を選択し、定数オブジェクトの右に

オブジェクトを配置します。

3. [Display Alphanumeric]を選択し、オブジェクトを MATLAB 

Scriptオブジェクトの右に配置します。
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4. 上の Int32オブジェクトの出力ピンを MATLAB Scriptオブジェクト

の入力ピン Aに接続します。下の Int32オブジェクトの出力ピンを

MATLAB Scriptオブジェクトの入力ピン Bに接続します。MATLAB 

Scriptオブジェクトの出力ピンを Alphanumericオブジェクトの入

力ピンに接続します。 

プログラムを実行します。入力されるデータ型は、Real64、

Complex、Waveform、Textのいずれかであるべきところに、代わり

に Int32のデータが入力されたことを伝える VEE の実行時エラーが生

成されます。

このようなエラーを避けるには、MATLAB Script オブジェクトの入力端子

のデータ型を変更します。

5. 端子 Aをダブルクリックして [Input Terminal Information]ダ

イアログ・ボックスを開きます。[Required Type:]をクリックして

ドロップダウン・メニューを表示し、[Real64]を選択し [OK]をク

リックします。端子 Bをダブルクリックし、図 4-13 と同様にしてデー

タ型を Real64に変更します。

6. プログラムを実行します。今度は、Int32データは、自動的に入力ピ

ンで Real64に変換され、MATLAB に渡されます。
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図 4-13. 入力端子のデータ型の変更
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テスト・データの表示

表 4-2 では、VEE のオブジェクト別の表示機能を解説します。

表 4-2. 表示機能

表示用オブジェクト 説明

Alphanumeric 値をテキストまたは数字として表示します。表示
できるのは SCALAR、ARRAY 1D、ARRAY 2D
のデータ型です。

Beep 音を鳴らして、プログラム内での場所を知らせ
ます。

Complex Plane Real ( 実数 ) および Imaginary ( 虚数 ) 軸上に

Complex、Polar Complex (PComplex)、Coord の

いずれかのデータ型の値を表示します。

Indicator ⇒ Meter、
Thermometer、Fill 
Bar、Tank、Color 
Alarm

これらのインジケータはすべて、名前から予測で
きるように数値をグラフィック表示します。これ
らはすべて、通常は 3 つ、また Meter については

5 つのカラーコード・レンジを持っています。

Color Alarm は、テキスト・メッセージを「LED
表示」して、各レンジでアラームの位置の色を発
光させます。

Label パネル・ビューにテキスト・ラベルを置くときに
使用するオブジェクトです。色とフォントは、パ
ネル・ビューで、オブジェクト・メニューにある
[Properties] を選択すると簡単に調整できます。

Logging 
Alphanumeric

繰返し記録された値をテキストまたは数字で表示
します。表示できるのは、SCALAR または

ARRAY 1D のデータ型です。

Note Pad プログラムを説明するためのテキストを入力し
ます。
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Picture (PC) パネル・ビューに画像を置くときに使用するオブ
ジェクトです。サポートされている形式は、
*.BMP ( ビットマップ )、*.GIF(GIF87a および 
GIF89)、*.ICN (X11 ビットマップ )、*.JPEG、

*.PNG、*.WMF(Windows メタ・ファイル ) です。

Picture (UNIX) *.GIF(GIF87a) および *.xwd (X11 Window ダンプ )

Polar Plot 半径と角度のデータに関して個別の情報を利用で
きるときに、データを極座標上にグラフィック表
示します。

Spectrum (Freq) Magnitude Spectrum、Phase Spectrum、

Magnitude vs Phase (Polar)、Magnitude vs 
Phase (Smith) といった周波数ドメイン表示が含

まれるメニューです。入力されるデータは、
Waveform、Spectrum、Coords の配列のいずれ

かでなければなりません。Waveform の入力値

は、高速フーリエ変換 (FFT) によって自動的に周

波数ドメインに変換されます。

Strip Chart プログラム実行中に連続して生成されるデータの
最新履歴をグラフィック表示します。各 y の入力

値ごとに、x 値が指定された Step サイズだけ増

分されます。新しいデータの表示が画面の右より
外側へ出てしまうと、自動的に最新のデータを表
示するようにスクロールします。

Waveform (Time) 実数のタイム・ドメインに波形またはスペクトラ
ムをグラフィック表示します。スペクトラムは逆
高速フーリエ変換 (IFFT) を使って自動的にタイ

ム・ドメインに変換されます。x 軸は入力波形の

サンプリング単位です。

X vs Y Plot X および Y データに関して個別のデータ情報を利

用できるときに、値をグラフィック表示します。

表 4-2. 表示機能 ( 続き )

表示用オブジェクト 説明
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テスト・データの分析と表示

テスト・データの表示テスト・データの表示テスト・データの表示テスト・データの表示
XY Trace スペースの均等な x 値を使って y データを生成し

たときに、マッピングされた配列または値の集合
をグラフィック表示します。自動的に生成される
x 値は、トレース・データのデータ型により異な

ります。たとえば、トレースが実数のときには、
x はスペースが均等な Real 値になります。一方、

トレースが波形のときには、x は時間値になり

ます。

表 4-2. 表示機能 ( 続き )

表示用オブジェクト 説明
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テスト・データの分析と表示

テスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズ
テスト・データ表示のカスタマイズ

表示は、さまざまな方法でカスタマイズできます。VEE のすべてのオブ

ジェクトと同様に、表示に対してラベルの作成、移動、サイズの変更など
を行うことができるだけでなく、x/y スケールの変更、トレースの修正、

マーカの設定、グラフィック表示の部分的な拡大表示なども行うことがで
きます。

次の例では、このような機能の一部を説明します。この例では、Noise 

Generatorを使って波形を生成し、生成した波形を Waveform (Time)

の画面に表示します。またこの例では、Xスケールの変更方法、波形セグ

メントの拡大表示方法、波形の点の間の距離を測定するためのマーカの設
定方法を説明します。操作の基本は、グラフィック表示すべてに共通です。

波形の表示

1. [Device]⇒ [Virtual Source]⇒ [Noise Generator]を選択し

ます。

2. [Display]⇒ [Waveform (Time)]を選択します。

3. Noise Generatorのデータ出力ピンを Waveform (Time)のデータ

入力ピンに接続してプログラムを実行します。図 4-14 のように表示さ

れます。
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テスト・データの分析と表示

テスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズ
図 4-14. 波形の表示

X および Y スケールの変更

1. Waveform (Time)のタイトル・バーをダブルクリックして [Y Plot 

Properties]ダイアログ・ボックスを表示します。[Scales]フォル

ダを選択し、[X Maximum]の [20m]を選択し「1m」を入力します。

これにより、表示のタイム・スパンが 20 ミリ秒から 1 ミリ秒に変わり

ます。

2. -1と表示されている Y軸の [Minimum]フィールドをダブルクリック

し、「- .5」を入力します。[OK] をクリックします。 

波形の部分的な拡大表示

1. Waveform (Time)のオブジェクト・メニューを開いて [Zoom]⇒

[In]を選択します。

カーソルの形が小さい右向きの角型になります。クリック・アンド・ド
ラッグすると、拡大表示する領域の輪郭線をグラフ上に四角く描くこと
ができます。
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テスト・データの分析と表示

テスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズ
2. 波形の山をいくつか含む領域の輪郭線を描いて、マウスのボタンを離し
ます。

画面には、この波形の選択した領域が拡大表示されます。xおよび yス

ケールは自動的に変更されます。

画面にデルタ・マーカを設定する

1. Noise Generatorをオープン・ビュー表示にします。

a. [Num Points]の設定を [16]に変更します。プログラムを再度実
行します。

b. Waveform (Time)のオブジェクト・メニューを開き、
[Properties]を選択します。または、タイトル・バーをダブルク
リックします。[Markers]の下にある [Delta]をクリックしま
す。次に [OK]をクリックします。

メモ 実行時にマーカの値の取得と設定を行うことができます。詳細は、
[Contents and Index]⇒「使用法」⇒「Display Data」にあるオン

ライン・ヘルプのトピックを参照してください。

波形のデータ点の 1 つに上下を向いた 2 つの白い矢印が表示されます。ま

た、これらのマーカの xおよび y座標が画面の一番下に表示されます。2
つのピーク間の x座標または y座標の距離を測定するには、測定するピー

クまで矢印をクリック・アンド・ドラッグします。マーカの 1 つが新しい

ピークへ移動し、図 4-15 のように、新しい座標が画面の一番下に表示され

ます。
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テスト・データの分析と表示

テスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズ
図 4-15. 波形画面上のデルタ・マーカ

VEE は、波形のデータ点の間にマーカを自動的に挿入できます。オブジェ

クト・メニューを開いて、[Properties]を選択し、[Markers]の下に

ある [Interpolate]をクリックします。

トレース色の変更

1. タイトル・バーをダブルクリックして [Properties]を開き、次に

[Traces]フォルダのタブをクリックします。

このフォルダで選択したトレースに関して、色、線種、点のタイプを選
択できます。

メモ また、Tracesまたは Scalesコントロール入力を使用して、プログラム

実行時にこれらの値を変更することもできます。詳細は、マニュアル
『VEE Pro Advanced Techniques』を参照してください。

2. 色を選択したら、[OK]をクリックします。[OK]を次にクリックし、

[Properties]ボックスを終了します。 
202 第第第第4章章章章 



テスト・データの分析と表示

テスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズテスト・データ表示のカスタマイズ
これで、トレースは新しい色で表示されます。Panel Layout、Grid Type、
Clear Control、Add Right Scale といったほかの表示特性は、上記例題の

説明と同じような方法でカスタマイズできます。

メモ また VEE には、表示のオブジェクト・メニューに [Plot]メニューがあ

り、プログラムの休止をプリント・アウトすることなくテスト結果を画面
にプロットできます。

さらに練習をつむには

このほかの VEE オブジェクトについて理解し、さらに練習を行うには、

475 ページの付録 A「追加の例題」の例題を行ってください。要点を中心

に解説が行われています。
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テスト・データの分析と表示

この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なト
ピックを復習してください。

VEE の主なデータ型について説明する。

VEE の主な分析機能について説明する。

[Function & Browser]ダイアログ・ボックスのオブジェクトに関す

るオンライン・ヘルプの説明を探す。

VEE の演算オブジェクトにおける入力ピンと変数の関係を説明する。

Formulaオブジェクトを使って算術式を評価する。次に Formulaオブ

ジェクトを使って 2 つの式を評価する。最初の行の後に忘れずにセミコ

ロンを付加する必要がある。

Formula オブジェクトの算術式に VEE の関数を使用する。

MATLAB Script オブジェクトを使用する。

VEE の主な表示機能を説明する。

スケールの設定、波形の部分表示、マーカの設定、トレース色などに関

してグラフィック表示をカスタマイズする。
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テスト結果の保管方法と読取り方法
テスト結果の保管方法と読取り方法

この章の内容

テスト・データの配列への入力方法

Collectorオブジェクトの使用方法

To/From Fileオブジェクトの使用方法

Recordを使った混用データ型の作成方法

DataSetを使った検索操作とソート操作の実行方法

DataSetオブジェクトを使った単純なテスト・データベースの作成方法

平均的な必要時間 :2 時間
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テスト結果の保管方法と読取り方法

概要概要概要概要
概要 
この章では、テスト・データの保管と読取りの基本を習得します。テスト
結果を保持するデータ型と適切なサイズの配列を作成し、次にデータまた
はその一部にアクセスして、解析または表示を行います。

この章では、To/From Fileオブジェクト、Record データ型、DataSet
ファイルについても説明します。To Fileオブジェクトと From Fileオ

ブジェクトは、I/O トランザクションに基づいてファイルにデータを書込ん

だり、ファイルからデータを読取ります。Recordデータ型を使用すると、

単一の構造体に異なる型のデータを保管できます。DataSetを使用する

と、1 つのファイルに 1 つ以上のレコードを保管して、データセットに対

して検索およびソート操作を実行できます。

メモ To Fileオブジェクトについては、第 2 章「Agilent VEE のプログラミン

グ技術」の 2-3 ページの「データ・ファイルの使用方法」でも説明してい

ます。 
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テスト結果の保管方法と読取り方法

配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管
配列を使ったテスト結果の保管 
データ型は次の 2 種類の方法で保管できます。

スカラ値。つまり、「9」、「(32, @10)」などの単一の数値。

または

1 次元から 10 次元までの配列。

メモ VEE データ型についての概要は、第 4 章「テスト・データの分析と表示」

を参照してください。

VEE の場合、配列のインデックスは 0 から始まり、角かっこを使って配列

要素の位置を示します。たとえば、配列 Aが要素 [4, 5, 6]を保持して

いる場合、これらの要素の位置は次のように示されます。

A[0] = 4、A[1] = 5、A[2] = 6 

配列の構文は次のとおりです。

配列の要素にアクセスするための構文は、Formulaオブジェクトまたは

To/From Fileオブジェクトなどに含まれる任意の式フィールドで使用で

きます。

コロン 要素の範囲を示します。たとえば、上の配列の場合、
A[0:2] = [4, 5, 6]となります。

アスタリス
ク (*)

配列の特定の次元にあるすべての要素を指定するための
ワイルドカードです。A[*]は、配列 Aのすべての要素
を返します。

コンマ サブ配列の構文では、配列の次元を区切るためにコンマ
を使用します。Bが、それぞれの次元に 3 つの要素を持
つ 2 次元の配列であれば、B[1,0]は、Bの 2 番目の行
の最初の要素を返します。
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テスト結果の保管方法と読取り方法

配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管
例題 5-1: テスト結果用の配列の作成

配列を作成する最も簡単な方法は、Collectorオブジェクトを使用する

ことです。

この例題では、For Countオブジェクトを使用して、計測器からの読取り

を 4 回シミュレートします。読取った値を配列に挿入し、結果を出力しま

す。Collectorでは、すべてのデータ型が受入れられ、送信した要素の

数に基づいて配列のサイズが作成されるため、データ型や配列のサイズに
かかわりなく、原理は 4 回とも同じです。

1. [Flow]⇒ [Repeat]⇒ [For Count]、[Data]⇒ [Collector]、

[Display]⇒ [AlphaNumeric]を選択します。

2. Collectorの [n+1 Dim]をクリックし、[1 Dim Array]に変更し

ます。

3. For Countデータ出力ピンを Collectorのデータ入力ピンに接続し

ます。

4. For Countシーケンス出力ピンを Collectorの XEQ入力ピンに接続

します。

For Count オブ

ジェクト
について

For Countは、入力フィールドで指定した反復回
数を基にして、0 から増加していく整数値を出力し
ます。デフォルトの回数 [10]をダブルクリックし
て強調表示してから、「4」と入力します。For 
Countは、0、1、2、3を出力します。

Collector オブ
ジェクトにつ
いて

Collectorは、データ入力端子を介してデータ値
を受信します。データの収集が完了したら、XEQ端
子を起動し、Collectorで配列を作成して出力し
ます。For Countシーケンス出力ピンを使用する
と、Collector XEQピンを起動できます。
Collectorは、1 Dim Arrayと n+1 Dim Array
をトグルするボタンを表示します。

このオブジェクトについての詳細は、
[Collector]をダブルクリックしてオープン・
ビューを表示し、オブジェクト・メニューのヘルプ
を参照してください。
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配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管
XEQ ピンは、特定のオブジェクトに存在する特殊なトリガ・ピンで、

オブジェクトをいつ実行するかを決定します。この場合、配列のすべて
のデータが収集されてから、オブジェクトを実行する必要があります。

5. Collectorのデータ出力ピンを AlphaNumericのデータ入力ピンに

接続します。

6. AlphaNumericを拡大して配列を表示するには、このオブジェクトの

四隅のいずれかをクリックし、ドラッグします。また、
AlphaNumericを初めて選択するときにオブジェクトの輪郭線をク

リック・アンド・ドラッグして、オブジェクトを拡大することもでき
ます。

7. プログラムを実行します。図 5-1 のように表示されます。

図 5-1. 配列を作成する Collector

例題 5-2: 配列の値の抽出

配列から値を抽出するには、式の中で角かっこ表記を使用するか、
[Access Array]⇒ [Get Values]オブジェクトを使用します。次の例

では、Formulaオブジェクトの中で式を使用します。この例題では、プロ

グラムに複数のオブジェクトを追加します。

1. Collectorと AlphaNumericをつなぐデータ・ラインにマウス・ポ

インタを置き、Shift キーを押したまま Ctrl キーを押し、マウスの左ボ

タンをクリックして、このラインを削除します。次に Collectorをア

イコン化します。
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テスト結果の保管方法と読取り方法

配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管配列を使ったテスト結果の保管
2. [Device]⇒ [Formula]を選択し、クローンを作成します。

AlphaNumericを右に移動し、Formulaオブジェクトを 2 つとも

Collectorの右に置きます。

3. Collectorのデータ出力を 2 つの Formulaオブジェクトのデータ入

力に接続します。上の Formula の入力フィールドに「A[2]」と入力し、

下の Formula の入力フィールドに「A[1:3]」と入力します。

A[2]は、配列の 3 番目の要素をスカラとして抽出し、A[1:3]は、A

入力端子上の配列を意味する Aの 2、3、4 番目の 3 つの要素から成るサ

ブ配列を返します。

4. AlphaNumericのクローンを作成し、それぞれを各 Formulaオブジェ

クトに接続します。

5. プログラムを実行します。図 5-2 のように表示されます。

図 5-2. 式を使った配列要素の抽出
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
To/From File オブジェクトの使用 
To Fileオブジェクトと From Fileオブジェクトは、I/O トランザク

ションに基づいてファイルにデータを書込んだり、ファイルからデータを
読取ります。2 つのオブジェクトには次の特性があります。

データ・ファイルは、初めて READまたは WRITEトランザクションが実

行されたときにオープンされます。プログラムが終了すると、VEE は、

オープンしているすべてのファイルを自動的にクローズします。

VEE は、多くのオブジェクトがファイルにアクセスしていても、ファイ

ルごとに 1 つの読取りポインタと 1 つの書込みポインタを保持します。

読取りポインタは次に読取るデータを識別し、書込みポインタは次に
データを書込む場所を示します。

To/From Fileオブジェクトは、既存のファイルにデータを追加した

り、既存のファイルを上書きできます。To Fileオブジェクトのオー

プン・ビューで [Clear File at PreRun & Open]設定にチェッ

ク・マークを付けた場合、書込みポインタはファイルの先頭から始まり
ます。チェック・マークを付けない場合、書込みポインタは、既存の
ファイルの末尾に位置します。各 WRITEトランザクションでは、ファ

イルの書込みポインタの位置に情報を追加します。EXECUTE CLEAR

トランザクションが実行された場合、書込みポインタはファイルの先頭
に移動し、ファイルの内容が消去されます。

読取りポインタは、ファイルの先頭から始まり、READトランザクショ

ンで読取るデータ量に応じて移動します。From Fileオブジェクトの

EXECUTE REWINDを実行すると、データに影響を与えることなく、読

取りポインタをファイルの先頭に戻すことができます。

メモ To Fileオブジェクトについては、第 2 章「Agilent VEE のプログラミン

グ技術」の 2-3 ページの「データ・ファイルの使用方法」でも説明してい

ます。 

I/O トランザクションについて

I/O トランザクションは、計測器、ファイル、文字列、オペレーティング・

システム、インタフェース、そのほかのプログラム、Rocky Mountain 
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
Basic、プリンタと通信するために、VEE によって使用されます。たとえ

ば、図 5-3 の中の To Fileオブジェクトについて説明します。

図 5-3. To File オブジェクト

図 5-3 に示した To Fileオブジェクトは、データを指定されたファイル

myFileに送信します。このオブジェクトは、プログラムからデータを受

入れるために、トランザクションと呼ばれる入力を保持できます。たとえ
ば、この To Fileオブジェクトは、WRITE TEXT a EOLトランザクショ

ンを保持しています。そのトランザクションをダブルクリックすると、図
5-4 に示す [I/O Transaction]ダイアログ・ボックスが表示されます。

このダイアログ・ボックスで、具体的なトランザクション・ステートメン
トを設定します。

図 5-4. [I/O Transaction] ダイアログ・ボックス

このダイアログ・ボックスは、オブジェクトによって形式が異なりますが、
いずれも、actions ( 操作 )、encoding ( エンコーディング )、expression list 
( 式リスト )、format ( フォーマット )、end-of-line (EOL) sequence ( 行末シー

ケンス ) などの共通要素を持っています。
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
I/O トランザクション・フォーマット

データを書込む I/O トランザクションは、通常、次のフォーマットを使用

します。

<action> <encoding> <expression list> <format> <EOL>

表 5-1 は、最もよく行われる操作、READ、WRITE、EXECUTE、WAIT に

ついて説明したものです。

メモ また、[I/O]⇒ [Advanced I/O Operations]を選択し、そのメ

ニューでオブジェクトを探して確認できる操作が多数あります。

エンコードとフォーマットは、データをパッケージにして送信する方法を
指します。たとえば、TEXT エンコードでは、データを ASCII 文字として

送信します。TEXT エンコードはさまざまな方法でフォーマットできます。

たとえば、文字と数字から成る文字列をファイルに送信する場合、WRITE 

TEXT STRINGトランザクションを使用すると、ASCII 文字で表現した文

字列全体が送信されます。WRITE TEXT REALトランザクションは、同じ

文字列から実数だけを抽出し、個々の数字について ASCII 文字を使用し

て、それらの実数を送信します。表 5-2 は、エンコードについて簡単に説

明したものです。

表 5-1. I/O トランザクションの種類

操作 説明

READ 指定されたエンコードとフォーマットを使用して、指定
されたソースからデータを読取ります。

WRITE 指定されたエンコード・フォーマットを使用して、指定
されたターゲットにデータを書込みます。

EXECUTE 特定のコマンドを実行します。たとえば、EXECUTE 
REWIND は、ファイルの内容を消去しないで、ファイル

読取りポインタまたはファイル書込みポインタの位置を
ファイルの先頭に変更します。EXECUTE CLOSE はオー

プンしているファイルをクローズします。

WAIT 指定された秒数だけ待ってから、次のトランザクション
を開始します。
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To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
書込みトランザクションの場合、式リストは、送信するデータを生成する
ために評価する必要がある式を単にコンマで区切ったリストです。式は、
算術式、データ入力端子名、文字列定数、VEE 関数、UserFunction、グ

ローバル変数で構成されます。読取りトランザクションの場合、式リスト
は、データを読取るときにその保管場所を示す出力端子名のコンマ区切り
のリストで構成する必要があります。

計測器からのデータの読取りとデータ・フォーマットについては、3-131
ページの第 3 章「簡単な計測器の操作」を参照してください。これらの

フォーマットのほとんどはすべての I/O トランザクションに適用されます。

EOL( 文字列の行末シーケンス ) はオンまたはオフにすることができます。

ほとんどの [I/O]⇒ [To]オブジェクトのオブジェクト・メニューでは、

[Properties...]を選択し、次に [Data Format]を選択して、EOL

表 5-2. I/O トランザクション・エンコード

エンコード 説明

TEXT 編集やほかのソフトウェア・アプリケーションへの移植
が容易で、人が読むことのできる形式 (ASCII) ですべて

のデータ型を読取ったり、書込みます。VEE 数値データ

は自動的にテキストに変換されます。

BYTE 数値データを 2 進数に変換し、最下位バイトを送信また

は受信します。

CASE 列挙値や整数を文字列にマッピングし、その文字列を読
取り / 書込みます。たとえば、CASE を使用すると、エ

ラー番号を受入れて、エラー・メッセージを書込むこと
ができます。

BINARY すべてのデータ型をマシン固有のバイナリ・フォーマッ
トで処理します。

BINBLOCK バイナリ・ファイル内のすべての VEE データ型につい

て IEEE488.2 で定義されている長さのブロック・ヘッダ

を使用します。

CONTAINER すべてのデータ型について VEE 固有のテキスト・

フォーマットを使用します。
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
シーケンスを指定できます。また、[Separator Sequence]で変更する

こともできます。

例題 5-3: To/From File オブジェクトの使用

この例題では、テスト・データをファイルとやり取りするプロセスについ
て説明します。ここでは、3 つの共通のテスト結果項目であるテスト名、

タイム・スタンプ、Real 値の 1 次元配列の保管と読取りを行います。すべ

ての VEE データ型で同じプロセスが適用されます。

ファイルへのテキスト文字列の送信

1. [I/O]⇒ [To]⇒ [File]を選択します。エントリを次のように設定

します。

2. トランザクション領域内をダブルクリックすると、[I/O 

Transaction]ダイアログ・ボックスが表示されます。必要であれば、

図 5-3 と図 5-4 を参照してください。

WRITE TEXT a EOLはデフォルト・トランザクションです。このトラ

ンザクションは、TEXT エンコードと指定された行末シーケンスを使用

して、ピンにデータを書込みます。VEE では大文字と小文字の区別は

必要ありません。データ入力端子名とデータ出力端子名には、大文字と
小文字どちらの文字列でも使用できます。

filename デフォルト・ファイルの myFileを使用しま
す。デフォルト・ファイルを変更するには、
[To File]入力フィールドをクリックして、
ホーム・ディレクトリ内のファイルを表示す
るリスト・ボックスを開きます。

Clear File At 
PreRun & Open

このボックスにチェック・マークを付けます。
特に指定しないかぎり、VEE は、新しいデー
タを既存のファイルの末尾に追加します。こ
のボックスにチェック・マークを付けると、
ファイルがクリアされてから、新しいデータ
が書込まれます。
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To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
エントリを次のように設定します。 

3. [OK]をクリックして、To Fileオブジェクトに戻ります。トランザク

ション・バーには、ステートメント WRITE TEXT "Test1" EOLが表

示されます。このトランザクションは、文字列 Test1を指定された

ファイルに送信します。

ファイルへのタイム・スタンプの送信

[Device]⇒ [Function & Object Browser]⇒ [Time & Date]カ

テゴリの中の関数 now()は、Real64 Scalarで表示された現在の時刻を

返します。Real 値は、西暦 0001 年 1 月 1 日 00 時 00 分から経過した秒数

です。

したがって、now()は約 63Gの値を返します。VEE がこのフォーマット

を提供する理由は、数学的に操作しやすく、記憶域を節約できるためです。
タイム・スタンプを読みやすいフォーマットで保管するには、To Fileオ

ブジェクト内の TIME STAMP FORMATを使用します。タイム・スタンプを

ファイルに送信するには、次の手順に従います。

a 
( 式フィールド )

式リスト・フィールドは、強調表示されてお
り、デフォルトは a です。「"Test1"」と入
力してから、[OK] をクリックします。Text
文字列であることを示すには、引用符が必要
です。引用符を付けないで「Test1」と入力
すると、VEE は、これを端子名またはグ
ローバル変数名と解釈します。

WRITE デフォルトの WRITEを使用します。

TEXT デフォルトの TEXTを使用します。TEXTエ
ンコードは、ASCII 文字を使ってデータを送
信します。

DEFAULT FORMAT DEFAULT FORMATを使用します。DEFAULT 
FORMATは、STRINGなどの適切な VEE
フォーマットを選択します。

EOL ON デフォルトを使用します。デフォルトの EOL
シーケンスは、新しい行のためのエスケープ
文字 \nです。
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
1. 同じ To Fileオブジェクト内で、トランザクション領域の中をダブル

クリックし、[I/O Transaction]ボックスを表示します。

2. 式リスト入力フィールドをダブルクリックして [a]を強調表示し、

「now()」と入力します。now()関数は、コンピュータ・クロックの現

在の時刻を Realフォーマットで送信します。

3. Realフォーマットを Time Stamp Formatに変更します。[DEFAULT 

FORMAT]の横の矢印をクリックしてドロップダウン・メニューを表示

し、[TIME STAMP FORMAT]を選択します。[I/O Transaction]ダ

イアログ・ボックスに追加エントリが表示されます。エントリを次のよ
うに設定します。 

[I/O Transaction] ダイアログ・ボックスは、図 5-5 のように表示されます。

図 5-5. [TIME STAMP I/O] ダイアログ・ボックス

4. [OK]をクリックして、To Fileボックスに戻ります。2 番目のトラン

ザクション・バーには、現在、ステートメント WRITE TEXT now() 

TIME:HM:H12 EOLが表示されているはずです。

Date & Time ドロップダウンで・メニュー [Time]を選択します。

HH:MM:SS クリックして、時、分、秒のフォーマットから
[HH:MM]( 時、分のフォーマット ) にトグルします。

24 HOUR クリックして、24 時間のフォーマットから [12 
HOUR]( 午前と午後のフォーマット ) にトグルします。
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テスト結果の保管方法と読取り方法

To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
ファイルへの Real 配列の送信

For Countオブジェクトと Collectorオブジェクトを使用して、4 つの

要素を持つ 1 次元の配列を作成し、myFileに追加します。

1. [Flow]⇒ [Repeat]⇒ [For Count]を選択します。For Countの

デフォルト値を 4に変更します。

2. [Data]⇒ [Collector]を選択します。[Collector]をダブルク

リックしてオープン・ビューに切替えます。For Countのデータ出力

を Collector( 一番上の入力ピン ) のデータ入力に接続します。For 

Countシーケンス出力ピンを Collectorの XEQピン ( 下部にある入

力ピン ) に接続します。Collectorをアイコン化します。

Collectorは配列 [0, 1, 2, 3]を作成するので、それをデータ・

ファイルに送信します。

3. 同じ To Fileオブジェクトを使用して、トランザクション領域をダブ

ルクリックします。[I/O Transaction]ダイアログ・ボックスで

[DEFAULT FORMAT]メニューをオープンし、[REAL64 FORMAT]を選

択します。

[I/O Transaction]ダイアログ・ボックスは、REAL64 FORMATを

選択するための追加ボタンを表示します。デフォルトの選択肢のままで
よいのですが、参考のために、デフォルト以外の選択肢を調べることも
できます。

4. [OK]をクリックして [I/O Transaction]ボックスをクローズしま

す。To Fileオブジェクト内のトランザクション・バーには、現在、

ステートメント WRITE TEXT a REAL64 STD EOLが表示されている

はずです。VEE が入力端子 aも自動的に追加します。

5. Collectorからの出力を To Fileの入力 aに接続します。プログラ

ムは図 5-6 のように表示されます。設定した [I/O Transaction]

ボックスも表示されます。
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To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
図 5-6. To File オブジェクトを使ったデータの保管

From File オブジェクトを使ったデータの読取り

From Fileオブジェクトを使ってデータを読取る場合は、そのデータがど

のようにして保管されたかを知っておく必要があります。

メモ To DataSetまたは From DataSetを使ってもデータの保管と読取りが

できます。この 2 つのオブジェクトを使用する場合は、ファイル内のデー

タの型を知っている必要はありません。データセットについては、234
ページの「DataSet を使って Record を保管および読取る方法」を参照して

ください。

この例では、String Formatのテスト名、Time Stamp Format型のタ

イム・スタンプ、Real64数の配列の順で保管されます。そのデータを

VEE が読取る場合は、From Fileで 3 つのトランザクションを作成します。

1. [I/O]⇒ [From]⇒ [File]を選択し、To Fileオブジェクトの下に

配置します。 
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To/From File オブジェクトの使用オブジェクトの使用オブジェクトの使用オブジェクトの使用
2. To Fileオブジェクトのシーケンス出力ピンを From Fileオブジェ

クトのシーケンス入力ピンに接続します。

このようにシーケンス・ピンを接続すると、From Fileは、To File

オブジェクトが myFileへのデータの送信を完了してから、データの抽

出を開始します。

3. From Fileオブジェクトでは、デフォルトのデータ・ファイルは

myFileのままにしておきます。トランザクション・バーをダブルク

リックして、[I/O Transaction]ダイアログ・ボックスを表示しま

す。[REAL64 FORMAT]をクリックし、図 5-7 のように、[STRING 

FORMAT]に変更します。

図 5-7. 文字列フォーマットの選択

4. そのほかのデフォルト値はすべて適正であるため、[OK]をクリックし

て [I/O Transaction]ボックスをクローズします。From Fileオ

ブジェクト内のトランザクション・バーには、現在、ステートメント
READ TEXT x STRが表示されているはずです。 

さらに 2 つのトランザクションを追加して、タイム・スタンプと real 配列

を読取ります。

5. 同じ From Fileオブジェクト内で、最初のトランザクション・バーの

下をダブルクリックします。[I/O Transaction]ダイアログ・ボッ
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クスが表示されます。2 番目のトランザクションでピン yにデータを読

取る場合は、式リスト入力フィールドをダブルクリックして [x]を強

調表示し、「y」と入力します。このピンを xのままにしておいた場合

は、2 番目のトランザクションは、最初のトランザクションが xに入力

したデータを上書きします。そのデータに追加するのではありません。
[REAL64 FORMAT]を [STRING FORMAT]に変更してから、[OK]を

クリックします。

メモ タイム・スタンプをテキスト文字列として読取るには、STRING FORMAT

を使用します。TIME STAMP FORMATは、タイム・スタンプのデータを変

換して実数に戻します。

6. 同じ From Fileオブジェクト内で、2 番目のトランザクション・バー

の下をダブルクリックし、[I/O Transaction]ダイアログ・ボック

スを表示します。エントリを次のように設定します。

メモ 配列のサイズがわからない場合は、[SIZE]を [TO END]にトグルします。

これにより、VEE が正確なサイズを知らなくても、ファイルの末尾までの

データが読取られます。たとえば、この機能を使用すると、文字列配列と
してのファイルの全内容を読取ってファイルの内容を検査できます。

From Fileオブジェクト内のトランザクション・バーには、現在、

READ TEXT y STRと READ TEXT z REAL64 ARRAY:4のステートメ

ントが表示されているはずです。VEE が x、y、z のデータ出力端子を自

動的に追加することに注目してください。入力端子と出力端子は手動で
追加または削除することもできます。それには、オブジェクト・メ
ニューの [Add Terminal]と [Delete Terminal]、またはショー

トカットの Ctrl+A キーと Ctrl+D を使用します。

( 式フィールド ) xを zに編集します。これで、Real配列が Z出力
端子に読取られます。

SCALAR [SCALAR]を [ARRAY 1D]に変更します。

SIZE: 現在、[I/O Transaction]ボックスには
[SIZE]ボタンが追加されています。この例題で
は、配列は 4 つの要素を持ちます。[10]を [4]に
変更し、[OK]をクリックします。
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7. [Display] ⇒ [AlphaNumeric]を選択し、2 つクローンを作成して 3
つのオブジェクトを表示します。3 つの AlphaNumericオブジェクト

を From Fileの 3 つのデータ出力ピンに接続します。オブジェクトの

いずれかの隅をクリック・アンド・ドラッグして、配列表示を拡大し
ます。

ヒント : AlphaNumericオブジェクトの表示サイズは、最初にメ

ニューで選択してオブジェクトを作成したときに、オブジェクトの輪郭
線をクリック・アンド・ドラッグして変更することもできます。

8. プログラムを実行します。図 5-8 のように表示されます。

図 5-8. From File オブジェクトを使ったデータの読取り

最初の Alphanumeric がタイトルを表示し、2 番目の Alphanumeric がテスト

時刻を表示し、3 番目の Alphanumeric が配列内の数字をリストしています。
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Record を使った混用データ型の保管を使った混用データ型の保管を使った混用データ型の保管を使った混用データ型の保管
Record を使った混用データ型の保管

Record データ型を使用すると、単一のデータ・コンテナに複数の異なる

データ型を保管できます。レコードには、VEE のどのようなデータ型でも

入れることができます。データは、スカラでも配列でもかまいません。単
一のデータ構造内に、テスト名、タイム・スタンプ、実数配列を保管でき
ます。

Record 内の個々の要素は、フィールドとして保管され、ドット表記を使っ

てアクセスできます。たとえば、Rec.Nameを使用すると、Recという名

前の Record 内の Nameという名前のフィールドにアクセスできます。レ

コードから成る配列では、Rec[2].Nameは、配列内の 3 番目のレコード

の Nameフィールドを意味します。配列の索引は 0 から始まります。

Record データ型を使ってテスト・データを構造化することには、次の利点

があります。

単一のコンテナ内で、混用データ型を論理グループ化できます。このた

め、プログラムの開発と保守がより容易になります。たとえば、テス
ト・データを保管するレコードには、テスト名、戻り値、成功 / 失敗イ

ンジケータ、タイム・スタンプ、公称期待値、成功の上限、成功の下
限、およびテストの説明を示すフィールドがあります。

8 つの別々のデータ・コンテナではなく、単一のデータ・コンテナを操

作できます。これにより、プログラムが単純になり、読みやすくなり
ます。

VEE では、DataSet の Record の保管と読取りができます。DataSet は、レ

コードを保管するために作成する特殊なファイルです。DataSet からレ

コードを読取る場合、データ型を知っている必要はありません。VEE
は、DataSet に保管している情報を読取り、ソートし、検索するための

オブジェクトを提供します。

例題 5-4: Record の使用

この例題では、Record データ型の使用方法について説明します。ここで習

得するのは、レコードを構築する方法、そのレコード内の特定のフィール
ドを読取る方法、選択されたフィールドを設定する方法、レコード全体を
単一の手順で解体 (unbuild) する方法です。また、タイム・スタンプ関数

now()の別の使用方法についても説明します。
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Record を使った混用データ型の保管を使った混用データ型の保管を使った混用データ型の保管を使った混用データ型の保管
Record の構築

3 つのフィールドを持つ Record を構築します。各フィールドは、String

として保管するテスト名、Real Scalarとして保管するタイム・スタン

プ、4 つの要素から成る Array of Realsとして保管するシミュレートさ

れたテスト結果です。次の例題でこれらのフィールドを読取る場合、タイ
ム・スタンプをさまざまなフォーマットに変換して表示できることがわか
ります。

1. [Data]⇒ [Constant]⇒ [Text]を選択し、入力フィールドで

「Test1」と入力してテスト名を作成します。オブジェクトの名前を

Text Constantに変更します。Text Constantをアイコン化します。

2. [Device]⇒ [Function & Object Browser]を選択します。

[Type]で [Built-in Functions]をクリックし、[Category]で

[Time & Date]をクリックし、[Functions]で [now]を選択し、

[Create Formula]をクリックします。オブジェクトを Text 

Constantの下に配置します。

3. [Data]⇒ [Constant]⇒ [Real64]を選択し、now()の下に配置し

ます。

Real64オブジェクトのメニューで [Properties...]をクリックし、

[1D Array]を選択すると、この Scalar Real64を Array 1Dに変

えることができます。

4. [Real64]のタイトル・バーをダブルクリックして [Constant 

Properties]ボックスをオープンします。[Configuration]で [1D 

Array]を選択し、[Size]を [4]に変更し、次に、[OK]をクリック

します。

この配列に 4 つの値を入力します。それには、要素 [0000]の横をダブ

ルクリックして、最初のエントリを強調表示し、次の値に移るときは
[Tab] キーを使用して、「2.2」、「3.3」、「4.4」、「5.5」を入力します。

Real64をアイコン化します。 

5. [Data]⇒ [Build Data]⇒ [Record]を選択し、ほかの 3 つのオブ

ジェクトの右側に配置します。3 つのフィールドを入力できるように、

3 番目のデータ入力端子を追加します。端子をダブルクリックしてそれ
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ぞれの端子をオープンし、3 つの入力端子の名前を testname、time、

dataに変更します。

Build Recordオブジェクトの Output Shapeは Scalarと Array

をトグルします。デフォルトの Scalarを通常使用します。詳細は、マ

ニュアル『VEE Pro Advanced Techniques』を参照してください。

6. Text Constantオブジェクトを Build Recordオブジェクトの

testname端子に、now()オブジェクトを time端子に、Real64オブ

ジェクトを data端子に接続します。

7. プログラムを実行します。Recordデータ出力端子をダブルクリックし

て、レコードを検査します。図 5-9 のように表示されます。

図 5-9. Record に関する出力端子情報

3 つのフィールドとその値が表示されています。[Real64: Array 1D]

ボタンをクリックすると、リスト・ボックスに現在の値が表示されます。
タイム・スタンプは Real64 Scalarとして保管されています。次の例題
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では、タイム・スタンプを読みやすい形式に変換します。[OK]をクリッ

クして [Output Terminal Information]ダイアログ・ボックスをク

ローズします。プログラムに records.veeと名前を付けて保存します。 

Record からのフィールドの取得

Get Fieldオブジェクトを使用して、レコードから 3 つのフィールドを抽

出し、それぞれの値を表示します。

1. records.veeプログラムを開きます。

2. [Data]⇒ [Access Record]⇒ [Get Field]を選択します。タイ

トルが rec.fieldであるオブジェクトが表示されます。

[rec]というラベルの付いたデータ入力は、フィールドの数と型に関

係なく、どのようなレコードでも受入れます。Rec.fieldは、入力

フィールドのデフォルトですが、これを編集すると、どのフィールドで
も読取れます。Recは、Rec という名前のデータ入力端子にあるレコー

ドを指します。VEE では大文字と小文字の区別を付ける必要がないの

で、注意してください。

メモ Get Fieldオブジェクトは、Function & Object Browser内の公式

と同じように、入力と式を使って設定する Formulaです。

3. rec.fieldのクローンを 2 つ作成し、3 つとも Build Recordの右に

配置します。

4. Build Recordデータ出力を 3 つの rec.fieldオブジェクトすべて

に接続します。

3 つのフィールドは testname、time、dataとして保管されるので、

rec.fieldオブジェクトを編集して適切なフィールドを取得する必要

があります。

5. 3 つの rec.fieldオブジェクト式フィールドを rec.testname、

rec.time、rec.dataに編集します。

6. [Display]⇒ [AlphaNumeric]を選択し、2 つのクローンを作成し

ます。3 つの AlphaNumericを 3 つの rec.fieldオブジェクトに接
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続します。real 配列を保持できるように、3 番目の表示サイズをほかの

オブジェクトの約 3 倍の長さに変更します。

7. 2 番目の AlphaNumeric表示のオブジェクト・メニューをオープンし、

[Properties]を選択し、次に、[Number]フォルダを選択します。

[Global Format]の左をクリックしてチェック・マークを外します。

表示フォーマットを設定します。[Real]セクションで [Standard]

メニューをオープンします。[Time Stamp]を選択し、[OK]をクリッ

クします。

8. [HH:MM:SS]をクリックして [HH:MM]にトグルします。[24 HOUR]

をクリックして [12 HOUR]にトグルします。図 5-10 を参照してくだ

さい。

図 5-10. [AlphaNumeric Properties] ボックス

9. プログラムを実行し、getfield.veeとしてセーブします。プログラ

ムは図 5-11 のように表示されます。
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図 5-11. Get Field オブジェクトの使用

2 番目の表示には、曜日、日付、および時、分、午前または午後の形式で

時刻が記載されています。

Record 内のフィールドの設定

この例題では、レコードの特定のフィールド内のデータを変更する方法に
ついて説明します。

メモ 別のテストで同じ Recordを再利用できます。

1. getfield.veeプログラムを開きます。

2. Build Recordの後のすべてのオブジェクトを選択し、Ctrl+X キーを

押して削除します。
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1. [Data]⇒ [Access Record]⇒ [Set Field]を選択し、Build 

Recordの右に配置します。Build Recordからの出力を Set Field

の rec入力に接続します。タイトルは rec.field = bとなります。

Set Fieldは、代入記号 (=) の右辺の式を左辺に代入します。した

がって、recの指定されたフィールドは、右辺の値で変更されます。レ

コードの残りの部分は変更されません。入力レコードを recに、新し

い入力値を bに接続します。変更されたレコードは、recというラベル

の付いたデータ出力端子に出力されます。

メモ Set Fieldオブジェクトは、Function & Object Browser内の公式

と同じように、入力と式を使って設定する Formulaです。

2. 式 rec.data[*]=bを編集して、データ・フィールドで 4 要素から成

る配列の値を変更するようにします。このレコードのフィールドで配列
全体を変更するので、配列 [*]表記を使用する必要があります。配列

の新しい値を入力端子 bに入力します。

3. [Data]⇒ [Constant]⇒ [Real64]を選択し、Build Recordオブ

ジェクトの下に配置します。オブジェクト・メニューを開き、
[Properties]を選択します。[Configuration]で [1D Array]を

選択し、[Size]を [4]に編集し、[OK]をクリックします。 

レコードのフィールドの新しい値を配列に保持する場合、配列のサイズ
は、現在の配列のサイズと同じでなければなりません。

最初のエントリを強調表示し、Tab キーで後続のエントリに移動しなが

ら、「1」、「2」、「3」、「4」を [Real64]に入力します。最後のエント

リに設定した後は、Tab キーを押さないでください。Real64を [b]と

いうラベルの付いた (rec.field=bというタイトルの ) Set Field入

力に接続します。

Get Fieldオブジェクトを使用して、そのレコードからフィールド

rec.dataを抽出し、結果を表示します。

4. [Data]⇒ [Access Record]⇒ [Get Field]を選択し、Set 

Field (rec.field=b) オブジェクトの下に配置します。Get Field

オブジェクトの式を rec.fieldから rec.dataに編集します。

rec.field = b のデータ出力を rec.field のデータ入力に接続し

ます。
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メモ 式フィールドで、Formulaオブジェクトと A.dataを併用することもでき

ます。

5. AlphaNumeric表示を選択し、配列を保持できるようにサイズを変更

し、rec.field出力ピンに接続します。

6. プログラムを実行し、setfield.veeとしてセーブします。プログラ

ムは図 5-12 のように表示されます。

図 5-12. Set Field オブジェクトの使用

この例で示しているように、Recordフィールドはすべて変更できます。

フィールドの一部を変更することもできます。たとえば、rec.field = 

b内の式を rec.data[1]=20に変更してみてください。次に、

rec.field = b入力 bを削除します。プログラムをもう一度実行すると、

配列 [2.2,20,4.4,5.5]が表示されます。

単一手順での Record の Unbuild 方法

レコードのすべてのフィールドを抽出し、そのフィールドの名前と型のリ
ストを取得するには、UnBuild Recordオブジェクトを使用します。

1. setfield.veeプログラムを開きます。Build Recordの後のすべて

のオブジェクトを削除します。

2. [Data]⇒ [UnBuild Data]⇒ [Record]を選択し、Build Record

の下に配置し、オープン・ビューに切替え、Build Recordの出力を
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UnBuild Recordの入力に接続します。UnBuild Recordにデータ

出力ピンをもう 1 つ追加し、A、B、C出力のフィールド名を

testname、time、dataに変更します。

3. AlphaNumeric表示を選択し、4 つクローンを作成します。5 つの表示

を UnBuild Recordの 5 つの出力端子に接続します。配列を保持でき

るように、Name List、Type List、dataの表示を拡大する必要が

あります。さらに、日 / 月 / 年、12 時間制の時、分表記で時刻を表示す

るように再設定します。

4. プログラムを実行し、unbuild.veeとしてセーブします。それは図 5-
13 のように表示されます。

図 5-13. UnBuild Record オブジェクトの使用方法

Type Listが testnameを Text型と識別し、timeと dataを Real64

型と識別するように、Name Listピンがレコード内の 3 つのフィールドの
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名前である testname、time、data を与えていることに注目してくだ

さい。
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DataSet を使って Record を保管および読
取る方法 
DataSetは 1 つ以上のレコードを読取ることができます。VEE オブジェ

クトはレコードをアンパックします。したがって、ファイルではなく
DataSet にレコードを保管すれば、データ型を覚えておく必要がなくなりま

す。データに対してソートや検索を行って、自分専用のカスタマイズされ
たテスト・データベースを作成することもできます。

例題 5-5: DataSet の使用方法

DataSetは、単にファイルに保管された Recordの配列です。この例題で

は、DataSetにデータを保管したり読取る方法について説明します。

DataSet に Record を保管したり読取る方法

この例題では、テスト名、Real64 Scalar、Realの配列を 3 つのフィー

ルドとして保持する 10 個の Record から成る配列を作成します。また、

Recordの配列を DataSetに保管し、そのレコードを読取って表示します。

1. [Flow]⇒ [Start]を選択します。[Flow]⇒ [Repeat]⇒ [For 

Count]を選択し、Startの下に配置します。[Device]⇒

[Formula]を選択し、そのオブジェクトを For Countの右に配置し

ます。Startを For Countのシーケンス入力ピンに接続し、For 

Countデータ出力ピンを Formulaデータ入力ピンに接続します。

2. Formula式フィールドをダブルクリックして、デフォルトの式を強調

表示し、次に、「"test" + a」と入力します。

[Start]をクリックすると、For Countオブジェクトは、整数 0 から

9 までを順に Formulaの Aピンに出力します。Formulaオブジェクト

では、これらの整数が testに追加され、Text Scalarsである

test0, test1, test2,...,test9が出力されます。この値は、10 個の

Record の最初のフィールドに書込まれます。
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3. [Data]⇒ [Build Data]⇒ [Record]を選択し、Formulaの右に

配置します。データ入力ピンを 1 つ追加します。Formulaのデータ出

力を Build Recordの A入力に接続します。

4. ツールバーで [Function & Object Browser] アイコンを選択します。

a. [Built-in Functions]、[Probability & Statistics]、
[random]を選択し、random (low, high)オブジェクトを作成
します。このオブジェクトを Formulaオブジェクトの下に配置し
ます。

b. 入力端子を削除し、入力パラメータを [low]から [0]に、[high]
から [1]に変更します。

c. オブジェクト Random Numberの名前を変更し、そのデータ出力を
Build Recordの B端子に接続します。

5. Formulaシーケンス出力ピンを Random Numberのシーケンス入力ピ

ンに接続します。シーケンス・ピンを互いに接続すると、プログラムを
実行するたびに、新しい乱数が特定のレコードの Bフィールドに必ず入

力されるようになります。

6. [Data]⇒ [Constant]⇒ [Real64]を選択します。Real64オブ

ジェクトを Formulaオブジェクトの下に配置します。

a. オブジェクト・メニューを開き、[Properties]をクリックしま
す。タイトルに「Real Array」と入力し、[Configuration]で
[1D Array]をクリックし、[Size]を [3]に変更します。[OK]
をクリックします。

b. 配列内の各エントリをダブルクリックして強調表示し、数字の「1」、
「2」、「3」を入力します。

c. Real Arrayデータ出力を Build Recordの C端子に接続します。

7. [I/O]⇒ [To]⇒ [DataSet]を選択し、Build Recordの下に配置

します。Build Recordのデータ出力をそのデータ入力に接続します。

デフォルトのファイル myfileはそのままにしておき、[Clear File 

At PreRun]にチェック・マークを付けます。

8. プログラムを実行します。図 5-14 に示すように、10 個のレコードから

成る配列が myFileという名前の DataSet に書込まれます。
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図 5-14. Record から成る配列の DataSet への保管方法

次に、From DataSetと Record Constantオブジェクトを使用して、

レコードから成る配列を読取って表示します。

9. [I/O]⇒ [From]⇒ [DataSet]を選択し、For Countの下に配置し

ます。デフォルトのファイル名 myFileはそのままにしておきます。

[Get Records]フィールドをクリックし、[One]から [All]にトグ

ルします。下部の式フィールドのデフォルト値 [1]はそのままにして

おきます。

VEE は、これらの設定を使用して、myFile内の DataSet を調べ、式

フィールド内の条件に一致するすべてのレコードを見つけます。Get 

Recordsを Oneに設定した場合、VEE は式フィールド内の条件に一致

する最初のレコードを出力します。1は、すべてのレコードが条件に一

致していることを意味する TRUE状態を表すので、そのファイル内のレ

コード配列全体が、Recというラベルの付いた出力ピンに出力されま

す。式フィールドのそのほかの使用方法については、ほかの例題で説明
しています。詳細は、オブジェクト・メニューのヘルプを参照してくだ
さい。

For Countシーケンス出力ピンを From Data Setオブジェクトの

シーケンス入力に接続します。これにより、プログラムの中の myFile

にデータを送信する部分は、必ず、ファイルからデータが読取られる前
に、実行されます。[Show Data Flow]をオンにすると、イベントの

順序を表示できます。
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10. [Data]⇒ [Constant]⇒ [Record]を選択し、To Data Setの下

に配置します。オブジェクト・メニューを開き、[Add Terminal]⇒

[Control Input]を選択します。表示されるリスト・ボックスで

[Default Value]をクリックし、次に、[OK]をクリックします。

Recordオブジェクトのサイズを大きくすると、プログラムを実行した

ときに結果を表示できます。

受信したレコードがデフォルト値となります。この場合、Recordは、

From Data Setオブジェクトからレコード配列を受信し、自分で

フォーマットしてそのレコード配列を表示します。

11. From Data Setの出力ピン Recを Recordの Default Valueピン

に接続します。この端子を表示するには、オブジェクト・メニューを
オープンして [Properties]を選択し、次に [Show Terminals]を

選択してから [OK]を選択します。From Data Setと Recordを結ぶ

波線が表示されます。

メモ オブジェクトを相互に結ぶ波線は、コントロール・ラインを表します。

12. プログラムを実行し、dataset1.veeとしてセーブします。プログラ

ムは図 5-15 のように表示されます。
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図 5-15. DataSet を使って Record を保管および読取る方法

メモ From Data Setオブジェクトは、条件に一致するレコードを少なくとも

1 つ保持する必要があります。そうでない場合は、エラー・メッセージが

表示されます。エラーを避けるには、条件に一致するレコードがなければ
アクティブ化するオブジェクトに、EOF (end-of-file) 出力ピンを追加しま

す。そうすれば、EOFになったときの動作をプログラムに追加できます。
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単純なテスト・データベースのカスタマ
イズ方法

DataSetを検索またはソートすると、テスト名、タイム・スタンプ、テス

ト・パラメータ、テスト値、成功 / 失敗インジケータ、テスト記述などの

情報を取得できます。したがって、DataSetレコードはテスト・データ

ベースの役割を果たすことができます。情報を検索する場合、From Data 

Setオブジェクトを次のように使用できます。

From Data Setオブジェクト内の式フィールドは、検索操作を入力す

るのに使用されます。

関数 sort()を使用すると、指定されたフィールドを使用してレコード

をソートできます。

例題 5-6: DataSet の場合の検索操作とソート操作の

使用方法

この例題では、DataSetを検索して情報を取得する方法、検索操作のため

のオペレータ・インタフェースを作成する方法、ソート操作をプログラミ
ングする方法を習得します。

DataSet を検索する方法

1. dataset1.veeプログラムを開きます。

2. From Data Setオブジェクトの下部の式フィールドをダブルクリック

して、現在の式 [1]を強調表示します。「Rec.B>=0.5」と入力しま

す。From Data Setオブジェクトは、フィールド B( たとえば乱数 )
が、0.5と比較して、大きいか等しいすべてのレコードを出力します。

3. 式フィールド内の条件に一致するレコードが 1 つもない場合に起動する

EOFピンを追加します。From Data Setオブジェクトのデータ出力領

域にカーソルを置き、Ctrl+A キーを押します。図 5-16 のように、From 

Data Setオブジェクトに EOF出力ピンが追加されます。
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単純なテスト・データベースのカスタマイズ方法単純なテスト・データベースのカスタマイズ方法単純なテスト・データベースのカスタマイズ方法単純なテスト・データベースのカスタマイズ方法
メモ EOFピンを追加する場合、オブジェクト・メニューをオープンし、[Add 

Terminal]⇒ [Data Output...]をクリックすることもできます。

4. プログラムを実行し、dataset2.veeとしてセーブします。

図 5-16. DataSet の検索

検索操作のためのオペレータ・インタフェースの作成
方法

この例題では、オペレータがテスト結果データベースからデータを抽出す
るためのメニューを追加します。オペレータ・インタフェースにより、プ
ログラムが保護され、不用意に変更されることがなくなります。 

プログラムの仕様は次のとおりです。

オペレータが test0からtest9までの中から特定のテストを選択し、関

連するすべてのテスト・データを取得するテスト・メニューを提供する。
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指定されたテスト結果をフィールドと値にラベルを付けて表示する。オ

ペレータは、対話形式で、より詳細な情報を取得できる。

明快な操作手順の説明を含める。

プログラムを作成するには、次の手順に従います。

1. dataset2.veeプログラムを開きます。

From Data Setオブジェクトにプログラムで式を入力できるようにコン

トロール入力を追加します。

2. From Data Setのオブジェクト・メニューをオープンし、[Add 

Terminal...]⇒ [Control Input...]を選択します。表示される

メニューで [Formula]を選択します。Formula入力端子が表示され

ます。[Get records]フィールドをクリックし、[All]から [One]

にトグルし、一度に 1 つのテスト・レコードにアクセスするようにし

ます。

ユーザに特定のテスト名を選択させる必要があります。テスト名は、す
べてのレコードのフィールド Aにあります。次の式を追加します。

Rec.A==< 引用符で囲んだテスト名 >

Rec.Aは、フィールド Aが、オペレータの選択したテスト名と一致す

るレコードを出力します。たとえば、オペレータが test6を選択した

場合、式は Rec.A=="test6"となります。このオブジェクトにより、

該当するテスト・レコードが抽出され、次に表示できます。

目的の選択肢をオペレータがクリックできるメニューを作成します。

3. [Data]⇒ [Selection Control]⇒ [Radio Buttons]を選択し、

For Countの左に配置します。

a. オブジェクト・メニューをオープンし、[Edit Enum Values...]
を選択します。[0000: Item 1]を強調表示し、「test0」と入力
します。Tab キーを押して [0001: Item2]に移り、「test1」と入
力します。3 番目のエントリ (test2) の後で Tab キーを押すと、別
のエントリが自動的に表示されます。test9になるまで、値の入力
を続けます。[OK]をクリックすると、test0から test9までの 10
個のエントリすべてが表示されます。
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b. オブジェクト・メニューで [Properties]をクリックし、そのオブ
ジェクト名を Radio Buttonsから Test Menuに変更し、
[Execution]で [Auto Execute]を選択し、[Open View]⇒
[Show Terminals]を選択し、[OK]をクリックします。

4. これで、オペレータがいつメニューを選択してもプログラムを実行でき
るため、Startオブジェクトを削除します。Startオブジェクト上で

マウスの右ボタンを押し、[Cut]を選択します。

5. プログラムは、メニューが選択された場合にのみ実行する必要があるの
で、Test Menuのデータ出力ピン Enumを For Countシーケンス入

力ピンに接続します。プログラムは図 5-17 のように表示されます。

図 5-17. Test Menu オブジェクトの追加方法

6. Test Menuの出力は Formulaオブジェクトに入り、このオブジェク

トは、次に、正しい公式を From Data Setオブジェクトに送信します。

[Device]⇒ [Formula]を選択し、Test Menuの下に配置します。

練習中は、項目を追加するときに、オブジェクトの位置とサイズを変更
できます。新しい Formulaオブジェクトで、次の式を入力します。
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"Rec.A==" + "\"" + A + "\""

たとえば、test6を選択した場合、最後の公式が Rec.A=="test6"を

読取ります。次に、From Data Setオブジェクトが、最初に見つけた

レコードを出力します。そのレコードの Aフィールドは test6と一致

しています。

7. Test Menu Enumデータ出力ピンを Formulaオブジェクトのデータ

入力ピンに接続します。Formulaオブジェクトをアイコン化します。

8. Formulaのデータ出力ピンを From Data Setオブジェクトの

Formulaというラベルの付いたコントロール入力ピンに接続します。

9. Formulaの古いデータが再使用されないようにするため、For Count

と From Data Setを結ぶシーケンス・ラインを削除します。For 

Count シーケンス出力ピンを Formula シーケンス入力ピンに接続し

ます。

10. Formulaシーケンス出力ピンを From Data Setシーケンス入力ピン

に接続します。これにより、確実に Formulaの正しいデータが使用さ

れるようになります。

11. オペレータのための手順説明を表示するボックスを作成します。
[Display]⇒ [Note Pad]を選択します。タイトルを Test 

Results Database Instructionsに変更します。Note Pad入力

“Rec.A==” "Rec.A=="は、Textデータ型を From Data 
Formula式入力に送信します。引用符はテキスト
文字列を示します。

A VEEは、DataSetファイル内のすべてのレコード
の最初のフィールド Aを調べ、選択されているテス
ト名と最初に一致するレコードを選択します。

“\”” 疑問符のエスケープ文字は \”です。エスケープ文
字は、テキスト文字列であることを示すために引用
符で囲まれます。

test name は、Enumデータ型として Test Menuに
あったものです。正しい公式を From DataSetオ
ブジェクトに入力するには、引用符が必要です。
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領域をクリックし、「Select the test results you want from 

the Test Menu.」と入力します。

12.Record Constant オブジェクトの名前を Test Results に変更し

ます。

13. プログラムは図 5-18 のように表示されます。プログラムを数回実行し、

機能するかどうかを確認します。Test Menuオブジェクトは

AutoExecuteをオンにしているため、プログラムを実行する場合は、

メニューで選択します。

図 5-18. 検索操作へメニューを追加する方法

次に、オペレータ・インタフェースを作成します。

14. Ctrl を押したまま、次のオブジェクトをクリックします。それらは、

Test Menu、Test Results Database Instructions、Test 

Resultsです。

選択したすべてのオブジェクトは、網かけ表示されます。上記以外のオ
ブジェクトが選択されていないこと確認します。
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次に、[Edit]⇒ [Add to Panel]を選択すると、オペレータ・イン

タフェースがパネル・ビューとして表示されます。次に、それらのオブ
ジェクトを移動したりサイズを変更できます。レイアウトの例を図 5-19
に示します。

メモ Add to Panelが淡色表示になっている場合は、作業領域内に、選択して

いるオブジェクトがないことを意味します。

図 5-19. データベースのオペレータ・インタフェース

15. Test Menuで選択する方法で、プログラムを数回実行します。プログ

ラムに database.veeと名前を付けて保存します。 

あるレコードについて、Record Constantオブジェクト内で (Test 
Resultsという名前の付いている ) フィールド名や値をクリックする

と、そのレコードに関するより詳細な情報を取得できます。
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メモ オペレータ・インタフェースとプログラムが変更されないようにするには、
[File]⇒ [Create RunTime Version...]を選択します。プログラム

の名前を入力すると、VEE は、自動的に *.vxe拡張子を追加して、保護

されていないバージョンから分離します。

Record のフィールドに基づくソート操作

この例題では、前の例題の dataset2.veeプログラムを使用します。

dataset2.veeプログラムは、From DataSetオブジェクト内で、

Rec.B>=0.5などの条件を設定するので、VEE は、それらの要件に一致す

るすべてのレコードを抽出します。結果レコードから成る配列が Record 

Constantオブジェクト内に表示されます。

この例題では、dataset2.veeを変更して、最も大きな値で失敗するテス

トを見るけるために、結果レコードをソートします。各テストを 2 番目の

フィールドで降順にソートします。

1. dataset2.veeプログラムを開きます。

2. [Device]⇒ [Formula]を選択し、From Data Setのデータ出力ピ

ン Recを Formulaオブジェクトのデータ入力ピンに接続します。

Formulaの式フィールドをダブルクリックしてデフォルトの公式を強

調表示してから、「sort(a, 1, “B”)」と入力します。

Sortオブジェクトは、Function & Object Browser関数と Array 

Category関数内にあります。オブジェクト・メニューの [Help]エン

トリで、その機能に関する詳細情報を参照できます。sort ()関数は、

Formulaオブジェクトから呼出されます。

最初のパラメータは、Formulaオブジェクトの Aピンにあるデータを

ソートします。そのデータは、レコード配列です。2 番目のパラメータ

はソートの方向を指定します。つまり、0 以外の数は昇順を指定し、0
は降順を指定します。デフォルトは昇順です。3 番目のパラメータは、

Recordデータ型の場合、ソート対象のフィールドの名前を指定しま

す。したがって、このパラメータにより、レコード配列内の Bフィール

ドに対して、昇順ソートが実行されます。

3. [Display]⇒ [AlphaNumeric]を選択し、Formulaオブジェクトの

データ出力ピンに接続します。
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4. プログラムを数回実行します。プログラムは図 5-20 のように表示され

るはずです。プログラムは、フィールド Bを使用して、DataSetファ

イルから返されたレコードのすべてを昇順でソートします。

図 5-20. Record のフィールドに対するソート操作
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テスト結果の保管方法と読取り方法

この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
トピックを復習してください。

配列を使用する場合の基本的な表記を説明する。

Collectorオブジェクトを使って配列を作成する。

Formulaオブジェクトを使用して、配列から要素を抽出する。

文字列、タイム・スタンプ、real 配列をファイルに送信する。

文字列、タイム・スタンプ、real 配列をファイルから読取る。

関数 now()を使ってタイム・スタンプを取得する。

タイム・スタンプをさまざまな方法でフォーマットして表示する。

レコードの構築と unbuild を行う。

レコード内のフィールドの取得と設定を行う。

DataSetにレコードを保管する。

DataSetからレコードを読取る。

DataSetに対して検索を実行する。

Recordフィールドに対してソートを実行する。

VEE ツールを組合わせて使用し、単純なテスト・データベースを作成

する。
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ActiveX を使ったレポートの簡単な作成方法
ActiveX を使ったレポートの簡単な作成方法

この章の内容

VEE での ActiveX オートメーション

ActiveX を使って MS Excel でレポートを表示する方法

ActiveX を使って MS Word でレポートを表示する方法

平均的な必要時間 :1.5 時間
250 第第第第6章章章章 



ActiveX を使ったレポートの簡単な作成方法

概要概要概要概要
概要

この章では、データを VEE プログラムから MS Excel プログラムに送信し

て、MS Excel などのほかのアプリケーションでレポートを生成する方法を

習得します。VEE は、ほかのアプリケーションを制御するために ActiveX
オートメーションを使用します。ActiveX オートメーションにより、詳細

で効果的なレポートを迅速に作成できます。

最初の例題では、ActiveX オートメーションを使用して、データを MS 
Excel スプレッドシートに自動的に送信する方法が示されます。2 番目の例

題では、レポートを生成するための共通テンプレートが示され、基本テン
プレートの機能を拡張する方法が解説されます。最後の例題では、VEE で

ActiveX を使用して、画面ダンプとテスト・データを MS Word 文書に送信

します。ActiveX オートメーションをサポートしているほかのスプレッド

シートやワード・プロセッサ・プログラムでも利用できます。

メモ VEE では、DDE が ActiveX に置き換わりました。ただし、DDE も引続き

サポートされています。既存のアプリケーションから DDE を使用する場合

は、『Visual Programming with HP VEE』第 2 版を参照してください。
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ActiveX を使ったレポートの簡単な作成方法

Agilent VEE におけるにおけるにおけるにおける ActiveX オートメーションオートメーションオートメーションオートメーション
Agilent VEE における ActiveX オートメー
ション

この章では、ActiveX オートメーションという用語で、VEE が MS Excel、
MS Word、MS Access などのオートメーション・サーバ・アプリケーショ

ンのオートメーション・コントローラとして機能する能力を指すことにし
ます。この章の例題では、Microsoft の ActiveX 技術の実用的な応用面に焦

点を合わせ、テストと計測のプログラムに関するレポートを生成します。

メモ このマニュアルには、ほかにも関連する例題があります。それらについて
は、404 ページの「ActiveX コントロールの使用方法」と、454 ページの

「Callable VEE ActiveX Automation Server」を参照してください。「オート

メーション」の用語と概念についての詳細は、マニュアル『 VEE Pro 
Advanced Techniques 』を参照してください。

ActiveX オートメーションのタイプ・ライブラリの一

覧表示

コンピュータにインストールされているオートメーション・オブジェクト
を確認するには、[Devices]⇒ [ActiveX Automation References]

をクリックします。

メモ ActiveX コントロールの参照については、第 10 章「オペレータ・インタ

フェースの使用方法」を参照してください。 第 12 章「プラットフォーム固

有の事項と Web モニタ管理」も参照してください。

[Devices]⇒ [ActiveX Automation References]を選択すると、

PC にインストールされているタイプ・ライブラリの一覧が表示されます。

オートメーション・サーバとなることができる各アプリケーションと
ActiveX コンポーネントは、タイプ・ライブラリを登録します。VEE は、

PC で使用可能なタイプ・ライブラリを表示します。このライブラリは、

ActiveX クライアントに公開されているアプリケーションやコンポーネン

トの機能に関する情報を保持しています。

タイプ・ライブラリは、通常、クラスの集合から成ります。一部のクラス
はプログラマが作成できます。そのほかのクラスは、常に、アプリケー
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Agilent VEE におけるにおけるにおけるにおける ActiveX オートメーションオートメーションオートメーションオートメーション
ションまたはコンポーネントによって作成されます。クラスは、プロパ
ティ、メソッド、およびイベントから成りますが、必ずしも 3 つすべてが

存在しなければならないわけではありません。タイプ・ライブラリは、プ
ログラマと VEE 環境の両方に、ActiveX インタフェースを使ってアプリ

ケーションまたはコンポーネントを利用する場合に必要な情報を提供し
ます。

[ActiveX Automation References] ボックスで、タイプ・ライブラリの横に

チェック・マークを付けると、そのライブラリのオブジェクトが VEE のプ

ログラムで使用可能になります。たとえば、図 6-1 では、Microsoft Excel 
9.0 にチェック・マークが付けられています。

図 6-1. [ActiveX Automation References] ボックス

Agilent VEE で ActiveX プログラムを作成および使用

する方法

VEE には、Objectと呼ばれる ActiveX プログラムのためのデータ型があ

ります。Objectとして指定されるデータ型を持つ VEE オブジェクトは、

オートメーション・サーバが保持しているデータなどを指すポインタです。
たとえば、Objectは、MS Excel 内のワークシートを指すポインタやその
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ActiveX を使ったレポートの簡単な作成方法

Agilent VEE におけるにおけるにおけるにおける ActiveX オートメーションオートメーションオートメーションオートメーション
ワークシート内のセルを指すポインタとなることができます。技術的には、
Objectは、MS Excel またはオートメーション・サーバが返す IDispatch イ

ンタフェースを指すポインタです。

たとえば、[Data]⇒ [Variable]⇒ [Declare Variable]を選択し、

[Name]を [App]に設定し、そのデータ型を [Object]に設定した場合、

Excel オートメーション・サーバなどの ActiveX オートメーション・オブ

ジェクトを指すために、変数 Appを使用できます。図 6-2 は、データ型

Objectの例です。

図 6-2. データ型 Object の例

ActiveX ステートメントを使って操作を実行する方法

Excel オートメーション・サーバなどの ActiveX オートメーション・サーバ

と通信する場合は、VEEFormulaオブジェクトに ActiveX のコマンドを入

力します。たとえば、図 6-3 は、Set Up Excel Worksheetという名前

の付いた VEEFormulaオブジェクトを示しています。このオブジェクト

は、Excel ワークシートをセットアップしてテスト結果を表示するためのコ

マンドのリストを保持します。
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Agilent VEE におけるにおけるにおけるにおける ActiveX オートメーションオートメーションオートメーションオートメーション
図 6-3. Excel ワークシートをセットアップしてテスト結果を表示するため

のコマンド

図 6-3 のようなコマンドやステートメントを作成する場合、VEE では、

Microsoft Visual Basic の標準の構文を使用します。コマンドやステートメン

トは、3 種類の操作を実行します。それらは、Get Property、Set Property、
または Call Methods です。

Get Property ステートメントは、通常、ある型のデータを取得する場合

に使用します。構文は、< オブジェクト >.<プロパティ > です。たと

えば、sheet.applicationは、sheetオブジェクトの

applicationプロパティを取得します。

Set Property ステートメントは、通常、同じ型のデータを設定する場合に

使用します。構文は、< オブジェクト >.< プロパティ > = < プロパ

ティの種類 > です。たとえば、object.property = MaxSizeで、1
つのプロパティが設定されます。

Call Methods は、メソッドを呼出します。メソッドは、操作を実行する

ようにオブジェクトに要求します。メソッドのパラメータを使用して、
データを受け渡すことができます。構文は、< オブジェクト >.< メ

ソッド >( パラメータ ) です。

メモ データ型 Objectの構文は、Record のフィールドを取得する VEE 構文

rec.fieldと、UserFunctionを呼出す VEE 構文 myLib.func()に似

ているため、変数にはわかりやすい名前を割当てることが重要です。
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Agilent VEE におけるにおけるにおけるにおける ActiveX オートメーションオートメーションオートメーションオートメーション
CreateObject と GetObject の使用方法

図 6-3 で、Set Up Excel Worksheet内のステートメントの 1 つが

CreateObject()関数呼出しを保持していることに注目してください。

CreateObject()と GetObject()は VEE の Function & Object 

Browserにある関数であり、VEE にある ActiveX オブジェクトを指すポイ

ンタを返すことを特定の目的として設計されています。

たとえば、CreateObject("Excel.Sheet")は、Excel を起動し、Excel
のワークブックのリファレンスを返します。Microsoft のステートメント

sheet はワークブックを返します。実行中の Excel の既存のデータなどを取

得する場合や、実行中の Excel にファイルをロードする場合は、

GetObject()を使用します。

CreateObjectと GetObjectは、[Device]⇒ [Function & Object 

Browser]、[Type: Built-in Functions]、[Category: ActiveX 

Automation]にあります。CreateObjectと GetObjectの例を図 6-4
に示します。

図 6-4. CreateObject と GetObject
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ActiveX を使ったレポートの簡単な作成方法

Agilent VEE データのデータのデータのデータの MS Excel への送信方法への送信方法への送信方法への送信方法
Agilent VEE データの MS Excel への送信
方法

この節では、レポートを生成するための VEE オブジェクトと MS Excel 関
数呼出しを紹介します。

例題 6-1: Agilent VEE データの MS Excel への送信

方法

この例題では、MS Excel 用の仮想テスト・データを生成します。ここでは

MS Office 2000 と MS Excel 9.0 オブジェクト・ライブラリを使用しますが、

MS Office 97 と MS Excel 8.0 オブジェクト・ライブラリも使用できます。適

切なオートメーション・タイプ・ライブラリを参照した後、Object型の

グローバル変数を複数個宣言し、globalsという名前で UserFunction

に保管します。グローバル変数を使用すると、プログラムが単純化して理
解しやすくなります。

メモ このマニュアルに記載されている練習問題やプログラミング例で使用した
VEE プログラムの多くは、VEE に付属しています。[Help]⇒ [Open 

Example...]⇒ [Manual]⇒ [UsersGuide]を選択してください。

1. オートメーション・ライブラリを参照します。[Device]⇒ [ActiveX 

Automation References...]をクリックし、[Microsoft Excel 

9.0 Object Library]を選択し、[OK]をクリックします。

2. グローバル変数を保管する UserFunctionを作成します。[Device]

⇒ [UserFunction]をクリックします。その名前を globalsに変更

します。UserFunctionについての詳細は、299 ページの第 8 章

「Agilent VEE 関数の使用方法」を参照してください。

3. [Data]⇒ [Variable]⇒ [Declare Variable]をクリックして、

オブジェクトを globals内の左に配置します。[Name]を [sheet]

に変更します。[Type]を [Object]に変更します。ダイアログ・ボッ

クスにそのほかの項目が表示されます。この例題の場合、[Object 

Type]と [Class]を指定する必要はありません。[Type]と

[Class]は、この章の別の例で指定します。
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Agilent VEE データのデータのデータのデータの MS Excel への送信方法への送信方法への送信方法への送信方法
4. このオブジェクトのクローンを 3 つ作成し、3 つのオブジェクトの名前

を app、range、windowに変更します。globals UserFunctionの

サイズを変更し、メインの下に移動します。図 6-5 のように表示され

ます。

5. エントリを図 6-5 と比較した後で、4 つのオブジェクトをアイコン化し

ます。

図 6-5. Globals UserFunction

globals UserFunctionでデータ型 Objectを使用すると、Object 

Typeと Classを指定できることに注目してください。Object Type

と Classを指定する理由は、より具体的に型を検査するためと、イベ

ントをキャッチするためです。

より具体的な型の検査 :  たとえば、Object appの型を

Excel.Applicationと指定した場合は、型が Excel.Application

の Objectしか、appに代入できません。Excel.worksheet型また

は Word.bookmark型の Objectを代入するとエラーが発生します。

イベントのキャッチ : VEEの UserFunctionを使用すると、アプリ

ケーションで発生する可能性のある MS Excelワークシートでマウス

の右ボタンが押されるなどのさまざまなイベントをキャッチすることも
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できます。どの種類のイベントについても、VEEの UserFunctionを

指定すると、そのイベントを処理し、情報を MS Excelに返すことが

できます。ActiveXコントロールが VEEとの通信に戻る方法が必要な

場合、イベントが役に立ちます。詳細は、マニュアル『VEE Pro 
Advanced Techniques』を参照してください。 

6. UserFunction globalsのオブジェクト・メニューをオープンし、

[Generate]⇒ [Call]をクリックします。これにより、正しく設定

された Call globalsオブジェクトが生成されます。それをメイン・

ウィンドウ内の左側に配置し、globals UserFunctionウィンドウ

をアイコン化します。

7. [Device]⇒ [Formula]をクリックし、それをメイン・ウィンドウの

上部中央に配置します。名前を Set up Excel Worksheetに変更し

ます。globalsのシーケンス出力ピンを Formulaのシーケンス入力ピ

ンに接続します。Set Up Excel Worksheetから入力端子 Aを削除

します。その Objectのメニューをオープンし、[Delete 

Terminal]⇒ [Input]を選択します。

8. Set up Excel Worksheet内で、図 6-6 のように入力します。ANSI 
C と同じように、行の区切り文字にはセミコロンを使用します。
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Agilent VEE データのデータのデータのデータの MS Excel への送信方法への送信方法への送信方法への送信方法
図 6-6. MS Excel ワークシートのセットアップ

Formulaオブジェクト Set Up Excel Worksheet内のコマンドは次の

とおりです。

set sheet = キーワード setは、代入演算子 ( この場合は、等
号 ) の右辺を式の左辺の変数に代入または設定す
るために使用します。たとえば、set appは、
Excel ワークシートと定義されているアプリケー
ション sheet.applicationに設定します。
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CreateObject
(“Excel.Sheet”).

オートメーション・サーバ ( この場合は、MS 
Excel) の新しいインスタンスを作成し、空のシー
ト (Excel の用語では新しいワークブック ) を作成
します。それぞれのオートメーション・サーバに
は独自の用語がありますが、構文は同じです。た
とえば、MS Word でレポートを作成する場合、
Word を起動して空白の文書を作成するために、
CreateObject(“Word.Document”) と入力し
ます。

setキーワードを使用した場合は、右辺のオブ
ジェクト・ポインタ自体が左辺の変数に代入され
ます。setを使用しない場合は、右辺のデフォル
トのプロパティ ( 多くの場合、名前 ) が左辺に代入
されます。詳細は、VEE Pro Advanced Techniques マ
ニュアルを参照してください。 

worksheets(1); Excel は新しいワークブックを使って実行されるの
で、CreateObject("Excel.Sheet") を使用し、
最初のワークシートを指定する必要があります。
ステートメントに worksheets(1)を追加しま
す。ステートメント全体は次のようになります。

setsheet = 
CreateObject("Excel.Sheet").worksheets(1);

これにより、sheetが、レポートの Sheet 1に
設定されます。確認するには、MS Excel をオープ
ンし、[ファイル ]⇒ [新規作成 ]を選択して、
新しいワークブックを作成します。Sheet1、
Sheet2などとラベルの付いた複数のシートがあ
ります。必要なのは Sheet1です。

set app = 
sheet.application;

ワークシートにプロパティ Applicationを要求
し、そのプロパティを変数 appに設定すると、
Excel に、ワークシートではなく、アプリケーショ
ン全体を指すポインタを要求できます。

app.visible = true; 画面に Excel を表示するために、appの visible プ
ロパティを [true]に設定します。

set window = 
app.windows(1);

最初のウィンドウを参照します。
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メモ アプリケーション・サーバのライブラリについての詳細は、ActiveX オー

トメーションと MS Visual Basic について書かれた書籍が多数市販されてい

るので、それらを参照してください。Office 2000 に関する書籍や、『Office 
97 Visual Basic Programmer's Guide』の注文方法については、WWW(World 
Wide Web) を参照してください。VEE の構文は MS Visual Basic と似ている

ため、これらの書籍は VEE でも役に立ちます。

9. [Device]⇒ [Formula]で、Formulaオブジェクトを作成します。

Formulaオブジェクトをクローンし、2 つ目の Formulaオブジェクト

を作成します。[Flow]⇒ [Repeat]⇒ [For Range]で、For 

Rangeオブジェクトを作成します。図 6-7 のようにオブジェクトの名前

を変更し、相互に接続し、設定します。Formulaオブジェクトの Fill 

in Titleにある入力端子は必ず削除してください。 

window.caption = 
“Test System 
Results”;

最初のウィンドウのキャプションを “Test System 
Results” に設定します。
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図 6-7. シートへのタイトルとデータの追加

Formulaオブジェクト内と For Rangeオブジェクト内の命庸 lにつ

いて、以下で説明します。

sheet.cells(1,1) = 
“DC Volts”

Excel ワークシートの 1 行目の 1 列目を参照します。
そこにテキスト DC Volts が配置されます。これによ
り、セル (1,1)のデフォルトのプロパティ ( 値 ) が
[DC Volts]に設定されます。

sheet.cells(A+1,1) = 
random(1,100)

このステートメントは、
sheet.cells(A+1,1).value=random(1,100)
の省略表記です。
入力ピン Aの値に 1を加算すると、ワークシートの
行 A+1、列 1のセルは、行番号を取得しますが、列
は 1のままです。randomが返す 1から 100まで
の値が、ワークシート内の指定されたセルに代入さ
れます。
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10. Formulaオブジェクトと AlphaNumericオブジェクトを作成し、図

6-8 のように、名前を変更し、設定し、相互に接続します。

図 6-8. 結果平均プログラム

1 から 20 まで、
ステップは 1
( For Range オブ
ジェクト )

For Rangeオブジェクトは 1から 20までの整数
を出力するので、Fill in Cellsは、指定された
セルにその乱数を保管します。
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Formulaオブジェクトでの設定項目は次のとおりです。 

11. プログラムに results_average.veeと名前を付けて保存します。プ

ログラムを実行します。MS Excel が起動して、図 6-9 のようなワーク

シートを表示します。

図 6-9. Results Average プログラムの Excel ワークシート

set range = 
sheet.range(“A2:A21");

VEE 変数の範囲を Excel ワークシー
トの A2から A21までの範囲を参照
するように設定します。Aはワーク
シート内の最初の列を参照します。

range.NumberFormat = 
“##,#00.00"; 

必要なら、より大きな数字も入力で
きるように、ポンド記号 (#) を使っ
てセルをフォーマットします。

app.worksheetFunction.average(r
ange);

指定された rangeの値の平均値を
返す Excel のメソッド average()
を呼出します。平均値は Results 
Averageに表示されます。
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MS Excel テンプレートに合わせたテンプレートに合わせたテンプレートに合わせたテンプレートに合わせた Agilent VEE の作成方法の作成方法の作成方法の作成方法
MS Excel テンプレートに合わせた
Agilent VEE の作成方法

この例題では、VEE テスト・データから成る配列を MS Excel で表示する

ためのプログラムを作成します。このプログラムは、ほかのテストの結果
を MS Excel スプレッドシートで表示するためのテンプレートとして使用で

きます。

例題 6-2: MS Excel テンプレートに合わせた Agilent 
VEE の作成方法

1. results_average.veeをオープンします。

2. 10回ループするように For Rangeオブジェクトを変更します。

3. 入力 Bを Fill in Cellsに追加し、中のステートメントを

sheet.cells(A+1,1) = B[A-1]となるように変更します。

[Device]⇒ [Formula]をクリックし、名前を Array of Test 

Dataに変更し、組込み関数「randomize(ramp(20), 4.5, 5.5)」

を入力し、4.5から 5.5までの値を持つ 20個の要素から成る乱数配列

を作成します。入力ピンを削除し、データ出力ピンを Fill in Cells

の B入力に接続します。

4. 画面下部の [Formula]ボックスで、範囲を [A21]から [A11]に変更

します。ステートメントは次のようになります。
set range = sheet.range(“A2:A11");

5. プログラムを report_template.veeとしてセーブし、実行します。

それを図 6-10 の Excel ワークシートおよび図 6-11 の完成プログラムと

比較します。
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図 6-10. テスト・データから成る配列の場合の Excel ワークシート

図 6-11. テスト・データから成る配列の場合のプログラム
第第第第 6 章章章章 267267267267



ActiveX を使ったレポートの簡単な作成方法

MS Excel テンプレートに合わせたテンプレートに合わせたテンプレートに合わせたテンプレートに合わせた Agilent VEE の作成方法の作成方法の作成方法の作成方法
このプログラムは、テスト結果を MS Excel で表示するためのテンプレート

として再利用できます。その場合は、テスト・データを配列に保管し、テ
ンプレートの残りを変更し、正しいフォーマットで適切なセルに入力する
ようにするだけです。

MS Excel のライブラリでさらにメソッドとプロパティを検索するには、

[Function & Object Browser]を調べ、[Type]で [ActiveX 

Objects]を選択し、[Library]で [Excel]を選択します。[Class]

または [Member]を選択し、[Help]を押すと、そのオートメーション・

サーバの作成者 ( この場合、Microsoft) が提供しているヘルプを表示できま

す。これらのライブラリについての詳細は、Microsoft のマニュアルを参照

してください。

独習課題

波形を生成し、Time Spanを削除して配列を取得します。ワークシートを

持つ MS Excel のための VEE オブジェクトを作成し、Object変数に設定

します。アプリケーションを表示します。次に、256 の点を持つ配列を

ワークシートの範囲 A1:A256に入力します。一度に 1 セルずつではなく、

1 ステップで全部のセルを入力します。

ヒント : Unbuild Waveformオブジェクトを使用します。配列構築構文

[a]を使用して、1 次元の配列から 2 次元の配列を作成します。次に、図

6-12 のように、関数 transpose()を呼出し、Excel が 1 ステップでその

配列を受入れられるように、配列を 1 行 256 列の配列ではなく、256 行 1
列の配列にします。

図 6-12. 独習プログラム
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MS Excel の機能の拡張

図 6-13 は、テスト結果を MS Excel で表示するための複雑なプログラムの

例です。MS Excel のライブラリをさらに使いこなすことができれば、VEE
データを MS Excel で表示するためのテンプレートの機能を拡張できます。

図 6-13. VEE から MS Excel にデータを渡すプログラムの例

図 6-13 内のエントリについて以下で説明します。

MS Excel Window 
Size

作業領域の上部左にある Drop-Down List オブジェ
クトに注目してください。このオブジェクトを使
用すると、3 つの選択肢、[xlMaximized]、
[xlMinimized]、[xlNormal]のいずれかを選
択して、Excel 内のワークシート・ウィンドウを
表示するサイズを選択できます。ウィンドウの各
サイズは番号に関連付けられるため、VEE はその
番号を算出し wndState変数に保管します。こ
の値は、次に、Excel ライブラリの
windowStateプロパティに代入されます。
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MS Excel テンプレートに合わせたテンプレートに合わせたテンプレートに合わせたテンプレートに合わせた Agilent VEE の作成方法の作成方法の作成方法の作成方法
Memory Tracking Formulaオブジェクトと Meterオブジェクトの
[Properties]ボックスで [Show 
Terminals]をクリックします。VEE の変数
memTotalと memUsedに割当てられている
Excel ライブラリの memoryTotalプロパティと
memoryUsedプロパティに注目してください。
次に、2 つの値は、MS Excel によって使用された
メモリが表示される前に、VEE のメータを設定す
るための範囲を計算するのに使用されます。

Number Format 数値フォーマットにドル記号を簡単に追加でき
ます。

sheet.SaveAs
(filename)

SaveAs()メソッドは、ワークシートを自動的に
セーブするために、Excel のライブラリから呼出
されます。[Data]⇒ [Dialog Box]メニュー
の [File Name Selection]ボックスが、ポッ
プアップ [Save As]ボックスを VEE から表示
するために使用されていることに注目してくださ
い。選択したファイル名は、次に、Excel 
SaveAs()メソッド呼出しでパラメータとして使
用されます。

Press to Kill Excel 確認 ([OK]) ボタンは、Excel をクローズする必要
があるときに、それを知らせるために使用されて
います。

Close Excel quit()メソッドは、MS Excel に終了するように
指示する場合に呼出されます。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
MS Word を使って Agilent VEE レポート
を表示する方法

この例題では、テキスト、タイム・スタンプ、XY 表示を使った VEE ポッ

プアップ・パネルの画面ダンプなどの VEE のテスト情報を MS Word 文書

で表示する方法について説明します。ActiveX オートメーションを使った

ほかのアプリケーシンから MS Word を制御するさらに複雑な方法について

は、Microsoft のマニュアルを参照してください。

例題 6-3: MS Word を使って Agilent VEE レポートを

表示する方法

まず、次の手順に従って、5 つの変数の型を Objectとして宣言します。

1. [Device]⇒ [ActiveX Automation References...]をクリック

し、[Microsoft Word 9.0 Object Library]を選択します。

2. [Data]⇒ [Variable]⇒ [Declare Variable]をクリックします。

a. [Type] フィールドを [Object]に変更します。クローンを 4 つ作成
します。

b. 5 つのオブジェクト変数に、App、Doc、Wnd、Sel、Bmpという名
前を付けます。

c. オブジェクトすべてで、[Specify Object Type]を選択します。
Library内で特定のクラスを宣言することの利点は次のとおりで
す。VEE は型検査を行ってプログラムのエラーを見つけることがで
き、ユーザはオートメーション・サーバからのイベントをキャッチ
できます。

d. どの場合も、次に [Edit...]ボタンをクリックし、[Word for 
Library]を選択します。次の [Classes]を選択します。

[App]は [Application]を使用します。

[Sel]は [Selection]を使用します。

[Wnd]は [Window]を使用します。

[Doc]は [Document]を使用します。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
[Bmp]は [Shape]を使用します。

e. クラスに [Enable Events]がある場合は、選択します。5 つをア
イコン化します。これらの変数のオープン・ビューについては図
6-14 を参照してください。

図 6-14. オブジェクト変数

3. Graphという名前の UserFunctionを作成します。これは、

Function Generator仮想ソースを使用して、正弦波を Waveform 

(Time)表示に送信します。表示のみのパネル・ビューを作成します。

次に、メイン・ウィンドウに Call Graphオブジェクトを生成します。

UserFunctionのオブジェクト・メニューは、呼出しを生成する容易

な方法を保持しています。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
MS Word でレポートを出力するときに使用するために、波形を表示するパ

ネルのビットマップ・ファイルを作成します。

4. ビットマップ・ファイル名を作成するには、[Device]⇒ [Formula]

をクリックします。その名前を Image Filenameに変更します。

[Formula]入力フィールドで、「installDir() + 

"\\panel.bmp"」と入力します。ASCII 文字 \を指定する場合は、エ

スケープ・シーケンス \\を使用します。入力端子 Aを削除します。

たとえば c:\Program Files\Agilent\にインストールした場合は、

次のテキスト文字列を Result出力ピンに生成します。

C:\Program Files\Agilent\VEE Pro 6.0\panel.bmp

5. Formulaオブジェクトをもう 1 つ作成し、

「savePanelImage("Graph", FileName, 256)」と入力します。

その入力端子の名前を FileNameに変更します。

これにより、ピクセル当たりの色の深さが 256で UserFunction 

Graphの画面ダンプが、インストール・ディレクトリ内の panel.bmp

ファイルにセーブされます。

6. Formulaオブジェクトをもう 1 つ作成し、次のステートメントを入力

します。
「Set App = CreateObject("Word.Application")」

このステートメントは、MS Word を起動し、アプリケーションのこのイ

ンスタンスを参照するためにオブジェクト変数 appを割当てます。入

力端子 Aを削除します。図 6-15 のように、Call Graph、

ImageFileName、savePanelImageを接続します。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
図 6-15. 置換 6-3 プログラムの初期段階

7. [Device]⇒ [Formula]をクリックし、図 6-16 のステートメントを

入力します。このステートメントについても下で説明します。入力端子
Aの名前を FileNameに変更します。データ入力ピンとシーケンス入力

ピンを図 6-16 のように接続します。 
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
図 6-16. ActiveX ステートメントの追加

図 6-16 では、Objectのドット表記を使用すると、プロパティとメソッド

の呼出しを一緒にネストできることに注目してください。ターゲット・ア
プリケーション内の適切なプロパティを検索する場合は、ActiveX のマ

ニュアルを参照してください。この章で説明しているプロパティとメソッ
ドを使用すると、テストと計測のレポートを生成できます。Formulaオブ

ジェクトでの設定項目は次のとおりです。 

App.Visible = 1; MS Word を画面に表示します。

Set Doc = 
App.Documents.
Add();

MS Word 内に Document を追加し、Object変
数 Docに代入します。
メモ : Excel の例では、
CreateObject(Excel.Sheet)を使用し
て、Excel を空白のワークシートで起動しまし
た。ここでは、Word を起動し、メソッド
Add()で空の Document を Word に追加しま
す。2 つのアプリケーションは、どの方法で
も作成できます。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
8. さらに 3 つの Formulaオブジェクトと 1 つの If/Then/Elseオブ

ジェクトを追加し、図 6-17 のように設定し、相互に接続します。

Doc.Activate(); 上の Document をアクティブにします。

Set Wnd = App.Active 
Window;

アクティブなウィンドウ内の文書を選択し、
Object変数 Wndに代入します。

Set Sel = App.Selection; 文書にフォーカスを合わせ ( 選択 )、Object
変数 Selに代入します。これにより、テキス
トを挿入できます。

Wnd.View.Type = 3; 文書を表示するためのウィンドウの種類を指
定します。3 は通常のサイズのウィンドウを
示します。1 はウィンドウをアイコン化します。

メモ : ここでは、定数 wdPageView のかわり
に、3 を使用します。この定数は Office 2000
のタイプ・ライブラリにないからです。

Sel.TypeText(*** Test 
Results ***), 
Sel.TypeParagraph();

タイトル *** Test Results ***を文書に
挿入し、キャリッジリターン / 改行を発行し
ます。

Set Bmp = Doc.Shapes.
AddPicture(FileName);

panel.bmpビットマップを文書に挿入し、
Shapes Class内でのこの呼出しを Object
変数 Bmpに代入します。

Sel.TypeParagraph();
Sel.InsertDateTime
(M/d/yy h:mm:ss 
am/pm, 0);

タイム・スタンプを文書に挿入します。
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図 6-17. MS Word 内のレポート用の完成プログラム

追加したオブジェクト内のエントリについて以下で説明します。

9. プログラムを実行します。図 6-18 のように表示されます。画面ダンプ

の色が正常でない場合は、オープンしているアプリケーションをすべて
アイコン化すると、PC のカラー・パレットが完全に解放されます。

App.ActivePrinter ポートを含む文字列を使用して、デフォルトの
プリンタを要求します。

strLen(str) != 0 ActivePrinterが、設定されたプリンタを検
出したかどうかを確認し ( 入力時の文字列がヌル
でない場合 )、次に Thenピンに 1(=TRUE)を出
力します。Thenピンは、PrintOut呼出しを保
持する Formulaオブジェクトを起動します。

DocPrintOut(0) 文書を出力します。

App.Quit(0) MS Word アプリケーションをクローズします。
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MS Word を使ってを使ってを使ってを使って Agilent VEE レポートを表示する方法レポートを表示する方法レポートを表示する方法レポートを表示する方法
図 6-18. 置換 6-3 で作成した MS Word 文書

ActiveX オートメーションを使って MS Excel と MS Word を制御する方法に

ついての詳細は、Microsoft のマニュアルを参照してください。ActiveX
オートメーションをサポートしているその他のサーバ・アプリケーション
も制御できます。これらのサーバは、単にオートメーション、OLE オート

メーションなどと呼ばれることもあります。

ActiveX コントロールの使用方法についての詳細は、第 10 章「オペレー

タ・インタフェースの使用方法」を参照してください。 VEE を制御するた

めに MS Visual Basic プログラムから ActiveX を使用する方法についての詳

細は、第 12 章「プラットフォーム固有の事項と Web モニタ管理」を参照し

てください。
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この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
トピックを復習してください。

VEE での ActiveX オートメーションの基本概念について説明する。

データを VEE から MS Excel に送信する。

共通テンプレートを使用して、テスト・データから成る複数の配列を

MS Excel ワークシートに送信する。配列を一括してスプレッドシート

に送信する。

プログラムが使ったメモリの検索など、MS Excel ライブラリの拡張され

た機能の一部を使用する。

テキスト、タイム・スタンプ、表示ビットマップを VEE から MS Word に

送信する。
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この章の復習この章の復習この章の復習この章の復習
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異なる言語で書かれた複数のプログラムの統合方法
異なる言語で書かれた複数のプログラムの統合
方法

この章の内容

Execute Programオブジェクト

VEE でオペレーティング・システム・コマンドを使用する方法

VEE プログラムをプラットフォーム間で移植可能にする方法

平均的な必要時間 :1 時間 
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概要概要概要概要
概要 
この章では、VEE でコンパイル済みプログラムとオペレーティング・シス

テム・コマンドを統合する最も簡単な方法を習得します。VEE の大きな利

点の 1 つは、ほかのアプリケーションやプログラムとうまく融合できるこ

とです。また、ActiveX により、ほかのプログラムのコンポーネントを使

用することもできます。詳細は、第 6 章「ActiveX を使ったレポートの簡

単な作成方法」を参照してください。

VEE では、Execute Programオブジェクトにプログラム、パラメータ、

およびオペレーティング・システムのコマンドを指定できます。Execute 

Programオブジェクトには、PC 用のバージョンと HP-UX 用のバージョン

があります。この章では、PC 用の Execute Programオブジェクトを使

用する例題と、HP-UX 用の Execute Programオブジェクトを使用する

例題の両方を紹介します。
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Execute Program オブジェクトについてオブジェクトについてオブジェクトについてオブジェクトについて
Execute Program オブジェクトについて

ほかの言語を使って VEE からプログラムを実行する方法には、ActiveX
オートメーション以外にも、次の 3 つがあります。

1. Execute Programオブジェクトを使用して、VEE をエスケープし、

別のプログラム、アプリケーション、またはオペレーティング・システ
ム・コマンドを実行します。これは最も用途が広く、使いやすい方法
です。

2. UNIX オペレーティング・システムの共用ライブラリ、または PC のダ

イナミック・リンク・ライブラリを介して、ほかの言語で書かれたコン
パイル済みの関数を VEE にリンクします。これは少し難しい方法です

が、パフォーマンスが大幅に向上します。共用ライブラリについての詳
細は、422 ページの「コンパイル済み関数の概要」を参照してくださ

い。ダイナミック・リンク・ライブラリについての詳細は、425 ページ

の「ダイナミック・リンク・ライブラリの使用法」を参照してください。

3. Rocky Mountain Basic プログラム専用の方法を使用します。詳細は、450
ページの「Rocky Mountain Basic プログラムを使った通信」を参照して

ください。 

Execute Programオブジェクトは [I/O]メニューにあります。図 7-1 と

図 7-2 に示すように、PC 用のバージョンと HP-UX 用のバージョンがあり

ます。PC バージョンの Execute Programオブジェクトは、プログラム

との通信にトランザクション I/O を使用しないため、コンパイル済みプロ

グラムにデータを渡すためのデータ入力ピンとデータ出力ピンを追加する
必要がないことに注意してください。

HP-UX バージョンはトランザクション I/O を使用するため、図 7-2 の例に

は、入力ピンと出力ピン、およびこのオブジェクトの使用方法を指示する
プログラムが含まれています。
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Execute Program オブジェクトについてオブジェクトについてオブジェクトについてオブジェクトについて
Execute Program オブジェクト (PC) の使用方法

図 7-1 は、PC の Execute Programオブジェクトを示します。

図 7-1. Execute Program オブジェクト (PC)

Execute Programオブジェクトを使用して、VEE から次を実行します。

ほかの言語で記述されたコンパイル済みプログラム

*.BATファイルまたは *.COMファイル

dirなどの MS DOS システム・コマンド

認識されている拡張子を持つ文書または URL。このファイルの中で

オープン操作が呼出されます。オープン操作を持たないファイルで
は、デフォルトの操作が呼出されます。
http://www.agilent.com/find/veeが URL の一例です。

Execute Program (PC) オブジェクトのフィールドについて、以下で説明

します。 

Run Style ウィンドウのサイズを決めます。[Normal]は標準ウィ
ンドウ、[Minimized]はアイコン、[Maximized]は
最大ウィンドウ・サイズを指定します。[Working 
directory]は、プログラムに関連のあるファイルを
保持するディレクトリです。
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Execute Program オブジェクトについてオブジェクトについてオブジェクトについてオブジェクトについて
Wait for prog 
exit

シーケンス・ピンをいつ起動するかを指定します。

Yes に設定した場合、プログラムが実行を完了するま

で、シーケンス・ピンは起動されません。

No に設定した場合、指定されたプログラムが実行を

完了する前に、シーケンス出力ピンが起動されます。
文書または URL を起動したとき、その文書または

web サイトが、すでに動作しているアプリケーショ

ンにロードされている場合、VEE はアプリケーショ

ンが終了するまで待たないことに注意してください。

Prog with 
params 

このフィールドには、DOS プロンプトに入力する文字
列が保持されます。たとえば、C 言語で書いたプログラ
ムを実行するには、次のように実行可能ファイル名を入
力します。
- myprog.exe   ( 拡張子 .exeは省略可能 )

プログラムがパラメータを持っている場合は、次の

ように、実行可能ファイル名の後に、1 つのハイフ

ンを置いてから、パラメータを入力します。
myprog -param1 -param2

DOS のシステム・コマンドを実行するには、最初に、

/cオプションを使用して DOS コマンド・インタプ

リタを実行します。たとえば、Windows 95 と

Windows 98 の場合は、コマンド command.com /c 
< システム・コマンド > を入力します。

Windows NT 4.0 と Windows 2000 の場合は、コマンド

cmd /c < システム・コマンド > を入力します。

このオプションは、コマンド・インタプリタに、/c 

の後に続く文字列をシステム・コマンドとして読取
るように指示します。
286 第第第第7章章章章 



異なる言語で書かれた複数のプログラムの統合方法

Execute Program オブジェクトについてオブジェクトについてオブジェクトについてオブジェクトについて
Execute Program オブジェクト (HP-UX) の使用方法

図 7-2 は HP-UX 用の Execute Programオブジェクトを示します。

図 7-2. Execute Program オブジェクト (UNIX)

HP-UX は、プロセスと呼ばれる多数のプログラムを同時に実行するように

設計されています。VEE が別のプログラムを開始した場合、VEE を親プロ

セスと呼び、開始されたプログラムを子プロセスと呼びます。Execute 

Programオブジェクトは、直接に、またはコマンド・シェルを介して、子

プロセスを生成します。Execute Program (UNIX) オブジェクトのフィー

ルドについて、以下で説明します。 

[Shell] フィールド [Shell]フィールドは、選択肢、none、sh、
csh、kshを使ってメニューをオープンします。

[Prog with params]フィールドの 1 番目のトー
クンは、実行可能プログラムの名前であると解釈さ
れ、その後に続くトークンはパラメータであると想
定されます。

[Prog with params]フィールドに、標準の入力
と出力のリダイレクション (<<と >>)、ワイルド
カード (*、?、[a-z])、またはパイプ ( |) などの、
シェル依存の機能を入力した場合、シェルを指定す
る必要があります。そうでない場合は、実行速度を
上げるために noneを選択します。
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Execute Program オブジェクトについてオブジェクトについてオブジェクトについてオブジェクトについて
入力端子または出力端子は、Execute Programオブジェクトに追加でき

ます。VEE プログラムからのデータは入力ピンで受信されるので、次に、

WRITE TEXTトランザクションを実行してそのデータを子プロセスに送信

します。READ TEXTトランザクションは、子プロセスからデータを読取

り、それを、VEE プログラムが使用するデータ出力ピンに置きます。

データ入力を追加すると使用可能になる Commandというラベルの付いた

データ入力端子を追加すると、プログラムやシェル・コマンドの名前を
Execute Programオブジェクトに送信することもできます。

[Wait for prog exit]
フィールド

[Wait for prog exit]フィールドは、Yesと
Noをトグルします。設定に関係なく、VEE は、子
プロセスがまだ 1 つもアクティブでない場合は、子
プロセスを生成します。Execute Programオブ
ジェクトで指定したすべてのトランザクションは完
了します。

Yesに設定した場合、子プロセスは、データ出

力ピンが起動される前に終了する必要があり
ます。

Noに設定した場合、子プロセスは、データ出力

ピンを起動し、アクティブなままです。この設
定のほうが、プログラムのパフォーマンスは高
くなります。

Prog with params 実行可能プログラム・ファイルの名前とコマンド・
ライン・パラメータ

または

シェルに送信されて解釈されるコマンド。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
システム・コマンドの使用方法

別の言語で書かれたコンパイル済みプログラムを呼出すには、実行可能
ファイルと、パラメータがあればパラメータを Execute Programオブ

ジェクトに入力します。

ただし、MS DOS のシステム・コマンドを実行するには、最初に DOS コマ

ンド・インタプリタを実行する必要があります。この例題では、DOS コマ

ンド・インタプリタを実行し、次に、MS DOS のシステム・コマンドを実

行します。

例題 7-1: システム・コマンド (PC) の使用方法

1. [I/O]⇒ [Execute Program (PC)]を選択します。[Prog with 

params]フィールドをクリックしてカーソルを表示し、次のように入

力します。

「command.com /c dir >> c:\bob」

メモ Windows NT 4.0 または Windows 2000 の場合は、command.comを cmdに

置換えます。ドライブ名が c:と異なる場合は、次の手順に従って、その

ドライブ名を置換えます。NT では、書込み権限を持っているディレクトリ

を指定する必要がある場合もあります。

command.com実行可能ファイルの完全パスを含める必要がある場合も

あります。このコマンドは DOS コマンド・インタプリタを実行します。

DOS コマンド・インタプリタは、システム・コマンドを実行して現在

のディレクトリを表示し、出力 (>) を、コンピュータの画面ではなく、

bobファイルにリダイレクトします。

[Wait for prog exit]の選択では、[Yes]のままにしておきます。

[Run Style]では [Normal]のままにしておき、[Working directory]
に「c:\」と入力します。

2. [I/O]⇒ [From]⇒ [File]を選択し、Execute Programの下に配

置します。Execute Programのシーケンス出力ピンを From Fileオ

ブジェクトのシーケンス入力ピンに接続します。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
myFileというラベルの付いた [From File:]入力フィールドをク

リックしてリスト・ボックスを表示し、「c:\bob」と入力してから、

[OK] をクリックします。プログラムがファイル bob を作成してくれ

ます。

3. トランザクション・バーをダブルクリックして、[I/O Transaction]

ボックスを表示します。

a. [REAL64 FORMAT]を [STRING FORMAT]に変更します。

b. [SCALAR]を [ARRAY 1D]に変更します。

c. [SIZE: (10)]フィールドをクリックして、[TO END: (*)]にト
グルしてから、[OK]をクリックします。トランザクション・バー
は、READ TEXT x STR ARRAY:* となっているはずです。このト
ランザクションが bobファイルの内容を読取ります。

4. [Display]⇒ [Logging AlphaNumeric]を選択し、データ入力ピ

ンを From Fileのデータ出力に接続します。

5. プログラムを実行します。図 7-3 のように表示されます。

図 7-3. ディレクトリ内のファイルの一覧表示方法 (PC) 
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
例題 7-2: ディレクトリ内のファイルの一覧表示方法
(UNIX)
この例題では、オペレーティング・システム・コマンドの lsを使用しま

す。このコマンドは、ディレクトリ内のファイル名を一覧表示します。こ
のコマンドはシェル依存コマンドではないので、Shell を noneに設定でき

ます。次に、シェル依存の機能であるパイプ (|) を使用して、この例題の

バリエーションをプログラミングします。

HP-UX プログラムでファイルを一覧表示するには、lsコマンドを次のよ

うに使用します。

1. [I/O]⇒ [Execute Program (UNIX)]を選択し、上部左の作業領域

内に配置します。

2. [Shell]フィールドが [none]に設定され、[Wait for prog 

exit]フィールドが [Yes]に設定されていることを確認します。その

ように設定されていれば、VEE がプログラムを継続する前に、lsコマ

ンドは必ず終了します。

3. [Prog with params]フィールドをクリックし、「ls /tmp」と入力

します。任意のディレクトリを指定できます。

4. データ出力端子を追加します。デフォルトの端子には、Xという名前が

付けられます。このプログラムには終了コードはないので、Exit 

codeというラベルの付いた端子は無視してください。

5. トランザクション・バーをダブルクリックして、[I/O Transaction]

ボックスを表示します。プログラムのデータはその出力端子に読込まれ
るので、デフォルトの変数を Xに編集します。

a. READ TEXTトランザクションを指定するため、WRITEを READに
変更します。

b. [REAL64 FORMAT]を [STRING FORMAT]に変更します。

c. 1 次元の配列を指定するため、データの型を SCALARから ARRAY 
1Dに変更します。

d. ディレクトリ内のファイル数はわからないので、[SIZE:]ボタンを
[TO END: (*)]にトグルします。[OK]をクリックします。トラン
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
ザクション・バーは、READ TEXT X STR ARRAY:*となっている
はずです。

6. [Display]⇒ [Logging AlphaNumeric]を選択し、データ入力ピ

ンを Execute Programオブジェクトの X端子に接続します。

7. プログラムを実行します。図 7-4 のように表示されます。

図 7-4. ディレクトリ内のファイルの一覧表示方法 (UNIX)

シェルを使ったディレクトリ内ファイルの一覧表示
方法

最後の例題のこのバリエーションでは、シェル依存の機能であるパイプ (|)
を使用して、1 つのオペレーティング・システム・コマンドの出力をもう 1
つのオペレーティング・システム・コマンドに送信します。受信するほう
のコマンドは wcで、これは word countの略です。wcコマンドは、名前

の付いているファイル内の行、語、文字をカウントします。コマンド、wc 

-l filename は、指定されたファイル内の行数をカウントします。この例で

は、ディレクトリ内のファイル数をカウントし、次にその数とファイル名
を表示する方法について説明します。

1. [I/O]⇒ [Execute Program (UNIX)]を選択します。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
a. シェル機能の |と ;を使用するため、[Shell]フィールドを [sh]
に設定します。

b. [Shell command]フィールドで、コマンド、「ls /tmp|wc 
-l;ls /tmp」を入力します。

c. 2 つのデータ出力端子を追加します。1 つは Xというラベルの付いた
端子、もう 1 つは Linesというラベルの付いた端子です。

d. 1 番目のトランザクションを READ TEXT Lines INT32と設定しま
す。デフォルト変数 aが Linesに変わります。

e. 2 番目のトランザクションを READ TEXT X STR ARRAY:Linesと
設定します。[SIZE]フィールドに「Lines」と入力し、配列の長
さを指定します。

2. [Display]⇒ [AlphaNumeric]を選択し、クローンを作成します。

一方の AlphaNumericを Lines出力に、もう一方の AlphaNumeric

を X出力ピンに接続します。

3. プログラムを実行します。図 7-5 のように表示されます。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
図 7-5. パイプを使ったシェル・コマンドの使用方法

容易に移植できるプログラムの作成方法

異なる言語で書かれた複数のプログラムを統合することを計画している場
合は、それらのプログラムをプラットフォーム間で容易に移植できるよう
に VEE プログラムを作成します。図 7-6 に示すように、VEE は、

[Function & Object Browser]⇒ [System Information]に、シ

ステム情報に関するオブジェクトを保持しています。これらのオブジェク
トは関数としても使用できます。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
図 7-6. システム情報関数

Function &Object Browserにある、プログラムの移植性を向上させる

ためによく使用されるシステム情報関数について、以下で説明します。

installDir VEE をインストールしているディレクトリを指定し
ます。
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システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法システム・コマンドの使用方法
whichOS オペレーティング・システムを判別し、次のいずれか
の文字列を送信します。Windows_95、
Windows_98、Windows_2000、Windows_NT、
HP-UX。

異なる言語で書かれた複数のプログラムを統合する場
合、プログラムは、上記の結果に基づいて分岐できま
す。たとえば、必ず正しい種類のライブラリがイン
ポートされることを目的として whichOS()を使用す
るプログラムを見たい場合は、examples\manual
ディレクトリの manual49.veeを見てください。
whichOS()は、HP-UX では、共用ライブラリをイン
ポートし、 PC では、ダイナミック・リンク・ライブラ
リをインポートします。

whichplatform VEE が実行されているハードウェア・システムを判別
し、そのプラットフォームを示す文字列を返します。

whichVersion VEE のバージョンを指定します。バージョンは、プロ
グラムの保守とデバッグの場合に役立ちます。
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この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
トピックを復習してください。

Execute Programオブジェクトの目的について説明できる。

Execute Program オブジェクトにある設定値の概要について説明で

きる。

Execute Programオブジェクトが、PC プラットフォーム上のプログラ

ムとの間でデータを送受信する全般的なプロセスについて説明できる。

HP-UX プラットフォームの相違について説明できる。

VEE からオペレーティング・システム・コマンドを実行する。

whichOS()、whichPlatform()、または whichVersion()オブジェ

クトを使用して、異なるオペレーティング・システム上で実行されるプ
ログラムを作成する。
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この章の復習この章の復習この章の復習この章の復習
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Agilent VEE 関数の使用方法
Agilent VEE 関数の使用方法

この章の内容

ユーザ関数を定義する方法

関数を作成、呼出し、編集する方法

関数ライブラリを作成、マージ、インポート、削除する方法

大規模プログラム内の関数を検索する方法

既存の VEE プログラムをテストとマージする方法

平均的な必要時間 :1 時間
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概要概要概要概要
概要

この章では、VEE UserFunction、コンパイル済み関数、リモート関数を

習得します。関数は、テストの開発に要する時間を大幅に減らすのに役立
つ再利用可能なモジュール式のコードです。以前のプログラムで作成した
関数を使用すると、既存の作業の効率を高め、プログラムのコードのサイ
ズを減らし、テスト・プログラムの保守を容易にすることができます。関
数は、グループにして使用したりライブラリに置いて使用できます。グ
ループやライブラリを作成すると、それらを新しいプログラムにマージで
きます。関数は、複数のプログラム間や複数の開発者間で共用できます。
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関数の使用方法

多くのプログラミング言語と同じように、VEE も、特定のタスクを実行す

るサブプログラムを作成する場合に関数を使用します。この章の例題では、
VEE のユーザ定義関数の作成、呼出し、編集の方法について説明します。

また、関数ライブラリの作成方法も習得します。関数ライブラリは、開発
フェーズでプログラムにマージしたり、実行時にプログラムにインポート
できます。 

Agilent VEE 関数の定義方法

VEE には、3 種類のユーザ定義関数があります。それぞれの関数の概要は

次のとおりです。

1. UserFunction 

UserFunctionを作成するには、[Device]⇒ [UserFunction]を

選択するか、または複数のオブジェクトを選択しておいて、[Edit]

⇒ [Create UserFunction]をクリックします。

プログラム内のそれぞれ異なる場所から UserFunctionを呼出すに

は、Call myFunction([Device] ⇒ [Call]) オブジェクトを使用す

るか、たとえば Formulaにある式をオブジェクト内で使用します。

UserFunctionのオブジェクト・メニューを使用し、[Generate]

⇒ [Call]などの選択肢を選択すると、メイン・プログラム内で、

UserFunctionから、call オブジェクトを生成することもできます。

UserFunctionを編集するには、[Edit]⇒ [Edit 

UserFunction...]をクリックし、表示されるリスト・ボックス

で、該当する UserFunctionを選択します。

あるプログラムから別のプログラムに UserFunctionを転送するに

は、プログラムの開発時に UserFunction をマージするか、実行時に

UserFunction をインポートします ([Device]⇒ [Import 

Library])。
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関数の使用方法関数の使用方法関数の使用方法関数の使用方法
2. コンパイル済み関数

コンパイル済み関数を作成するには、VEE 以外のコンパイル済み言

語を使って作業します。次に、その関数を DLL などのライブラリに

保管します。

コンパイル済み関数をプログラムにリンクするには、Import 

Libraryオブジェクトを使用します。このオブジェクトは、実行時

に関数ライブラリを VEE にリンクします。詳細は、第 11 章

「Agilent VEE プログラムの最適化」を参照してください。

コンパイル済み関数を呼出すには、Call myFunctionオブジェク

トを使用するか、VEE オブジェクト内で式を作成します。

3. リモート関数

リモート関数は、自分のネットワークに接続しているリモート・ホ

スト・コンピュータで実行される点を除き、UserFunctionsに似

ています。

UserObject と UserFunction の違い

UserObjectsについては、これまでの章ですでに作成して使用しました。

VEE が UserObjectと UserFunctionを提供する理由は、2 つは異なる

特性を持っており、異なる目的で使用できるためです。UserObjectと

UserFunctionの違いは次のとおりです。

[Device]⇒ [UserObject]にある UserObjectは、自分で定義するオ

ブジェクトであり、VEE にあるほかのオブジェクトとまったく同じように

使用できます。UserObject は、サブプログラムと同じようにプログラミ

ングしますが、画面にグラフィカルに表示されたままとなります。プログ
ラム内のある場所で使用する必要がある場合は、そのクローンを作成して
すべてのコピーを保持する必要があります。UserObjectのクローンをい

くつも作成すると、プログラムが大きくなり、プログラムのロードに時間
がかかるようになるので、注意してください。ある機能を 1 つの

UserObjectに追加した場合、すべての UserObjectを同じにしておき

たければ、ほかのすべてのオブジェクトにも同じ機能を追加する必要があ
ります。

[Device]⇒ [UserFunction]にある UserFunctionの場合、メモリ

にはサブルーチンのコピーのみが存在します。表示する必要がある場合は、
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ワークスペース内のそれ自身のウィンドウにのみグラフィカルに表示され
ます。表示する必要がない場合は、保管されて、Callオブジェクトまた

は他の式フィールドから呼出されます。UserFunctionに加えた変更は、

その UserFunctionを呼出すプログラムの中のすべてのインスタンスに

よって継承されます。コードの再利用が多い場合は、UserFunctionのラ

イブラリを作成することもできます。 

例題 8-1: UserFunction による演算

この例題では、ArrayStatsという名前の UserFunctionの作成方法に

ついて説明します。この UserFunctionは、配列を受付け、その最大値、

最小値、平均値、標準偏差を計算し、結果を出力ピンに出力します。

UserFunction の作成方法

1. [Device]⇒ [Formula]を選択し、デフォルトの入力ピンを削除し、

デフォルトの式を ramp(1024,1,1024)に変更します。

これにより、1 から 1024 までの値を 1024 個の要素として持つ配列が 1
つ作成されます。

2. [Device]⇒ [UserFunction]を選択します。その名前を

ArrayStatsに変更します。

a. 配列用のデータ入力端子を 1 つ追加します。

b. 結果用のデータ出力端子を 4 つ追加します。

c. 出力端子の名前を Max、Min、Mean、Sdevに変更します。
[Function & Object Browser]ボックスの [Probability & 
Statistics]カテゴリで、[max]、[min]、[mean]、[sdev]を
選択します。

d. それらを ArrayStats内に配置し、データ入力を Aに接続し、デー
タ出力を一致する出力端子に接続します。[ArrayStats]ウィンド
ウのサイズを小さくして、メインと ArrayStatsの両方のウィンド
ウが見えるようにします。図 8-1 を参照してください。
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関数の使用方法関数の使用方法関数の使用方法関数の使用方法
図 8-1. メイン・ウィンドウと ArrayStats ウィンドウ

3. ArrayStatsをアイコン化します。ワークスペースの下部にアイコン

として表示されます。

4. [Device]⇒ [Call]をクリックし、オブジェクト・メニューをオープ

ンし、図 8-2 に示すように、[Select Function]をクリックします。

次に [OK]をクリックします。VEE が、オブジェクトの名前を自動的に

変更し、正しいピンを追加することに注目してください。
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図 8-2. Call myFunction のためのピンの設定

5. Formulaの出力を Call ArrayStatsの入力に接続します。

[Display]⇒ [AlphaNumeric]を選択し、3 つのクローンを作成し、

Call ArrayStatsの出力ピンに接続します。オブジェクトの名前を

変更します。

6. プログラムを実行します。図 8-3 のように表示されます。プログラムを

「array_stats.vee」のファイル名で保存します。

図 8-3. ユーザ関数 ArrayStats を呼出す方法

ArrayStatsをプログラム内で使用するには、[Device]⇒ [Call]をク

リックし、オブジェクト・メニューから [Select Function]ボックス

をオープンし、[ArrayStats]を選択します。VEE は、オブジェクトの

名前を自動的に Call ArrayStatsに変更し、必要な入出力端子を追加し

ます。
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ショートカット : UserFunctionのオブジェクト・メニューで、

[Generate]⇒ [Call]を選択し、Call ArrayStatsオブジェクトを表

示します。この場合、絶対に UserFunctionをワークスペース全体に拡

大しないでください。

UserFunction の編集方法

この例題では、ArrayStatsを編集し、配列の統計情報を提供する 4 つの

フィールドを持つレコードを送信します。

1. 4 つの AlphaNumeric表示を削除します。

2. [Edit]⇒ [Edit UserFunction...]を選択し、[Edit 

UserFunction]リスト・ボックスで [ArrayStats]を選択します。

プログラム内のすべての UserFunctionが表示されます。

3. ArrayStatsのオブジェクト・メニューをオープンし、[size]をク

リックし、編集ウィンドウを拡大します。オブジェクトのサイズを変更
する必要がある場合は、オブジェクトの 4 隅のいずれかをクリック・ア

ンド・ドラッグします。

4. 出力端子に向かう 4 つの線を削除します。Ctrl+Shift キーを押したまま、

削除する必要のある線をクリックします。

5. [Data]⇒ [Build Data]⇒ [Record]を選択し、[ArrayStats]

ウィンドウの右側に配置します。

a. データ入力端子を 2 つ追加します。

b. 統計関数のラベルにならって、4 つの端子に max、min、mean、
sdevというラベルを付けます。

c. 4 つの Formulaオブジェクトの出力を Build Recordのそれぞれ
の入力に接続します。

d. [Max]をダブルクリックし、新しい名前を入力し、[OK]をクリッ
クして、Maxの出力端子 Xの名前を変更します。

e. ArrayStatsのほかのデータ出力端子を削除します。
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f. User Functionの編集ウィンドウで、Build Recordの出力を X
出力端子に接続します。プログラムは図 8-4 のように表示されます。 
次に、編集ウィンドウのアイコン化ボタンをクリックします。

図 8-4. UserFunction ArrayStats の編集方法

6. Call ArrayStatsのオブジェクト・メニューをオープンし、

[Configure Pinout]をクリックします。これにより、ピンの数が最

新の編集と一致するように調整されます。

メモ UserFunction内の入力または出力の数を変更したときは必ず、ピンの数

を更新するために、オブジェクトをオープンし、[Configure Pinout]

をクリックする必要があります。Callオブジェクトの入力ピンと出力ピ

ンは手動でも更新できますが、[Configure Pinout]を使用するほうが

ずっと簡単です。[Find]を使用すると、ある UserFunctionを呼出す

Callオブジェクトと式をすべて検索できます。詳細は、327 ページの「大

規模プログラム内の関数を検索する方法」を参照してください。 

Record Constantオブジェクトを使ってレコードを 1 つ表示します。

Default Valueのコントロール入力を使用して、ArrayStatsからのレ

コードを受入れます。 VEE は、Record Constantが受信レコードを保持

するように自動的に設定します。
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7. [Data]⇒ [Constant]⇒ [Record]を選択し、Call Functionオ

ブジェクトの右に配置します。 

a. Recordのオブジェクト・メニューをオープンし、[Add 
Terminal]⇒ [Control Input...]をクリックします。表示さ
れるリスト・ボックスで [Default Value]を選択します。必要で
あれば、[Properties]メニューをオープンすると、Show 
Terminalsを表示できます。

b. Call Functionのデータ出力を Recordオブジェクトのコント
ロール入力ピンに接続します。データ・ラインと区別するために、
コントロール・ラインが破線で表されています。

8. プログラムを実行します。図 8-5 のように表示されます。

図 8-5. ArrayStats の出力を Record に編集した後

式から UserFunction を呼出す方法

この例題では、Formulaオブジェクト内の式から ArrayStatsを呼出す

方法を習得します。

1. [Device]⇒ [Formula]を選択し、デフォルトの公式を

ArrayStats(A)に置換します。Call ArrayStatsのオブジェクト・

メニューで、[Replace]をクリックします。

VEE 画面下部のステータス・バーに、置換オブジェクトを選択するよ

うに表示されます。ArrayStats関数を呼出す Formulaオブジェクト

をクリックします。VEE は自動的に、Call ArrayStatsオブジェク
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トを新しい Formulaオブジェクトに置換し、データ・ラインの配線を

保持します。

Formulaオブジェクトは、端子 Aの入力を受取り、UserFunction 
ArrayStatsに送信します。ArrayStatsは、統計情報のレコードを

端子 Xに送信します。UserFunction (X)からの最初の出力値は、

Formulaオブジェクトに返され、Result出力に送信されます。

2. プログラムを実行します。図 8-6 のように表示されます。

図 8-6. ユーザ関数 ArrayStats を呼出す方法

Formulaオブジェクトにある ArrayStatsの機能は、それが Call 

ArrayStatsオブジェクトにあったときの機能とまったく同じです。

この例では Formulaオブジェクトを使用しますが、ArrayStatsは、

式を受付ける入力フィールドであれば、To Fileオブジェクトなど、

どの入力フィールドからでも呼出すことができます。

メモ 式から UserFunctionを呼出した場合、UserFunctionは単一の出力 (
一番上のデータ出力ピン ) のみを送信します。すべての出力を必要とする

場合、またはそれらの出力を Recordに保管できない場合は、Call 

Functionオブジェクトを使用します。
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メモ 式から UserFunctionを呼出した場合、入力端子は、その関数に渡る関

数パラメータとして使用されます。データをその関数に渡さない場合でも、
関数名の後に空の丸かっこ () を含める必要があります。そうしなければ、

VEE は、Global変数または入力端子が参照されていると仮定します。た

とえば、MyFunctionという名前の UserFunctionが入力パラメータを

持っていなくても、式の中で MyFunction()と書く必要があります。

Callオブジェクトについては、VEE は関数が参照されていることを認識

できるので、丸かっこ () を必要としません。

UserFunction 呼出しを生成する方法

UserFunctionから呼出しオブジェクトを生成し、メイン・プログラムに

配置するには、UserFunctionのオブジェクト・メニューの Generate

メニューを使用します。Generateメニューには、UserFunctionを呼出

すのによく使用されるオブジェクトのほとんどがあります。呼出す側のオ
ブジェクトを選択した場合は、適切な名前とピンで適切に設定されて、メ
イン・プログラムなどの呼出す側のウィンドウに配置されます。

この例題では、ArrayStats UserFunctionから、メイン・プログラム

内に ArrayStatsオブジェクトを生成する方法を習得します。

1. 図 8-6 で使用している例で、Formulaオブジェクトの [ArrayStats]

をダブルクリックしてこのオブジェクトを削除します。オブジェクト・
メニューを選択し、[Cut] を選択することもできます。

2. UserFunction ArrayStatsで、オブジェクト・メニューを選択し、

[Generate]⇒ [Formula Call]を選択します。図 8-7 は、

UserFunctionのオブジェクト・メニュー内の [Generate]メニュー

を示します。
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図 8-7. UserFunction の Generate メニュー

3. オブジェクトをメイン内に配置します。VEE は、自動的に新しいオブ

ジェクトに ArrayStats(A)という名前を付け、UserFunction 

ArrayStatsを呼出す式 ArrayStats(A)を含めることに注目してく

ださい。

4. Formulaオブジェクトからの出力を ArrayStats(A)に接続し、

ArrayStats(A)からの出力を Recordに接続します。

5. プログラムを実行します。図 8-8 のように表示されます。

UserFunctionのオブジェクト・メニューをオープンし、[Generate]

メニューを選択して、UserFunctionを呼出すためにプログラム内に配置

できるほかのオブジェクトを検討します。それらは、Call、( この例で使

用する )Formula Call、If/Then/Else Call、ShowPanel、

HidePanelオブジェクトです。
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図 8-8. UserFunction から呼出しオブジェク ArrayStats(A) を生成する方法

UserFunction とプログラム・エクスプローラ

UserFunctionと UserObjectを使用すると、VEE プログラムがよりモ

ジュール化されるので理解しやすくなります。プログラム・エクスプロー
ラは、複雑なプログラムの中を探索する場合の貴重なツールです。たとえ
ば、図 8-9 のプログラムの階層構造は、プログラム・エクスプローラを使

用して表示します。プログラム・エクスプローラを表示するには、[View]

⇒ [Program Explorer]をクリックするか、ツールバーの [Program 
Explorer] アイコンをクリックします。

図 8-9. ツールバーの Program Explorer アイコン

図 8-10 は、使用されているプログラム・エクスプローラを示します。

プログラム・エクスプローラ
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図 8-10. UserFunction の場合にプログラム・エクスプローラを使用する方法
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Agilent VEE の UserFunction の場合にラ
イブラリを使用する方法

既存の VEE テスト・プログラムの効率を高めるために、UserFunction

を再利用できます。プログラムをセーブすると、UserFunctionも自動的

にセーブされます。UserFunctionは、VEE プログラム、または論理的

に関連付けられている複数の UserFunctionから成るライブラリを保持

できます。

既存の UserFunctionを新しいプログラムの中に保管する場合、次の 2
つの方法があります。

1. [File]⇒ [Merge Library...]コマンドを使用して、元となる

UserFunctionのコピーを、現在のプログラムに保管します。それぞ

れの UserFunctionのコピーをこのプログラムに保持することになり

ます。これらのマージされた UserFunctionは編集できるので、

UserFunctionを変更する場合は、[File]⇒ [Merge 

Library...]コマンドを使用します。

または

2. [Device]⇒ [Import Library]オブジェクトを使用して、元となる

UserFunctionにアクセスします。この場合は、コピーを作成しない

で、別のファイルにある元となる関数にアクセスします。これらの
UserFunctionは実行時にインポートされます。この方法では、ロー

ドが複数回にわたって行われ、ディスク領域が浪費されず、メモリが節
約されます。インポートされた UserFunctionは ( デバッグなどの目

的で ) 表示できますが、編集はできません。そのかわり、元のファイル

を編集できます。[Device]⇒ [Delete Library]オブジェクトを使

用すると、インポートされた UserFunctionをプログラムから削除で

きます。

したがって、関数の新しいコピーを作成して変更する必要がある場合や、
スタンドアローン・プログラムが必要な場合は、UserFunctionをマージ

し、関数の出所を単一にしておきたい場合やディスク領域を節約したい場
合は、UserFunctionをインポートします。
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例題 8-2: UserFunction ライブラリの作成とマージの

方法

この例題では、UserFunctionの VEE ライブラリを保持するレポート生

成プログラムを作成します。次に、その UserFunctionライブラリを

マージする新しいプログラムを作成します。

UserFunction ライブラリの作成方法

1. UserFunctionの細部をプログラミングするのではなく、最上位レベ

ルのプログラムを作成します。

a. 4 つの UserFunctionを作成します。それらは、1 つの出力ピンを
持つ BuildRecAry、ReportHeader、1 つの入力ピンを持つ
ReportBody、ReportDisplayです。すべての UserFunction
をアイコン化します。

b. メインで、図 8-11 に示すとおりに設定して接続した 4 つの
[Device]⇒ [Call]オブジェクトを作成します。プログラムに
Report.veeと名前を付けて保存します。

図 8-11. 最上位レベルにある Report.vee
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メモ Callオブジェクトでは、UserFunctionを参照する場合、丸かっこ () は
必要ありません。Formulaオブジェクトから関数を呼出す場合は、関数で

パラメータを使用していても使用していなくても、丸かっこ () を含める必

要があります。

この 4 つの UserFunctionの集まりが 1 つのライブラリです。[Edit]⇒

[Edit UserFunction...]をクリックすると、一覧表示できます。

[Cancel]をクリックし、リスト・ボックスをクローズします。

2. 以下の図に示すように、4 つの UserFunction をプログラミングし

ます。

図 8-12 は BuildRecAry UserFunctionを示します。A<=5であるか

をテストする 3 項式を持つ Formulaオブジェクトが保持されていま

す。式の評価が TRUEである場合、このオブジェクトは PASSを出力し

ます。そうでない場合は、FAILを出力します。丸かっこ () が必要なの

で、注意してください。 

図 8-12. BuildRecAry UserFunction
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図 8-13 は ReportHeader UserFunctionを示します。

図 8-13. ReportHeader UserFunction
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図 8-14 は ReportBody UserFunctionを示します。レコード A[B]

から成る配列であることに注意してください。< レコード >.< フィール

ド > 表記を使用すると、Bの値が 0から 1、2へと変わっていくにつ

れ、Value、 Limit、PassFailという Record内の特定のフィール

ドにアクセスできます。For Countの出力はゼロから開始されるので、

注意してください。最初のトランザクションが EOL offを持つことに

も注意してください。

引用符で囲んだ縦棒 "|"は、縦棒の定数文字列文字を表します。FW:5

は、5文字の幅を持つ文字列フィールドを表します。RJは右詰めを表

します。

図 8-14. ReportBody UserFunction
第第第第 8 章章章章 319319319319



Agilent VEE 関数の使用方法

Agilent VEE のののの UserFunction の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法
図 8-15 は、ReportDisplay UserFunctionを詳細ビューで示したもの

です。この関数は、アスタリスク (*) で指定した文字列配列を、STR 

ARRAYフォーマットに従って、ファイルの末尾に読込みます。

図 8-15. ReportDisplay の詳細ビュー

図 8-16 は、[Properties]ボックスで [Show Panel on Execute]が

選択されている ReportDisplay UserFunctionのパネル・ビューを示

します。[Properties]ボックスで、Pop-up Panel Titleも

ReportDisplayに変更されています。パネルを作成するには、Confirm 

(OK)と Logging AlphaNumericオブジェクトを選択し、[Edit]⇒

[Add to Panel]をクリックします。Logging AlphaNumeric表示で

は、[Show Title Bar]の選択が解除されています。[Confirm (OK)]

ボタンの名前が DONEに変更されています。[Confirm (OK)]ボタンがあ

るのは、ユーザがボタンを押すまで、Logging AlphaNumeric表示を画

面に表示し続けるためです。

3. プログラムを実行すると、ReportDisplayパネルがポップアップし、

図 8-16 に示す値が表示されます。[DONE]をクリックして実行を完了

します。次に、プログラムを Report.veeとしてセーブします。
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図 8-16. ReportDisplay のパネル・ビュー

別のプログラムを作成しライブラリをマージする方法

この例題では、新しいプログラムを作成し、その中にライブラリをマージ
します。ここでは、レポートを生成するための関数から成るライブラリを
構築します。新しいプログラムは、ライブラリ内の各関数について説明す
る Note Padオブジェクトを保持します。新しいプログラムには RepGen

という名前を付けます。

新しいレポート生成用の User Functionを作成し、プログラムとマージ

し、Note Padオブジェクトを更新して関数に関する情報を最新にするこ

とにより、RepGenを再利用できます。次に、Merge Library...コマ

ンドを使用すると、RepGenにあるすべての関数を利用できます。

1. [File]⇒ [New]を選択します。

2. [File]⇒ [Merge Library...]を選択します。[Merge Library]

リスト・ボックスから [Report.vee]を選択します。別のディレクト

リにいる場合は、ファイル・パス全体を入力します。

[Edit]⇒ [Edit UserFunction]を選択し ( またはプログラム・エ

クスプローラを調べて ) 、Report.veeから新しいプログラムにライブ

ラリが転送されたかどうかを確認します。Merge Library...コマン

ドを使用した場合は、ローカル関数を編集するように、マージされた関
数を編集できます。
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3. [Display]⇒ [Note Pad]を選択し、図 8-17 に示しているように

UserFunctionについての記述を入力します。次に、プログラムを

RepGen.veeとしてセーブします。

メモ 関数を呼出す VEE プログラムが実際には存在しない場合でも、ライブラリ

を作成する目的で、UserFunction 自体の「プログラム」をセーブでき

ます。

図 8-17. UserFunction から成る RepGen.vee ライブラリ

例題 8-3: ライブラリのインポートと削除の方法

UserFunctionから成るライブラリを作成しても、プログラムにライブラ

リをマージしないこともあります。ライブラリを実行時に持ってきて、そ
の中の一部の関数を使用したうえで、メモリを浪費しないようにライブラ
リを削除できます。Import Libraryと Delete Libraryオブジェクト

は、この場合のために設計されています。

この例題では、RepGenプログラムから関数をインポートします。次に、

BuildRecAry関数を呼出して、あるテスト・データをシミュレートして

表示し、最後にそのライブラリを削除して、メモリとスワップ領域を解放
します。 

1. [File]⇒ [New]を選択します。
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Agilent VEE のののの UserFunction の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法
2. [Device]⇒ [Import Library]を選択し、メイン内に配置します。

Import Libraryオブジェクト内のフィールドを次のように設定します。

3. オブジェクト・メニューをオープンし、実行時まで待つのではなく、た
だちにライブラリをインポートするために [Load Lib]を選択します。

このコマンドは開発段階で役に立ちます。次のステップで、Callオブ

ジェクト内で [Select Function]を選択したときに、

myLib.BuildRecAryなどと、先頭にライブラリ・ハンドルの付いた

関数が示されます。 

インポートされた関数のライブラリを表示するには、プログラム・エク
スプローラを使用します。

Library Type [Library Type]フィールド内のメニューを使用する
と、UserFunction、コンパイル済み関数、またはリ
モート関数を選択できます。この場合、必要なのは
UserFunction ライブラリなので、デフォルトのままにし
ておきます。

Library Name [Library Name]には、デフォルトで myLibが表示
されています。この名前は、インポートされるそれぞ
れ異なるライブラリを区別するための「ハンドル」と
して、VEE プログラムによって使用されます。
Delete Libraryオブジェクトは、この名前を使用し
て、削除するライブラリを識別します。デフォルトの
名前を使用して差支えありません。

File Name PC では、[File Name]フィールドには、ユーザ・プ
ログラムのデフォルトのディレクトリを選択するため
のダイアログ・ボックスが表示されます。 HP-UX シス
テムは、VEE を起動したときのディレクトリにアクセ
スします。関数ライブラリを保持しているファイルを
指定します。

デフォルト名 [myFile]をクリックして、リスト・
ボックスを表示します。316 ページの「UserFunction ラ
イブラリの作成とマージの方法」にあるように、
[RepGen.vee]を選択します。このファイルは、イン
ストール時にプログラムの場所として指定したディレ
クトリにあります。
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Agilent VEE のののの UserFunction の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法
メモ ライブラリのインポートが終わったので、UserFunctionのみを表示し

て、ブレークポイントを設定できます。UserFunctionは編集できませ

ん。編集できる UserFunctionをプログラムに追加するには、Merge 

Library...コマンドを使用します。

4. [Device]⇒ [Call]を選択し、Import Libraryオブジェクトの下

に配置します。Import Libraryの出力シーケンス・ピンを Callオ

ブジェクトの入力シーケンス・ピンに接続します。

5. Call Functionのオブジェクト・メニューをオープンし、[Select 

Function]をクリックし、Load Libコマンドを使ってインポートし

た関数の一覧を表示します。図 8-18 に示すように、

[myLib.BuildRecAry]を選択します。

図 8-18. インポートされたライブラリから関数を選択する方法

VEE は、自動的に [Function Name]フィールドに関数を挿入し、必

要な出力端子を追加します。[Function Name]フィールドに
324 第第第第8章章章章 



Agilent VEE 関数の使用方法

Agilent VEE のののの UserFunction の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法
「myLib.BuildRecAry」と入力しても、同じ結果が得られます。ライ

ブラリ内の関数の名前を一覧表示する必要がある場合は、Select 

Functionを使用します。

6. AlphaNumeric 表示を選択して拡大し、Call のデータ出力に接続し

ます。

7. [Device]⇒ [Delete Library]を選択し、Callオブジェクトの下

に配置します。シーケンス・ピンどうしを接続します。そうすると、
BuildRecAry関数が呼出された後でライブラリが削除されます。デ

フォルトの Library Nameは、Import Libraryオブジェクトの場

合に使用した名前と同じなので、そのままでかまいません。

8. プログラムを実行します。図 8-19 のように表示されます。プログラム

を「libraries.vee」のファイル名で保存します。

図 8-19. ライブラリから関数を呼出す方法

マージされた関数とインポートされた関数の名前については、下記の点に
注意してください。

マージされた関数の名前がローカル関数の名前と同じ場合、VEE はエ

ラーを表示します。
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Agilent VEE のののの UserFunction の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法の場合にライブラリを使用する方法
インポートされた関数の名前がローカル関数の名前と同じでもよいので

すが、関数名のみを使用すると、ローカル関数が呼出されます。図 8-19
の Callオブジェクトにあるような MyLib_func()構文を使用すると、

インポートされた関数を明示的に呼出せます。. 

2 つのインポートされたライブラリで同じ関数名を使用している場合、

どうなるかはわかりません。Callオブジェクトは Library名

myLib.BuildRecAryを使用しているため混乱しません。同じ名前を

持つ別のローカル関数または別のインポートされた関数が存在したとし
ても、この名前によって、BuildRecAryの名前と場所が指定されるた

めです。
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大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法
大規模プログラム内の関数を検索する
方法

VEE は、大規模プログラム内でのオブジェクトやテキストの検索に役立つ

ように Find機能を提供します。この機能は [Edit]メニューにあります。

たとえば、Examples/Gamesディレクトリ内の Solitaire.veeプログ

ラムをオープンします。詳細ビューに切替え、[Edit]⇒ [Find...]を

クリックして、図 8-20 に示すダイアログ・ボックスを表示します。

図 8-20. [Find] ダイアログ・ボックス

図に示すように、このプログラム内の UserFunctionの名前を

「makeamove」と入力し、[Find]をクリックします。VEE は、自動的に

makeamoveという名前の UserFunctionを検索し、図 8-21 に示すよう

に、この関数が呼出されたプログラムの部分を表示します。
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大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法大規模プログラム内の関数を検索する方法
図 8-21. [Find Results] ダイアログ・ボックス

Findを使用すると、オブジェクトにある変数、タイトル、設定など、ど

のようなオブジェクトやテキストでも検索できます。[Find Results]

ボックス内のどの行をダブルクリックしても、オブジェクトを検索でき
ます。

メモ プログラム・エクスプローラで、マウス・ポインタをオブジェクト上に置
き、マウスの右ボタンをクリックしても、Findを使用できます。これに

より、検索範囲が、特定の UserFunction や UserObject に限定され

ます。
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Agilent VEE プログラムのマージプログラムのマージプログラムのマージプログラムのマージ
Agilent VEE プログラムのマージ 
既存のプログラムの効率を高める最も容易な方法は、過去のプログラムを
現在のテストとマージすることです。マージしてから、現在の必要に合う
ように編集すると、プログラムを再利用できます。

[File]⇒ [Merge...]コマンドは、プログラムの内容またはセーブされ

ているオブジェクトの集合を作業領域に追加すると同時に、作業領域の既
存の内容を保持します。デフォルトでは、[File]⇒ [Merge...]は、

VEE とともに出荷されたプログラムのあるディレクトリを表示します。そ

れらのプログラムは、棒グラフ表示や (ID 番号などの ) ユーザ入力用の

データ入力キーパッドなどよく使用されるプログラムです。

例題 8-4: 棒グラフ表示プログラムをマージする方法

この例題では、既存のプログラムと新しいプログラムをマージします。例
では、VEELibディレクトリにあるプログラムを使用しますが、どのプロ

グラムでも使用できます。ramp()関数を使用して、1 から 5 までの 5 つの

値を持つ配列を作成します。その配列を VEE 内部の表示オブジェクトを

使って表示するのではなく、BarChartプログラムとマージします。

1. [Device]⇒ [Formula]を選択し、左の作業領域に配置します。

2. データ入力端子を削除します。

3. デフォルトの公式を ramp(5,1,5)に変更します。

1 番目のパラメータは ramp 配列内の目的の要素の数、2 番目のパラメー

タは開始位置、3 番目のパラメータは終了位置です。この関数の詳細

は、Formulaには現在 ramp呼出しがあるため、オブジェクト・メ

ニュー内の [Help]を選択します。または、[Help]⇒ [Contents & 

Index]を選択し、次に、Index フォルダ内の Search 機能を使用します。

4. [File]⇒ [Merge...]をクリックして、[Merge File]リスト・

ボックスを表示します。BarChart.veeを選択して、Formulaオブ

ジェクトの右に配置します。2 つのオブジェクトどうしを接続します。
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Agilent VEE プログラムのマージプログラムのマージプログラムのマージプログラムのマージ
5. プログラムを実行します。図 8-22 のように表示されます。

図 8-22. BarChart プログラムをマージする方法

Bar Chart Display が 1 次元の配列を受取り、値を棒グラフで表示します。こ

のプログラムでは、配列内の値を表示するのに必要なだけのバーが使用さ
れます。このプログラムがどのように作成されているかを理解するには、
表示の詳細ビューをオープンします。プログラムの作成方法に関するアイ
デアをさらに知りたい場合は、library ディレクトリで実例を調べることが

できます。

メモ [File]⇒ [Merge]コマンドは、UserObjectとオブジェクトにマージ

するのに使用されます。[File]⇒ [Merge Library]コマンドは、

UserFunctionをマージするのに使用されます。
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この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
トピックを復習してください。

UserFunctionを定義し、それをコンパイル済み関数とリモート関数

と比較する。

UserFunctionを作成し、呼出し、編集する。

複数の UserFunctionライブラリを作成し、マージし、インポートし、

削除する。

いずれかのゲーム・プログラムで Find機能を使用する。

VEE プログラム全体を現在のプログラムとマージする。
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この章の復習この章の復習この章の復習この章の復習
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テストのシーケンスを決定する方法
テストのシーケンスを決定する方法

この章の内容

Sequencerオブジェクト

Sequencer用のテストを設定する方法

実行時の結果に基づくテスト実行順序を作成する方法

Sequencerがログとして記録したデータにアクセスする方法

Sequencerテストとデータを受渡す方法

Sequencerがログとして記録したデータに対して解析を行う方法

Sequencerのテスト・データを保管する方法

平均的な必要時間 :2 時間 
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概要概要概要概要
概要

この章では、Sequencerオブジェクトの使用方法の基本を習得します。

Sequencerオブジェクトは一連のシーケンス・トランザクションを実行

でき、それぞれのシーケンス・トランザクションは、UserFunction、コ

ンパイル済み関数、またはリモート関数を呼出すことができます。通常、
Sequencerは一連のテストを実行するために使用されます。

Sequencerを使用する利点の一部は次のとおりです。

テスト計画の開発が容易

テスト間にまたがる分岐機能が多数ある

カスタマイズされたテスト用実行可能ファイルを構築するための主要コ

ンポーネントであること

VEE とその他の言語で書かれたテストを呼出せること

テスト結果の自動ログ記録が可能なこと

メモ Sequencerは、VEE の最も強力な機能の 1 つです。Sequencerについて

の詳細は、オンライン・ヘルプを参照してください。

最初の例題では、Sequencerオブジェクトのテストを設定する方法、テ

スト実行フローにテストを追加または挿入したりそのフローからテストを
削除する方法、および Sequencerによってログに記録されたテスト・

データにアクセスする方法を示します。ここでは、random()関数を使っ

てテスト結果をシミュレートします。

2 番目の例題では、テストに渡すデータをグローバル変数を使って作成す

る方法、Sequencerから UserFunctionを呼出す方法、および

Sequencerデータのログをファイルに記録する方法を習得します。最後

に、データの各部分を解析します。

メモ 一連のテストによって更新されるステータス・パネルを使用する場合は、
407 ページの「ステータス・パネルを作成する方法」を参照してください。
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概要概要概要概要
メモ この章の例題のほかに、Sequencerの使用について学ぶ場合は、付録 A
「追加の例題」の 516 ページの「テスト・シーケンサ」を参照してください。
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Sequencer オブジェクトの使用方法オブジェクトの使用方法オブジェクトの使用方法オブジェクトの使用方法
Sequencer オブジェクトの使用方法

Sequencerオブジェクトは、複数のテストを指定された順序で実行時の

結果を基にして実行します。テストとして有効なものは、VEE 
UserFunction、コンパイル済み関数、リモート関数、またはそのほかの

単一の結果を返す式です。テストの結果はテスト仕様と比較され、テスト
が成功 (PASS) したかどうかが判定されます。Sequencerは、次に、成功

/ 失敗インジケータを使用して、次のテストを実行する必要があるかを判定

します。

次のテストに分岐する場合は、6 つの異なる選択肢があります。これらの

選択肢は、「次のテストを実行する」、「同じテストを繰返す」、「より以前の
テストにジャンプする」などです。例題 9-1 で、分岐の選択肢について詳

細に説明しています。Sequencerは、必要な操作を決定するために、

ユーザ入力を要求することさえできます。

指定されたテストの実行が終わると、Sequencerは、自動的にテスト・

データのログを出力端子に記録します。これ以降は、データの解析や表示、
または将来の調査に備えてのデータのファイルへの保管ができるようにな
ります。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
テスト実行順序の作成方法

この例題では、random()関数を使ってテスト結果をシミュレートし、テ

スト実行順序を確立し、その順序を変更する方法を習得し、ログとして記
録された結果から特定のデータを読取ります。

例題 9-1: テストの設定方法 

メモ この例では、テスト結果の一定の期待範囲を使用して、random()関数を

実装する方法について説明しますが、原則はどのようなテストでも同じです。

1. [Device] ⇒ [Sequencer]を選択し、上部左の作業領域内に配置し

ます。

2. [Display]⇒ [AlphaNumeric]表示を選択し、Sequencerの下に

配置し、幅を広げ、Sequencer Log出力端子を Alphanumericデー

タ入力に接続します。

3. Sequencerトランザクション・バーをダブルクリックし、[Sequence 

Transaction]ダイアログ・ボックスを表示します。フィールドを次

のように設定します。

メモ フィールドを編集する場合、フィールドを変更するには新しいフィールド
をクリックし、別のフィールドに前進するには Tab キーを使用します。

カーソルを後退させるには Shift+Tab キーを使用します。ダイアログ・

ボックスの編集が終わったときにのみ Enter キーを押します。

TEST: デフォルト名は test1で、このデフォルト名を使用で
きます。テスト名は Sequencerにおけるテストの単
なるラベルです。テスト名はテスト関数そのものでは
ありません。

SPEC 
NOMINAL:

期待されるテスト値を表します。デフォルトは .5で
す。この値を .25に変更し、次に、右端にある
[RANGE]フィールドの上限値を [1]から [.5]に変
更します。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
その他のフィールドはデフォルト値のままにしておけます。この設定で
実行すると、約半分の実行結果が成功 (PASS)になります。ダイアロ

グ・ボックスは図 9-1 のように表示されます。

図 9-1. [Sequence Transaction] ダイアログ・ボックス

[OK]をクリックして、ダイアログ・ボックスをクローズします。次の

トランザクションがトランザクション・バーに表示されます。
test1 0 <= (.25) <= .5 

これは、戻り値が 0以上 .5以下である場合、test1は成功 (PASS) す
ることを意味します。期待される結果は約 .25です。

FUNCTION: デフォルトのエントリ [testFunc(a)]は、テストを
実行する実際の関数を保持しています。この場合、こ
のデフォルトのフィールドを [random()]関数に置換
えます。Random()は、テスト結果をシミュレートす
る 0から 1までの Real64値を返します。この結果が
テスト仕様と比較されます。

random(low,high)オブジェクトは、[Function & 
Object Browser]ボックスの [Probability & 
Statistics]カテゴリにあります。この算術関数は、
実際に Formulaオブジェクトを使用しなくても、式
フィールドから呼出すことができます。この例のよう
に、パラメータ low と high を指定しなかった場合は、
デフォルトのパラメータ 0と 1を使用します。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
4. プログラムを実行します。プログラムは、図 9-2 に示すように、表示オ

ブジェクトにテスト名、テスト結果、成功 / 失敗インジケータ ( 成功

(PASS)の場合は 1、失敗 (FAIL)の場合は 0) を表示します。

図 9-2. テストの設定方法

先に進む前に、[Sequence Transaction]ダイアログ・ボックス内のさ

まざまな選択肢を理解するため、表 9-1 を学習してください。トランザク

ション・バーをダブルクリックして、このダイアログ・ボックスをもう一
度オープンします。さまざまなメニューをオープンし、それぞれ異なる選
択肢を学んでください。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
表 9-1. [Sequence Transaction] ダイアログ・ボックス

フィールド 説明

TEST: Sequencerでテストを参照するために使用する一

意な名前。デフォルトの名前は、test1から始ま

り、テストごとに数字の部分が増分します。TEST:

を選択すると、テスト結果がテスト仕様と比較さ
れ、設定に基づいて次のテストへの分岐が行われ
ます。

[TEST:]ボタンは [EXEC:]にトグルします。

[TEST:]を [EXEC:]にトグルした場合は、テス

ト結果とテスト仕様の比較が行われないで、テスト
が実行されます。たとえば、UserFunctionでグ

ローバル変数をセットアップしている場合は、
[EXEC:]を選択できます。[EXEC:]を選択する

と、テストについてのログ記録もディセーブルされ
ます。

ENABLED テストをいつ実行するかを決めます。このメニュー
では 4 つの選択肢が表示されます。

ENABLEDは、条件にかかわりなくテストを実行

します。

ENABLED IF:を選択すると、記述されている式

が TRUEと評価された場合にテストを実行しま

す。たとえば、入力ピン Aが値 1 (A == 1)を

保持する場合にテストを実行できます。監査テ

ストの制御のた Ｇl に ENABLED IF:を使用で

きます。たとえば、10 回テストを実行するたび

に、特定のテストを 1 回実行することもでき

ます。

DISABLEDは ENABLEDの反対です。

DISABLED IF:は ENABLED IF:の反対です。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
SPEC 
NOMINAL:

テストの期待値。

RANGE: テスト値の範囲を指定します。このメニューでは 4
つの選択肢が表示されます。

RANGEは、成功 (PASS)条件であるテスト値の範

囲を意味します。次の通常の比較演算子からも

選択できます。>、>=、<、<=、==、!=。

LIMITは、テスト・データの比較のた Ｇl に 1 つ

の値だけを使用します。

TOLERANCEは、SPEC NOMINAL値に対して上下

に許される誤差の値を指定することにより、許

容範囲を指定します。

%TOLERANCEは、SPEC NOMINAL値に対して上

下に許される誤差のパーセンテージを指定する

ことにより、許容範囲を指定します。

FUNCTION: 実行するテストを指定します。UserFunction、

コンパイル済み関数、リモート関数を呼出すか、評
価対象となる式を入力できます。呼出した関数 ( ま
たは評価対象の式 ) の結果は、仕様と比較してテス

トされます。

UserFunctionが 1 つの値以上を返す場合、VEE
は、一番上の出力ピンがテスト対象となる結果を保
持していると想定します。

関数は組合わせたりネストすることもできます。た
とえば、(random(0,myfunc()+3,100)*2)。

表 9-1. [Sequence Transaction] ダイアログ・ボックス ( 続き )

フィールド 説明
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
LOGGING 
ENABLED

テスト・データのログを記録します。ログ記録に関
するオプションを指定するには、Sequencerのオ

ブジェクト・メニューをオープンし、
[Properties]を選択し、[Logging]フォルダ

をクリックし、一覧から選択します。デフォルトで
は、[Name]、[Result]、[Pass]にチェック・

マークが付けられています。[Log to Output 

Pin Only]と [Log Each Transaction To:]

のいずれかを選択するフィールドもあります。ログ
記録をイネーブルに設定した場合は、各テストでロ
グのレコードが記録されます。

このボタンは [LOGGING DISABLED]にトグルし

ます。

IF PASS 分岐命令を決めます。テストが成功した場合、VEE
は、ここで分岐命令を確認します。[IF PASS]で

は、VEE はドロップダウン・メニューで選択され

ている分岐命令を実行します。

このボタンは [IF PASS CALL:]にもトグルしま

す。
[IF PASS CALL:]では、指定した関数が呼出さ

れてから、分岐メニューで選択した命令に分岐し
ます。

この表の次の項目である [THEN CONTINUE]も参

照してください。

表 9-1. [Sequence Transaction] ダイアログ・ボックス ( 続き )

フィールド 説明
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
THEN 
CONTINUE 

テストへの分岐を決めます。[IF PASS]と [IF 

FAIL]の場合、ドロップダウン・メニュー [THEN 

CONTINUE]には 6 つの分岐オプションがあります。

[THEN CONTINUE]は、Sequencerで設定して

いる次のテストを実行します。

[THEN RETURN:]では、VEE はテストの実行を

停止し、指定された式を Sequencerの

Return出力ピンに出力します。

[THEN GOTO:]は、フィールドで指定している

テストにジャンプします。

[THEN REPEAT]は、最大で [MAX TIMES:]

フィールドで指定している回数だけ、現在のテ
ストを繰返します。最大回数だけ繰返した後も
まだ PASS/FAIL条件が存在する場合は、VEE
は次のテストを続けます。

[THEN ERROR:]は、所定のエラー番号の付い

たエラー条件を生成することにより、実行を停
止します。エラーは、Sequencerの Error出

力ピンを使って蒜 l 捉できます。ほかの出力ピ

ンはデータを送信しません。

[THEN EVALUATE:]は、指定された

UserFunctionを呼出します。この

UserFunctionは、分岐メニューのいずれかの

オプションを指定する文字列を返す必要があり
ます。UserFunctionが返す有効な文字列は、

Continue、Return < 式 >、Goto < 名前 >、
Repeat <式 >、Error <式 >です。ここで、

< 式 > は有効な VEE 式、< 名前 > はシーケン

ス内のテストの名前です。このオプションを使
用すると、次に行うことをユーザとの対話で決
Ｇl ることができます。

表 9-1. [Sequence Transaction] ダイアログ・ボックス ( 続き )

フィールド 説明
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
テストを追加、挿入、または削除する方法

この節では、別のテスト・トランザクションを Sequencerオブジェクト

に追加します。同じ random()関数を使用するとテスト結果をシミュレー

トできますが、今回は、結果を値の範囲と比較するのではなく、リミット
と比較します。

1. 最初の Sequencerトランザクション・バーの下をダブルクリックし、

[Sequence Transaction]ダイアログ・ボックスを表示します。

フィールドに次のように入力します。

ほかの選択肢はデフォルトのままにしておき、[OK]をクリックして、

Sequencerに戻ります。

IF FAIL 分岐の指示。テストが失敗した場合、VEE は、こ

こで分岐命令を確認します。[IF FAIL]は [IF 

FAIL CALL:]にトグルします。オプションは [IF 

PASS]の場合と同じです。

DESCRIPTION: テストについてのテキスト・コメント。テキスト・
コメントは Sequencerトランザクション・バーに

表示され、[Properties]ダイアログ・ボックス

内の Loggingフォルダを使用すると、テスト・レ

コードとともに保管できます。

test2 デフォルトを使用します。

SPEC NOMINAL 設定を .5 から .25 に変更します。

RANGE ドロップダウン・メニューで [LIMIT:] を選択

します。演算子は < を選択します。リミット

を 1 から .5 に変更します。

FUNCTION testFunc(a) から random() に変更します。

表 9-1. [Sequence Transaction] ダイアログ・ボックス ( 続き )

フィールド 説明
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
メモ オブジェクト・メニューで [Add Trans...]を選択すると、強調表示さ

れているトランザクションの後にトランザクションを追加することもでき
ます。

Sequencerテスト計画には、現在、test2 (.25) < .5という 2 番目の

トランザクションが表示されています。次に、2 つのテストの間にトラン

ザクションを 1 つ挿入します。

2. 2 番目のトランザクション・バーが強調表示されているかどうか確認し

ます。次に、オブジェクト・メニューをオープンし、[Insert 

Trans...]を選択します。フィールドに次のように入力します。 

[OK]をクリックします。2 番目のトランザクション・バーに Insert 

0 <= (.5) <= 1と表示されます。プログラムを実行し、3 つのテスト

からの 3 つのレコードを表示します。すべてのエントリを表示するに

は、表示を拡大する場合もあります。

3. [Insert]トランザクション・バーをクリックして、Insertを削除

し、マウス・ポインタを [Insert]トランザクション・バー上に置き、

Ctrl+K を押します。

メモ ターゲットのトランザクション・バーをクリックし、オブジェクト・メ
ニューで [Cut Trans]を選択することもできます。オブジェクト・メ

ニューで [Paste Trans]を選択し、切取っておいたトランザクションを

貼付けることもできます ( ショートカットは Ctrl+Y)。同じようにして、

[Copy Trans]を選択すると、トランザクションをコピーできます。

4. プログラムを実行し、2 つのテストからのデータ・レコードを確認しま

す。プログラムに seq1.veeと名前を付けて保存します。プログラム

は図 9-3 のように表示されます。

TEST 名前フィールドを Insertに変更します。

FUNCTION random() に変更します。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
図 9-3. 単純な Sequencer の例

中かっこ {} は、Recordデータ型を示します。Sequencerは、

AlphaNumeric表示に表示されているように、Record of Records( レ
コードから成るレコード ) を出力します。このことは、ループ内に

sequencer を置いて同じテスト・シーケンスを数回実行すると、Records 

of Records( レコードから成るレコード ) を要素とする配列を生成できる

ことを意味します。

ログとして記録されているテスト・データにアクセス
する方法

Sequencerは Record of Records( レコードから成るレコード ) を出力

します。それぞれのテストは、Sequencerレコード内のフィールド名と

してテスト名を使用します。それぞれのテスト内のフィールドの名前は、
ログ記録に関する設定に従って付けられます。フィールド Name、

Result、Passについてデフォルトの設定を使用すると、図 9-4 に示すよ

うに、Log.Test1.Resultという表記を使って test1にある結果にアク

セスできます。
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
.

図 9-4. ログとして記録されているレコードまたは複数のレコード

テスト結果にアクセスするには、次の手順に従います。

1. seq1.veeをオープンします。

2. [Device]⇒ [Formula]を選択し、表示オブジェクトの下に配置しま

す。式を Log.Test1.Resultに変更します。VEE では大文字と小文

字を区別する必要がないので、名前の中で大文字を使用しているのは、
マニュアルの中で名前を明確に示すためです。

入力端子名を Aから Logに変更します。デフォルト名 Aをそのままに

しておくこともできます。その場合、公式は A.Test1.Resultとなり

ます。Sequencerの出力端子 Logを Formulaの入力端子 Logに接続

します。

3. [Display]⇒ [AlphaNumeric]表示を選択し、Formula の出力に接

続します。

4. プログラムを実行します。プログラムは、Test1内の Resultフィー

ルドにアクセスします。プログラムに seq2.veeと名前を付けて保存

します。プログラムは図 9-5 のように表示されます。 
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テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法テスト実行順序の作成方法
図 9-5. ログとして記録されているデータにアクセスする方法

メモ それぞれのテストは、Sequencer内で実行されたときに、テスト名を

使って名前を付けたレコードを作成します。このレコードは後続のテスト
で使用できます。たとえば、test1が成功 (PASS) した場合、test2をイ

ネーブルできます (ENABLED IF: test1.pass == 1)。テストがまだ実

行中であるときに、式フィールド内のテスト・データにアクセスする必要
がある場合、テスト・データはテンポラリ・レコード thistestに保管さ

れています。

5. 公式を Log.test1に変更し、プログラムをもう一度実行します。プロ

グラムは test1のレコード全体を読取ります。test1のレコード全体

は、表示内の 3 つの値を囲んでいる中かっこ {} によって示されています。

6. 公式を変更すると、test1と test2のレコード内のフィールド

result、pass、name、またはその他のフィールドにアクセスできま

す。[Properties]ボックス内の [Logging]タブを選択し、ログと

して記録されているレコードに Nominalと Time Stampフィールドを

追加します。Formulaオブジェクトを使用して、新しいフィールドに

アクセスします。
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Sequencer を使ってデータを渡す方法

この例題では、UserFunctionを作成し、3 つの別々のテストから呼出し

ます。1 つ目では、Sequencerの入力端子を介して UserFunctionに

データを渡します。2 つ目では、入力端子ではなく、グローバル変数を使

用するようにプログラムを変更します。これにより、TESTモードではな

く EXECモードで関数を呼出すことができます。3 つ目では、波形出力を

マスクと比較するテストを行う方法を習得します。

例題 9-2: 入力端子を使用してデータを渡す方法 
最初に、次の手順に従って UserFunction Randを作成します。これは

計測手順をシミュレートするものです。Rand()は、入力パラメータを

random(low,high)オブジェクトの出力に追加し、結果を出力ピンに出

力します。3 つの別々のテストから Rand()を呼出します。

1. [Device]⇒ [UserFunction]を選択します。名前 UserFunction1

を Randに変更します。

2. random(low,high)関数を表示し、入力端子を削除し、パラメータを

削除し、Rand内に配置します。パラメータがなければ、デフォルトは

0と 1になります。A+Bオブジェクトを random(low,high)の右に配

置します。random(low,high)の出力を A+Bオブジェクトの左上の入

力に接続します。

3. Randにデータ入力端子を追加します。入力端子 Aを A+Bオブジェクト

の左下の入力端子に接続します。

4. Randにデータ出力端子を追加します。A+Bオブジェクトの出力を

Randの出力端子に接続します。

UserFunction Randは図 9-6 のように表示されます。
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図 9-6. Rand UserFunction

5. プログラムに seqdat1.veeと名前を付けて保存します。一番上の右端

にある [x] ボタンを使って Randウィンドウをクローズします。

メモ ウィンドウをクローズしても、UserFunctionは削除されません。このこ

とを確認する場合は、[Edit]⇒ [Edit UserFunction]をクリックし

ます。編集対象の UserFunctionを一覧表示したリスト・ボックスに

Randが表示されます。または Rand関数をアイコン化することもできま

す。その場合は、VEE 画面の下部にアイコンが表示されます。

Sequencer内の 3 つのテストをセットアップします。3 つのテストでは、

Randを呼出し、Sequencerの入力ピンを使って入力パラメータを Rand

に与えます。

6. [Device]⇒ [Sequencer]を選択し、メイン内に配置します。

Sequencerに入力端子を追加します。トランザクション・バーをク

リックして、[Sequence Transaction]ダイアログ・ボックスを表

示します。[FUNCTION]フィールドを [testFunc(a)]から

[rand(a)]に変更します。これにより、UserFunction Rand()が呼

出され、Sequencerの入力端子 Aの値が Rand() に送信されます。

[OK]をクリックして、Sequencerのオープン・ビューに戻ります。

メモ Sequencerの入力端子名 Aなどを使用しても、[Sequence 

Transaction]ボックス内のどの式フィールドにもデータを渡せます。た

とえば、Aを使用すると、RANGE:と SPEC NOMINAL:にデータを渡せます。
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トランザクションが強調表示されていることを確認してから、カーソル
をトランザクション・バー上に置き、Ctrl+K を押してテストをカット

し、次に、Ctrl+Y を 3 回押して、テストをカット元の Sequencerに貼

付けます。オブジェクト・メニューを使ってもカットと貼付けができ
ます。

デフォルトのテスト名は、test1x2、test1x1、test1となります。3
つの [Sequence Transaction]ダイアログ・ボックスをオープンし、

これらの名前を test1、test2、test3というわかりやすい名前に変

更します。

1. [Data]⇒ [Continuous]⇒ [Real64 Slider]を選択し、

Sequencerの左に配置します。名前をユーザからの入力を要求する方

式の Select Num:に変更し、オブジェクトのサイズを少し小さくし、

Sequencerの入力端子に接続します。

ヒント : オブジェクトを配置したとき、マウスの左ボタンを使ってオブ
ジェクトの四隅のいずれかをクリック・アンド・ドラッグすると、オブ
ジェクトのサイズを決められます。

2. AlphaNumeric表示を選択し、Sequencerの下に配置し、少し幅を拡

大し、Sequencerの Log出力端子に接続します。

3. プログラムを seqdat1として再度セーブします。Real64 Sliderオ

ブジェクトにある数字を 1 つ選択し、seqdat1を実行します。図 9-7
のように表示されます。
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図 9-7. 入力端子を使用してデータを渡す方法

テスト数が増えると、入力端子を使ってデータを渡すのに必要な入力ピン
が多くなります。入力ピンを減らすには、入力端子にレコードを渡して、
レコード内の別々のフィールドを別々のテストのために使用します。別々
の UserFunctionを使用しても、グローバル変数をセットアップできま

す。グローバル変数は、ほかの UserFunctionから、またはプログラム

内の式フィールドから呼出すことができます。次の例題でこのことを例証
します。

グローバル変数を使用してデータを渡す方法

この例題では、seqdat1プログラムを変更して、UserFunction Rand

にパラメータ a を渡すためにグローバル変数を追加します。

1. Select Numというラベルの付いている Real64 Sliderオブジェク

トを削除します。Sequencerの A入力端子を削除します。

2. test1トランザクション・バーを強調表示し、オブジェクト・メ

ニューをオープンし、[Insert Trans...]をクリックします。

[Sequence Transaction]ボックスが表示されたら、[TEST]をク

リックして、[EXEC]にトグルし、名前を Setupに変更します。
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EXECモードを使用する理由は、User Functionがグローバル変数を

セットアップするだけで、仕様に照らしてテストされる結果は生成しな
いことにあります。

3. [FUNCTION]フィールドを [global()]に変更し、[OK]をクリック

して、ダイアログ・ボックスをクローズします。

次に、UserFunction global()を作成します。

4. [Device]⇒ [UserFunction]を選択します。名前 UserFunction1

を globalに変更します。

[Data]⇒ [Continuous]⇒ [Real64 Slider]を選択し、

UserFunction内に置き、名前を Select Num:に変更し、縦方向の

サイズを少し小さくします。

[Data]⇒ [Variable]⇒ [Set Variable]を選択し、Real64 

Sliderの右に配置します。

グローバル変数名を globalAから aに変更します。Real64 Slider

を Set Variableオブジェクトに接続します。

画面にオペレータが数字を選択するための関数を表示するため、ポップ
アップ・パネル・ビューを追加します。[Confirm (OK)]ボタンを加えま

す。これにより、オペレータが選択を終えるまで、パネルは画面に表示さ
れたままとなります。この作業は、global() UserFunction内の実数入

力用ダイアログ・ボックスを使って行うこともできます。

5. [Flow]⇒ [Confirm(OK)]を選択し、Real64 Sliderオブジェクト

の上に配置します。OKデータ出力ピンを Real64 Sliderのシーケン

ス入力ピンに接続します。

メモ OKボタンを Set Variableオブジェクトの下に配置した場合は、論理エ

ラーとなります。これは、VEE が Sliderにある古い値を Set 

Variableオブジェクトに送信し、[OK]ボタンが押されるまで休止する

からです。ポップアップ・パネルで入力した新しい値はすべて無視されま
す。OKを Real64 Sliderの上から接続した場合は、[OK]が押されてか

らグローバル変数が設定されるため、新しい Slider値を使用できます。

[Show Data Flow]をオンにすると、実行の順序を監視できます。 
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6. [Display]⇒ [Note Pad]を選択し、[OK]ボタンの右に配置しま

す。Note Padに、次のユーザ・プロンプトを入力します。

Please select a number for this run of tests 1, 2, and 
3.

7. Ctrl キーを押したまま、[Note Pad]、[Real64 Slider]、[OK]ボ

タンをクリックして、3 つのオブジェクトを選択します。各オブジェク

トは、選択されていることを示す網かけ表示になります。[Edit]⇒

[Add To Panel]をクリックします。[Edit]メニューは、VEE 画面

内の空いている領域、UserObject、または UserFunctionの詳細

ビューで右ボタン・クリックしても表示できます。パネル・ビューで、
パネルのサイズを少し小さくし、Note Padを一番上に、Real64 

Sliderを中ほどに、[OK]ボタンを一番下に配置します。

メモ パネル・ビュー内でオブジェクトを再配置しても、詳細ビュー内でのオブ
ジェクトのレイアウトには影響ありません。

UserFunctionの [Properties]ウィンドウをオープンします。

[Pop-up Panel]の [General]フォルダで、[Show Panel on 

Execute]をクリックして選択します。図 9-8 は詳細ビューの

UserFunctionを示し、図 9-9 はそのパネル・ビューを示します。
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図 9-8. Global UserFunction ( 詳細 )

図 9-9. Global UserFunction ( パネル ) 
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8. seqdat2という名前を付けてプログラムをセーブし、実行します。

ポップアップ・パネルが表示されたら、値を選択し、[OK]を押します。

図 9-10 のように表示されます。

メモ ポップアップ・パネルは、デフォルトでは、画面の中央に表示されます。
移動するには、タイトル・バーをクリック・アンド・ドラッグします。

図 9-10. グローバル変数を使用してデータを渡す方法

波形出力をマスクと比較する方法

この例題では、noisyWvという名前の UserFunctionを作成し、

Sequencer内の単一のトランザクション・バーから呼出します。オペ

レータは、波形の振幅を 0から 1の間で変更できます。この関数は、ノイ

ズの波形を返すテスト結果をシミュレートします。[Data]⇒

[Constant]メニューの Coordオブジェクトを使用して、0.6で直線マ

スクを作成します。Sequencerは、これを使ってノイズの波形をテスト

します。

1. 図 9-11 の詳細ビューで示されているように noisyWvという名前の

UserFunctionを作成します。
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図 9-11. noisyWv UserFunction( 詳細 )

2. パネル・ビューを作成するため、Ctrl キーを押したまま、[OK]ボタン、

[Real64 Slider]、[Note Pad]をクリックして、強調表示します。

[Edit]⇒ [Add To Panel]を選択します。

パネル・ビューが表示されたら、オブジェクトを任意に並替え、ウィン
ドウのサイズを変更します。

オブジェクト・メニューをオープンし、[Properties]をクリックし、

[Pop-up Panel]で [Show Panel on Execute]の横をクリックし

ます。

パネル・ビューは図 9-12 のように表示されます。
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図 9-12. noisyWv UserObject( パネル )

3. [Device]⇒ [Sequencer]を選択し、メイン左中央に配置します。

データ入力端子を追加し、maskという名前を付けます。

4. トランザクション・バーをクリックし、[Sequence Transaction]

ダイアログ・ボックスを表示します。フィールドを次のように変更し
ます。

test1では noisyWv()から結果が得られるので、その結果を maskと

いう名前の入力端子のリミット値と比較するテストを行います。すべて
の点でノイズ波がマスクと比較して小さいか等しい場合、ノイズ波のテ
ストは成功 (PASS) です。そうでない場合、ノイズ波のテストは失敗

(FAIL) です。

FUNCTION 「noisyWv()」と入力します。

RANGE ポップアップ・メニューで [LIMIT]をクリッ
クして選択します。<=と、LIMITの端子名
フィールドの種類である maskはそのままにし
ておきます。その他のデフォルト値はすべてそ
のままでよいので、[OK]をクリックします。
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5. [Data]⇒ [Constant]⇒ [Coord]を選択し、Sequencerの上に配

置します。その出力を Sequencerの入力端子 maskに接続します。

Coordのオブジェクト・メニューをオープンし、[Properties]をク

リックし、フィールドを次のように設定します。

[OK]をクリックします。

6. Coordオブジェクトに 2 組の座標のインデックスが表示されます。最

初のインデックスの [0000:]をダブルクリックして、カーソルを表示

します。コンマで区切って座標を入力すると、VEE が自動的に丸かっ

こを追加します。「0, 0.6」と入力し、Tab キーを押し、「20m, 0.6」

と入力してから、このオブジェクトの外の作業領域をクリックします。
次のエントリがあります。

noisyWv()内のNoise Generatorのx軸(時間軸)は0から20ミリ秒

まで進みます。したがって、x軸の 2 つの値は 0と 20mです。

直線マスクが必要なので、y軸の 2 つの値は、両方とも 0.6です。

メモ 正しい数の座標の組を設定して入力すると、どのようなマスク波形でも作
成できます。

Sequencerの比較のメカニズムは、Coordデータ型を受付けて波形を

テストする Comparatorオブジェクトと同じように働きます。もちろ

ん、2 つの Waveform データ型を比較することもできます。座標の組を

移動するときは Tab キーを押し、入力が終わったら作業領域をクリック

します。

7. AlphaNumeric表示を選択し、幅を拡げ、Sequencerの Log出力に

接続します。

8. seqdat3という名前を付けてプログラムをセーブし、実行します。図

9-13 のように表示されます。 

Configuration 1D Array に設定します。

Size 「2」と入力します。直線を指定するには、2 組
の座標があればよいためです。
360 第第第第9章章章章 



テストのシーケンスを決定する方法

Sequencer を使ってデータを渡す方法を使ってデータを渡す方法を使ってデータを渡す方法を使ってデータを渡す方法
図 9-13. 波形をマスクと比較する方法

Sequencerを使ってデータを渡す例題はこれで完了です。次の例題では、

Sequencerを数回繰返して得たデータにアクセスし、解析する方法を習

得します。
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Sequencer から得たデータを解析する
方法

前に触れたように、Sequencerのデータは、レコードから成るレコード

として出力されます。ただし、多くの場合、Sequencerは一連のテスト

を数回実行することができます。これにより、レコードを要素とする配列
が生成されます。各レコードは Sequencerによる 1 回の実行を表し、1
回の実行内の各テストを表すほかのレコードを保持しています。このこと
を視覚的に理解する最も容易な方法は、図 9-14 に示すようなメモリ内の

データから成る立方体を想像してみることです。

図 9-14. ログとして記録されたレコードから成るレコードを要素と
する配列

レコードを要素とする配列は Logと呼ばれます。これは、Logが

Sequencerの出力ピンに関連付けている名前だからです。特定の実行に

アクセスするには、角かっこ [] 表記を使って配列のインデックスを作成し

ます。
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Log[0]はSequencerによる最初の実行、Log[1]は2番目の実行などと

なります。

各実行のメイン・レコードには、Test1と Test2の 2 つのフィールドが

あります。

レコード Test1内には、Name、Result、Passの 3 つのフィールドがあ

ります。レコード Test2の場合も同じです。

したがって、Log.Test1.Resultは、4 回の実行のいずれかを表す 4 つ

の値を要素とする配列となります。Log[0].Test1.Resultは、1 回

目の実行 (Log[0]) での Test1の Resultであるスカラ値を出力します。

ログとして記録されたレコードを要素とする配列は、データの解析と調査
を簡略化してくれます。たとえば、特定の実行で成功したテストの数を確
認する場合があります。すべての実行での Test2の結果を平均したり、4
回目の実行での Test1のすべてのデータを見る場合もあります。このデー

タを使用すれば、これらの照会はすべて可能です。次の例題では、データ
に対する解析操作を行います。

例題 9-3: Sequencer を数回実行して得られたデータ

を解析する方法 

1. 画面をクリアし、seqdat1.veeプログラムをオープンします。

Sequencerを 3 回実行するように seqdat1.veeプログラムを変更しま

す。次に、そのデータに対する解析操作を行います。

2. [Flow]⇒ [Repeat]⇒ [For Count]を選択し、Real64 Slider

オブジェクトの上に配置します。繰返し回数を 3に変更し、データ出力

ピンを Sequencer のシーケンス入力ピンに接続します。

3. Sequencerの Logピンと表示オブジェクトを結んでいるデータ・ライ

ンを削除します。[Data]⇒ [Collector]を選択し、Sequencerの

右に配置します。左上のデータ入力ピンを Sequencerの Logピンに

接続し、XEQピン ( 左下 ) を For Countオブジェクトのシーケンス出

力ピンに接続します。Collectorデータの出力ピンを AlphaNumeric

の画面に接続します。3 つの要素を持つ配列が表示できるように表示を

縦芳香に少し拡大します。
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Sequencerは test1と test2を 3 回実行し、データを 3 つの要素か

ら成る配列の中に収集し、各要素は各実行のレコードから成るレコード
を保持します。これを視覚的に理解するには、図 9-14 のデータから成

る立方体を参照してください。

この時点でプログラムを実行し、Sequencerデータの表示を調べます。

Formulaオブジェクトを使用して、解析する部分のデータを抽出します。

この例題では、3 回の実行に関する test1の結果を例に取り上げ、配列の

平均値を計算します。

4. [Device]⇒ [Formula]を選択し、表示オブジェクトの下に配置しま

す。Formulaの入力ピンを Collectorの出力に接続します。

Formulaの入力フィールドを a[*].test1.resultに変更します。

mean(x)オブジェクトを Formulaに、AlphaNumeric表示を

mean(x)に接続します。

a は入力端子 Aにある配列を参照します。Test1.resultは正しい

フィールドにアクセスします。すべての実行が 1 つの配列に表示されま

す。たとえば、A[0].test1.resultとすると、1 回目の実行だけを

参照します。

5. プログラムを実行します。図 9-15 のように表示されます。
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図 9-15. Sequencer を数回実行して得られたデータを解析する方法

この例題では、単一の配列にアクセスしますが、Sequencerの出力から

データを要素とするほかの複数の配列を抽出する場合も、原則は同じです。
[Sequencer Properties]ダイアログ・ボックスの [Logging 

folder]をオープンすると、それぞれの配列についてどのフィールドを

セーブするかを容易に変更できます。
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ログとして記録されているデータの保管
と読取りの方法

この例題では、To/From Fileオブジェクトと To/From DataSetオブ

ジェクトの使用方法を示します。

例題 9-4: ログとして記録されているデータに関して
To/From File オブジェクトを使用する方法

1. seqdat2ファイルをオープンし、表示オブジェクトに接続されている

データ・ラインを削除します。

2. [Flow]⇒ [Repeat]⇒ [For Count]を選択し、Sequencerの左に

配置します。For Countの数を 3に変更し、データ出力ピンを

Sequencerのシーケンス入力ピンに接続します。

3. 作業領域を縦方向に拡大し、AlphaNumeric表示を下部近くに配置し

ます。[Data]⇒ [Collector]を選択し、左の作業領域に配置しま

す。Sequencerの Logピンを Collectorのデータ入力ピンに接続し

ます。For Countのシーケンス出力ピンを Collectorの XEQピンに

接続します。

Collectorは Sequencerのレコードを使用して、レコードから成る

レコードを要素とする配列を作成します。To Fileオブジェクト内の

WRITE CONTAINERトランザクションを使用すると、任意の VEE デー

タ・コンテナを容易にファイルに書込むことができます。

4. [I/O]⇒ [To]⇒ [File]を選択し、Collectorの右に配置します。

[I/O]⇒ [From]⇒ [File]を選択し、To Fileオブジェクトの下に

配置します。入力端子を To Fileオブジェクトに追加し、Collector

の出力を接続します。To Fileのシーケンス出力を From Fileの

シーケンス入力ピンに接続します。From Fileのデータ出力を表示オ

ブジェクトに接続します。

To File内の [Clear File At PreRun & Open]にチェック・マー

クを付け、WRITE CONTAINER aトランザクションを設定します。

From Fileオブジェクト内でトランザクションを READ CONTAINER 

xと設定します。
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デフォルトのデータ・ファイルを保管のために使用できます。

5. プログラムを実行します。図 9-16 のように表示されます。

図 9-16. To/From File を使用して、ログとして記録されているデータを保管

する方法

ログとして記録されているデータに関して To/From 
DataSet オブジェクトを使用する方法

テスト・データをレコードとして保管しようとしているので、To/From 

DataSetオブジェクトが適しています。この場合、Collectorは必要あ

りません。Sequencerのそれぞれの実行結果を DataSetの末尾に追加で

きるからです。

最後のプログラムを図 9-17 のように変更します。To/From DataSetオブ

ジェクトは [I/O]メニューにあります。From DataSetに向かうシーケ

ンス・ラインに注目してください。このシーケンスが加えられているのは、
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3 回すべての実行結果が DataSetの末尾に追加されるのを待ってから、

From DataSetをトリガする必要があるからです。

From DataSetオブジェクト内の Search Specifier機能を使用する

と、データを役立つ情報に変換できるので、To/From Fileオブジェクト

ではなく、To/From DataSetオブジェクトを使ってデータを収集するほ

うが有利です。

メモ From DataSet内の [Get records]フィールドを忘れずに [One]から

[All]に変更してください。

図 9-17. To/From DataSet を使用して、ログとして記録されているデータを

保管する方法
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この章の復習この章の復習この章の復習この章の復習
この章の復習 
次の章に進む前に、次のチェックリストを使用して、必要ならトピックを
復習してください。

Sequencerオブジェクトの概念を説明できる。

Sequencer用のテストを設定する。

Sequencerによるテストについて操作を追加、挿入、削除する。

ログとして記録されているデータに Sequencerからアクセスする。

Sequencerの入力端子を使ってデータをテストに渡す。

Global variableを使ってデータをテストに渡す。

波形出力をマスクと比較する。

Sequencerを数回実行して得られたデータを解析する。

To/From Fileオブジェクトを使ってデータを保管する。

To/From DataSetオブジェクトを使ってデータを保管する。
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この章の復習この章の復習この章の復習この章の復習
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オペレータ・インタフェースの使用方法
オペレータ・インタフェースの使用方法

この章の内容

オペレータ・インタフェースを構築する方法

オペレータ用のメニューを使用する方法

明快さを加えるためのビットマップをインポートする方法

テスト・プログラムを保護する方法

オペレータ・インタフェースの機能

ActiveX コントロールを使って VEE の機能を拡張する方法

平均的な必要時間 :2 時間 
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概要概要概要概要
概要

この章では、メニューを追加する方法、インタフェースをカスタマイズす
る方法、警告信号を追加する方法、ビットマップをインポートする方法を
始めとするオペレータ・インタフェースの詳細を習得します。この章では、
前のほうの章でオペレータ・インタフェースとポップアップ・パネルを作
成した例題を詳細にしています。

VEE のオペレータ・インタフェース機能を使用する利点の一部は次のとお

りです。

オペレータにとって使いやすさが最大限になること

プログラムのパフォーマンスが向上すること

許可のない変更から保護されること

視覚的補助による明快さがあること
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オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点
オペレータ・インタフェースに関する重
要点

この節では、VEE でオペレータ・インタフェースを作成する方法の概要に

ついて説明します。

オペレータ・インタフェースを作成する方法

VEE には、オペレータ・インタフェースを作成するためのさまざまな選択

コントロール、ポップアップ・ダイアログ・ボックス、インジケータ、表
示があります。選択コントロールには、ボタン、スイッチ、チェックボッ
クス、ドロップダウン・メニュー、リスト・ボックスなどがあります。イ
ンジケータには、タンク、温度計、塗りつぶしバー、音量単位メータ、
color alarm などがあります。

VEE 内で提供するオペレータ・インタフェース要素に加え、外部から入手

した要素を追加できます。WWW からダウンロードできるオペレータ・イ

ンタフェース要素は多数あります。ActiveX コントロールを介して使用で

きるオペレータ・インタフェースもあります。ダウンロードできるものに
は、無料のものと有料のものがあります。

VEE で提供されているオペレータ・インタフェース・オブジェクトだけを

使用しても、外部から入手した自分専用の要素を追加しても、オペレー
タ・インタフェースを作成するプロセスは同じです。

VEE プログラムのためのオペレータ・インタフェースを作成するには、プ

ログラムのパネル・ビューを作成します。

1. パネル・ビューに必要なオブジェクトを選択します。複数のオブジェク
トを選択する場合は、Ctrl キーを押したまま、それぞれのオブジェクト

をクリックします。

2. [Edit]⇒ [Add To Panel]を選択します。画面が詳細ビューで強調

表示したオブジェクトを含むパネル・ビューに切替わり、デフォルトで
は青で表示されます。

これで、オペレータに必要なものだけを表示するようにカスタマイズでき
る VEE プログラムのビューが作成されました。
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オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点
パネル・ビューと詳細ビュー間を移動する方法

VEE プログラムのパネル・ビューと詳細ビュー間を移動するには、図 10-1
に示すように、ウィンドウのタイトル・バーにあるパネル・アイコンまた
は詳細アイコンをクリックします。

メモ ウィンドウのタイトル・バーにパネル・ビュー・ボタンを表示させるには、
プログラムのパネル・ビューを作成する必要があります。

通常は、詳細ビューでプログラムを開発してから、オペレータ・インタ
フェースのためのパネル・ビューを作成します。パネル・ビュー・ボタン
は、UserObjectウィンドウ、UserFunctionウィンドウ、またはメイ

ン・ウィンドウのタイトル・バーに置くことができます。

.

図 10-1. タイトル・バーのパネル・ビュー・ボタンと詳細ビュー・
ボタン

オペレータ・インタフェースをカスタマイズする方法

VEE プログラムのパネル・ビュー内では、オブジェクトのサイズを変更し

たり、オブジェクトの配置を変更したり、オブジェクトを表示する方法を
変更できますが、詳細ビュー内の同じオブジェクトには影響を与えません。
たとえば、Waveform (Time)表示のパネル・ビューからタイトル・バー

と目盛り類を削除しても、同じ Waveform (Time)表示の詳細ビューには

影響を与えません。ただし、詳細ビュー内のオブジェクトを削除した場合
は、パネル・ビュー内の該当オブジェクトも削除されます。

パネル・ビュー内では、強調を加えるために異なる色またはフォントを選
択したり、明瞭に見せるために拡大可能なビットマップを選択できます。

詳細ビュー・ボタンパネル・ビュー・ボタン
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オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点オペレータ・インタフェースに関する重要点
オペレータのためにパネル・ビューの文書化を行うこともできます。その
場合は、Note Padと Labelオブジェクトを使用し、オブジェクト・メ

ニューの Descriptionオプションを使用して、タイトル・バーを編集し

ます。

図 10-2 は、使用可能な VEE インジケータを示したものです。

図 10-2. 選択の対象となる VEE インジケータ
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
オペレータ・インタフェース・オブジェ
クトの使用方法

この節では、VEE で使用可能なオペレータ・インタフェースのオブジェク

トとオプションを紹介します。この節を一とおり読むと、プログラムのオ
ペレータ・インタフェースを作成するために選択できる項目と、インタ
フェースをカスタマイズする方法がわかります。次に、通常のタスクの一
部のオペレータ・インタフェースをセットアップする方法を理解するため
の実習を行います。

色、フォント、インジケータ

色とフォント    色とフォントについては、[File]⇒ [Default 

Preferences]を選択するか、それぞれのオブジェクト・メニューの

[Properties]を選択すると設定できます。色とフォントの選択肢は、

インストールしているオペレーティング・システムとフォントによって
異なります。

Color Alarm   Color alarmオブジェクトは[Display]⇒[Indicator]メ

ニューにあります。Color alarm オブジェクトには 3 つの異なる範囲の色

とテキスト・メッセージを設定でき、四角または円形を選択できます。
通常 Alarm は、LED をシミュレートしたり、または対処が必要な状況

であることをオペレータに警告するために使用されます。

タンク、温度計、塗りつぶしバー、メータ   これらのオブジェクトは、

[Display]⇒ [Indicator]サブメニューにあります。色とラベルを

使用してカスタマイズできます。水平フォーマットまたは垂直フォー
マットに設定でき、デフォルトの 3 つの異なる範囲を保持するように設

定できます。設定はオブジェクト・メニューの [Properties]で行い

ます。

グラフィック・イメージ

Propertiesボックスの [Panel]フォルダで、[Background 

Picture]を設定すると、パネル・ビュー内にビットマップをインポート

できます。VEE がインポートするファイルは、*.jpeg、*.png、*.wmf、

*.xwd、*.GIF、*.bmp、*.icnで、メイン、UserObject、または

UserFunctionパネルの背景として使用できます。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
ビットマップを背景のピクチャと設定した場合、ほかの VEE オブジェクト

はそのピクチャの上に載った形で表示されます。インポート方法について
の詳細は、397 ページの「パネルの背景に使用するビットマップをイン

ポートする方法」を参照してください。イメージは拡大または縮小したり、
タイルにしたり、切取ったり、中央寄せできます。図 10-3 は、サイズを設

定して背景イメージとして使用している VEE のロゴ・マークを示します。

図 10-3. 背景ピクチャとして使用しているロゴ・マーク
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-4 は、タイルにした背景ピクチャを示します。

図 10-4. タイルとして使用している背景ピクチャ

プログラム内にビットマップを配置する必要がある場合は、[Display]

メニューに Pictureオブジェクトもあります。図 10-5 は、[Display]⇒

[Picture]を選択して組込んだ上で、VEE で切取ったピクチャを示します。

図 10-5. VEE で切取られたイメージ

メモ [Properties]⇒ [Icon]タブを使用すると、ビットマップをアイコン用

に変更できます。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
オペレータ入力のためのコントロールの表示方法

入力を行うことによってオペレータがプログラムを制御できるようにプロ
グラムをセットアップする方法は多種あります。プログラムがユーザ入力
を取得できるのは、ポップアップ・ダイアログ・ボックス、データ定数、
スライダ、ノブからです。コントロールを選択するには、[Data]⇒

[Selection Control]、[Data]⇒ [Toggle Control]、[Data]⇒

[Continuous]などのメニューに移動します。図 10-6 は、オペレータに

プログラムをわかりやすくするために使用できるオブジェクトのコレク
ションを示します。

図 10-6. [Data] のさまざまなサブメニューにあるコントロール

図 10-6 に示しているオブジェクトは、外観をカスタマイズできます。たと

えば、図 10-7 の [Real64 Knob Properties]ダイアログ・ボックスを

見てください。このオブジェクトを設定するには、Colorsなどのフォル

ダを選択して行います。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
メモ ActiveX を使用すると、404 ページの「ActiveX コントロールの使用方法」

に示しているように、ほかのアプリケーションにあるコントロールと表示
を使用することもできます。

図 10-7. [Properties] ダイアログ・ボックス

オペレータ入力のためのダイアログ・ボックスの表示
方法

VEE には、自動エラー検出機能、プロンプト、エラー・メッセージを備え

た組込みポップアップ・ダイアログ・ボックスがあります。これらのダイ
アログ・ボックスは、[Data]⇒ [Dialog Box]にあります。

たとえば、プログラムの実行中にオペレータに実数の入力を要求できます。
プログラムの実行中にオペレータのために [Real64 Input]ボックスを

自動的に表示する Real64 Inputオブジェクトをプログラムに組込むこ

とができます。また、[Real64 Input]ボックスはオペレータがプロンプ

トで正しい情報を入力しなかった場合に、エラー・メッセージを自動的に
表示します。図 10-8 は、プログラムに組込むオブジェクトと、プログラム

の実行中に表示される [Real64 Input]ボックスを示しています。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-8. テキスト入力ボックス

図 10-9 は、プログラムの実行中に、オペレータが [Real64 Input]ボッ

クスに正しい情報を入力しないで [OK]を押した場合に表示される設定可

能エラー・メッセージを示します。

図 10-9. 自動エラー検出の例

Int32と Text用の入力ボックスは、[Data]⇒ [Dialog Box]にあり、

[Real64 Input]に似ています。さらに、[Data]⇒ [Dialog Box]メ

ニューには、[Message Box]、[List Box]、[File Name 

Selection]の選択肢があります。

図 10-10 は、ポップアップしてメッセージを表示するダイアログ・ボック

スを示します。

図 10-10. ポップアップ・メッセージ・ボックス

このオブジェクト
をプログラムに組
込み、適切に接続
する

プログラムの実行中に、
この入力ボックスがオ
ペレータのために表示
される
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-11 は、オペレータがリストを入力するためにポップアップするダイ

アログ・ボックスを示します。

図 10-11. リスト選択ボックス

図 10-12 は、オペレータがファイル名を選択するためにポップアップする

ダイアログ・ボックスを示します。

図 10-12. ポップアップ・ファイル選択ボックス

オペレータのためにトグル・コントロールを表示する
方法

VEE には、0 または 1 を送出するために使用できる組込みトグル・コント

ロールがあります。トグル・コントロールを使用するには、初期状態を設
定しておき、トグルがアクティブ化されたときにサブプログラムを実行し
ます。Toggleにカスタム・ビットマップを置くこともできます。

たとえば、オペレータがスイッチまたは alarm を設定する必要があるプロ

グラムの場合、トグル・コントロールを使用できます。図 10-13 は、オペ

レータがスイッチを設定するためのパネルを示します。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-13. 組合わせたスイッチと Alarm

オペレータ・インタフェースでオブジェクトを位置合
わせする方法

パネル・ビューには、オブジェクトの位置合わせに役立つ「snap-to-grid」
という機能があります。図 10-14 に示すように、グリッドのサイズを 10 か

ら 1(10 がデフォルト ) に変更すると、厳密な位置合わせができます。この

機能を使用すると、プログラムにきれいな外観を与えることができます。
「snap-to-grid」機能は、[UserObject]または [UserFunction]メ

ニューの [Properties]の下の Panelフォルダにあります。Panelフォ

ルダを選択するダイアログ・ボックスを表示するためのパネル・ビューを
あらかじめ作成しておく必要があるので、注意してください。
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-14. パネルのプロパティを設定する方法

キーボードのみのオペレータ・インタフェースを作成
する方法

VEE を使用すると、オペレータがキーボードだけを使用して制御できるイ

ンタフェースを作成することもできます。これらのインタフェースはマウ
スを必要としません。

たとえば、OKオブジェクトをソフトキーとして設定することができます。

通常、OKオブジェクトの設定ではいずれかのファンクション・キーに接続

します。これにより、図 10-15 に示すように、ファンクション・キーを押

して、プログラムを制御できます。

図 10-15. UserFunction を実行するソフトキー
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-16 は、Properties...ダイアログ・ボックスを使用して、OKオブ

ジェクトをファンクション・キー、Enter キー、または Esc キーに接続す

るように設定する方法を示します。

図 10-16. Confirm (OK) オブジェクトをソフトキーとして設定する方法

さらに、パネル・ビュー内のキーボードを使ってプログラムを制御できま
す。VEE は、点線を使ってパネル用のボタンを自動的に強調表示します。

オペレータが Enter を押すと、実際の該当ボタンが「押されます」。オペ

レータがテキスト入力領域を編集している場合、Enter キーを押すと編集

内容が受付けられ、Esc キーを押すと編集が中止されます。Tab キーを押

すと、異なる入力オブジェクトの選択肢間を前進し、アクティブ・オブ
ジェクトを表示します。Shift+Tab キーを押すと後退します。プログラムの

実行を制御する場合は、次の組合わせを使用します。

Ctrl+G 実行または継続 ( 再開 )

Ctrl+P 休止

Ctrl+T 停止
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
画面の色を選択する方法

画面の色を選択するには、[File]⇒ [Default Preferences]ダイア

ログ・ボックスを使用します。VEE 環境を任意に設定し、変更をセーブし

ます。図 10-17 と図 10-18 は、特定の画面要素を目的の色に変更する方法

を示します。

図 10-17. [Default Preferences] ダイアログ・ボックス
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オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法オペレータ・インタフェース・オブジェクトの使用方法
図 10-18. 画面要素の色の選択

プログラムを保護する方法 (RunTime バージョンを作

成する方法 ) 
不用意にプログラムが変更されるのを防ぐために、またはプログラムの機
密を保護するために、VEE プログラムの実行時バージョンを作成できま

す。元のプログラムと実行時バージョンは別のファイルにセーブします。

メモ VEE プログラムの実行時バージョンを作成した場合、実行時バージョンは

編集できません。詳細ビューを表示できません。したがって、実行時バー
ジョンの作成を開始する前に、元のプログラムのコピーを作成したうえで、
次の手順説明に注意深く従ってください。

VEE プログラムの RunTimeバージョンを作成するには、次の手順に従い

ます。

1. プログラムの実行時バージョン用のパネル・ビューを作成します。

2. 編集できるコピーを作成するためにプログラムをセーブします。
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3. [File]⇒ [Create RunTime Version...]を選択します。実行時

バージョンであることを示す *.vxe拡張子が自動的に使用されます。

実行時にポップアップ・パネルを表示する方法 
UserObjectまたは UserFunctionがプログラムで実行されたときにパ

ネルをポップアップさせることができます。ポップアップ・パネルを表示
するには、オブジェクト・メニューの [Properties]で [Show Panel 

on Execute]を選択します。オペレータが先に進む準備ができるまでパ

ネルを画面に表示したままにしておくには、Confirm (OK)オブジェクト

を追加します。追加しなければ、UserObjectまたは UserFunctionの

実行が終わると、パネルは表示されなくなります。

UserFunctionを複数回呼出す間、ポップアップ・パネルを表示したまま

にしておくには、ShowPanel()と HidePanel()関数を使用します。た

とえば、プログラムの実行中、ポップアップ・パネルをステータス・パネ
ルとして表示したままにしておく場合があります。例が必要な場合は、次
の節を参照してください。

ステータス・パネルを作成する方法

VEE では、複数回のテストや関数の結果を監視するためのステータス・パ

ネルを実装できます。この機能は、図 10-19 に示すように、ShowPanel()

と HidePanel()関数を使用して実装します。詳細は、407 ページの「ス

テータス・パネルを作成する方法」を参照してください。 
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図 10-19. ステータス・パネルを作成する方法
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以下の例題では、オペレータ・インタフェースの多くの機能を実装する方
法を習得します。具体的には、メニューを作成する方法、警告を作成する
方法、ステータス・パネルを作成する方法、プログラムにより視覚的なイ
ンパクトを加えるためのビットマップをインポートする方法を習得します。
これらにより、オペレータ・インタフェースをカスタマイズします。

例題 10-1: メニューを使用する方法

この例題では、3 つの選択肢 die1、die2、die3のあるメニューを持つオ

ペレータ・インタフェースを作成します。オペレータが選択肢を選択する
と、同じ名前の関数が呼出され、表面に 1 つ、2 つ、または 3 つの目を持

つサイコロを表示します。このプログラムでは、オペレータが実行するテ
ストをメニューで選択しなければならない状況をシミュレートします。ア
イコンの外観を変更するためのビットマップをインポートする方法も習得
します。このプログラムは Dice Program と呼びます。

3 つの UserFunctionを作成することから始めます。

1. [Device]⇒ [UserFunction]を選択します。

インポートされたビットマップを表示するのにアイコンを使用できますが、
この例では Pictureオブジェクトを使用します。

2. [Display]⇒ [Picture]を選択し、UserFunction内に配置します。

3. Pictureのオブジェクト・メニューをオープンし、[Properties]を

クリックしてから、[Open View]の [Show Title Bar]の選択を解

除します。[Picture]で [die1.gif]を選択し、[Scaled]をク

リックしてから、[OK]をクリックします。

メモ [Show Title Bar]をオフにするときにオブジェクト・メニューにアク

セスするには、オブジェクトの右上のボタンをクリックします。

メモ デフォルトでは bitmaps サブディレクトリが使用されますが、任意のディ

レクトリにあるビットマップも使用できます。
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次に、サイコロの表面に目が 1 つあるピクチャを作成する必要があります。

4. [Flow]⇒ [Confirm (OK)]を選択し、サイコロの下に配置します。

Pictureシーケンス出力ピンを OKシーケンス入力ピンに接続します。

Pictureと OKオブジェクトを選択します。Ctrl キーを押したままオブ

ジェクトをクリックして、網かけ表示にします。背景にマウス・ポイン
タを置いてマウスの右ボタンを押し、ポップアップの [Edit] メ

ニューをオープンします。[Add to Panel] を選択します。 

5. UserFunction Titleと Panel Titleを die1に変更します。必要

に応じて、オブジェクトの配置とサイズを変更します。

メモ パネル・ビュー内でオブジェクトを移動するには、オブジェクトを右ク
リックし、[Move]を選択します。

[Properties]ダイアログ・ボックスで [Show Panel on 

Execute]を選択します。位置合わせをより正確に行うため、

[Panel]フォルダをクリックし、グリッド・サイズを 2に変更します。

次に [OK]をクリックします。

6. die1のオブジェクト・メニューで [Clone]を選択し、

UserFunctionのクローンを 2 つ作成します。新しい UserFunction

は、自動的に die2および die3として表示されます。ピクチャ・オブ

ジェクトをそれぞれ die2.gifと die3.gifに変更します。名前と

ビットマップを除いて、新しい関数のすべての設定が必ず die1と一致

するように設定します。プログラムは図 10-20 のように表示されます。

関数ウィンドウをアイコン化します。
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図 10-20. Dice Program の初期段階

3 つの関数から呼出す関数を選択するメニューを作成します。

7. [Data] ⇒ [Selection Control] ⇒ [Radio Buttons] を選択し

ます。

Radio Buttonsは、ユーザ定義のリストにある列挙型の値 (Enum
データ型は、序数を自分に関連付けているテキスト文字列 ) を上の出力

ピンに出力するオブジェクトです。たとえば、リストを Monday、
Tuesday、Wednesday、Thursday、Friday と定義した場合、オペレータは

メニューで曜日を選択でき、選択すると、Radio Buttonsは曜日を出

力します。

リスト内の最初の項目には、順序を表す位置 0を割当てます。リスト内

の n 番目の項目には、順序を表す位置 n-1が割当てられます。たとえ

ば、上述のリスト内の Monday の順序を表す位置は 0、Friday の順序を

表す位置は 4 です。順序を表す位置は、下の出力ピンに表示されます。

詳細は、オブジェクト・メニュー内のヘルプのエントリを参照してくだ
さい。
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8. Radio Buttonsのオブジェクト・メニューをオープンし、[Edit 

Enum Values...]を選択します。

関数の名前を「die1」、「die2」、「die3」と入力します。最後のエン

トリを除き、次のエントリに移るときは Tab キーを押します。[OK]を

クリックします。

メモ データ選択を制御するためのメニュー・フォーマットは 6 種類あります。

Radio Buttonsは、エントリをボタンとして表示します。オペレータの

選択したデータは、Enumデータ型としてテキスト・フォーマットで出力

されます。Cyclic Buttonは、オペレータがボタンを 1 度クリックする

たびに 1 つずつ列挙型値を循環させます。Listは、リスト内のすべての

列挙型値について選択されている項目を強調表示して表示します。そのほ
かの選択肢として Drop-down list、Pop-up list、Slider listが

あります。

9. Radio Buttonsのオブジェクト・メニューをオープンし、

[Properties]をクリックしてから、[Auto Execute]を選択しま

す。タイトルをプロンプト形式の Make a Selectionに変更します。

Radio Buttonsオブジェクトで選択される値が Call Functionオブ

ジェクトによって呼出される関数の名前となるように、Callオブジェク

トをセットアップします。

10. [Device]⇒ [Call]をクリックします。[Add Terminal]⇒

[Control Input]を選択してから、[Function Name]を選択し、

[OK]をクリックします。Function Nameコントロール・ピンは

Enum値または Text値を入力として受入れます。Radio Buttonsの

データ出力ピンを Call Functionオブジェクトの Function Name

入力端子に接続します。Radio Buttonsのシーケンス出力ピンを

Call Functionのシーケンス入力ピンに接続します。Make a 

Selection:内の [die2]をクリックし、図 10-21 に示すように、

Call Function Nameが die2に変わることに注目します。
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図 10-21. Dice Program( 詳細ビュー )

メモ Callの入力端子は、Text Scalarを要求するため、VEE は Enum 

Scalarを Text Scalarに変換します。

波線はコントロール・ピンを示すので、注意してください。Auto 

Executeをオンにした場合、Radio Buttonsは、変更が加えられた

ときはいつでも実行され、選択されたデータを Callに送信します。

Call Functionのコントロール・ピンは、データを受信するとすぐ関

数名を置換えます。Callオブジェクトは、シーケンス入力ピンが起動

されるまで、指定された関数を呼出しません。

メモ プログラムが Auto Executeとシーケンス・ピンを使用している場合、

オペレータは [Run] ボタンをクリックしてプログラムを開始する必要はあ

りません。

プロンプト、メニュー、および選択対象を表示するポップアップ・パネル
だけを表示するオペレータ・インタフェースを追加します。

11. Ctrl を押したままターゲット・オブジェクトをクリックして、Radio 

Buttonsオブジェクトを選択します。[Edit]⇒ [Add To Panel]を

次に選択します。

12. 必要であれば、オブジェクト・メニューをオープンし、
[Properties]を選択し、色とフォントを調整します。

13. プログラムを選択して実行します。プログラムはメニューですでに選択
されたデータを使用するため、[Run] ボタンは使用しないでください。

プログラムを実行すると、図 10-22 のように表示されます。
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図 10-22. Dice Program( パネル・ビュー )

次の例題に移る前に留意点がいくつかあります。

プログラムのためのメニューを作成する場合は、前の例題で使用した手

法を使用できます。

呼出し対象のプログラムを示したコントロール・ピン (Command) のある

Execute Programオブジェクトを使用すると、コンパイル済み言語

のプログラムを選択する場合に Radio Buttonsも使用できます。コ

ンパイル済み関数のライブラリをすでにインポートしている場合は、
Call オブジェクトを使ってライブラリの関数を実行することもでき

ます。

単一のUserFunction内でPictureオブジェクトのFile Nameデータ

入力ピンを使用し、適切なビットマップ・ファイルをオブジェクトに送
信すると、プログラムを最適化できます。これは、異なるビットマップ
を多数使用しようとする場合より効率的な方法です。

より複雑なプログラムでは、AutoExecuteの代わりに Run を使用する

のが通例です。AutoExecuteの代わりに Wait for Inputを使用す

ると、データ定数または選択制御オブジェクトで、プログラムを休止さ
せることができます。詳細は、ヘルプを参照してください。
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例題 10-2: パネルの背景に使用するビットマップをイ
ンポートする方法

ビットマップはプログラムに必須のものではありませんが、テストに明快
さとインパクトを加えることができます。たとえば、テスト対象をよりよ
く図解するための図をインポートする場合があります。ここでは、標準
VEE オブジェクトが表示されているパネルの背景に使用するビットマップ

をインポートします。

ビットマップは、アイコンや Pictureオブジェクト用、または

UserObjectや UserFunction内のパネル・ビューの背景用としてイン

ポートできます。Labelオブジェクトと Confirm (OK)オブジェクトを

保持する Bitmapという名前のポップアップ UserFunctionを作成します。

1. [Device]⇒ [UserFunction]を選択します。

2. [Flow]⇒ [Confirm (OK)]⇒ [Display]⇒ [Label]を選択し、

UserFunctionウィンドウ内に配置します。

3. UserFunctionの名前を Bitmapに変更します。

4. OKと Labelオブジェクトを選択して、網かけ表示で強調表示します。

ポインタを UserFunctionの作業領域に置き、マウスの右ボタンをク

リックして、ポップアップの [Edit]メニューをオープンします。

[Add to Panel]を選択します。

5. UserFunction のメニューをオープンし、[Properties]を選択してか

ら、[Show Panel on Execute]を選択します。[Properties]

ボックスを表示するにはタイトル・バーをダブルクリックするので、注
意してください。[Pop-up Panel]で [Show Title Bar]の選択を

解除します。

Panelフォルダをオープンし、[Grid Size]を [2]に変更し、

[Background Picture]で [default.gif]と [Scaled]を選択し

てから、[OK]をクリックします。

6. Labelオブジェクトのための [Properties]ボックスをオープンし、

次のように設定します。

General/Title: [Bitmap Function]に変更します。
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7. タイトル Bitmap Functionと [OK]ボタンの配置を決めます。

Bitmap UserFunction をアイコン化します。

8. メイン・ウィンドウに行きます。[Device]⇒ [Call]をクリックして

から、オブジェクト・メニューで [Select Function]をクリックし、

[Bitmap]を選択します。プログラムを実行します。ポップアップ・

ボックスは図 10-23 のように表示されます。

 

図 10-23. Bitmap Function

Label Justification [Center Justify]に変更します。

Colors/Object/
Background

[Light Gray]を選択し、[OK]をクリッ
クします。

Fonts/Object/Text: 太字のより大きいフォントを選択し、[OK]
をクリックします。[Automatically 
Resize Object on Font Change]に
チェック・マークを付けます。

Appearance/Border [Raised]をクリックします。[OK]をク
リックして変更を行い、[Properties]を
クローズします。
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例題 10-3: インパクトの強い警告を作成する方法

この例題には、ネストされている数個の UserFunctionがあります。最

初の UserFunctionは、alarm 自体で、赤い四角とビープを表示します。

2 番目の UserFunctionは、オペレータが alarm をオフにするまで、光が

点滅する効果と短い間隔の断続音を繰返し生成する alarm を呼出します。

alarm 関数のプログラミングから始めます。

1. [Device]⇒ [UserFunction]を選択します。名前を alarmに変更

します。

2. [Display]⇒ [Beep]を選択し、UserFunctionの左上に配置しま

す。高いビープ音が 1 秒間鳴り続くように設定を調整します。

[Duration (sec)]フィールドを [1]に変更します。[Volume 

(0-100)]フィールドを [100]に変更します。

メモ 次の手順では、ビープ音をサポートするハードウェアを使用しているとい
う仮定に立っています。一部の Windows 95、Windows 98、Windows 2000、
and Windows NT 4.0 システムでは、すでに [Default System Beep]の

[Default System configuration]が変更されています。

メモ Beepオブジェクトはどこにも接続する必要はありません。関数が実行さ

れると、このオブジェクトがアクティブ化します。

3. [Display]⇒ [Indicator]⇒ [Color Alarm]をクリックし、

UserFunction内に配置します。Color Alarmのオブジェクト・メ

ニューをオープンし、[Properties]をクリックし、次のように設定

します。[Open View]で [Show Title Bar]の選択を解除し、

[Layout]で [Rectangular]をクリックします。[Limits/High 

Test]で、[High Text]の横にテキストがあれば削除します。[OK]

をクリックします。 

4. [Data]⇒ [Constant]⇒ [Real64]をクリックし、[1]に変更し、

Color Alarmの入力ピンに接続します。これにより、Alarmは、常

に、高い音域とデフォルト色である赤に設定されます。

Beep オブジェクトと同期をとるために表示を 1 秒間画面に表示し続け

るには、1秒に設定した Delayオブジェクトを使用します。
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5. [Flow]⇒ [Delay]を選択し、[1]に設定し、シーケンス入力ピンを

Color Alarmのシーケンス出力ピンに接続します。これで、alarm が 1
秒間鳴り続けます。

6. [Display]⇒ [Note Pad]を選択し、TURN OFF INSTRUMENTS!と

いうメッセージを追加します。必要に応じて Note Padのサイズを調

整します。

7. メイン・ウィンドウに行きます。[Device]⇒ [Call]をクリックして

から、Callのオブジェクト・メニューで [Select Function]を選

択し、[alarm]を選択します。プログラムを実行してテストします。

UserFunction alarmの詳細ビューは図 10-24 のように表示されます。

図 10-24. UserFunction alarm ( 詳細ビュー )

8. alarm ウィンドウに戻ります。[Color Alarm]表示と [Note Pad]を

選択します。ポップアップの [Edit]メニューをオープンし、[Add 

To Panel]を選択します。パネル・ビューでオブジェクトのサイズと
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配置を調整します。Note Padのオブジェクト・メニューをオープン

し、[Properties]をクリックします。次のように設定します。

[OK]をクリックし、[Properties]ダイアログ・ボックスを閉じます。

9. [Color Alarm]も [Raised Border]に変更します。

10. UserFunction のタイトル・バーをダブルクリックして、[Properties]

ダイアログ・ボックスを表示し、[Show Panel on Execute]を選択

します。[Show Title Bar]の選択を解除します。[Panel Title]

を [alarm]に変更します。alarmをアイコン化します。

11. メイン・ウィンドウに移動し、Callオブジェクトを削除します。VEE
はまだ関数 alarm をメモリに保持しています。この関数をもう一度編集

する必要がある場合は、[Edit]⇒ [Edit UserFunction]を選択す

るか、アイコンをダブルクリックします。

alarm 関数を繰返し呼出す関数を作成します。

12. [Device]⇒ [UserFunction]を選択し、UserFunctionの名前を

warningに変更します。

13. [Flow]⇒ [Repeat]⇒ [Until Break]を選択します。

14. [Device]⇒ [Call]を選択し、Function Nameを alarmに変更し、

シーケンス入力ピンを Until Breakのデータ出力ピンに接続します。

alarm をオフにする必要があるかどうかをオペレータに尋ねるための

Check Boxオブジェクトを追加します。

Open View/
Show Title Bar

選択を解除します。

Editing/Enabled 選択を解除します。

Fonts/Text size テキスト・サイズを拡大し、[Font Style: 
Bold]を選択します。

Fonts [Automatically Resize Object on 
Font Change]を選択します。

Appearance/Border [Raised border]に変更します。
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15. [Data]⇒ [Toggle Control]⇒ [Check Box]を選択します。

[Check Box Properties]ボックスをオープンし、名前を Turn 

off alarm?に変更し、[Layout]で [Scaled]を選択し、

[Initialize at PreRun]を選択して、その値が [0]であることを

確認し、名前のフォント・サイズを大きくしてから、[OK]をクリック

します。Callのシーケンス出力ピンを Check Boxのシーケンス入力

ピンに接続します。

これにより、Check Boxを使用する入力オブジェクトが作成されます。

オペレータがこのボックスをクリックした場合、Xが表示され、1が出

力されます。そうでない場合は 0が出力されます。この出力を

If/Then/Elseオブジェクトでテストすると、次に何を行うかを VEE
に指示できます。

16. [Flow]⇒ [If/Then/Else]を選択し、Toggleの右に配置します。

Toggleのデータ出力を If/Then/Elseオブジェクトのデータ入力 A

に接続します。If/Then/Elseオブジェクトの式を編集して、a == 1

にします。「に等しい」を意味する記号は ==です。=ではありません。

端子 Aが 1を保持している場合は、Then出力が起動され、そうでない

場合は、Else出力が起動されます。

Toggleの出力を If/Then/Elseの入力に接続します。

17. [Flow]⇒ [Repeat]⇒ [Break]を選択し、図 10-25 に示すように、

If/Then/Elseオブジェクトの Then出力に接続します。
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図 10-25. Warning UserFunction ( 詳細ビュー )

18. Check Boxオブジェクト (Turn off alarm?)の右側をクリックし

て選択します。ポップアップの [Edit]メニューをオープンし、[Add 

To Panel]を選択します。Check Boxを囲む配置になるようにパネ

ル・ビューのサイズを調整します。

19. warning UserFunction Propertiesボックスをオープンし、

[Show Panel on Execute]を選択し、[Show Title]の選択を解

除します。タイトルはオペレータにとって意味がないためです。[OK]

をクリックします。

20. メインに移動し、[Device]⇒ [Call]をクリックし、オブジェクト・

メニューをオープンし、[Select Function]をクリックしてから、

[warning]を選択します。Callオブジェクトを画面の上部中央に移

動します。メイン・ウィンドウをアイコン化します。

21. デフォルトでは、alarm と warning の両方のパネルが画面の中央に表示

されるので、alarm は、alarm を停止するためのチェックボックスの上で

点滅します。画面の位置は両方ともロックされないので、ポップアッ
プ・パネルを新しい場所にクリック・アンド・ドラッグすると、画面上
の位置を変更できます。ただし、alarm パネルが点滅していると、位置

の変更はしづらくなります。その代わりに、パネルの端をクリック・ア
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ンド・ドラッグします。必要であれば、ツールバーの stop ボタンを使

用して、プログラムを停止します。プログラムを実行します。

2 つのパネルを図 10-26 に示すように配置させた場合は、Turn off 

alarm?プロンプトの横のボックスをクリックするとプログラムを停止で

きます。

図 10-26. Warning プログラム

例題 10-4: ActiveX コントロールの使用方法

この例題では、VEE 内での ActiveX コントロールの使用方法を示します。

ほかのアプリケーションの ActiveX コントロールを VEE プログラムに取込

むことができます。この例題では、ProgressBarコントロールを取込み、

ループを使用して、進行状況表示バーを 0% から 100% 完了まで表示しま

す。この原則はほかの ActiveX コントロールにも当てはまります。

1. [Device]⇒ [ActiveX Control References...]をクリックし、

[Microsoft Windows Common Controls 6.0]を選択します。

[OK]をクリックします。
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2. [Device]⇒ [ActiveX Controls]⇒ [ProgressBar]をクリック

します。ProgressBarオブジェクトのサイズを少し大きくします。オ

ブジェクト・メニューをオープンし、オブジェクト名が ProgressBar

であることに注目します。ActiveX コントロール・オブジェクトを参照

するように宣言された変数は自動的に作成されます。ほかの変数やデー
タ入力と同じように、ProgressBarという名前を Formula式の中で

使用できます。

3. [Device]⇒ [Formula & Object Browser]をクリックし、

[ActiveX Objects]、[Library: MSComcltLib]、[Class: 

ProgressBar]、[Members: Value]を選択し、[Create Set 

Formula]をクリックします。オブジェクトをメイン・ウィンドウの上

部中央に配置します。

4. 0 から 100 までループさせ、完了済みの割合をパーセントで表示させる

ために、For Rangeオブジェクトを追加します。[Flow]⇒

[Repeat]⇒ [For Range]を選択し、ProgressBarの下に配置し、

次のように設定します。[From:]を [0]に、[Thru:]を [100]に、

[Step:]を [10]に設定します。For Rangeの出力を ProgressBar

の入力端子 Valueに接続します。

5. ProgressBarが更新されていくのを確認できるように、プログラムの

実行速度を遅くするには、[Flow]⇒ [Delay]を選択し、For Range

オブジェクトの右に配置します。.2に設定します。図 10-27 に示すよ

うに、ProgressBarのシーケンス出力ピンを Delayオブジェクトの

シーケンス入力ピンに接続し、プログラムを実行します。
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図 10-27. ActiveX コントロール ProgressBar の使用方法

メモ ActiveX コントロールのオブジェクト・メニューには [Properties]と

[Control Properties]があります。[Properties]メニューではオ

ブジェクトの VEE プロパティを設定します。[Control Properties]

は、ActiveX コントロールが提供するもので、ActiveX コントロールの種類

ごとに異なる可能性があります。

VEE とともに出荷されるコントロールの動作をよりよく理解するために、

すべてを調べてください。さらに、VEE でのユーザ・インタフェース機能

を向上させるために必要な市販のコントロールと表示を探してください。

図 10-28 は、MS Chart からコントロールを取込んだ VEE の例を示します。

[Device]⇒ [ActiveX Controls References]ダイアログ・ボック

スでコントロール・ライブラリを選択したら、[Function & Object 

Browser]または [Declare Variable Object]を使用して、コント

ロールのプロパティとメソッドを識別できます。
406 第第第第10章章章章 



オペレータ・インタフェースの使用方法

オペレータ・インタフェースを作成する場合の通常の作業オペレータ・インタフェースを作成する場合の通常の作業オペレータ・インタフェースを作成する場合の通常の作業オペレータ・インタフェースを作成する場合の通常の作業
図 10-28. MSChart を使用する ActiveX コントロールの例

例題 10-5: ステータス・パネルを作成する方法

この例題では、dice program の関数を使ってステータス・パネルを作成する

方法を習得します。dice program の例題は 391 ページの「メニューを使用す

る方法」にあります。通常、このパネルは、テストが多数あり、結果が返
されたときに結果を表示する場合に、Sequencerオブジェクトとともに

使用されます。デフォルトの設定を使用する場合は、0から 1までの real
値を返す関数 random()を使用します。

1. [Device]⇒ [Sequencer]をクリックします。トランザクション・

バーをダブルクリックし、デフォルト名 test1を使ってテストを設定

し、[FUNCTION:]フィールドを [random()]に置換えます。図 10-29
を参照してください。
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図 10-29. Test1 の設定

2. 2 番目のテストに test2という名前を付けて、同じように設定します。

3. Sequencer Propertiesボックスをオープンし、[Logging]タブを

選択し、[Logging Mod]で [Log Each Transaction To: 

logTest(thisTest)]を選択してから、[OK]をクリックします。

Sequencerは各トランザクションを実行したとき、thisTestと呼ば

れる各テストのレコードを作成します。レコードのフィールドは同じタ
ブで設定できます。これにより、logTestという名前 ( または別の名

前 ) の UserFunction を作成できるので、Sequencerは、実行される各

トランザクションの末尾にある Record thisTestを使用して、

LogTest() UserFunctionを呼出します。このようにして、ステー

タス・パネルを更新できます。

4. [Device]⇒ [Function & Object Browser]⇒ [Built-in 

Functions]⇒ [Panel]⇒ [showPanel]を選択し、Sequencerの

上に配置します。入力ピンをすべて削除してから、パラメータを
"logTest",420,180と編集し、最後の 2 つのパラメータは無視しま

す。showPanelの Result出力ピンを Sequencerのシーケンス入力

ピンに接続します。成功した場合、ShowPanelは 1を出力します。

LogTestは UserFunctionの名前です。ほかの 2 つのパラメータは、

左上の隅から開始する画面上の Xと Y座標です。これらのパラメータ

は、UserFunctionパネルを表示する場合に、どこに配置するかを

VEE に指示するものです。パネルの次元はこの例にはありません。
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5. 下に示すように、logTestという名前の UserFunctionを作成しま

す。入力ピンを追加します。ログを記録する Recordが入力となりま

す。Logging AlphaNumericをパネル上に配置し、入力ピンに接続

します。Logging AlphaNumericを選択し、[Edit]⇒ [Add to 

Panel]をクリックします。パネル・ビュー内で、必要に応じて、サイ

ズと配置を調整します。表示とパネルのタイトル・バーの選択を解除し
ます。

図 10-30. UserFunction LogTest( 詳細 )

図 10-31 はプログラム実行後のパネル・ビューを示します。これにより

データがどのように表示されるかがわかります。

図 10-31. UserFunction LogTest( パネル )

6. Function & Object Browserボックスで [hidePanel]を選択し、

[Flow]⇒ [Confirm(OK)]を選択します。hidePanel()パラメータ

を [logTest]に変更します。入力ピンを削除します。図 10-32 のよう

にオブジェクトを接続します。
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図 10-32. ステータス・パネル・プログラム ( 実行前 )

7. プログラムを実行します。図 10-33 のように表示されます。
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図 10-33. ステータス・パネル・プログラム ( 実行後 )

要約すると、showPanelオブジェクトは、UserFunctionパネルを表示

しますが、UserFunctionを呼出しません。Sequencerは logging 関数

を介して、UserFunctionを 2 回呼出し、それぞれの呼出しでパネルが更

新されます。次に、オペレータは作業が終わると、[OK]を押すことがで

き、これによりパネルは表示されなくなります。この例では、OKオブジェ

クトを使用して、hidePanelオブジェクトをトリガしていますが、OKオ

ブジェクトは、プログラムの実行時間を計測するためにプログラム内の別
の場所に配置することもできます。プログラムをステップ実行して、ス
テータス・パネルが表示され、Test1と Test2の結果を使って更新され、

次に表示されなくなるのを確認します。
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この章の復習この章の復習この章の復習この章の復習
この章の復習

この章では、次の操作について学びました。次の章に進む前に、必要なら
復習してください。

オペレータ・インタフェースに関する重要点を要約できる。

メニューを使用して、オペレータ・インタフェースにあるテストを選択

する。

オペレータ・インタフェースのためのビットマップをインポートする。

ステータス・パネルを作成する。

VEE が提供するオペレータ・インタフェース機能の一部を挙げることが

できる。

プログラムを保護する。

インパクトの強い警告を作成する。

ActiveX コントロールを作成し、Function & Object Browserでプ

ロパティとメソッドを検索する。
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Agilent VEE プログラムの最適化

この章の内容

プログラムを最適化するための基本的な手法

PC にあるダイナミック・リンク・ライブラリ (DLL) の使用法

コンパイル済みの関数を使った最適化

ほかの言語で記述されたコンパイル済みの関数を UNIX プラットフォー

ムで使用する方法

VEE コンパイラの使用法

VEE プロファイラの使用法

平均的な必要時間 :2 時間
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概要概要概要概要
概要

この章では、VEE プログラムの実行速度を向上させる方法を習得します。

テスト・プログラムのパフォーマンスには、3 つの基本要素があります。

つまり、測定の速度、データがコンピュータに転送されるレート、プログ
ラムがデータを処理する速度です。VEE プログラムを最適化することによ

り、処理速度を向上させることができます。

最初の節では、VEE プログラムを最適化するための基本原則を習得しま

す。PC のダイナミック・リンク・ライブラリ (DLL) についても学びます。

次の節では、コンパイル済みの関数を使って最適化する方法について説明
します。UNIX プラットフォームで、ほかの言語で記述されたコンパイル

済みの関数をリンクすることにより、プログラムの各部を最適化する方法
も習得します。次に、VEE コンパイラの概要について説明します。さら

に、VEE プロファイラについて説明します。

メモ この章で説明されている手法は、コンパイラを使用する場合にも使用しな
い場合にも適用されます。
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プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法
プログラムを最適化するための基本的な
手法

VEE プログラムを最適化する場合は、この節の情報を参照してください。

この節に説明されている手法を使用すると、VEE に最適なプログラミング

習慣を身に付けることができます。

できるだけ配列に対して演算を実行する

配列に対して演算を行うと、プログラムのパフォーマンスが大幅に向上し
ます。たとえば、取得した測定値の平方根を求めるテストがあるとします。
通常のプログラム方法では、ループの内で 1 つずつ測定値を受取り、平方

根を計算します。VEE では、そのようにしないで、すべての測定値を配列

に格納し、1 ステップでその平方根を計算できます。

図 11-1 のプログラムは、1024 回の反復を行います。各反復で 1 つの平方根

が計算されます。

図 11-1. 測定値ごとに平方根を計算する

図 11-2 のプログラムは、1024 個の要素がある配列を作成し、配列の平方根

を計算します。これで、それらの平方根を要素とする配列が生成されます。
2 つのプログラムの結果は同じですが、図 11-2 のプログラムは、図 11-1 の

プログラムより 6 倍速く実行されます。この例では、HP Pavilion PC 
(300MHz) を使用しています。
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プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法プログラムを最適化するための基本的な手法
図 11-2. 配列演算を使って平方根を計算する

2 つのプログラムの実行速度の違いは、オブジェクトの実行に必要な時間

によるものです。オブジェクトが実行されるときのオーバーヘッドの大き
さは決まっています。したがって、スカラ値のかわりに配列を使用して、
オブジェクトの実行回数を減らすと、プログラムの実行速度が上がります。

どちらのプログラムでも、時間を計測するには、Doオブジェクトを使って

最初にタイマを起動するのがよい方法です。ramp関数は、0 から始まり

1023 で終わる 1024 個の要素を持つ配列を生成します。

メモ 高速に実行するには、VEE の最新の実行モードを使用しているかどうかを

必ず確認してください。それには、[File]⇒ [Default 

Preferences]をクリックするか、ツールバーにあるそのボタンを使用し

ます。[Execution Mode]の [VEE6]を選択し、[Save]をクリックし

ます。VEE ウィンドウの下部にあるステータス・バーに、"VEE6" と表示

されます。

できるだけオブジェクトをアイコン化する

VEE が画面上で管理する情報が増えるほど、プログラムの実行に要する時

間も増えます。プログラムを最適化するには、表示内容が更新されるオブ
ジェクト (Counterなど ) にはオープン・ビューを使用せず、アイコン・

ビューを使用します。図 11-3 の例では、For Countと Counterの各オブ

ジェクトにアイコン・ビューを使用すると、約 46 倍速く動作します。
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図 11-3. アイコンを使ったプログラムの最適化

プログラム内のオブジェクトの数を減らす

プログラミングの経験が増すにつれて、VEE プログラム内で使用するオブ

ジェクトの数は少なくなります。オブジェクトの数を減らして、プログラ
ムを最適化するには、さらに 2 つの方法があります。

1. 別々の数学オブジェクトを使用するかわりに、Formulaオブジェクト

で単一の計算式を使用します。たとえば、加算、乗算、除算ごとに別々
のオブジェクトを使用するのではなく、Formulaオブジェクトに式

「((a + b) * c)/d」を入力します。また、定数オブジェクトを入力

に接続するかわりに、式の中で定数を使用します。定数は、Set 

Variableを使って設定します。

2. 関数のパラメータ・リスト内に別の関数呼出しをネストします。たとえ
ば、図 11-4 の関数 randomize は、関数 ramp によって生成された配列を

使用しています。図 11-5 では、ramp関数呼出しが randomize呼出し

の中にネストされているため、プログラムの実行が少し速くなります。
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図 11-4. 最適化されていない関数呼出し

図 11-5. 最適化されている関数呼出し
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Agilent VEE プログラムを最適化するその他の方法

ほかに次のような最適化方法があり、適宜プログラム内で使用できます。

VEE 4 以上の実行モードでプログラムを実行することにより、VEE コン

パイラを使用していることを確認します。詳細は、435 ページの

「Agilent VEE の実行モード」を参照してください。

詳細ビューでなく、パネル・ビューからプログラムを実行します。そう

すると、VEE が画面上で管理するオブジェクトの数が減ります。

UserObjectや UserFunctionの間では、値 ( 特に大きな配列やレコー

ド ) を受渡すかわりに、グローバル変数を使用します。すべてのグロー

バル変数を宣言します。これにより、ローカル変数も使用できます。
[Data]⇒ [Variable]⇒ [Declare Variable]を参照してください。 

グラフィカル表示用のデータは、個々のスカラ点をプロットするのでは

なく、データを配列の収集して、配列全体を一度にプロットします。プ
ロット点の X値が一定の間隔を持つ場合は、X vs. Yプロットではなく、

XY Trace表示を使用します。

複数の If/Then/Elseオブジェクトを使用するかわりに、複数の条件

を持つ単一の If/Then/Elseオブジェクトを使用します。

グラフィカル表示の設定は、できるだけ単純にします。更新速度を最大

にする設定では、[Grid Type]を [None]にし、[Properties]ダ

イアログ・ボックスで何もチェックしません。必要な場合に
AutoScaleコントロール・ピンだけを使用し、必要でない場合は、

Scalesフォルダの [Automatic AutoScaling]をオフにします。

ファイルからデータを読取る場合は、一度に 1つの要素に対して READト

ランザクションを実行し、EOFピンを使用するのではなく、ARRAY 1D 

TO END: (*) トランザクションを使用します。

複数の UserFunctionの実行フローを制御するには、別々の Callオブ

ジェクトではなく、Sequencerを使用します。

Sequencerを使用する場合は、Logレコードが必要なトランザクショ

ンについてのみログを有効にします。
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Strip Chartsと Logging AlphaNumeric表示を使用する場合は、

[Properties]の [Buffer Size]をアプリケーションにとっての最

小値に設定します。

If/Then/ElseオブジェクトをGateやJunctionと組合わせるかわり

に、3 項演算子 (condition ? expression1 : expression2) を使用します。

ビットマップを使用する場合は、[Scaled]ではなく、[Actual]また

は [Centered]に設定します。[Scaled]の方が少し時間がかかります。

Fill Barや Thermometerなどのインジケータを使用する場合は、

[Show Digital Display]をオフにします。

Color Alarmを使用している場合、色をすばやく切替えるには、

[Show 3D Border]をオフにします。

以上のような手法のほかに、ほかの言語で記述されたコンパイル済みの関
数を自分の VEE プログラムにリンクすると、実行速度が向上します。PC
でコンパイル済み関数 (DLL) を使用する方法については、次の節で説明し

ます。UNIX プラットフォームでコンパイル済み関数を使用する方法につ

いては、432 ページの「C を使ったコンパイル済み関数 (UNIX)」で説明し

ています。 
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コンパイル済み関数の概要

VEE プログラム内で、DLL ( ダイナミック・リンク・ライブラリ ) などの

コンパイル済み関数を使用できます。それには、コンパイル済み関数を入
手するか、次の手順にしたがって作成する必要があります。

1. C、C++、Fortran、または Pascal で関数を作成し、コンパイルする。

2. 関数の定義ファイルを作成する。

3. コンパイル済み関数を保持する共有ライブラリを作成する。

コンパイル済み関数を使用する利点

VEE プログラムでコンパイル済み関数を使用することには、次の利点があ

ります。

実行速度が上がる。

現在のテスト・プログラムをほかの言語で利用する。

ほかの言語でデータ・フィルタを開発し、それを VEE プログラムに統合

する。

著作権のあるルーチンを保護する。

メモ コンパイル済み関数を追加すると、開発プロセスが複雑になります。した
がって、VEE UserFunction、Execute Program ( オペレーティング・

システムへのエスケープ )、または ActiveXオートメーション ( 別のプロ

グラムの呼出し ) を使用しても、必要な機能やパフォーマンスを得ること

ができない場合にのみ、コンパイル済み関数を使用してください。

コンパイル済み関数の使用における設計上の留意点

VEE プログラムでコンパイル済み関数の使用する予定の場合は、次の情報

を考慮に入れてください。
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演算ルーチン、測定 I/O など、オペレーティング・システムで使用でき

る任意の機能を使用できます。ただし、リンク先のプログラム内から
VEE の内部機能にアクセスすることはできません。

VEE は、外部ルーチン内のエラーを捕捉できないため、コンパイル済み

関数内にエラー検出機能を用意する必要があります。

外部ルーチン内で割当てたメモリは、すべて解放する必要があります。

外部ルーチンにデータを渡す場合は、Callオブジェクトの入力端子を

そのルーチンに必要なデータの型と種類に設定する必要があります。

システム I/O のリソースはロックされる可能性があるため、外部ルーチ

ンは、このような状態に対応できる必要があります。

外部ルーチンが配列を受取る場合は、検査するデータ型の有効なポイン

タを持つ必要があります。また、配列のサイズをチェックする必要があ
ります。ルーチンで配列のサイズを変更した場合は、新しいサイズを
VEE プログラムに戻す必要があります。

コンパイル済み関数では、最後のステートメントとして、exit()では

なく、return()ステートメントを使用する必要があります。コンパイ

ル済み関数は VEE にリンクされるため、コンパイル済み関数が終了す

ると、VEE も終了します。

配列の範囲を超えて書込んだ場合の結果は、使用している言語によって

異なります。Pascal では、範囲検査が行われるため、実行時エラーとな

り、VEE は停止します。C などの言語では、範囲検査が行われないた

め、結果は予測できません。断続的にデータが損傷したり、VEE がク

ラッシュする可能性があります。

コンパイル済み関数を使用する際のガイドライン

VEE プログラムでコンパイル済み関数を使用する場合は、次のガイドライ

ンに従ってください。

UserFunctionを呼出す場合とまったく同様に、コンパイル済み関数

を呼出したり、設定します。目的の関数を選択する場合は、Callのオ

ブジェクト・メニューで [Select Function]を使用するか、関数の

名前を入力します。どちらの場合も、VEE がその関数を認識すると、
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Call Functionオブジェクトの入力端子と出力端子が自動的に設定さ

れます。必要な情報は定義ファイルから提供されます。ライブラリがイ
ンポート済みであれば、VEE は定義ファイルを認識します。

オブジェクト・メニューの [Configure Pinout]を選択して、Callの

入力端子と出力端子を再設定します。どちらの方法の場合も、VEE は、

関数に必要な入力端子と、関数の戻り値用の Ret Value出力端子を使

用して、Callオブジェクトを設定します。さらに、参照によって渡さ

れる入力のそれぞれに対応する出力端子が設定されます。

Formulaオブジェクト内の式、または実行時に評価されるほかの式か

ら、コンパイル済み関数を名前で呼出します。たとえば、To Fileト

ランザクションの式の中にコンパイル済み関数の名前を入れると、その
関数を呼出すことができます。

メモ 式の中からは、コンパイル済み関数の戻り値 (Callオブジェクトの Ret 

Value) だけを取得できます。関数から返されるほかのパラメータを取得す

る場合は、Callオブジェクトを使用する必要があります。

コンパイル済み関数のライブラリを削除するには、[Device]メニュー

の Delete Libraryオブジェクトを使用します。Import Library、

Call、Delete Libraryの各オブジェクトを使用して、コンパイル済

み関数をインポートし、プログラムがコンパイル済み関数の呼出しを完
了したときにそれらを削除することにより、プログラムのロード時間を
短縮し、メモリの浪費を防ぐことができます。
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ダイナミック・リンク・ライブラリの使
用法

PC では、ダイナミック・リンク・ライブラリ (DLL) のコンパイル済み関数

を VEE プログラムの一部として使用できます。DLL は、独自に記述した

関数をコンパイルして作成したり、購入または Web からダウンロードする

ことができます。DLL の作成方法については、Microsoft に問合わせてくだ

さい。

メモ VEE は、"_cdecl" と "_stdcall" の両方の呼出し規則をサポートします。

カスタマ作成 DLL のほとんどは、_cdec1呼出し規則を使用しています。

Win32 API 呼出しのほとんどは、_stdcall呼出し規則を使用しています。

VEE は両方の命名規則をサポートしているため、独自の DLL だけでなく、

ほとんどの既製の DLL も使用できます。

DLL を Agilent VEE プログラムに統合する方法

この節では、VEE プログラムに DLL をインポートする方法について説明

します。上で説明したように DLL を作成または入手した後、次の手順に

従って DLL を使用します。

1. [Device]⇒ [Import Library]を選択します。

[Library Type]には、[UserFunction]、[Compiled 

Function]、[Remote Function]の 3 つの選択肢があります。

[Library Type]フィールドを [Compiled Function]に変更しま

す。デフォルトは UserFunctionです。図 11-6 に示すように、

[Compiled Function]を選択した場合、Import Libraryオブ

ジェクトには [Definition File]のフィールドがあります。
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図 11-6. コンパイル済み関数のライブラリのインポート

次のフィールドがあります。 

メモ 開発段階では、オブジェクト・メニューの [Load Lib]を選択して、ライ

ブラリを手動でロードすることもできます。

2. [Device]⇒ [Call]を選択します。

[Import Library]を使ってライブラリをインポートしたら、[Device]

⇒ [Call]を選択して Callオブジェクトを作成します。次に、Callの

オブジェクト・メニューで [Select Function]を選択し、表示される

リスト・ボックスで目的の関数を選択すると、コンパイル済み関数を呼出
すことができます。たとえば、図 11-7 に示した Callオブジェクトは、

arraySizeと arrayをパラメータに使用し、myLibraryにある

myFunctionという名前のコンパイル済み関数を呼出します。

[Library Name] VEE がライブラリの識別に使用する名前。通常、

この名前は、プログラムでライブラリを使用した
後、それを削除するために使用されます。

[File Name] 共有ライブラリを保持するファイル。

[Definition File] 関数のプロトタイプが記述されたインクルード・
ファイル。通常は、*.hファイルです。
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図 11-7. コンパイル済み関数の Call オブジェクト

VEE は、関数名および適切な数の入力ピンと出力ピンを使用して、自

動的に Callオブジェクトを設定します。2 番目以降の出力ピンは、そ

の関数に参照によって渡されるパラメータにマッピングされます。関数
名を入力した場合は、オブジェクト・メニューの [Configure 

Pinout]を選択して Callオブジェクトを設定することもできます。

メモ ライブラリがすでにロードされている場合は、式フィールドから DLL 関数

を呼出すこともできます。このように関数を使用する場合は、関数名の後
のパラメータを丸かっこで囲む必要があり、関数は戻り値だけを返します。
参照によって渡されるパラメータは、Callオブジェクトを使用する場合

にのみ取得できます。たとえば、Formulaオブジェクト内で次の式を使用

するとします。

2 * yourFunc(a,b)

aと bは Formulaオブジェクトの 2 つの入力ピンを参照し、yourFunc

の戻り値の 2 倍の値が出力ピンに出力されます。

3. ( 省略可 )[Device]⇒ [Delete Library]をクリックします。

プログラムの開発中は、オブジェクト・メニューの [Delete Lib]を

選択して、プログラムからライブラリを削除することもできます。プロ
グラムで使用した後にライブラリを削除すると、ロード時間を短縮し、
メモリの浪費を防ぐことができます。

DLL の使用例

この練習では、DLL をインポートし、その DLL 内の関数を呼出します。

使用する DLL は、Windows の VEE 製品に付属するものです。すべてのプ

ラットフォームで同じ VEE プログラムが動作するように設計されています。
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manual49.veeファイルを開きます。このファイルは次の場所にあります。

< インストール先ディレクトリ >\EXAMPLES\MANUAL\MANUAL49.

この例を詳細に検討してください。図 11-8 のように表示されます。

図 11-8. DLL を使ったプログラム (MANUAL49) 

Import 
Library

コンパイル済み関数 Call Functionを最初に呼出す前
に、Import Libraryオブジェクト ([Device]メニュー )
を使用して、DLL をロードする必要があります。

Call 
Function

MANUAL49は、myFuncという名前のコンパイル済み関数
を呼出します。MyFuncは、VEE の Int32と同じ C の
データ型 longを必要とします。この数は配列のサイズを
指定するものです。2 番目の入力パラメータは、実数の配
列へのポインタです。定義ファイルは MANUAL49.H、C
コードのソース・ファイルは MANUAL49.Cです。MyFunc
は、配列のすべての要素に 1を加算します。
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プログラムを実行し、2 番目のトレースが波形上のすべての点で 1 番目の

トレースより大きいことを確認します。

このプログラムで注意しておく点の 1 つは、プログラムをすべての VEE プ

ラットフォームで使用できるようにする方法です。HP-UX プラットフォー

ムでは、ファイル名拡張子 *.slで示される共有ライブラリが使用されま

す。Windows 95、Windows 98、Windows 2000、and Windows NT 4.0 では、

Microsoft 32 ビット・コンパイラが使用されます。これらの DLL は、すべ

て *.dll拡張子で示されます。

Shared Library Nameという名前の UserObjectは、使用されるオペ

レーティング・システムを識別し、図 11-9 に示すように、正しいライブラ

リ名を Import Libraryオブジェクトに伝えます。

Function 
Generator

Function Generatorは波形の作成に使用され、波形は
Call myFuncオブジェクトの array ピンに出力されます。

totSize totSizeオブジェクト ([Math & Functions]ダイアロ
グ・ボックス ) は、波形のサイズを決めるために使用され、
Call myFuncの arraySize入力ピンに出力されます。

XY Trace XY Traceオブジェクトは、元の波形と新しい波形の両方
を表示します。

Formula "Ret Value" というラベルが付いた Callオブジェクトの
出力ピンは、返された配列のサイズを保持するため、
Formulaオブジェクト内の式 B[0:A-1]は、この配列を
正しく表示オブジェクトに指定します。
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図 11-9. Shared Library Name UserObject

whichos()関数は、オペレーティング・システムを識別するために、名

前が変更された Formulaオブジェクト内で使用されています。展開され

た If/Then/Elseオブジェクトは、whichos()関数の出力を検査し、適

切なテキスト定数を出力します。次に、このファイル名拡張子は、名前が
変更された Formulaオブジェクトを使って MANUAL49ファイルに追加さ

れます。"shared library" というラベルが付いた Formulaオブジェク

トの入力端子も、"ext" に変更されています。

Import Libraryオブジェクトに File Nameのコントロール・ピンが追

加されています。このため、UserObjectと Import Libraryは点線で

結ばれています。

メモ データベースにデータを送信するなど、混合環境でデータを共有する場合
は、To/From Socketを調査します。また、サンプル・ゲーム、

Battleship と Euchre は、複数の VEE プロセス間で通信するために、ソケッ

トを広範に使用します。

Execute Program オブジェクトとコンパイル済み関数

の比較

コンパイル済み言語プログラムを VEE と統合するために、Execute 

Programオブジェクトとコンパイル済み関数のどちらを使用するかを決定

する場合は、次の情報を考慮してください。
430 第第第第11章章章章 



Agilent VEE プログラムの最適化

ダイナミック・リンク・ライブラリの使用法ダイナミック・リンク・ライブラリの使用法ダイナミック・リンク・ライブラリの使用法ダイナミック・リンク・ライブラリの使用法
Execute Program
オブジェクト

Execute Programオブジェクトには、次の特徴があります。

使いやすい

起動時間が長い 

パイプを介した通信 (HP-UX のみ )

アドレス空間の保護

同期実行と非同期実行の選択

非同期イベントのサービス

安全性が高い ( 呼出されたプログラムがクラッシュすると、エラー・

メッセージが表示される )

連続的なデータの取得に便利

コンパイル済み
関数

Import Libraryと Callオブジェクトを使ったコンパイル済み関数に

は、次の特徴があります。

起動時間が短い

VEE と共有されたスタックとメモリ空間上での通信

同期実行

信号と例外はブロックまたはキャッチされない (GPF メッセージなど )

テキスト言語のコンパイラが必要

使い方が複雑。使用上のリスクが大きい ( 範囲外の配列エラーやメモリ

の上書きがあると、VEE がクラッシュする )
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C を使ったコンパイル済み関数 (UNIX)
ほかの言語で記述されたコンパイル済み関数を使用する場合は、HP-UX プ

ラットフォーム上に共有ライブラリが必要です。UNIX ワークステーショ

ンでは、C、C++、Fortran、Pascal で記述されたプログラムを VEE プログ

ラムと動的にリンクできます。Pascal のコンパイル済み関数は、HP 9000, 
Series 700 ワークステーションでのみサポートされているので、注意してく

ださい。

図 11-10 に示すプログラムは、ライブラリをインポートし、C 関数を呼出

します。この C 関数は、実数の配列を受取り、配列内の各要素に 1 を加算

します。変更された配列は、VEE の Call Functionオブジェクトの

Array端子に返され、配列のサイズは Ret Value端子に返されます。こ

のサンプルは、次の VEE ディレクトリにあります。

< インストール先ディレクトリ >/examples/manual/manual49.vee

メモ ファイル拡張子は次のように使用されます。".vee" 拡張子はプログラム、

".c" 拡張子は C ソース・コードを保持するファイル、".h" または ".def"
拡張子は定義ファイル、".sl" 拡張子は共有ライブラリ・ファイルをそれ

ぞれ表します。
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図 11-10. コンパイル済み関数を呼出すプログラム

このプログラムでは、次の点に注意してください。

配列のサイズ C 関数内の 1 つの変数 ( および、対応する Callオブ

ジェクト内の 1 つのデータ入力端子 ) は、配列のサイ

ズを示すために使用されます。arraySize変数は、配

列の末尾を超えてデータが書込まれることを防ぐため
に使用されます。

Call Function
オブジェクト

配列は参照によって渡されるため、VEE は、入力ピン

と出力ピンの両方を Call Functionオブジェクトに

自動的に作成します。

arraySize変数は値によって渡されるため、VEE は、

入力端子だけを作成します。ただし、関数の戻り値は、
出力配列のサイズを VEE に返すために使用されます。

この手法は、入力配列より要素数の少ない配列を返す
必要がある場合に便利です。
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C のルーチン この C ルーチンは関数であり、プロシージャではあり

ません。Compiled Functionは戻り値を必要とする

ため、プロシージャと関数を区別する言語を使用する
場合は、必ず関数としてルーチンを作成してください。

実行順序 プログラムの中で、Import Libraryオブジェクトは

Callオブジェクトの前に実行されます。これらの 2 つ

のオブジェクトの実行順序が明確でない場合は、シー
ケンス・ピンを使用して、正しい順序を確保してくだ
さい。

変数の渡し方 参照によって関数に渡されるパラメータ変数 array に

は、入力端子と出力端子の両方がありますが、値に
よって渡される変数 arraySizeには。入力端子だけ

があります。

配列の要素数 Formulaオブジェクトは、Ret Value端子にある配

列サイズを使用して、配列の正しい要素数を表示に送
信します。

XY Trace XY Traceは、2 つの波形を自動的にスケーリングし

ます。
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Agilent VEE の実行モード

Agilent VEE の実行モードを使用すると、以前のバージョンの VEE を使っ

て作成されたプログラムを実行できます。実行モードを使用すると、古い
バージョンの VEE を使って作成されたプログラムを古いバージョンの

VEE で実行する場合とまったく同様に、新しいバージョンの VEE で実行

できます。これにより、VEE は下位互換となるため、既存のプログラムが

サポートされます。

メモ 実行モードは、以前のバージョンの VEE では、「互換モード」と呼ばれて

いました。

VEE には、次の 4 つの実行モードがあります。

VEE 6 ( 新しいデータ型の追加 )
VEE 5 (ActiveX の追加 )
VEE 4 ( コンパイル )
VEE 3.x

図 11-11 に示すように、実行中のプログラムの実行モードは、VEE のス

テータス・バーに表示されます。

VEE に開かれている既存のプログラムは、デフォルトでは、そのプログラ

ムの作成に使用されたバージョンの VEE の実行モードで実行されます。た

とえば、VEE 6.0 に開かれている VEE 5.0 プログラムは、デフォルトでは

VEE 5 実行モードで実行されます。
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図 11-11. VEE のステータス・バーに表示される実行モード

Agilent VEE コンパイラ

VEE コンパイラは、VEE 4 以上の実行モードで自動的に有効になります。

コンパイラは、高度なオブジェクト伝達を可能にし、プログラムの実行速
度を上げます。コンパイラと実行モード間の相違についての詳細は、『VEE 
Pro Advanced Techniques』を参照してください。

実行モードの変更

新しいプログラムは、すべて VEE 6 モードで作成する必要があります。既

存のプログラムがあり、そのプログラムに新しい機能を追加する場合は、
実行モードを変更します。たとえば、VEE 5.0 で記述されたプログラムに

VEE 6.0 の新機能を追加する場合は、実行モードを VEE 6 に変更する必要

があります。そうしないと、その VEE 5.0 プログラムは正しく実行されま

せん。

実行モード
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実行モードを変更するには、次の手順に従います。

1. VEE のメイン・メニューで、[File]⇒ [Default Preferences]を

クリックするか、図 11-12 に示すツールバーの [Default Preferences] ボ
タンを押します。

図 11-12. ツールバーの [Default Preferences] ボタン

2. 図 11-13 に示すように、[General]フォルダの [Execution Mode]

で [VEE 6.0] を選択します。このフォルダは最初のフォルダなので、す

でに表示されています。同じフォルダで、[Disable Debug 

Features]が選択されていないことを確認します。[OK]をクリック

します。 

図 11-13. [Default Preferences] ダイアログ・ボックスで実行モードを変更

[Default Preferences] ボタン

VEE 6 に設定さ

れた実行モード

オフに設定された
( チェックされて

いない )[Disable 
Debug Features]
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実行モードの変更の効果

次の例は、プログラムを更新した場合の速度の向上を実証するものです。
これらの例は、計測 I/O がない場合のプログラム速度に注目しています。

1. examples\Applicationsサブディレクトリの chaos.veeプログラ

ムを開きます。

このプログラムは、爆発的な人口増加をシミュレートします。次に示す
ように、Timerオブジェクトを使用して、このプログラムを変更しま

す。これらの例では、HP Pavilion PC (300MHz) を使って Windows 95 上

でプログラムが実行され、同時にほかに 2 つの大きなアプリケーション

を実行しています。

図 11-14 では、VEE 3 実行モードで、表示を開き、プログラムの実行時間

を測定します。

図 11-14. VEE 3 モードで、表示を開いた Chaos.vee

タイマ
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図 11-15 では、コンパイラをオンにしないまま、表示をアイコン化して速

度を上げています。これにより、実行時間が約 1/6 短縮されます。

図 11-15. VEE 3 モードで、表示を閉じた Chaos.vee

最後に、図 11-16 では、デバッグ機能を無効にして、コンパイラをオンに

しています。プログラムを完全にデバッグして、使用準備が完了したら、
最適なパフォーマンスを得るため、[File]⇒ [Default 

Preferences]の [Disable Debug Features]ボックスをチェックし

ます。

デバッグ機能により、[Show Execution Flow]や [Activate 

Breakpoints]などのツールが有効になります。[Disable Debug 

Features]ボックスをチェックすると、メモリ内でのサイズが小さくな

り、プログラムの速度が向上します。図のように、プログラムは約 12 倍速

く実行されます。これらの 3 つの図により、最適化の手法とコンパイラを

組合わせて、最大の処理速度が得られることがわかります。
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図 11-16. VEE 4 以上のモードで、デバッグを無効にした Chaos.vee

図 11-17 と図 11-18 では、VEE の速度向上のために、反復スカラ演算ルー

チンを含むプログラムでコンパイラを使用します。この例では、スカラ値
の平方根を計算しています。結果は保持しません。コンパイラを使用する
と、速度は、VEE 3 実行モードを使用する場合より約 107 倍速くなります。

図 11-17. VEE 3 モードでの反復演算ルーチン
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図 11-18. VEE 4 以上のモードでの反復演算ルーチン

VEE に実行モードがあるのは、古いバージョンの VEE では使用できたが、

現在のバージョンでは使用できないプログラミング・オプションが多少あ
るからです。これらは、現在エラー・メッセージを生成します。さらに、
ActiveX オートメーションとコントロールの機能の一部が拡張されたため、

VEE 4 または VEE 5 モードで実行されていたプログラムを VEE 6モードで

実行するには、小さな変更が必要になることがあります。実行モード間の
相違についての詳細は、『VEE Pro Advanced Techniques 』を参照してくださ

い。新しいプログラムは、すべて VEE 6 モードで作成する必要があります。
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Agilent VEE プロファイラ

プロファイラは、VEE のプロフェッショナル開発環境における機能の 1 つで

す。プロファイラには、プログラム内にある UserFunctionや UserObject

の実行速度が表示されるため、プログラムの最適化に役立ちます。

プロファイラを使用すると、プログラム内の速度の遅い場所を識別し、こ
の章で説明している手法を適用して、プログラムの速度を向上させること
ができます。図 11-19 に、examples\Applications\mfgtest.veeプロ

グラムを示します。

プロファイラをオンにするには、[View]⇒ [Profiler]を選択します。

次に、プログラムを実行します。画面の下半分にプロファイラが表示され
ます。プロファイラは、各 UserObjectと UserFunctionの実行に要し

た時間を比較できるように情報を一覧表示します。

図 11-19. プロファイラの例
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この章の復習

この章では、次のことをできるようになりました。必要に応じて、各項目
を復習してください。

VEEプログラムを最適化するための3つの基本的な手法について説明し、

それぞれの例を示す。

上の 3 つの手法のほか、少なくともあと 2 つの手法について説明する。

DLL の基本概念について説明する。

DLL をインポートし、関数を呼出し、その DLL を削除する。

ほかの言語で記述されたコンパイル済み関数をHP-UXプラットフォーム

で使用する方法について説明する。

VEE 6 実行モードを使用して、または VEE 5、VEE 4、VEE3 実行モード

を使用してプログラムを実行し、どちらかの実行モードを選択する場合
の理由について説明する。

VEE プロファイラを使用する。
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プラットフォーム固有の事項と Web モニタ
管理

この章の内容

PC と HP-UX プラットフォームの相違点

Rocky Mountain Basic プログラムとの通信方法

VEE ActiveX Automation Server を使用して、ほかのアプリケーションか

ら VEE 関数を呼出す方法

Web モニタ管理

平均的な必要時間 :2 時間
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概要概要概要概要
概要

この章では、オペレーティング・システム間の重要な相違点と、それらの
相違点を処理するオブジェクトが VEE でどのように設計されているかにつ

いて学びます。次に、Callable VEE ActiveX Automation Server を使用して、

VEE 関数をほかのアプリケーションやプログラムの中に取込むための重要

な手法ついて学びます。最後に、Web モニタ管理の主要な概念について学

びます。

VEE プログラムは、サポート対象のプラットフォーム間を移動しますが、

特定のオペレーティング・システムに固有のオブジェクトもあります。た
とえば、PC では、コンパイル済み関数としてダイナミック・リンク・ライ

ブラリ (DLL) が使用され、HP-UX では、共有ライブラリが使用されます。

プロセス間通信の場合、PC では ActiveX オートメーションが使用され、

HP-UX では名前付きパイプが使用されます。
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PC とととと HP-UX プラットフォーム間の相違点プラットフォーム間の相違点プラットフォーム間の相違点プラットフォーム間の相違点
PC と HP-UX プラットフォーム間の
相違点

PC における VEE の使用法と、HP-UX における VEE の使用法の間には、

いくつかの相違点があります。

プログラム

VEE のすべての機能をすべてのプラットフォーム上のプログラムで使用で

きます。ただし、オブジェクトがオペレーティング・システムに依存して
いる場合、そのオブジェクトはそのオペレーティング・システム上でしか
実行できません。プログラムを移植する場合は、[Function & Object 

Broswer]ボックスの System Informationオブジェクト (whichOS()
または whichPlatform()) を使用すると、これらの相違を考慮できます。

これらのオブジェクトは、オペレーティング・システム (OS) またはプラッ

トフォームを出力するため、プログラムは、「OS 依存」のオブジェクトを

使用するかどうかを検出できます。「OS 依存」のオブジェクトは、メ

ニュー内のオブジェクト名の末尾に "PC" または "UNIX" が付いています。

名前付きパイプと ActiveX の機能

To/From Named Pipe (UNIX)オブジェクトと、PC の ActiveX 

Automationは、それぞれのオペレーティング・システムにおいて、別の

プログラムまたはアプリケーションと通信するという同じ機能を実現します。

Rocky Mountain Basic
Initialize Rocky Mountain Basic (UNIX)と To/From Rocky 

Mountain Basic (UNIX)は、HP-UX 上の Rocky Mountain Basic だけと

機能するように設計されています。

Execute Program オブジェクト

Execute Programオブジェクトには、HP-UX 用と PC 用の 2 つのバー

ジョンがあります。どちらも、ほかのプログラムまたはアプリケーション
を起動するために使用されます。
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To/From Stdout、Stderr (UNIX)
これらのオブジェクトは、PC 上で動作しますが、ファイルを使って実装さ

れており、一般のプログラミングにはお勧めできません。これらのオブ
ジェクトは、VEE プログラムを HP-UX プラットフォームから PC に移植す

る場合にのみ使用してください。

フォントと画面の解像度

PC 上の VEE では、画面の解像度に合わせて見栄えのよいフォント・サイ

ズが選択されます。プログラムの外見を変更するには、[File]⇒

[Default Preferences]ダイアログ・ボックスを使用します。個々の

オブジェクトをカスタマイズするには、オブジェクト・メニューの
[Properties]のオプションを使用します。VEE は、必要に応じて、プ

ログラム内に保存されているフォントを移植先のマシンで利用できるフォ
ントに変換します。最良の結果を得るには、画面の解像度とフォントを移
植先のマシンと同じように設定したコンピュータでプログラムを構築する
必要があります。プログラムを移植する場合は、問題の発生を避けるため、
画面の解像度が同じであることを確認してください。詳細は、オンライ
ン・ヘルプのインデックスで、「fonts, using」を参照してください。

データ・ファイル

To Fileオブジェクトを使って生成される ASCII データ・ファイルは、

HP-UX と Windows のどちらのプラットフォームでも From Fileオブジェ

クトを使って読取り可能です。バイナリ・ファイルは、HP-UX と Windows
でバイト・オーダーが逆のため、プラットフォームにまたがっては機能し
ません。
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Rocky Mountain Basic プログラムを使っ
た通信

VEE には、HP-UX 上で VEE と Rocky Mountain Basic 間の通信を容易にす

るオブジェクトが用意されています。Series 700 ワークステーション

(HP-UX 10.20) では、VEE 6.0 を使用できます。Series 300 と Series 400 ワー

クステーション (HP-UX 9.0) では、HP VEE 3.1 を使用する必要があります。

Initialize Rocky Mountain Basic オブジェクトの使用法

図 12-1 に示すように、Initialize Rocky Mountain Basicオブジェ

クトにはフィールドが 1 つだけあり、ここで、実行する Rocky Mountain 
Basic (RMB) プログラムを指定します。

図 12-1. Initialize Rocky Mountain Basic オブジェクト

パス全体とプログラムのオプションを入力します。たとえば、プログラム
~installDir/examples/rmb/man34a.basが RMB で保存されている

とします。このオブジェクトは、RMB のプロセスを生成し、そのプログラ

ムを実行します。現在の作業ディレクトリからの相対パスを使ってプログ
ラムを指定することもできます。このオブジェクトは、RMB への、または

RMB からのデータ・パスを何も提供しません。プログラムを指定するに

は、To/From Rocky Mountain Basicオブジェクトを使用します。1
つの VEE プログラムで複数の Initialize Rocky Mountain Basicオ

ブジェクトを使用できます。
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メモ VEE プログラムから RMB プロセスを直接終了する方法はありません。そ

のかわり、VEE プログラムから一定のデータ値を受信した場合に RMB プ

ログラムで QUITステートメントを使用します。Execute Programオブ

ジェクトを使用すると、rmbkillなどのシェル・コマンドを使って RMB
プロセスを強制終了できます。VEE を終了したとき、まだ接続されている

RMB プロセスがあれば、すべて自動的に終了されます。

To/From Rocky Mountain Basic オブジェクトの使用法

図 12-2. To/From Rocky Mountain Basic オブジェクト

図 12-2 に、[I/O]⇒ [Rocky Mountain Basic (UNIX]にある

To/From Rocky Mountain Basic (UNIX)オブジェクトを示します。

このオブジェクトは、RMB プログラムとの間のデータ転送を可能にしま

す。このオブジェクトは、プロセス間通信のために名前付きパイプを作成
して使用します。処理を簡単にするため、VEE は、READトランザクショ

ンと WRITEトランザクションのために、パイプを 1 つずつ実装します。

図 12-2 に示す To/From Rocky Mountain Basic (UNIX)オブジェクト

には、2 つのトランザクションがあります。つまり、Int32整数の書込み

と、Int32整数の読取りです。デフォルトのパイプを使用することもでき

ますが、Write Pipeと Read Pipeの新しいパスとファイル名を入力し

て、独自のパイプを作成することもできます。トランザクションは、VEE
のその他のトランザクション・オブジェクトと同様に設定されます。

メモ Write Pipeと Read Pipeのフィールドは、コントロール・ピンとして

オブジェクトに追加できます。
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次に、Rocky Mountain Basic との通信についてさらに詳細に説明します。

読取りパイプと
書込みパイプの
デフォルト名

すべての To/From Rocky Mountain Basicオブ
ジェクトでは、読取りパイプと書込みパイプが同じデ
フォルト名を持ちます。したがって、READや WRITE
に正しいパイプを指定するようにしてください。異な
るプログラムに対するパイプは一意な名前を持つよう
にしてください。RMB プログラムでは、正しいパイ
プに対して OUTPUTと ENTERステートメントを指定
してください。

自動的に作成さ
れるパイプ

To/From Rocky Mountain Basicが動作する前に
パイプが存在していない場合は、次のパイプが自動的
に作成されます。

/tmp/to_rmb

/tmp/from_rmb

ただし、あらかじめパイプが存在している方が、プロ
グラムはすばやく実行されます。

追加のパイプの
作成

追加のパイプを作成するには、オペレーティング・シ
ステム・コマンド mknodを使用します。

パイプを開くお
よび閉じる

Rocky Mountain Basic のパイプ ( 単純な名前付きパイプ )
は、PreRun後、パイプに対する最初の READまたは
WRITEトランザクションが動作したときに開かれま
す。すべての名前付きパイプは、PostRun時に閉じ
られます。PreRunと PostRunについての詳細は、

『VEE Pro Advanced Techniques』を参照してください。
EXECUTE CLOSE READ PIPEと EXECUTE CLOSE 
WRITE PIPEトランザクションを使用すると、いつで
もパイプを閉じることができます。

パイプを持つト
ランザクション
の構築

名前付きパイプの動作により、既知の、または容易に
解析できるデータ・ブロックを送信するトランザク
ションの構築はたいへん簡単です。たとえば、文字列
を送信する場合は、送信するブロックの最大長を判定
し、それより短い文字列には空白を補います。これに
より、パイプから利用できる以上のデータを読取ろう
としたり、パイプ内に不要なデータを残してしまう問
題を回避できます。
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図 12-3 に、RMB プログラムとの通信をセットアップする方法を示します。

このプログラムは HP-UX プラットフォームだけにあり、examples/rmb

サブディレクトリの manual34.veeに収録されています。

図 12-3. Rocky Mountain Basic との通信

DATA READY
トランザクショ
ンの使用

データが使用可能になるまで READトランザクション
が停止してしまうことをできるだけ防ぐには、それぞ
れの To/FromRocky Mountain Basicオブジェク
ト内で READ IOSTATUS DATA READYトランザク
ションを使用します。このトランザクションは、読取
り対象のデータが少なくとも 1 バイトある場合は 1を
返し、まったくない場合は 0を返します。読取りパイ
プにある使用可能なすべてのデータを読取るには、
READ ... ARRAY ID TO END:(*)トランザクショ
ンを使用します。

ディスクのない
環境内での実行

ディスクのない環境で実行する場合は、必ず一意な名
前付きパイプとの間で WRITEと READを使用してく
ださい。そうでない場合は、ディスクのない同じクラ
スタ上のいくつかのワークステーションが同じ名前付
きパイプにアクセスしようとして、競合の問題が発生
する可能性があります。
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Callable VEE ActiveX Automation Server
Windows 95、Windows 98、Windows 2000、and Windows NT 4.0 上の VEE で

は、MS Visual Basic や C などの標準言語で書かれた市販の、または著作権

を持つほかのテスト・システムの中に VEE オブジェクトを取込むことがで

きます。Callable VEE ActiveX Automation Server は、VEE UserFunction
をカプセル化して、MS Excel や MS Visual Basic などのオートメーション・

アプリケーションに取込きます。この Callable VEE ActiveX Automation 
Server は、言語に依存しないオートメーション・インタフェースを実装し、

オートメーション・サーバを呼出すことのできる任意のアプリケーション
または言語でこのインタフェースを使用できます。

メモ VEE では、ActiveX オートメーションとコントロールを使用して、VEE か

らほかのアプリケーションを制御できます。MS Visual Basic などのほかの

アプリケーションは、Callable VEE ActiveX Automation Server を使用して、

VEE を制御できます。

Callable VEE ActiveX Automation Server は、プロパティとメソッドを介して

クライアントと通信します。Callable VEE ActiveX Automation Server の呼出

し元となる Visual Basic や C などの環境により、呼出し方法が決まります。

Callable VEE ActiveX Automation Server には、その呼出し元の環境内で幅広

く使用できるオンライン・ヘルプが用意されています。詳細は、VEE のオ

ンライン・ヘルプ、『VEE Pro Advanced Techniques』、および VEE に付属す

るサンプルを参照してください。

メモ Callable VEE ActiveX Automation Server は、VEE バージョン 5.0 に付属する

Callable VEE ActiveX Control に代わるものです。
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Web 対応技術

VEE を使用すると、プログラムで収集したデータの配布、テスト・システ

ムの監視、テスト結果の確認をリモートで行うことができます。この節で
は、テストと測定用アプリケーションの Web 対応技術と、VEE によるサ

ポートについて説明します。

Web 技術の概要

この例では、組織内に Web サイト ( イントラネット Web サイト ) を構築

し、これをサーバとして参照データを提供する方法について説明します。
このサイトにアクセスするユーザは、ブラウザを持つとします。また、
Microsoft 環境 (Windows 95, Windows 98, Windows NT 4.0, or Windows 2000)、
MS Office、MS Internet Explorer を使用します。図 12-4 に示すように、情報

は、測定器からサーバへ、サーバからクライアントのブラウザへと順に送
信されます。

メモ この例では、PC 画面ダンプを使用します。VEE は、HP-UX 上でも Web に

対応します。

図 12-4. Web 測定アプリケーションのモデル

図 12-4 には、次の情報の流れが示されています。

テスト対象の装置 (DUT)、センサ、または測定器は、ネットワーク I/O レ

イヤを介して、情報をサーバ・アプリケーションに送信します。ネット
ワーク I/O レイヤには、インタフェースとバックプレーン (GPIB、

I/O HTTP

DUT/ センサ / 測定器 サーバ・アプリケーション クライアントのブラウザ
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RS232、VIX、MXI、PC プラグイン )、および I/O プログラム・レイヤ (
ドライバ、VISA、SICL など ) があります。

サーバ・アプリケーションは、測定データを生成する VEE プログラム

です。

HTTP (HyperText Transfer Protocol) は、情報をクライアントのブラウザに

送信します。

HTTP は、Web が使用する TCP/IP (Transmission Control Protocol/Internet 
Protocol) 通信プロトコルの 1 つです。TCP/IP プロトコルの下位レベルに

は、トランスポート・レイヤ、ネットワーク・レイヤ、物理レイヤの各通
信レイヤがあります。どの TCP/IP アプリケーションもクライアント / サー

バ・アプリケーションになります。たとえば、Internet Explorer や Netscape 
Navigator などのクライアント・ブラウザは、サーバ・アプリケーションに

よって生成された情報を要求できます。

次の URL (Universal Resource Locator) を Internet Explorer に入力すると、

Agilent Technologies サーバから情報を要求することになります。

http://www.agilent.com/find/vee

httpは、情報を転送するためにアクセスされるリソースの種類を表し

ます。

www.agilent.com/find/veeは、リソースの URL です。HTTP によっ

て使用されるハイパーテキスト・フォーマットは、HTML (HyperText 
Markup Language) と呼ばれるスクリプト記述フォーマットの 1 つです。

HTML は、文書どうしをリンクする方法の 1 つで、過去には Web ペー

ジの作成に使用できる唯一の言語でした。HTML は、当初はテキスト専

用でしたが、現在では音声、ビデオ、イメージ、対話型画面、ActiveX
コントロール、Java アプレットが導入されています。

ブラウザからサーバに情報を要求しても、ブラウザがそのように設計され
ていないかぎり、その後で情報が自動的に更新されることはありません。
また、ブラウザを使った対話も、それがブラウザ・ページ内に組込まれて
いないかぎり、可能ではありません。これらの機能を最も簡単に実現する
方法は、VBScript、JavaScript、JBscript などのスクリプト記述言語を使用す

ることです。

スクリプト記述言語は、ブラウザによってサポートされるインタープリタ
言語の 1 つです。スクリプト記述言語により、HTML の使用範囲が広がり、
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より対話型の Web ページを提供できます。スクリプト記述言語はインター

プリタ言語なので、Web ページに埋込み、ブラウザによってサポートされ

る必要があります。これは独立したプログラムではありません。これを図
12-5 に図示します。

図 12-5. スクリプト記述言語ホスト・モデル

VBScript、JavaScript、JScript はスクリプト記述言語です。VBScript は、MS 
Visual Basic をベースにします。JavaScript は、Java とともに Sun によって

作成されています。JScript は、Microsoft バージョンの JavaScript をベース

にします。

スクリプト記述言語は、ホスト・アプリケーション内にある必要がありま
す。ホスト・アプリケーションは、通常、Internet Explorer や Netscape 
Navigator などの Web ブラウザです。ブラウザ内の Web ページの全体的な

外見は、HTML によって制御されます。

Microsoft の COM ( コンポーネント・オブジェクト・モデル ) は、ActiveX
コントロールと呼ばれるコンパイル済みソフトウェア・コンポーネントを
定義し、ActiveX コントロールには、特定の用途を持つ機能がカプセル化

されます。通常、ActiveX コントロールは、ユーザ・インタフェースの機

能を提供するために使用され、クライアントのコンピュータで実行される
ように設計されます。ActiveX コントロールは、最適化されたソフトウェ

ア・コンポーネントであり、以前は OLE コントロールと呼ばれていました。

外部ソフトウェア・コンポーネント

ActiveX コント

ロール

ホスト・アプリケーション

ドキュメント・オブ
ジェクト
HTML コントロール

スクリプト
記述言語
(VBScript、
JavaScript)
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Agilent VEE を使った Web モニタ管理

VEE には、HTTP を介してほかのプログラムと通信するための Web サーバ

が組込まれています。自分のコンピュータにある VEE プログラムと情報に

リモート・ユーザからアクセスできます。この節では、VEE データを共有

し、リモート・ユーザからそのデータにアクセスする方法について説明し
ます。

全般的なガイドラインとヒント

サーバ側のシステムで実行される VEE プログラムが、リモート・ユーザ

がアクセスする VEE プログラムになります。

サーバ側のシステムで VEE を実行する必要があります。サーバ側のシス

テムの VEE プログラムにアクセスするために、リモート・ユーザ側に

VEE がインストールされている必要はありません。

リモート・ユーザがネットワーク・ブラウザから VEE に要求を送ると、

VEE は、ピクチャを 1 つ作成してリモート・ユーザのブラウザ・ウィ

ンドウに表示します。このピクチャは、VEE プログラムの「スナップ

ショット」であり、編集することはできません。

リモート・ユーザは、VEE プログラムのさまざまな部分を表示したり、

( プログラムの進捗を監視するため ) 一定間隔でブラウザ表示を更新す

るように VEE プログラムに指示したり、エラー・メッセージ情報を表

示することができます。それには、VEE Web サーバ・ホームページで

オプションを選択するか、ブラウザで URL にコマンド・ライン・オプ

ションを指定します。

Agilent VEE のデータをリモート・ユーザに提供する

方法

リモート・ユーザがサーバ側のシステムにあるデータにアクセスできるよ
うに、VEE Web サーバをセットアップします。一般には、次の手順に従い

ます。

1. サーバ側のシステムがネットワークに接続されていることを確認します。
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2. サーバ側システムの URL に関する情報をリモート・ユーザに提供しま

す。リモート・ユーザは、この URL をブラウザに入力して、サーバ側

のシステムにアクセスします。詳細については、後述します。

3. VEE を起動します。リモート・ユーザからアクセスされるプログラム

を開いたり、リモート・ユーザからアクセスされるファイルを作成しま
す。

4. [File]⇒ [Default Preferences]⇒ [Web Server]ダイアロ

グ・ボックスの設定を選択して、Web サーバを有効にします。詳細につ

いては、後述します。

5. リモート・ユーザは、Internet Explorer や Netscape などの Web ブラウザ

を実行します。

[Web Server] ダ
イアログ・ボッ
クス

[File]⇒ [Default Preferences]⇒ [Web Server]を選択すると、

図 12-6 に示すように、[Web Server]ダイアログ・ボックスが表示され

ます。

図 12-6. [Default Preferences] の [Web Server] ダイアログ・ボックス
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[Web Server]ダイアログ・ボックスには、次のフィールドがあります。

[Enable 
Server]

[Enable Server]をチェックした場合は、VEE の内蔵 Web
サーバがオンになります。Web サーバにより、リモート・
ユーザは、自分の Web ブラウザにサーバ側の VEE プログラ
ムを表示して、サーバ側システムの VEE プログラムを表示、
監視、トラブルシューティングできます。

VEE の Web サーバは、標準の HTTP プロトコルを使用しま
す。デフォルトでは、[Enable Server]はオフ ( チェッ
ク・マークなし ) です。リモート・ユーザが VEE Web サーバ
にアクセスするには、サーバ側のシステムがネットワークに
接続され、そこで VEE が実行されており、リモート・ユーザ
は Web ブラウザを実行している必要があります。

[Root 
Directory]

リモート・ユーザがアクセスできるファイルの場所を指定し
ます。デフォルトは、~installDir/wwwです。Windows 95、
Windows 98、Windows 2000、and Windows NT 4.0 において、
VEE Pro 6.0 がデフォルト設定のままインストールされている
場合、このフィールドには次のように表示されます。

C:\Program Files\Agilent\VEE Pro 6.0\www

このディレクトリやそのサブディレクトリには、個人的な

ファイルを置かないでください。サーバ側のシステムにア
クセスできるリモート・ユーザならだれでも、Web ブラウ

ザを使ってそれらのファイルを表示できるからです。

VEE は、インストール時に、Web サーバのデフォルトの

ルート・ディレクトリにファイル index.htmlをインス

トールしています。デフォルトでは、このファイルは
C:\Program Files\Agilent\VEE Pro 

6.0\www\index.htmlです。これがデフォルトの VEE 
Web サーバ・ホームページであり、リモート・ユーザが

サーバ側システムにアクセスしたときに表示されます。こ
のホームページは、必要に応じて編集できます。

Web ファイルのルート・ディレクトリを変更した場合は、

index.htmlファイルを新しいディレクトリに移動して

ください。ファイル名を変更してはいけません。
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[HTTP 
Port 
Number]

VEE Web サーバのポート番号を指定します。デフォルトの
ポート番号は 80 です。デフォルトのポート番号を変更する必
要があるのは、同じシステムでもう 1 つの Web サーバ (VEE
の別のインスタンスなど ) を実行する場合、または VEE Web
サーバにアクセスするリモート・ユーザを制限する場合だけ
です。

0 ～ 65535 の HTTP ポートを指定することにより、サーバ側

のシステムにあるデータにアクセスおよび表示できるリ
モート・ユーザを制限できます。

HP-UX では、1024 より大きいポート番号だけを指定できま

す。デフォルトのポート番号は 8080 です。

別のポート番号を指定した場合、VEE プログラムを表示す

るリモート・ユーザも、同じポート番号を各自のブラウザ
に入力する必要があります。たとえば、このフィールドを
85 に設定した場合は、リモート・ユーザも URL に

「http://ホスト名 :85」と入力する必要があります。ホ

スト名については、この章の後の方で詳しく説明します。

[Server 
Timeout]

VEE Web サーバが VEE のコマンド処理を待機する最大の時
間を指定します。デフォルトでは、60 秒に設定されていま
す。VEE プログラムがコマンドを処理するために、指定され
ているより多くの時間を要した場合、VEE は Web サーバにタ
イムアウトを送信します。

[Log File] Web サーバによって処理されるすべての着信 HTTP 要求を記
録するログ・ファイルを指定します。PC では、このファイル
のデフォルトの場所は C:\windows\TEMP\http.logです。
[Default Preferences]⇒ [Web Server]ダイアログ・
ボックスで変更を行い、ログ・ファイルがまだ存在しない場
合は、それが作成されます。

[Save] 表示されている属性を永続的な選択として保存します。これ
で、Windows では vee.rcファイルに、HP-UX では .veerc
ファイルに設定値が保存されます。

再び変更しないかぎり、以降の VEE Web セッションではこれ
らの値がデフォルト値になります。現在の VEE セッションで
のみ、指定されている値を使用する場合は、[OK]をクリッ
クします。
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リモート・ユーザがサーバ側システムの Agilent VEE
にアクセスする方法

リモート・ユーザが別の場所からサーバ側のシステムにある VEE ファイル

にアクセスするには、一般に次の手順に従います。

1. リモート・ユーザのシステムがネットワークに接続されている必要があ
ります。

2. リモート・ユーザが Netscape や Internet Explorer などのネットワーク・

ブラウザを実行している必要があります。

3. リモート・ユーザがサーバ側システムの URL を入力する必要がありま

す。このアドレスは、サーバ側のユーザからリモート・ユーザに提供す
る必要があります。詳細については、後述します。

メモ サーバ側のシステムにある VEE プログラムにアクセスするために、リモー

ト・ユーザが VEE を実行する必要はなく、VEE がインストールされてい

る必要もありません。

リモート・ユーザはネットワークに接続し、ブラウザを実行し、URL を入

力します。以下の説明に基づき、入力する URL をリモート・ユーザに指示

してください。リモート・ユーザは、次の形式で URL を入力できます。

http://hostname {:port}

VEE Web サーバ・ホームページを表示します。リモート・ユーザは、

このページで、VEE プログラムの表示方法に関するオプションを入力

できます。

http://hostname{:port}{/command}{?parameter}

リモート・ユーザが VEE プログラム内に表示するビューまたは

UserFunctionを指定します。たとえば、http://ホスト名

/ViewMainDetailにより、メイン VEE プログラムの詳細ビューが表

示されます。

http://hostname{:port}{/file}

リモート・ユーザが表示する保存済みのファイル (*.jpeg、*.htmlな

ど ) を指定します。
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メモ 中かっこ {}で囲まれたフィールドは、省略可能です。

次に、URL アドレス内のフィールドについて説明します。

ホスト名 ( 必須 ) VEE が実行されているサーバ側のシステム
を識別します。フォーマットは、
「< コンピュータ名 >.domain.com」です。

「http://< ホスト名 >」のように、リモート・
ユーザに URL として < ホスト名 > だけを入力して
もらうこともできます。このコマンドにより、VEE 
Web サーバ・ホームページ (index.html) が開き、
リモート・ユーザに表示されます。リモート・ユー
ザは、この VEE Web サーバ・ホームページのメ
ニューから、VEE プログラムの表示、監視、トラ
ブルシューティングを選択できます。

ポート ( 省略可 ) デフォルト値 80 を使用しない場合に、
Web サーバのポート番号を識別します。[File]⇒
[Default Preferences]⇒ [Web Server]で
入力した値が 80 以外の場合にだけ、この値を指定
します。

たとえば、リモート・ユーザがサーバ側システムの
VEE にアクセスしようとしており、[File]⇒
[Default Preferences]⇒ [Web Server]の
ポート番号が 85に設定されている場合、リモー
ト・ユーザは「http://< ホスト名 >:85」と入力
する必要があります。 
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リモート・ユーザがサーバ側のシステムにある VEE プログラムにアクセス

する場合、URL 内で使用できるコマンドとパラメータは次のとおりです。

ファイル ( 省略可 ) ブラウザで開くディレクトリやファイル
をルート・ディレクトリからの相対ディレクトリで
識別します。リモート・ユーザが表示するファイル
を *.jpegや *.htmlなどのファイルに保存して
いる場合にだけ、ファイルを指定します。

リモート・ユーザがサーバ側のシステムにあるファ
イルを表示するには、サーバ側の VEE の
[Default Preferences]⇒ [Web Server]ダ
イアログ・ボックスで、そのファイルのディレクト
リをルート・ディレクトリとして指定する必要があ
ります。

コマンドと
パラメータ

( 省略可 ) VEE Web サーバがサポートしているコマ
ンドと、コマンドに必要なパラメータを指定しま
す。コマンドとパラメータを使用すると、リモー
ト・ユーザは、ブラウザを介して VEE プログラム
を監視したり、トラブルシューティングできます。
コマンドとパラメータの一覧を下に示します。

VEE ウィンドウ全体の
表示

ViewVEE 

例 : http://ホスト名 /ViewVEE

メイン VEE プログラム
のパネル・ビュー

ViewMainPanel

例 : http://ホスト名 /ViewMainPanel

メイン VEE プログラム
の詳細ビュー

ViewMainDetail

例 : 
http://ホスト名 /ViewMainDetail

実行時の VEE 実行ウィ
ンドウ

ViewExecWindow

ó·: 
http://ホスト名 /ViewExecWindow

パネル・ビュー内の
VEE UserFunction

http://ホスト名 /ViewPanel?
<UserFunction 名 >

例 (UserFunctionが AddNoiseの場合 ): 
http://ホスト名 /ViewPanel? AddNoise
464 第第第第12章章章章 



プラットフォーム固有の事項と Web モニタ管理

Agilent VEE を使ったを使ったを使ったを使った Web モニタ管理モニタ管理モニタ管理モニタ管理
Agilent VEE Web サーバ・ページの表示方法

VEE は、インストール時に、デフォルトの index.htmlファイルを www

ディレクトリに作成します。このファイルは、VEE Web サーバ・ホーム

ページを表示します。リモート・ユーザは、このページにあるオプション
をクリックして、サーバ側の VEE プログラムを表示できます。図 12-7 に、

デフォルトの VEE Web サーバ・ホームページを示します。MS Word などを

使用し、必要に応じてこのページを編集することもできます。

UserFunction の詳細
ビュー

http://ホスト名 /ViewDetail?
UserFunctionName

例 (UserFunctionが AddNoiseの場合 ): 
http://ホスト名 /ViewPanel? AddNoise

現在のプログラムのエ
ラー・ウィンドウ

http://ホスト名 /ViewError

URL で使用できるコマ
ンドの一覧表示

ViewHelp
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図 12-7. デフォルトの Index.html ページ

メモ サーバ側のシステムでこのメニューを表示するには、システムを
localhostとして参照します。たとえば、VEE とネットワーク・ブラウ

ザを実行し、ブラウザに「http://localhost」と入力すると、図 12-7
の VEE Web サーバ・ホームページがブラウザに表示されます。このよう

に、リモート・ユーザがさまざまなコマンドを使って表示する内容を簡単
に確認できます。

リモート・ユーザは、図 12-7 に示すメニューを表示し、メニューからオプ

ションを選択することにより、VEE プログラムのさまざまな部分にアクセ

スできます。たとえば、[Main Detail]をクリックすると、メイン VEE
プログラムを詳細ビューで表示できます。メニューでそのように選択する
と、ネットワーク・ブラウザにコマンド「http://ホスト名

/ViewMainDetail」を入力した場合と同じ情報が表示されます。
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Lab 12-1: Agilent VEE Web ブラウザを使った練習

セッション

この練習では、リモート・ユーザがサーバ側のシステム上で
Solitaire.veeプログラムを表示する Web セッションを紹介します。こ

の場合、プログラムにはエラーが 1 つあるため、リモート・ユーザからそ

の解決方法の問い合わせがあります。

1. VEE を起動します。[File]⇒ [Default Preferences]⇒ [Web 

Server]ダイアログ・ボックスを選択し、[Enable Server]をク

リックします。デフォルトの設定を使用します。リモート・ユーザが表
示する Solitaire.veeプログラムを開きます。サーバ側のネット

ワーク・ブラウザを実行します。

2. リモート・ユーザに連絡し、「http://Server5」と入力して Web 経

由でサーバ側のシステムに接続するように知らせます。
「http://Server5」は、実際に使用しているコンピュータ名に置換え

てください。

3. リモート・ユーザが URL に「http://Server5」と入力すると、リ

モート・ユーザのブラウザにサーバ側の VEE Web サーバ・ホームペー

ジが表示されます。表示内容については、-466 ページの図 12-7 を参照

してください。

4. リモート・ユーザは、最初に VEE プログラム全体を表示することにし

ました。リモート・ユーザは、VEE Web サーバ・ホームページで

[Main Detail]⇒ [View]をクリックします。ブラウザには、図

12-8 に示すビューが表示されます。
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図 12-8. ブラウザに表示された Solitaire.vee メイン・プログラム

図 12-8 に、VEE 内のメイン・プログラムを示します。

メモ この練習の Solitaire.veeプログラムには 1 つのエラーがありますが、

このエラーは、VEE プログラム・サンプルにはありません。このプログラ

ムを表示する場合は、[Help]⇒ [Open Example...]⇒ [Games]⇒

[Solitaire.vee]を選択してください。

5. リモート・ユーザは、ブラウザで [Back]をクリックして VEE Web
サーバ・ホームページを表示し、[Last Error Message]を選択しま

す。ブラウザには、図 12-9 に示すエラー・メッセージが表示されます。 
468 第第第第12章章章章 



プラットフォーム固有の事項と Web モニタ管理

Agilent VEE を使ったを使ったを使ったを使った Web モニタ管理モニタ管理モニタ管理モニタ管理
図 12-9. ブラウザを使った VEE エラー・メッセージの表示

VEE エラー・メッセージに "UserFunction makeAMove" と明記されて

いることがわかります。

6. リモート・ユーザは、再び VEE Web サーバ・ホームページに戻り、

[Detail View of UserFunction]をクリックして、

UserFunction名の「makeAMove」を入力します。図 12-10 に示すよ

うに、ブラウザには、UserFunction makeAMoveが表示されます。
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図 12-10. ブラウザに表示された UserFunction の詳細ビュー

リモート・ユーザは、VEE プログラム内のエラーを確認できます。図

12-10 に示すように、JCTオブジェクトの入力ピンが接続されていません。

ここで、リモート・ユーザは、Solitaire.veeのトラブルシューティン

グに参加して、エラーを解決します。Web を介した同様の共同作業を行う

ことにより、リモート・ユーザと協力して作業したり、合同してプログラ
ムを開発することができます。

Web を介して表示されるプログラムへのアクセスを

制限する方法

VEE プログラムを Web 上で使用可能にする場合でも、リモート・ユーザが

プログラム内の一定の部分を表示できないようにする必要が生じることが
あります。リモート・ユーザがすでにサーバ側システムの URL を知ってい
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る場合は、一定のリモート・ユーザだけが特定のプログラムや Web ディレ

クトリのファイルにアクセスできるようにする必要があります。

リモート・ユーザが Web 上で VEE プログラムの特定の部分を表示できな

いようにする場合、そのようにプログラムを保護する方法は、3 とおりあ

ります。

1. 許可されたユーザだけがプログラムを表示できるように、[Default 

Preferences]⇒ [Web Server]フォルダでポート番号を変更します。

または

保護された RunTimeバージョンの VEE プログラムを作成します。これ

で、プログラム・コードをまったく表示できなくなります。詳細は、
388 ページの「プログラムを保護する方法 (RunTime バージョンを作成

する方法 )」を参照してください。

または

無効にするコマンドと正確に同じ名前を付けた HTML ファイルを作成

し、それを VEE の wwwディレクトリに保存します。ブラウザは、VEE
を表示する前に、必ずすべての *.htmlファイルにアクセスします。こ

れで、リモート・ユーザからの要求を途中で止めて、適切な警告やコメ
ントを記載した HTML ページを表示できます。

たとえば、リモート・ユーザが VEE プログラムの詳細ビューを表示で

きないようにするとします。その場合は、MS Word などのプログラムで

ファイルを作成し、それを ViewMainDetail.htmlという名前で www

ディレクトリに保存します。そのファイルの中に、リモート・ユーザに
対して表示するメッセージを記入します。

リモート・ユーザが VEE Web サーバ・ホームページで [Main 

Detail]を選択したり、ViewMainDetailオプションを使って URL
を入力しても、ブラウザはメイン VEE プログラムを詳細ビューで表示

しません。そのかわり、ブラウザは、wwwディレクトリ内の

ViewMainDetail.htmlファイルにアクセスし、そのファイルを表示

します。図 12-11 に、リモート・ユーザに表示するメッセージの例を示

します。
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メモ ファイル名が VEE の Web コマンドと同じ名前であることを確認してくだ

さい。また、それを [Web Server]で指定したルート・ディレクトリに

置く必要があります。

図 12-11. VEE プログラムのかわりに表示する HTML メッセージの例

*.htmlファイルは、その他の目的でも使用できます。たとえば、VEE プ

ログラムをパスワードで保護し、パスワードを持つユーザだけがプログラ
ムを表示できるようにできます。図 12-12 に、パスワードによる保護の例

を示します。
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図 12-12. パスワード・ウィンドウの例
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この章の復習

この章では、次のことをできるようになりました。

PC と HP-UX プラットフォームの重要な相違点と、プログラムを移植す

る際に発生する問題について説明する。

Rocky Mountain Basic プログラムを呼出し、そのプログラムと通信する

方法について説明する。

Callable VEE ActiveX Automation Server の使用法と、それを使用する場面

について説明する。

VEE の機能をほかのアプリケーションやプログラムに統合する方法につ

いて説明する。

Web を使って VEE プログラムを監視する際のキー・ポイントについて説

明する。
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追加の例題

以下の例題では、このマニュアルで学んだ VEE の概念を実践します。練習

問題は、いくつかのカテゴリに分かれています。

この付録を使用する場合は、自分の解答を作成してから、記載されている
解答と比較します。指定された作業をプログラミングする方法は多数ある
ため、自分の解答が問題の条件を満たしていれば、有効な解法を開発でき
たことになります。ただし、実行時間が短く、使いやすいプログラムの方
が一般に優れた解法です。解答には、それぞれのキー・ポイントが簡潔に
まとめられています。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
一般的なプログラミング技術

りんごのかご入れ

かごにりんごを入れて 10 ポンドにするには何個のりんごが必要かを調べま

す。何個のりんごでかごがいっぱいになるかを数える VEE プログラムを作

成してください。りんごの重さは、それぞれ 0 ～ 1 ポンドだとします。

ヒント

このプログラムは、10 個以下のオブジェクトを使って作成できます。次の

中から選択してください。

Start
Until Break
random() 関数
Accumulator
Break
Real64
Conditional(A>=B)
Stop
Counter
If/Then/Else
Alphanumeric

メモ このマニュアルに記載されている練習問題やプログラミング例で使用した
VEE プログラムの多くは、VEE に付属しています。[Help]⇒ [Open 

Example...]⇒ [Manual]⇒ [UsersGuide]を選択してください。

解答 1-「りんごのかご入れ」

図 A-1 に、練習「りんごのかご入れ」の解答例を示します。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
図 A-1. 「りんごのかご入れ」解答 1

キー・ポイント

最適な解法 : プログラムのパフォーマンスを上げるには、できるだけ使

用するオブジェクトの数を少なくします。この解答では、6 個のオブ

ジェクトを使用しています。このプログラムは、図 A-2 に示すように、

10 個のオブジェクトを使って実装することもできます。

Until BreakとBreakオブジェクト : これらのオブジェクトは、条件の判定

を必要とするループに使用します。この例のループは、りんごの総重量
が 10 ポンドより大きくなったときに、停止する必要があります。

Accumulator: Accumulatorを使って積算合計を保持します。

Counter: Counterを使って積算カウントを保持します。この例の

Counterは、かごの中のりんごの数を追跡するために使用されます。

総重量が 10 を超えた場合は、If/Then/Elseオブジェクトの Thenピ

ンだけが起動して、Counterの答が正しくなります。

解答 2-「りんごのかご入れ」

図 A-2 に、もう少しオブジェクトを使った解答例を示します。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
図 A-2.  「りんごのかご入れ」解答 2 

キー・ポイント

Start: このプログラムに Startオブジェクトを使用するのは冗長です。

なぜなら、メイン・メニュー・バーの [Run] ボタンを使用できるからで

す。画面に 2 つのプログラムがあり、それらを互いに無関係に実行する

必要がある場合は、Startを使用するのが適切です。また、プログラ

ムにフィードバック・ループがあり、どこで実行を開始するのかを定義
する必要がある場合も、Startを使用するのが適切です。

Shift Register: Shift Registerは、以前の出力値にアクセスするため

に使用します。解答 2 では、Counterは、りんごの重さを測定する前

にりんごの積算カウントを保持しているため、総重量が 10 を超えた場

合は、そのカウントから 1 だけ減算する必要があります。

Gate: Gateは、別の操作が発生し、それがシーケンス・ピンをアクティ

ブ化するまで、出力を保持するために使用します。この図では、条件
A<=10はすでに TRUE ではなくなっており、If/Then/Elseオブジェ

クトの Elseピンがゲートをアクティブ化します。

数の判定

「数の判定」ステップ 1

ユーザが 0 ～ 100 の数を入力できるプログラムを作成します。その数を 50
と比較し、大きいか等しい場合はその数を表示します。その数が 50 より小
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さい場合は、ポップアップ・ボックスに "Please enter a number between 50 
and 100." というメッセージを表示します。

ヒント

このプログラムは、5 個以下のオブジェクトを使って作成できます。次の

中から選択してください。

Start
Int32
Slider
Real64
If/Then/Else
Formula
Gate
Text
Junction
Alphanumeric
Message Box

解答 -「数の判定」ステップ 1

図 A-3 に、5 つのオブジェクトを使った練習「数の判定」の解答例を示し

ます。

図 A-3. 「数の判定」ステップ 1 ( ポップアップが表示されている )
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
「数の判定」ステップ 2

5 つのオブジェクトを使ったモデルが動作し、Message Box がポップアップ

を生成したら、Gateオブジェクトを使用しないで、4 つのオブジェクトで

プログラミングしてみてください。

解答 -「数の判定」ステップ 2

図 A-4 に、4 つのオブジェクトを使った練習「数の判定」の解答例を示し

ます。

図 A-4. 「数の判定」ステップ 2 

キー・ポイント

Auto Execute: Int32 Sliderなどのすべての入力オブジェクトは、

[Properties]ダイアログ・ボックスに [Auto Execute]オプショ

ンを持っています。これを選択した場合は、[Start]または [Run] ボ
タンを押さなくても、オブジェクトの値が変わるごとに、オブジェクト
が動作します。

Gate の削除 : If/Then/Elseオブジェクトの式 (A>=50)*Aは、評価さ

れると、A>=50が TRUE の場合は 1*Aになり、FALSE の場合は 0にな

ります。したがって、この式が TRUE の場合は Aが Thenピンに出力さ

れ、FALSE の場合は 0が Elseピンに出力されます。非 0 と評価され

る式はすべて TRUE と見なされ、その値が Thenピンに伝達されます。

「数の判定」ステップ 3

オブジェクトを 3 つだけ使った解法を作成してください。
付録付録付録付録 A 481



追加の例題

一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
ヒント : Formulaオブジェクト内で 3 項式を使用します。その構文は、(<
式 > ? <TRUE の場合の出力値 > : <FALSE の場合の出力値 >)で

す。たとえば、A < 10が TRUEと評価される場合は、Aの値を Resultピ

ンに出力し、そうでない場合は、文字列 "FALSE" を Resultピンに出力す

るとします。この場合は、3 項式 (A<10 ? A : "FALSE")を使用します。

解答 -「数の判定」ステップ 3

図 A-5 に、3 つのオブジェクトを使った練習「数の判定」の解答例を示し

ます。

 

図 A-5. 「数の判定」ステップ 3

メモ これは、自動エラー検出機能を持つ [Real64 Input]ダイアログ・ボッ

クスを使用すると実装できます。ただし、オペレータが有効な数を入力す
るまで、プログラムは完了できません。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
乱数の収集

100 個の乱数を生成し、それらを表示するプログラムを作成します。それ

らの値の生成と表示にかかった合計時間も記録してください。

ヒント

このプログラムは、6 個以下のオブジェクトを使って作成できます。次の

中から選択してください。

Start
For Range
Until Break
randomseed() 関数

random() 関数
Collector
Formula
Set Values
Alloc Int32
Logging AlphaNumeric
Strip Chart
Meter
Date/Time
Timer
Now()
Break
Do

ヒント

パフォーマンスを上げるには、最初に Collectorオブジェクトを使って

配列内にデータを収集したうえで、データを一度だけ表示に送信します。
パフォーマンスの違いに注意してください。

解答 -「乱数の収集」

図 A-6 に、練習「乱数の収集」の解答例を示します。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
図 A-6. 「乱数の収集」

キー・ポイント

Logging AlphaNumericとAlphaNumeric: 連続する入力(ScalarとArray 

1Dのどちらか ) を以前の値に続けて表示する場合は、Logging 

AlphaNumericを使用します。一度 ( 直前 ) の実行のデータだけを単一

の値、Array 1D、または Array 2Dとして表示する場合は、

AlphaNumericを使用します。Logging表示は、インデックス値のな

い配列であり、AlphaNumeric表示は、省略可能なインデックス番号

と値を持つ同じ配列です。

時間測定のピン : Doオブジェクトは、どのオブジェクトを最初に実行す

るかを制御します。プログラム終了までの時間は、For Countオブ

ジェクトのシーケンス出力ピンを使って測定されます。このピンは、
ループ内のすべてのオブジェクトの実行が終わるまで起動されません。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
乱数生成プログラム

「乱数生成プログラム」ステップ 1

外部入力を必要とする乱数生成プログラムを作成します。乱数は、スト
リップ・チャートに表示してください。次の項目を入力できる必要があり
ます。

乱数の最大値
乱数の最小値
生成する乱数の数

解答 -「乱数生成プログラム」ステップ 1

図 A-7 に、練習「乱数生成プログラム」ステップ 1 の解答例を示します。

図 A-7. 「乱数生成プログラム」ステップ 1

キー・ポイント

Slider オブジェクトのレイアウト : Slider オブジェクトの画面イメージに

ついては、[Properties]ボックス内の [Layout]にある

[Horizontal]をクリックすると、垂直または水平の形式を選択でき

ます。

XY Trace: 連続して生成されるデータの最近の履歴を表示するには、XY 

Traceを使用します。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
「乱数生成プログラム」ステップ 2

乱数を配列に収集します。移動平均を計算し、それを乱数とともに表示し
てください。

解答 -「乱数生成プログラム」ステップ 2

図 A-8 に、練習「乱数生成プログラム」ステップ 2 の解答例を示します。

図 A-8. 「乱数生成プログラム」ステップ 2 

MovingAvg(x, numPts): [Function & Object Browser]の [Data 

Filtering]カテゴリにあるこのオブジェクトを使用すると、平滑化

の計算対象となるデータ点の前にある指定した数のデータ点の平均を使
用して、入力データを平滑化できます。

マスクの使用方法

「マスク・テスト」ステップ 1

調整可能な量のノイズを使用して、50Hz の正弦波を作成します。正弦波の

ノイズが次の制限内にあるかどうかを判定してください。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
(0,0.5)
(2.2m, 1.2)
(7.2m, 1.2)
(10.2m, 0.5)
(20m, 0.5)

正弦波が制限を超えた場合は、その点を赤いひし形でマークします。

ヒント

線の表示フォーマットは、ドットやひし形に変更できます。
[Properties]ダイアログ・ボックスで、各トレース入力の [Traces]

タブを選択して、線の種類を実線、破線、点のみなどに変更できます。ま
た、[Point Type]には、ただの点、ひし形、四角などの形状がありま

す。Comparatorオブジェクトが有効であることがわかります。

解答 -「マスクの使用方法」ステップ 1

図 A-9 に、ステップ 1 の解答例を示します。

図 A-9. 「マスク・テスト」ステップ 1

「マスクの使用方法」ステップ 2
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失敗の割合を計算して表示するように、プログラムの機能を拡張してください。

解答 -「マスクの使用方法」ステップ 2

図 A-10 に、ステップ 2 の解答例を示します。

図 A-10. 「マスク・テスト」ステップ 2 

キー・ポイント

マスク : マスクを作成するには、[Data]⇒ [Constant]⇒ [Coord]オ

ブジェクトを使用します。これを 5 つの配列要素用に設定します。座標

の組をコンマで区切って入力すると、VEE によって丸かっこ () が追加

されます。x値は、波形のタイム・スパンが 20 ミリ秒であることに

よって選択されています。また、Waveform (Time)表示は、Coord

データ型を入力として受入れることに注意してください。[Data]⇒

[Build Data]⇒ [Arb Waveform]オブジェクトを使用することも

できます。このオブジェクトは、Waveform内の点の数を指定すること

により、Coordを Waveformデータ型に変換します。

Comparator: このオブジェクトは、テスト値を参照値と比較します。つ

まり、波形と座標の配列を比較できます。Failuresピンは、失敗した

データ点の配列を出力するため、それを表示に送信し、異なる種類の線
や色で強調表示できます。
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一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術一般的なプログラミング技術
TotSize: このオブジェクトは、単に、配列内の要素の数を出力します。

これは失敗の数を保持するため、その数を元の波形の要素の総数 256 で

除算し、100 を乗算すると、失敗の割合 (%) を得ることができます。

Formula: A/256*100は、失敗の割合 (%) を計算する式です。Function 

Generatorと Noise Generatorは、256 の点を出力するように設定

されています。
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文字列とグローバルの使用方法文字列とグローバルの使用方法文字列とグローバルの使用方法文字列とグローバルの使用方法
文字列とグローバルの使用方法

文字列とグローバルの操作

文字列のオブジェクトや関数を使用して、「< 空白 > < 名 > < 空白 > <
姓 >」という形式のユーザ名を受付けるプログラムを作成してください。

ユーザが名前を入力した後は、「名」を外して「姓」だけを出力します。文
字列をグローバル変数に保管します。Formulaオブジェクトを使用して、

文字列を取得します。

解答 -「文字列とグローバルの操作」

図 A-11 に、練習「文字列とグローバルの操作」の解答例を示します。

図 A-11. 「文字列とグローバル変数の操作」
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文字列とグローバルの使用方法文字列とグローバルの使用方法文字列とグローバルの使用方法文字列とグローバルの使用方法
キー・ポイント

文字列のオブジェクトと関数 : まず、StrTrim(str)は、名前の先頭と

末尾からすべてのスペースとタブを削除します。StrPosChar(str1, " ") は、

名と姓の間にあるスペースのインデックスを生成します。StrLen(str) は、

文字列の長さを出力します。これらの操作は、文字列のオブジェクトを
使って実行されましたが、Formula オブジェクト内で文字列の関数を

使って実行することもできます。

Formulaオブジェクト : StrFromThru(A,B+1,C-1)では、入力Aから文

字列を受取り、入力 B のスペースのインデックスに 1 を加算し、入力 C
の文字列の長さから 1 を減算しています。インデックスは 0 から始まる

ことに注意してください。

Set変数 : lastnameという名前のグローバル変数を簡単に設定できるこ

とに注目してください。この後、この変数は、任意の式フィールド ( こ
の例では、Formulaオブジェクト ) で参照できます。

最適化の方法 : 3 つの式は、組合わせて 1 つの式にできます。strTrim()

の出力は何回か使用されるため、1 つのままにしておく方が適切です

が、ほかの式は組合わせて 1 つの式にすると、処理速度が上がります。

ただし、多少読みにくくなります。
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最適化の手法最適化の手法最適化の手法最適化の手法
最適化の手法

この例題では、2 つの異なる方法で VEE プログラムを構築し、その実行速

度の差に注目します。

「最適化の手法」ステップ 1

sin 関数と cos 関数の両方を介して 0～ 710(ステップ 10)の範囲を送信す

るプログラムを作成してください。関数の結果は、X vs.Y表示に出力し

ます。
プログラムの実行にかかる時間を測定するには、Timerオブジェクトを使

用します。[Trig Mode]のデフォルトを [Radians]に設定します。

解答 -「最適化の手法」ステップ 1

図 A-12 に、ステップ 1 の解答例を示します。

 

図 A-12. 「VEE プログラムの最適化」ステップ 1

「最適化の手法」ステップ 2 

最初のプログラムにあるすべてのオブジェクトをクローンします。範囲を
配列内に収集するように新しいセットを変更します。これで、sinと cos

関数は点の配列に対して実行され、一度だけプロットされます。どれだけ
時間が節約されるかに注目してください。
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最適化の手法最適化の手法最適化の手法最適化の手法
解答 -「最適化の手法」ステップ 2

図 A-13 に、ステップ 2 の解答例を示します。

図 A-13. 「VEE プログラムの最適化」ステップ 2

キー・ポイント

配列を使った最適化 : 配列を使用したことで、ステップ 1 とステップ 2 の

間でパフォーマンスが向上していることに注目してください。できるか
ぎりスカラ値ではなく配列を使用して、結果の解析や表示を行ってくだ
さい。

X vs. Y 表示 : この例では、Waveformや XY表示のかわりに、この表示を

使用しています。それは、Xと Yにデータが分かれているからです。
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UserObject
UserObject

「不規則ノイズ UserObject」
「不規則ノイズ UserObject」ステップ 1

不規則ノイズの波形を生成する UserObjectを作成してください。ノイズ

の波形とノイズ・スペクトルを UserObjectの外に表示します。

UserObjectの外に、amplitude、number of points、interval 

(time span)、DC offsetの各コントロールを用意します。

メモ UserObjectの中で仮想ソースを使用しないでください。UserObjectの

作成には、Build Waveformや Randomなどのオブジェクトを使用します。

解答 -「不規則ノイズ UserObject」

図 A-14 に、「不規則ノイズ UserObject」の解答例を示します。
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UserObject
図 A-14. 「不規則ノイズ UserObject」

解答 —「不規則ノイズの NoiseGen オブジェクト」

図 A-15 に、「NoiseGen UserObject」の解答例を示します。
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UserObject
図 A-15. 「NoiseGen UserObject」

キー・ポイント

UserObject: UserObjectは、本質的に、ユーザがカスタマイズして

VEE に追加するオブジェクトです。

Build Waveform: このオブジェクトは、振幅値の Real配列と time 

span(yデータがサンプリングされる秒単位の周期 ) から Waveform

データ型を作成します。
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Agilent VEE UserFunction
Agilent VEE UserFunction

UserFunction の使用方法

「UserFunction」ステップ 1

スライダから振幅値 (0 ～ 1) を受入れ、ノイズ波形を返す、NoiseGenと

いう名前の関数を作成してください。

次は使用しません。
Virtual Source
For Count
For Range

次を使用してください。
Formula
Ramp
Build Waveform

ヒント

randomize(array, -a,a)を使用します。ここで、配列の要素は 256 で

あり、aは振幅です。この関数を呼出す簡単なメイン・プログラムを構築

して、それが正しく機能していることを確認してください。

解答 -「UserFunction」ステップ 1

図 A-16 に、ステップ 1 の解答例を示します。
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Agilent VEE UserFunction
図 A-16. 「User Function」ステップ 1

キー・ポイント

Ramp(): 256 の点を持つ配列を生成するために、randomize()のパラ

メータ・リスト内で ramp()関数を使用しています。

Build Waveform: デフォルトのタイム・スパンは 20 ミリ秒であり、この

オブジェクトに配列を送信するだけで、波形を構築できます。

「UserFunction」ステップ 2

同じプログラム内で、最初の関数 NoiseGenを呼出す AddNoiseという名

前の別の関数を作成します。AddNoiseは、NoiseGen関数のノイズ波形

を正弦波に追加するものです。AddNoiseは、NoiseGen と正弦波の 2 つの

入力を持つ必要があります。また、結果の出力を 1 つ持ちます。
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Agilent VEE UserFunction
ノイズ振幅用のスライダを持つ簡単なメイン・プログラムを構築し、ノイ
ズの追加先の波形として [Virtual Source]⇒ [Function 

Generator (sine wave, Freq = 100 Hz)]を選択します。結果の波

形を表示します。

解答 -「UserFunction」ステップ 2

図 A-17 に、ステップ 2 の解答例を示します。

図 A-17. 「User Function」ステップ 2

「UserFunction」ステップ 3

同じプログラム内で、今回は Formulaオブジェクトから再び AddNoise

関数を呼出し、その結果の絶対値を受取ります。その絶対値波形を同じ表
示上に表示します。次に、AddNoise関数を編集する準備をします。

[Debug]⇒ [Show Data Flow]をオンにします。AddNoiseウィンドウ

を開いたまま、プログラムを実行します。こうするとデバックにたいへん
便利であることに注目してください。

解答 -「UserFunction」ステップ 3

図 A-18 に、ステップ 3 の解答例を示します。
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Agilent VEE UserFunction
図 A-18. 「User Function」ステップ 3

「UserFunction」ステップ 4

スライダで Amplitudeという名前のグローバル変数を設定するように、

プログラムを変更します。NoiseGen関数でそのグローバルを使用します。

したがって、NoiseGen に入力ピンは必要なくなります。プログラムを正し

く実行します。このファイルを uflab.veeという名前で保存します。

解答 -「UserFunctions の使用方法」ステップ 4

図 A-19 に、ステップ 4 の解答例を示します。
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Agilent VEE UserFunction
図 A-19. 「User Function」ステップ 4

ヒント : Call AddNoiseと Formulaオブジェクトはグローバル

Amplitudeを使用するため、それらのオブジェクトは、どちらも Set 

Amplitudeオブジェクトの実行後に実行される必要があります。シーケ

ンス・ピンを Set Amplitudeから Call AddNoiseに、また Call 

AddNoiseから Formulaに接続すると、これらのオブジェクトが必要な

順序で実行されます。

UserFunction ライブラリのインポートと削除

前の練習の uflab.vee関数をインポートする簡単なプログラムを構築し

ます。ノイズを追加する関数を呼出した後、プログラムからライブラリを
削除します。Callオブジェクトのオブジェクト・メニューにある

[Select Function]を使用します。
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Agilent VEE UserFunction
ヒント : Import Libraryのオブジェクト・メニューにある [Load Lib]

をクリックし、指定したライブラリを手動でロードします。そうすると、
Call内の Select Function機能を使用できます。

解答 -「ライブラリをプログラムからインポートおよび削除する方法」

図 A-20 に、「ライブラリをプログラムからインポートおよび削除する方法」

の解答例を示します。

図 A-20. ライブラリのインポートと削除

キー・ポイント

Select Function: 関数を選択すると、選択した関数に対する正しい入力

ピンと出力ピンが設定されます。

UserFunctionの編集 : プログラムを使ってUserFunctionのライブラリ

をインポートした場合、UserFunctionを編集することはできません。

それらを表示したり、ブレークポイントを設定してデバッグすることは
できます。インポートした UserFunctionを編集する必要がある場合

は、Merge Libraryコマンドを使用します。
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Agilent VEE UserFunction
変数設定の注意 : 関数内でグローバル変数を使用している場合、その関

数をほかのプログラムで使用するには、そのグローバル変数を作成する
必要があることに注意してください。入力と出力を明示的に作成する利
点の 1 つは、それらの管理が容易になることです。
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オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成
オペレータ・パネルとポップアップの
作成

「オペレータ・パネルとポップアップの作成」ステップ 1

オペレータに数字の入力を求めるパネルを作成してください。オペレータ
と対話するための UserObjectを作成します。オペレータに、Aと Bの 2
つの入力を要求します。両方の入力を表示に送信します。[Show On 

Execute]をチェックして UserObjectを使用すると、パネルを表示でき

ます。

解答 -「オペレータ・パネルとポップアップの作成」ステップ 1

図 A-21 に、詳細ビューでの解答例を示します。図 A-22 は、プログラムが

実行されたときに表示されるパネルを示します。

図 A-21. オペレータに A と B の入力を求める UserObject
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オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成
図 A-22. オペレータが A と B を入力するためのパネル

キー・ポイント

UserObject のプロパティ : [UserObject Properties]ダイアログ・

ボックスで、[Pop-Up Panel]を選択し、[Show Panel On 

Execute]をクリックしてオンにします。[Pop-Up Panel]⇒

[Panel Title]で名前を "Enter A or B" に変更します。

「オペレータ・パネルとポップアップの作成」ステップ 2

2 つの数が異なる場合は、Aと Bの両方を表示するかわりに、オペレータ

に Aと Bのどちらを表示するかをたずねてください。2 つの値の入力を求

めた後、Aと Bの値が等しい場合は、その値を表示します。Aと Bの値が

異なる場合は、表示する値の選択をオペレータに求めます。オペレータの
選択に基づいて、Aまたは Bを表示します。

ヒント : [Show Panel on Execute]を設定したポップアップ・パネル

を持つ別の UserObjectを追加し、そこでオペレータに値をたずねます。

解答 -「オペレータ・パネルとポップアップの作成」ステップ 2

図 A-23 に、Aと Bが異なる数である場合に、オペレータに選択を求める

UserObjectを示します。図 A-24 は、Aと Bのどちらを表示するかをオ

ペレータにたずねる 2 つ目のポップアップ・パネルが表示されたところ

です。
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オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成
図 A-23. オペレータに A または B のどちらを表示するかをたずねる UserObject

図 A-24. A と B のどちらを表示するかをオペレータが選択するためのパネル

キー・ポイント

Gate: Gateオブジェクトは、2 つの数が等しい場合に、単に一方の値を

送信します。
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オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成
結合 : JCTオブジェクトは、オブジェクト Alphanumericに対する複数

の入力を可能にします。JCTオブジェクトは、配線による OR オブジェ

クトです。

オブジェクト・リストのメニュー : 2 つの選択肢とリストが配置される

ように編集された [Data]⇒ [Selection Controls]⇒ [List]オ

ブジェクトの使用方法に注意してください。この設定により、テキスト
Aまたは Bが出力されます。序数値 (0または 1) が必要な場合は、かわ

りに Listオブジェクトの序数データ出力を使用します。

「オペレータ・パネルとポップアップの作成」ステップ 3

オペレータが数を入力しなかった場合に、エラー・メッセージを生成しま
す。2 つの数が異なる場合に、Aと Bのどちらを表示するかをオペレータ

にたずねる 2 つ目の UserObjectにエラーを追加します。オペレータが

10 秒以内に Aか Bを選択しなかった場合は、エラーを生成します。

解答 -「オペレータ・パネルとポップアップの作成」ステップ 3

図 A-25 に、オペレータが 10 秒以内に Aか Bを選択しなかった場合にエ

ラーを生成するように変更された UserObjectを示します。

図 A-25. オペレータが選択を入力しなかった場合にエラーを生成
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オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成オペレータ・パネルとポップアップの作成
キー・ポイント

Exit UserObject: ユーザが 10 秒以内に応答した場合、Delayオブジェク

トがまだ実行を完了していなくても、このオブジェクトは
UserObjectを終了させます。

DelayとRaise Error: DelayオブジェクトがRaise Errorオブジェクト

を起動してから 10 秒後に、Raise Errorオブジェクトはプログラム

の実行を休止し、指定されたエラー・メッセージを表示します。エラー
を起こしたオブジェクトの周りには赤の輪郭線も表示されますが、メイ
ン・メニュー・バーの [Stop] または [Run ] ボタンをクリックすると消

えます。

OKとDelay: AorB内の2つのスレッドは独立しているため、OKとDelay

の両方が同時に実行されることに注意してください。
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ファイルの扱い方ファイルの扱い方ファイルの扱い方ファイルの扱い方
ファイルの扱い方

ファイルとの間のデータの移動

ファイルに現在の時刻を書込む VEE プログラムを作成します。100 個の不

規則な数を生成し、そのファイルに書込みます。それらの平均と標準偏差
を計算し、次の形式でファイルの末尾に追加します。

Mean:  xxxxxx
Std Dev:  yyyyyy

次に、ファイルから平均と標準偏差だけを読取ります。図 A-26 に、ファイ

ルとの間でデータを移動する方法を示します。

解答 -「ファイルとの間のデータの移動」

図 A-26 に、「ファイルとの間のデータの移動」の解答例を示します。

 

図 A-26. ファイルとの間のデータの移動 

キー・ポイント

配列の生成: Formulaオブジェクト内でrandomize(ramp(100,0,1), 

0, 1)を使用して、100 個の乱数の配列を作成します。ramp()関数
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ファイルの扱い方ファイルの扱い方ファイルの扱い方ファイルの扱い方
は、1 次元配列を生成し、それを randomize()関数に渡します。次

に、randomize()関数が 0～ 1の乱数値を生成します。

タイム・スタンプ : To Fileオブジェクトのトランザクション 1 に対す

る [I/O Transaction]ダイアログ・ボックス内の式フィールドで、

now()関数が使用されています。フォーマットを TIME STAMP 

FORMATに変更した場合、ダイアログ・ボックスには、時刻を保存する

方法を指定するための追加ボタンが表示されます。

1行に2つの値を保管する: To Fileオブジェクトの3番目と4番目のトラ

ンザクションでは、定数の Text文字列の後に Real値を保存します。

たとえば、3 番目のトランザクションでは、[I/O Transaction]ダイ

アログ・ボックスの式フィールドに「"Mean: ",B」と入力します ( 平
均値が B入力ピンにある場合 )。

ファイルから値を抽出する : 平均と標準偏差を取得するには、まず、読

取りポインタを先頭に置くため、EXECUTE REWINDを送信します。次

に、正しいフォーマットの NULLを使用し、タイム・スタンプと Real
配列を読飛ばします。これで、読取った値が出力端子に入力されずに捨
てられます。最後に、ファイル内の最後の 2 行を文字列として読取り

ます。

結合 : 複数の出力を単一の入力に接続する場合は、[Flow]⇒

[Junction]オブジェクトを使用します。この例では、meanと sdev

の出力を Logging AlphaNumeric表示に接続します。
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レコードレコードレコードレコード
レコード

レコードの操作

「レコードの操作」ステップ 1

3 つのフィールドを持つレコードを構築し、そのレコードに整数、現在の

時刻の文字列、および 4 つの Real 要素を持つ配列を 1 つずつ格納します。

フィールドには、それぞれ int、daytime、rarryという名前を付けま

す。このレコードと、0 ～ 1 の乱数と波形を保持する別のレコードをマー

ジします。これらのフィールドには、rand と wave という名前を付け

ます。

解答 -「レコードの操作」ステップ 1

図 A-27 に示すように、結果のレコードには 5 つのフィールドがあります。
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レコードレコードレコードレコード
図 A-27. 「レコードの操作」ステップ 1 

キー・ポイント

タイム・スタンプ : このプログラムのためのタイム・スタンプを作成す

るには、To Stringオブジェクト内で now()関数を使用し、フォー

マットを指定します。

データ定数を配列として設定する: [Data]⇒[Constant]メニューにあ

る任意のデータ型を配列にできます。それには、[Properties]を選

択し、[Configuration]の [1D Array]を選択します。ここでサイ

ズを入力します。または、値の入力して Enter キーを押すと、続けて値

を追加できます。

フィールドに名前を付ける : Build Recordオブジェクトの入力端子の

名前を変更すると、レコードの特定のフィールドに int、rand、wave

などの名前を付けることができます。
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レコードレコードレコードレコード
デフォルト値コントロール入力 : Default Value Controlピンを追加

すると、Record Constantは、優れた対話型表示オブジェクトとな

ります。Record Constantは、自分が受信したレコードで自分を自

動的に設定します。

「レコードの操作」ステップ 2 

Formulaオブジェクト内で条件式を使用して、レコード内の乱数を判定

し、値またはテキスト文字列のどちらかを表示します。値が 0.5 より小さ

い場合はその乱数値を表示し、そうでない場合はテキスト文字列 "More 
than 0.5" を出力します。次に、時刻と波形だけを抽出します。

ヒント

時刻と波形を抽出する場合に、Formulaオブジェクトを使用しません。

AlphaNumericオブジェクトを使用して、このレコードを表示します。

解答 -「レコードの操作」ステップ 2

図 A-28 に、「レコードの操作」ステップ 2 の解答例を示します。

図 A-28. 「レコードの操作」ステップ 2 
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レコードレコードレコードレコード
キー・ポイント

条件式の使用方法 : VEE は条件式をサポートしており、if-then-else 操作を

効率的に実装できます。この Formulaオブジェクト内の条件式

(a.rand < 0.5? a.rand: "More than 0.5")は、3 項式と呼ば

れ、これ全体が 1 つの式です。図に示されているように、改行を入れな

がら Formulaオブジェクト内に記述できることに注目してください。

Formulaオブジェクト内に複数の式がある場合、それらの式どうしは

セミコロン (;) で区切られます。

Sub Recordオブジェクト : [fields]というラベルが付いたSub Recordの

入力ピンに接続されている Text配列のフィールドに注目してくださ

い。指定されたフィールドを保持するように Sub Recordオブジェク

トを設定した場合、このオブジェクトは、それらのフィールドだけを保
持するレコードを出力します。

「レコードの操作」ステップ 3

1 番目のフィールドの整数入力を For Countオブジェクトに置換し、10
回の反復実行を行います。各反復で、乱数生成と時刻の関数を起動します。
完成したレコードを To DataSetオブジェクトに送信します。別のスレッ

ドで、データセット内のレコードのうち、乱数値が 0.5 より大きいレコー

ドをすべて読取ります。読取ったレコードをレコード定数に入力します。

ヒント

Record Constantオブジェクトには、Default Valueのための制御ピ

ンが必要です。
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レコードレコードレコードレコード
解答 -「レコードの操作」ステップ 3

図 A-29 に、「レコードの操作」ステップ 3 の解答例を示します。

図 A-29. 「レコードの操作」ステップ 3

キー・ポイント

To DataSet オブジェクト : [Clear File at PreRun]オプションは、

データがファイルに初めて送信される前に、ファイルをクリアします。
プログラムは、10 個の異なるレコードを同じファイルに続けて送信し、

それらのレコードはファイルに追加されていきます。

From DataSet オブジェクト : このオブジェクトは、randフィールドが

0.5 より大きいレコードをすべて読取るように設定されます。この例で

は、10 個のレコードのうち 5 個のレコードが条件を満たし、最初のレ

コードがインデックス番号 0 として表示されています。
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テスト・シーケンサ

「テスト・シーケンサの使用方法」ステップ 1

Real64 Sliderと Confirm (OK)オブジェクトを持ち、UpperLimit

という名前のポップアップ・パネル UserFunctionを作成します。

UpLimitという名前のグローバル変数と出力端子の 1 つにスライダの出力

を送信します。Sequencerオブジェクトを作成します。その Sequencer

の test1に、UpperLimitを呼出す EXECトランザクションを設定します。

呼出すテストをシミュレートするために AddRandという名前の関数を別

に作成します。この関数は、入力値に乱数値 (0～ 1) を加算し、入力ピン

と出力ピンを 1 つずつ持ちます。

Sequencerで、AddRandを呼出し、0 を送信する test2を作成します。

戻り値をテストして、グローバル UpLimit値より小さいかどうかを比較

します。戻り値が条件を満たす場合は、"PASS" + test2.resultを返

します。そうでない場合は、"FAILED" + test2.resultを返します。

Sequencerの Returnピンに Alphanumeric表示を接続します。

Sequencerオブジェクトの後に、Get Variableオブジェクト

(UpLimit) と、別の Alphanumeric表示を起動します。プログラムを数

回実行します。

解答 -「テスト・シーケンサの使用方法」ステップ 1

図 A-30 に、「テスト・シーケンサの使用方法」ステップ 1 の解答例を示し

ます。
516 付録付録付録付録A 



追加の例題

テスト・シーケンサテスト・シーケンサテスト・シーケンサテスト・シーケンサ
図 A-30. 「テスト・シーケンサの使用方法」ステップ 1

キー・ポイント

UserFunctionを使ったグローバル変数の設定 : Sequencerの最初のトラ

ンザクションは、この場合のように、UserFunctionを呼出してグ

ローバル変数を設定するためによく使用されます。これで、この例のよ
うに、後続のテストでもそれらの変数を利用できます。

Sequencer の Return ピン : この例の Returnピンは、PASS または FAIL
メッセージとテスト値を渡します。このピンを使用すると、特定のテス
トからメッセージを渡すことができます。

「テスト・シーケンサの使用方法」ステップ 2

テスト 1 を無効にします。特にほかの場所でグローバルが必要ないとする

と、UpperLimit関数を直接呼出すことができます。test2によって
付録付録付録付録 A 517



追加の例題

テスト・シーケンサテスト・シーケンサテスト・シーケンサテスト・シーケンサ
AddRand(0)の戻り値と UpperLimit関数の結果が比較されるように、

test2を変更します。

ヒント : テスト 1 を無効にするには、図 A-31 に示すように、[Sequencer 

Transaction]ダイアログ・ボックスを使用します。

図 A-31. シーケンサのテスト 1 を無効にする

図 A-31 で、Sequencerのテスト 1 が無効であることを示すために、テス

ト 1 が 2 つのスラッシュで「コメント・アウト」されていることに注意し

てください。

解答 -「テスト・シーケンサの使用方法」ステップ 2

図 A-32 に、「テスト・シーケンサの使用方法」ステップ 2 の解答例を示し

ます。
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図 A-32. 「テスト・シーケンサの使用方法」ステップ 2

キー・ポイント

式フィールドの UserFunction: この例では、テスト結果を UpLimit変数

と比較するのではなく、式フィールド内の変数のあった位置に関数名
UpperLimit()を入力できます。

「テスト・シーケンサの使用方法」ステップ 3

VEE 関数 random (0,1)を呼出す test2 Sequencerトランザクション

を編集します。結果が 0.5より小さいかどうかを比較します。テストが全

部で 4 つになるまで、test2トランザクションを切取って貼付けます。

Sequencerを 5 回実行するプログラムを構築します。データをレコード

のデータセットに記録し、そのデータを配列に収集します。その配列を使
用して、テスト 2 の結果の最小値、最大値、平均、標準偏差をそれぞれ計

算します。
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解答 -「テスト・シーケンサの使用方法」ステップ 3

図 A-33 に、「テスト・シーケンサの使用方法」ステップ 3 の解答例を示し

ます。

図 A-33. 「テスト・シーケンサの使用方法」ステップ 3 

キー・ポイント

シーケンサを複数回の実行するためのデータ・フォーマット ( 最初のス

レッド ): Sequencerが 1 回実行されると、レコードから成るレコード

が出力されます。最初のレコードは、テスト名に一致するフィールド名
を持ち、次に各フィールドが、その特定のテストに対するそれぞれ異な
るデータを保持するレコードを 1 つずつ保持します。Sequencerが数

回実行されると、レコードから成るレコードがそれぞれ配列に追加され
ます。そこで、その配列を調査できます。Formulaオブジェクト内で
520 付録付録付録付録A 



追加の例題

テスト・シーケンサテスト・シーケンサテスト・シーケンサテスト・シーケンサ
「< レコード >[*].< レコード >.< フィールド >」フォーマットを使

用すれば、データの配列を取得できます。この例では、test2の 5 回

の実行結果を示す Real 値の配列を得ることができます。次に、この配

列から、その最小値、最大値、平均、標準偏差を計算できます。「レ
コードから成るレコード」の配列内の特定の要素を指定すると、test2

の 1 回の実行を指定できます。たとえば、test2の初回の実行結果を

得るには、式 A[0].test2.resultを使用します。

「テスト・シーケンサの使用方法」ステップ 4

記録レコードにタイム・スタンプ・フィールドを追加します。各ステップ
が 1 秒間隔で実行されるように Delay を追加します。別のスレッドで、

test2のすべての結果を取得し、それらをレコード定数に送信します。

ヒント

Delayオブジェクト (最初のスレッド ): このオブジェクトは、指定され

た秒数の間、実行フローを保留します。この例では、Sequencer

が実行されるたびにタイム・スタンプが変わるように、このオブ
ジェクトが使用されます。

タイム・スタンプの追加 : タイム・スタンプを追加するには、

Sequencerのオブジェクト・メニューを開き、[Properties]⇒

[Logging]タブを選択し、[Record Fields to Log]⇒ [Time 

Stamp]をチェックします。図 A-34 に、[Properties]ダイアログ・

ボックスの [Logging]タブを示します。
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図 A-34. 記録レコードへのタイム・スタンプの追加
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解答 -「テスト・シーケンサの使用方法」ステップ 4

図 A-35 に、「テスト・シーケンサの使用方法」ステップ 4 の解答例を示し

ます。

図 A-35. 「テスト・シーケンサの使用方法」ステップ 4 

ヒント : 

レコードを表示するには、いずれかのテストの [Record]⇒ [Record: 

Scaler]フィールドをクリックして、[Record Field Data] ダイアログ・

ボックスを表示します。図 A-36 に、[Record Field Data] ダイアログ・ボッ

クスを示します。
付録付録付録付録 A 523



追加の例題

テスト・シーケンサテスト・シーケンサテスト・シーケンサテスト・シーケンサ
図 A-36. レコードの確認

「テスト・シーケンサの使用方法」ステップ 5

レコードのタイム・スタンプ・フィールドを Logging Alphanumeric表

示に出力します。

ヒント : 各テストごとに 1 つの 4 つの Formulaオブジェクトを使用しま

す。4 つの Formulaの結果すべてを 1 つの Logging Alphanumeric表

示に表示するには、Junctionオブジェクトを追加します。To String

を使用して、63G タイム・スタンプ値を読みやすい文字列にフォーマット

します。
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解答 -「テスト・シーケンサの使用方法」ステップ 5

図 A-37 に、「テスト・シーケンサの使用方法」ステップ 5 のタイム・スタ

ンプを表示に出力するプログラム・スレッドを示します。

図 A-37. 「テスト・シーケンサの使用方法」ステップ 5

キー・ポイント

タイム・スタンプ・フォーマットの変換 : タイム・スタンプを読みやす

くするため、Logging AlphaNumericの前の To Stringオブジェク

トにより、タイム・スタンプが Realフォーマットから Time Stamp

フォーマットに変換されます。
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「テスト・シーケンサの使用方法」ステップ 6

Sequencerに多数のテストがある場合、多くの Formulaオブジェクトを

使って Junctionに個々に接続すると、扱いにくくなることがあります。

そのかわり、式を保持する Formulaを使用し、実行時に式を生成して、

考えられる式をすべてループします。

最初に、例として式の文字列を生成します。

別のスレッドで、Loop と Formulaを使用して、テスト式の文字列を生成

します。情報を文字列として Logging Alphanumericに出力します。

Formulaで生成される文字列は、"a[*].test<x>.timestamp" であり、

<x>は 1 ～ 4 です。

解答 -「テスト・シーケンサの使用方法」ステップ 6

図 A-38 に、ステップ 6 の解答例を示します。

図 A-38. 「テスト・シーケンサの使用方法」ステップ 6

「テスト・シーケンサの使用方法」ステップ 7

次に、ステップ 6 で構築した Loop と Formulaを利用して、以前のステッ

プの 4 つの Formulaと Junctionをこの Loop と Formulaで置換えま

す。さらに、構築した文字列を評価する必要があります。生成した文字列 (
式 "a[*].test<x>.timestamp") が実行時に評価されるように、それら

を Formulaに送信します。

ヒント

Formula オブジェクトの Formula 制御ピン : 評価する Formulaは、Loop
内の Formulaによって生成されます。その Formula式に対するコン

トロール入力を持つ別の Formulaボックスを作成します。2 つ目の

Formulaが評価する式は、実行時に生成されます。
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解答 —「テスト・シーケンサの使用方法」ステップ 7

図 A-39 に、ステップ 7 の解答例を示します。

図 A-39. 「テスト・シーケンサの使用方法」ステップ 7 

キー・ポイント

To Stringオブジェクトは、やはり Real64をタイム・スタンプの

フォーマットに変換するために使用されています。

最初の「generate」用の Formulaと 2 番目の「evaluate」用の Formulaを

結ぶシーケンス線に注目してください。これにより、2 番目の

Formulaは、評価対象の新しい文字列を受取るまで、実行されなくな

ります。

「テスト・シーケンサの使用方法」ステップ 8

テスト 1 に成功し、テスト 2 に失敗したレコードだけを表示します。

解答 -「テスト・シーケンサの使用方法」ステップ 8

図 A-40 に、「テスト・シーケンサの使用方法」の最後のステップの解答例

を示します。
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図 A-40. 「テスト・シーケンサの使用方法」ステップ 8

キー・ポイント

From Data SetオブジェクトのEOFピン (2番目のスレッド ): 条件に一致

するレコードがない場合に、EOFピンが追加されます。この状態が起こ

ると、EOFピンが起動されます。エラー・メッセージとともに VEE が

停止することはありません。

From Data Set オブジェクト内の条件式 (2 番目のスレッド ): この式は

「(Rec.test1.pass==1) OR (Rec.test2.pass==0)」であり、同じ「< レ

コード >.< レコード >.< フィールド > 」フォーマットを持っていま

す。Recは、読取りおよびテストされているデータセット内の各レコー

ドの名前です。test1と test2は、VEE が検査するテストを指定しま

す。フィールド名 pass は、VEE によって割当てられている成功 / 失敗
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インジケータ (1または 0) のデフォルト名です。すべてのテストについ

て、それぞれのフィールドを有効または無効にする場合は、
[Sequencer Properties]ダイアログ・ボックスの [Logging]タ

ブを選択します。
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用語集

用語集では、このマニュアルで使用している用語を定義します。VEE 6.0
のさらに詳細な用語集が必要な場合は、[Help]⇒ [Contents and 

Index]をクリックします。さらに、[Reference]、[Glossary]を順

に選択します。[Glossary]で用語をクリックすると、その定義が表示さ

れます。定義を読み終えたら、画面の任意の箇所をクリックするとテキス
トがクリアされます。

ボタン
押しボタンや選択ボタンに似せたグラフィカル・オブジェクト。VEE
の画面に飛び出たように表示されます。VEE 内のボタンをマウスでク

リックして「押す」と、その操作が行われます。マウスの左または右の
ボタンを指す場合もあります。

カスケード・メニュー
プルダウン・メニューやポップアップ・メニューで追加の選択肢を提供
するサブメニュー。

チェックボックス
VEE のメニューやダイアログ・ボックスに表示されるくぼんだ四角形

のボックス。設定を選択するために使用します。設定を選択するには、
ボックスをクリックします。ボックスの中にチェック・マークが表示さ
れて、選択されたことが示されます。設定をキャンセルするには、ボッ
クスを再びクリックします。

クリック
マウス・ボタンを押して離すこと。通常は、クリックにより、VEE
ウィンドウ内でメニュー機能やオブジェクトを選択します。「ダブルク
リック」と「ドラッグ」も参照してください。

クローン
VEE のオブジェクト・メニューにあるメニュー項目の 1 つ。オブジェ

クトとオブジェクト間の相互接続を複製し、そのコピーを Pasteバッ

ファに置きます。クローンは、クローンされるオブジェクトのピン、パ
ラメータ、サイズなどのすべての属性をコピーします。
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コンポーネント
VEE の計測器パネルやコンポーネント・ドライバにある単一の計測関

数または測定値。たとえば、ボルタメータ・ドライバには、範囲、トリ
ガ・ソース、最新の読取り値を記録するコンポーネントがあります。

コンポーネント・ドライバ
特別に選択されたコンポーネントについて値の読取りまたは書込みを行
う計測器制御オブジェクト。一度に少数のコンポーネントの値だけを設
定することにより、ドライバを使用する計測器を制御するには、コン
ポーネント・ドライバを使用します。コンポーネント・ドライバはカッ
プリングをサポートしません。

コンテナ
「データ・コンテナ」を参照してください。

コンテキスト
ほかのレベルの作業領域 ( ネストされた UserObjectなど ) を保持で

きるが、それに依存しない作業領域のレベル。

カーソル
キーボードから情報を入力するときに、英数字データが表示される箇所
を示す入力フィールド内のポインタ ( カレット )。

カット・バッファ
切取りまたはコピーされたオブジェクトを保持するバッファ。
[Paste]ツールバー・ボタン ([Edit]⇒ [Paste]) を使用すると、作

業領域にオブジェクトを貼付けることができます。

データ・コンテナ
回線上を伝送され、オブジェクトによって処理されるデータ・パッケー
ジ。各データ・コンテナは、データのほか、データ型、データの種類、
およびマッピング ( ある場合 ) を保持します。

データ・フロー
VEE オブジェクトを介した VEE オブジェクト間のデータの流れ。デー

タは、オブジェクトを介して左から右へと流れますが、オブジェクト
は、そのデータ入力ピンのすべてにデータが伝達されるまで実行されま
せん。データは、1 つのオブジェクトのデータ出力ピンから、次のオブ

ジェクトのデータ入力ピンに伝達されます。データ・フローは、VEE
プログラムの実行を決定する主要な要素です。
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データ入力ピン
オブジェクトの左側にある接続点。ここからオブジェクトにデータが流
込みます。

データ出力ピン
オブジェクトの右側にある接続点。データ・フローを次のオブジェクト
に伝達したり、このオブジェクトの操作結果を次のオブジェクトに渡し
ます。

データの種類
各データ・コンテナには、種類と型の両方があります。データの種類
は、スカラまたは 1 次元以上の配列のどちらかになります。VEE では、

1 次元の配列を「Array 1D」、2 次元の配列を「Array 2D」などと呼び

ます。

データ型
各データ・コンテナには、型と種類の両方があります。VEE は、Text、
Real64、Real32、Int32 などの多くのデータ型をサポートしています。

詳細ビュー
すべてのオブジェクトと、それらを接続する線を示す VEE プログラム

のビュー。

Direct I/O オブジェクト
VEE が計測ドライバを使用しないで計測器を直接制御するための計測

器制御オブジェクト。

ダブルクリック
マウス・ボタンを続けて 2 度すばやく押して離すこと。通常、ダブルク

リックは、選択とある操作の実行を一度に行うための方法です。たとえ
ば、[File]⇒ [Open]の後にファイル名をダブルクリックすると、そ

のファイルが選択されて開かれます。

ドラッグ
マウス・ボタンを押し、それを押したままマウスを移動すること。ド
ラッグにより、オブジェクトやスクロール・バーなどを移動します。

ドロップダウン・リスト
選択フィールドの右側にある矢印をクリックすることによって表示され
る選択肢の一覧。
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入力フィールド
データ入力に使用されるフィールド。ダイアログ・ボックスや編集可能
なオブジェクトの一部であることが普通です。入力フィールドは、背景
色が白の場合に編集できます。

式
入力フィールド内で入力端子名、グローバル変数名、演算関数、ユーザ
定義関数を含むことができる計算式。式は、実行時に評価されます。式
は、Formula、If/Then/Else、Get Values、Get Field、Set 

Field、Sequencer、、Dialog Boxの各オブジェクトと I/O トランザ

クション・オブジェクトの中で使用できます。

フォント
VEE では、さまざまな VEE オブジェクトやタイトルなどのテキストの

表示に使用されるフォントのサイズとスタイルを変更できます。

淡色表示
メニューが黒ではなく灰色で表示されること。これは、その機能がアク
ティブでないか、使用できないことを示します。ボタン、チェックボッ
クス、ラジオ・ボタンなどのダイアログ・ボックス内のアイテムも、淡
色表示になることがあります。

グループ・ウィンドウ
Microsoft Windows で使用され、1 つのグループ内のアプリケーション・

アイコンを保持するウィンドウ。それぞれのアイコンにより、グループ
内の 1 つのアプリケーションを起動できます。

HP-UX
Hewlett-Packard 社によって開発された UNIX オペレーティング・システ

ムの派生システムの 1 つ。

ハイパーテキスト
関連するトピックにジャンプして、さらに情報を得ることができるよう
にトピックどうしをリンクするシステム。オンライン・ヘルプ・システ
ムでは、ハイパーテキスト・リンクは下線付きのテキストとして示され
るのが普通です。そのテキストをクリックすると、関連する情報が表示
されます。

アイコン
1. VEE オブジェクトを小さくグラフィカルに表現したもの。計測器、

制御、表示などのオブジェクトを表します。
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2. Microsoft Windows と HP-UX (with VUE) オペレーティング・システム

で、アプリケーション、ファイル、またはフォルダを小さくグラフィカ
ルに表現したもの。

メイン・ウィンドウ
VEE プログラムを開発する基本の作業領域を含むウィンドウです。こ

のウィンドウの作業領域は、VEE ウィンドウのワークスペース内にあ

ります。

最大化ボタン
UserObject、UserFunction、またはメインの各ウィンドウにある

ボタンの 1 つ。UserObject、UserFunction、またはメインの各

ウィンドウを有効なワークスペース全体に広げます。

メニュー・バー
VEE ウィンドウの上部にあるバー。プルダウン・メニューのタイトル

が表示され、そこからコマンドやオブジェクトを選択できます。

最小化ボタン
オブジェクトの VEE ウィンドウにあるボタンの 1 つ。そのオブジェク

トまたは VEE ウィンドウをアイコン化します。

オブジェクト
1. 計測器、制御、表示、算術演算子などのプログラム内の要素をグラ

フィカルに表現したもの。オブジェクトは作業領域に配置され、ほかの
オブジェクトに接続されてプログラムを形成します。

2. ActiveX オートメーションとコントロールで使用されるデータ型の

1 つ。

オブジェクト・メニュー
オブジェクトに関連付けられ、そのオブジェクトを操作するための機能
( 移動、サイズ変更、コピー、削除など ) を保持するメニュー。オブ

ジェクト・メニューを利用するには、オブジェクトの左上隅にあるオブ
ジェクト・メニュー・ボタンをクリックするか、マウス・ポインタをオ
ブジェクト上に置き、マウスを右クリックします。

オブジェクト・メニュー・ボタン
オープン・ビュー・オブジェクトの左上隅にあるボタン。これをクリッ
クすると、オブジェクト・メニューが表示されます。
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オープン・ビュー
最小化ビュー ( アイコン ) より詳細な VEE オブジェクトの表示方法。ほ

とんどのオブジェクトのオープン・ビューには、そのオブジェクトの操
作を変更するためのフィールドがあります。

パネル・ドライバ
対応する物理計測器のすべての機能設定をオブジェクトのオープン・
ビューに表示されている制御パネルの設定と一致させる計測器制御オブ
ジェクト。

パネル・ビュー
ユーザがプログラムを実行し、その結果データを表示するために必要な
オブジェクトだけが表示される VEE プログラム (UserObjectまたは

UserFunction) のビュー。パネル・ビューを使用すると、プログラム

のオペレータ・インタフェースを作成できます。

ピン
線を接続できるオブジェクトの外部接続点。

ポインタ
マウスの移動位置をグラフィカルに示すもの。ユーザは、ポインタを
使って選択したり、ポインタから特定の操作の状態を知ることができま
す。VEE では、操作の状態に対応して、矢印、十字、砂時計などのさ

まざまな形状のポインタが表示されます。

ポップアップ・メニュー
マウスの右ボタンをクリックして画面に表示されるメニュー。たとえ
ば、作業領域内の何もない領域でマウスの右ボタンをクリックすると、
[Edit]メニューが表示されます。また、オブジェクトのアクティブで

ない領域でマウスの右ボタンをクリックすると、オブジェクト・メ
ニューが表示されます。

設定
VEE 環境の属性。設定は、ツールバーの [Default Preferences]

ボタンまたは [File]⇒ [Default Preferences]メニューを使って

変更できます。たとえば、デフォルトの色、フォント、数字のフォー
マットなどを変更できます。
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プログラム
VEE では、線で接続されたオブジェクトの集合で構成されるグラフィ

カルなプログラム。一般に、プログラムは、エンジニアリング上の問題
に対する解決策を表現します。

プログラム・エクスプローラ
プログラムを探索するために VEE ウィンドウに用意された機能。特に、

物理的に画面上には表示されない部分の探索を可能にします。

伝達
オブジェクトやプログラムが操作または実行される場合に従う規則。

「データ・フロー」も参照してください。

プロパティ
色、フォント、タイトルなどの VEE オブジェクトの属性。オブジェク

トのプロパティは、オブジェクト・メニューの [Properties]を使

用って変更できます。

プルダウン・メニュー
メニュー・タイトルの上にポインタを置き、マウスの左ボタンをクリッ
クしたときに、メニュー・バーの下に表示されるメニュー。

スクロール矢印
クリックすることにより、ダイアログ・ボックス内でデータ・ファイル
などの選択対象のリストをスクロールしたり、作業領域を移動するため
の矢印。

スクロール・バー
ドラッグすることにより、ダイアログ・ボックス内でデータ・ファイル
などの選択対象のリストをスクロールしたり、作業領域を移動するため
の長方形のバー。

選択
オブジェクト、実行する操作、またはメニュー項目を選択すること。通
常は、マウスをクリックして選択を行います。

選択フィールド
オブジェクトやダイアログ・ボックス内にあり、ドロップダウン・リス
トから項目を選択できるフィールド。
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シーケンス入力ピン
オブジェクトの上部のピン。接続された場合、このピンがコンテナを
受信する ( 起動される ) まで、オブジェクトの実行は延期されます。

シーケンス出力ピン
オブジェクトの下部のピン。接続された場合、このオブジェクトとこ
のオブジェクトからのすべてのデータ伝達が実行を完了したときに、こ
の出力ピンがアクティブ化されます。

ステータス・バー
VEE ウィンドウの下端にある行。VEE の現在の状態や VEE に関する情

報が表示されます。

ステータス・フィールド
編集できない情報が表示されるフィールド。ステータス・フィールド
は、入力フィールドに似ていますが、背景が灰色です。

端子
ピンとピンが保持するデータ・コンテナに関する情報を表示するための
ピンの内部的な表現。端子をダブルクリックすると、コンテナ情報が表
示されます。

タイトル・バー
オブジェクトのオープン・ビューまたはウィンドウの上部にある長方形
のバー。そのオブジェクトまたはウィンドウのタイトルが表示されま
す。オブジェクト・メニューの [Properties]を使用すると、オブ

ジェクトのタイトル・バーを非表示にできます。

ツールバー
VEE ウィンドウの上部にある長方形のバー。頻繁に使用するコマンド

にすばやくアクセスするためのボタンが用意されています。ボタンは、
[File]、[Edit]、[View]、[Device]、[Debug]などのメニューの

コマンドを実行します。

トランザクション
VEE の一定のオブジェクトによって使用される入出力 (I/O) の仕様。To 

File、From File、Sequencer、Direct I/Oなどがオブジェクト

の例です。トランザクションは、これらのオブジェクトのオープン・
ビューの中に句としてリストされます。
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UserObject
プログラム内で特定の目的を果たすためにオブジェクトのグループをカ
プセル化できるオブジェクト。UserObject を使用すると、トップダウン

の設計手法を使ってプログラムを構築できます。また、ユーザ定義オブ
ジェクトを構築し、ライブラリ内にセーブして再使用できます。

ビュー
プログラムを表示するための方法。VEE には、2 つのビューがありま

す。パネル・ビューは、VEE プログラムのユーザ・インタフェースで

す。詳細ビューは、VEE プログラムを開発するためのウィンドウです。

Windows 95、Windows 98、Windows NT 4.0、Windows 2000
Microsoft 社の開発によるオペレーティング・システム。VEE は、これ

らのオペレーティング・システムの下で実行されます。

作業領域
メイン ( および UserObjectと UserFunction) ウィンドウ内の領域。

この領域内に VEE オブジェクトを配置し、それらのオブジェクトを互

いに接続して VEE プログラムを作成します。

ワークスペース
VEE ウィンドウ内にあり、メイン、UserObject、UserFunctionな

どのプログラミングまたは編集ウィンドウを保持する領域。これらの
ウィンドウには、VEE オブジェクトを配置し、それらを互いに接続す

るための作業領域があります。
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To/From DataSet オブジェクト 367
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